Synapse Link for Dataverse-SYN-806: Default storage container in Synapse workspace is not accessible error while enbling tables

Sandz 66 Reputation points
2024-05-17T12:32:44.3633333+00:00

Hi, I'm trying to setup a synapse link via dataverse to F&O. I'm able to setup the connection but when I enable tables sync status is throwing out error .

Error details - SYN-806: Default storage container in Synapse workspace is not accessible.

Pleaes note that , At the time of synapse workspace creation, Initially I setup with wrong primary storage account details. later I delete the synapse account and recreated with the correct details.

screenshot:

Any help will be highly appreciated.

Thanks

Sandy

Azure Synapse Analytics
Azure Synapse Analytics
An Azure analytics service that brings together data integration, enterprise data warehousing, and big data analytics. Previously known as Azure SQL Data Warehouse.
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  1. BhargavaGunnam-MSFT 28,061 Reputation points Microsoft Employee
    2024-05-17T17:15:47.6333333+00:00

    Hello Sandz,

    Welcome to the Microsoft Q&A forum.

    This issue has been documented on the below Azure Synapse Link for Dataverse troubleshooting guide

    <copied from the documentation page>

    Error message: SYN-806: Default storage container in Synapse workspace isn't accessible

    Root Cause:

    Synapse workspace associated with this Azure Synapse Link profile doesn't contain a primary Azure Data Lake Storage Gen2 file system. The default storage container might be deleted or the default storage container isn't accessible. A default storage container is used by Synapse workspace as temporary storage in creating the file system. A default storage container must be provided when creating a Synapse workspace. It's possible that this storage container was deleted or no longer accessible.

    Resolution:

    Ask your administrator to launch Synapse workspace and verify the name of the primary Azure Data Lake Storage Gen2 file system. Also verify that an Azure Data Lake Storage Gen2 storage container exists with that name within the same subscription. If the storage container is missing, create a storage container with the same name.

    Reference document:
    https://learn.microsoft.com/en-us/power-apps/maker/data-platform/azure-synapse-link-troubleshooting-guide

    I hope this helps. Please let me know if you have any further questions.

    If this answers your question, please consider accepting the answer by hitting the Accept answer and up-vote as it helps the community look for answers to similar questions.