次の方法で共有


macOS LOB アプリをデプロイするときのエラー 0x87D13BA2

この記事では、Microsoft Intuneに macOS 基幹業務 (LOB) アプリをデプロイするときに、次のエラー メッセージを解決します。

1 つ以上のアプリに無効な bundle ID が含まれています。 (0x87D13BA2)

現象

Intuneを使用して macOS LOB アプリを発行します。 Microsoft Intune管理センターでアプリを選択すると、デバイスのインストール状態にアプリに関する次の情報が表示されます。

  • 状態: 失敗しました
  • 状態の詳細: 1 つ以上のアプリに無効なバンドル ID が含まれています。 (0x87D13BA2)

Microsoft Teams の例を次に示します。

Microsoft Teams のエラー 0x87D13BA2のスクリーンショット。

この問題は、アプリがデバイスに正常にインストールされている場合でも発生する可能性があります。

原因

この問題は、次の条件下で発生します。

  • macOS アプリ パッケージには、複数のアプリケーションが含まれています。
  • パッケージに含まれる個々のアプリケーションのインストール状態は、Intuneに報告されません。

Microsoft Teams などの複数のコンポーネントを持つアプリは、このエラー メッセージを生成できます。

ソリューション

この問題を解決し、macOS LOB アプリがその状態を正しく報告できるようにするには、次の手順を使用します。

  1. Intuneを介してアプリがインストールされている macOS デバイスで、ターミナルを開き、次のコマンドを実行して、インストールされているアプリの一覧を現在のディレクトリに出力します。

    sudo /usr/libexec/mdmclient QueryInstalledApps > InstalledApps.txt
    
  2. テキスト エディターで InstalledApps.txt ファイルを開きます。

    InstalledApps.txt ファイルのスクリーンショット。

  3. [プロパティ>] [アプリ情報>] [編集] を選択して、Intuneで影響を受けるアプリに移動します。

    [アプリケーションの編集] ページのスクリーンショット。

  4. Intuneに含まれているアプリの一覧を、InstalledApps.txt ファイルに一覧表示されているアプリと比較し、テキスト ファイルに表示されていないアプリをすべて削除します。

    Intuneに含まれているアプリの一覧。

    テキスト ファイルに含まれるアプリの一覧。

  5. アプリケーションを確認して保存し、デバイスを同期して最新のアプリのインストール状態を取得します。

    最新のアプリのインストール状態のスクリーンショット。