次の方法で共有


macOS LOB アプリがMicrosoft Intuneにデプロイされていない

この記事では、Microsoft Intuneが対象デバイスに macOS 基幹業務 (LOB) アプリをデプロイできない場合の解決に役立つトラブルシューティング手順について説明します。

現象

macOS 基幹業務 (LOB) アプリをMicrosoft Intuneに追加し、macOS デバイスにアプリをデプロイしようとします。 ただし、アプリはターゲット デバイスにインストールされておらず、Intuneにエラー メッセージは表示されません。

原因

この問題は、パッケージ情報ファイルに .pkg 次の情報がパッケージに含まれていない場合に発生します。

  • パッケージ versionCFBundleVersion 文字列
  • 正しい install-location

この情報は、Intune対象のデバイスにアプリをデプロイできるようにするために必要です。

次の手順を使用して、パッケージに必要な情報が含まれているかどうかを.pkgチェックします。

  1. 次のコマンドを実行して、パッケージから pkg-info ファイルを抽出します .pkg

    xar -x -f <.pkg file path> -C <Output folder>

  2. 出力に と install-locationが含まれているかどうかを確認しますCFBundleVersion。 次の例のように、インストール場所は /Applications またはそのサブフォルダーにする必要があります。

    <pkg-ref id="com.microsoft.teams" version="1.00.522362">
    <choice id="TeamsApp" title="Microsoft Teams" customLocation="/Applications"/>

ソリューション

この問題を解決するには、アプリ開発者に問い合わせて、必要な情報を .pkg 含むようにパッケージを再構築します。 Apple 固有の開発者向けドキュメントについては、を参照してください https://developer.apple.com/

詳細

現在、macOS アプリの展開のサポートは、/Applications フォルダーにインストールされている単純な.pkgアプリと macOS 用のアプリOffice 365に制限されています。

サードパーティの情報に関する免責事項

この資料に記載されているサードパーティ製品は、マイクロソフトと関連のない他社の製品です。 明示的か黙示的かにかかわらず、これらの製品のパフォーマンスや信頼性についてマイクロソフトはいかなる責任も負わないものとします。

サードパーティのお問い合わせ窓口に関する免責事項

Microsoft では、このトピックに関する追加情報を見つけるのに役立つサード パーティの連絡先情報を提供しています。 将来予告なしに変更されることがあります。 Microsoft は、第三者の連絡先情報の正確性を保証しません。