SCCM Software Center - How to reset or cancel an application download

Thomas Faherty 151 Reputation points
2020-10-12T17:32:40.99+00:00

Hello,

We had some applications stuck at 0% downloading and as we make changes I would like to stop these and restart them to see if the issue is fixed but I am not totally sure if just restarting something like the ccmexe service would do that or not?

Basically I found the palo alto was not liking the way the apps were downloading but as we make changes to the palo alto I need to test if it fixed it or not but just staring at it hoping that it will just eventually go doesn't feel very satisfying.

Microsoft Configuration Manager Application
Microsoft Configuration Manager Application
Microsoft Configuration Manager: An integrated solution for for managing large groups of personal computers and servers.Application: A computer program designed to carry out a specific task other than one relating to the operation of the computer itself, typically to be used by end users.
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Accepted answer
  1. Fiona Yan-MSFT 2,311 Reputation points
    2020-10-26T02:05:02.007+00:00

    @Thomas Faherty

    Thank you very much for the update and sharing the solution here. I believe this should be useful for someone who has similar issue in the future. Here's a short summary for the problem.

    Problem/Symptom:

    ===================

    some applications stuck at 0% downloading in software center and want to reset the app status in software center.

    Possible Cause:

    ===================

    The status of our app pending and so on.

    Solution:

    ===================

    Run the WMIC command reset our sc status.

    Reference Links:

    ===================

    https://learn.microsoft.com/en-us/answers/questions/123991/sccm-software-center-how-to-reset-or-cancel-an-app.html

    Have a nice day!


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  1. Thomas Faherty 151 Reputation points
    2020-10-23T16:50:08.06+00:00

    FionaYan that worked

    "WMIC /Namespace:\root\ccm path SMS_Client CALL ResetPolicy 1 /NOINTERACTIVE"

    I also reset the SMS Agent Host service too add to this solution.

    Thank you! I don't see where I can accept that as the answer though for some reason.

    3 people found this answer helpful.

  2. Fiona Yan-MSFT 2,311 Reputation points
    2020-10-13T07:45:55.44+00:00

    @Thomas Faherty

    Thank you for posting in Microsoft Q&A forum.

    To achieve our goal, maybe we could try the following step:

    1. We may need to remove our failed deployment from our CM console.
    2. We could distribute the changed app to our DP, and then deploy this changed application to our client.
    3. To speed up getting the new status, we could refresh the application Deployment Evaluation Cycle and the Machine Policy Retrieval & Evaluation Cycle on our client.

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    1 person found this answer helpful.

  3. Thomas Faherty 151 Reputation points
    2020-10-13T22:01:54.727+00:00

    The app isn't failed. It works perfectly on all machines except one environment where the Firewall is different. In this case I get a 416 error When researching I found people were saying the Palo Alto is getting an error dealing with the packet header range. They said if this is the case you will see it in wireshark. So I ran wireshark and I see the palo alto is the one responding with the 416 instead of the server like it should. So that proved it is the palo alto. So now as I make adjustments to the palo alto I would like to test without having to wait a ton of time or deleting the deployment bringing it down for everyone else when it works. The issue is not the deployment at all so I don't find that reasonable. I just want to reset the app in software center so it goes from being stuck at installing back to where I click the install button. Anything done should be local not a SCCM change.


  4. Cathy Chapman 0 Reputation points
    2023-07-06T16:44:46.03+00:00

    I reimage 10's of thousands of machines and best resolve I've found is to perform net stop. then pull as many actions out of config manager. that usually gets the job done.

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