إنشاء مخطط لتصدير بيانات التكوين

 

تاريخ النشر: جمادى الأولى, 1438

ينطبق على: Dynamics 365 (online)، Dynamics 365 (on-premises)، Dynamics CRM 2016، Dynamics CRM Online

ملاحظة

المحتوى الوارد في هذا الموضوع الذي ينطبق على إصدارات Dynamics 365 على الإنترنت يتعلق بالإصدارات التي تسبق الإصدار 9.0 من Dynamics 365 (على الإنترنت). للحصول على أحدث الوثائق، راجع إنشاء مخطط لتصدير بيانات التكوين‬‏‫.

تتيح أداة أداة ترحيل التكوين لك إنشاء مخطط لوصف بيانات التصدير الخاصة بك. كما تمكَِنك من التحقق من التبعيات والعلاقات المفقودة في الكيانات أو الحقول ليتم تصديرها لتجنب عدم تناسق مجموعة بيانات.

في هذا الموضوع

قبل البدء

إنشاء مخطط وتصدير بيانات التكوين

إعادة استخدام مخطط موجود لتصدير بيانات التكوين

قبل البدء

قم بتنزيل حزمة SDK لـ Microsoft Dynamics CRM. قم باستخراج محتويات الحزمة على الكمبيوتر الخاص بك. تكون أداة أداة ترحيل التكوين متوفرة تحت مستند SDK\Tools\ConfgurationMigration في حزمة SDK Dynamics 365 التي تم استخراجها. ولا تحتاج إلى تثبيت أداة ترحيل التكوين. قم بتشغيل الأداة بالنقر المزدوج على ملف DataMigrationUtility.exe في المجلد SDK\Tools\ConfgurationMigration.

إنشاء مخطط وتصدير بيانات التكوين

  1. ابدأ تشغيل أداة ترحيل التكوين.

  2. على الشاشة الرئيسية، انقر فوق إنشاء مخطط ،ثم انقر فوق متابعة‏‎.

  3. على شاشة تسجيل الدخول قم بإدخال تفاصيل المصادقة للاتصال بمثيلDynamics 365 الخاص بك المراد تصدير البيانات منه. إذا كان لديك مؤسسات متعددة على خادم Dynamics 365 وأردت تحديد المنظمة المراد تصدير البيانات منها، حدد مربع الاختيار عرض قائمة المؤسسات المتاحة دائمًا. انقر فوق تسجيل الدخول.

  4. إذا كان لديك مؤسسات متعددة، وقمت بتحديد مربع الاختيار عرض قائمة المؤسسات المتوفرة دائمًا ، ستظهر لك الشاشة التالية لتحديد المؤسسة المراد التوصيل بها. حدد إحدى منظمات Dynamics 365 للاتصال بها.

  5. من قائمة تحديد الحل ، حدد حل الذي تريد تصدير البيانات منه:

  6. في الحل المحدد، يمكنك تحديد الكيانات والحقول المراد تصديرها أو تصدير جميع الكيانات داخل الحل.

    1. لتحديد الكيانات والحقول المراد تصديرها من قائمة تحديد كيان ، حدد الكيان الذي تريد تصدير البيانات إليه. تعرض قائمة حقول الكيان جميع حقول الكيان المحدد.

      1. لإضافة الحقول المحددة في الكيان، انقر فوق إضافة حقول.

      2. لإضافة الكيان نفسه وجميع الحقول، انقر فوق إضافة كيان.

    2. لتصدير جميع الكيانات، انقر فوق إضافة جميع بجوار قائمة تحديد الكيان .

    إنشاء مخطط للبيانات لتصديره في Dynamics 365

  7. يمكنك تحديد إظهار علاقات الكيان المحدد لعرض الكيانات ذات الصلة بالكيان المحدد حتى تتمكن من تصديرها أيضًا.

  8. يتم عرض الكيانات المحددة في مربع الكيانات والحقول المحددة .

    • إذا أردت إزالة كيان أو حقل أو علاقة، انقر فوق أي من الثلاث لتحديده ثم انقر بالزر الأيمن، و حدد خيار إزالة.

    • إذا كنت تريد إزالة جميع العناصر في الكيانات والحقول المحددة والبدء من جديد، انقر فوق مسح التحديد.

    إزالة علاقة في مخطط Dynamics 365

  9. للتحقق من صحة البيانات المحددة ليتم تصديرها، انقر فوق أدوات > التحقق من صحة المخطط.

    Validate the schema

  10. يتم عرض رسالة إذا كان هناك أي تبعيات مفقودة. لإغلاق الرسالة، انقر فوق موافق.

    رسالة نتائج التحقق من الصحة في Dynamics 365

  11. قم بإضافة الكيانات المفقودة ثم قم بتنفيذ الخطوة 9 مرة أخرى للتحقق من صحة البيانات. يتم عرض رسالة تأكيد في حالة عدم وجود أخطاء التحقق من الصحة.

    System_CAPS_tipتلميح

    إذا لم يكن الكيان المفقود في الحل الذي حددته للتصدير، يمكنك إضافة الكيان من الحل الافتراضي بتحديده من قائمة تحديد الحل .

  12. تحديد شرط تفرد البيانات المراد تصديرها. لفتح شاشة جديدة، انقر فوق أدوات > تكوين إعدادات الاستيراد. لكل كيان قمت بتحديده للتصدير، قم بإضافة الحقل أو الحقول التي تريد مقارنة بها السجلات مع السجلات الموجودة على النظام الهدف أثناء الاستيراد. حدد حقل، ثم انقر فوق إضافة حقل.

    تكوين إعدادات الاستيراد في Dynamics 365

  13. لتعطيل المكونات الإضافية لجميع الكيانات قبل استيراد البيانات إلى النظام الهدف، حدد خانة اختيار تعطيل المكونات الإضافية في جميع الكيانات للاستيراد. ستقوم الأداة بتعطيل جميع المكونات الإضافية أثناء استيراد البيانات إلى الخادم الهدف، وإعادة تمكينها بعد عملية الاستيراد.

  14. لحفظ الإعدادات والعودة إلى الشاشة الرئيسية، انقر فوق حفظ.

    ملاحظة

    إذا أردت التراجع عن أي تغييرات في مربع حوار تكوين إعدادات الاستيراد ،يجب يدويًا إعادة هذه التغييرات في مربع الحوار هذا ثم انقر فوق حفظ لحفظ التغييرات وقم بإغلاق مربع الحوار.

  15. في الشاشة الرئيسية:

    1. انقر فوق ملف > حفظ المخطط لحفظ المخطط فقط دون تصدير البيانات. ستتم مطالبتك بتحديد اسم وموقع ملف المخطط (.xml) لحفظه. يمكنك استخدام المخطط لاحقًا لتصدير البيانات. يمكنك إنهاء الأداة الآن.

    2. انقر فوق تصدير البيانات لتصدير البيانات وملف المخطط.. ستتم مطالبتك بتحديد اسم وموقع ملف المخطط لتصديره. حدد موقع الملف واسمه ثم انقر فوق حفظ. انتقل إلى الخطوة التالية.

    3. انقر فوق الحفظ والتصدير لاختيار ما إذا كنت تريد تصدير البيانات بعد حفظ ملف المخطط أم لا. ستتم مطالبتك بتحديد اسم وموقع ملف المخطط لتصديره. حدد موقع الملف واسمه ثم انقر فوق حفظ. ستتم مطالبتك بحفظ ملف البيانات: انقر فوق نعم لتصديره أو لا لتصديره لاحقًا. إذا قمت بالنقر فوق نعم، انتقل إلى الخطوة التالية.

  16. في الشاشة التالية، حدد موقع ملف البيانات ليتم تصديره إلى مربع حفظ إلى ملف بيانات ، ثم انقر فوق تصدير البيانات. تعرض الشاشة حالة تقدم التصدير وموقع الملف المُصدر في أسفل الشاشة بمجرد اكتمال عملية التصدير.

    لقطة شاشة لتصدير البيانات في Dynamics 365

  17. المس إنهاء لإغلاق الأداة.

إعادة استخدام مخطط موجود لتصدير بيانات التكوين

يمكنك إعادة استخدام ملف مخطط تم إنشاؤه باستخدام أداة ترحيل التكوين لتصدير البيانات سريعًا عبر مثيلات Dynamics 365 دون الحاجة لإنشاء المخطط كله مرة أخرى.

  1. ابدأ تشغيل أداة ترحيل التكوين.

  2. على الشاشة الرئيسية، انقر فوق تصدير البيانات،ثم انقر فوق متابعة.

  3. على شاشة تسجيل الدخول ، قم بإدخال تفاصيل المصادقة للاتصال بمثيل Dynamics 365 الخاص بك المراد تصدير البيانات منه. إذا كان لديك مؤسسات متعددة على خادم Dynamics 365 وأردت تحديد المنظمة المراد تصدير البيانات منها، حدد مربع الاختيار عرض قائمة المؤسسات المتاحة دائمًا. انقر فوق تسجيل الدخول.

  4. إذا كان لديك مؤسسات متعددة، وقمت بتحديد مربع الاختيار عرض قائمة المؤسسات المتوفرة دائمًا ، ستظهر لك الشاشة التالية لتحديد المؤسسة المراد التوصيل بها. حدد إحدى منظمات Dynamics 365 للاتصال بها.

  5. في الشاشة التالية، حدد ملف المخطط ليُستخدم لتصدير البيانات.

  6. حدد الاسم وموقع ملف البيانات ليتم تصديره.

  7. انقر فوق تصدير البيانات. تعرض الشاشة حالة تقدم التصدير وموقع الملف المُصدر في أسفل الشاشة بمجرد اكتمال عملية التصدير.

  8. المس إنهاء لإغلاق الأداة.

انظر أيضا

تعديل مخطط بيانات تكوين
إدارة بيانات التكوين
‏‫استيراد بيانات التكوين

© 2017 Microsoft. جميع الحقوق محفوظة. حقوق النشر