Po přesunutí vzdálené poštovní schránky z místního Exchange Server prostředí do Microsoftu 365 nejde získat přístup k poštovní schránce pomocí Outlooku

Příznaky

Když přesunete poštovní schránku uživatele z místního Microsoft Exchange Server prostředí do Microsoftu 365, nebude mít uživatel přístup k poštovní schránce pomocí Microsoft Outlooku. Uživatel ale může k poštovní schránce přistupovat pomocí Outlook Web App.

Kromě toho se může zobrazit chybová zpráva v Konzola pro správu serveru Exchange, která se po přesunutí vzdálené poštovní schránky, která selhala, podobá následující:

<Date><Time> [] <Date> <Time> [] Po přesunutí se nepodařilo převést zdrojovou poštovní schránku Primary (00000000-0000-0000-00000000000) na uživatele s povolenou poštou. Pokus 6/6. Chyba: UpdateMovedMailboxPermanentException.

Příčina

K tomuto problému může dojít, pokud zakážete dědičnost oprávnění u cílového uživatele ve schématu místní Active Directory.

Proto i když je místní poštovní schránka uživatele označená jako přesunutá v Exchange Server, nepřevádí se na poštovní schránku vzdáleného uživatele podle očekávání. Místní poštovní schránka uživatele dál zahrnuje běžného uživatele s povolenou poštovní schránkou.

Řešení

Chcete-li tento problém vyřešit, postupujte takto:

  1. Identifikujte všechny vlastnosti uživatele v poštovní schránce a pak tyto informace uložte do textového souboru. Uděláte to tak, že otevřete prostředí Exchange Management Shell a pak spustíte následující příkaz:

    Get-Mailbox <UserMailbox> | fl | Out-File C:\UserMailbox.txt
    
  2. Zakažte místní poštovní schránku uživatele. K tomu použijte jednu z následujících metod:

    • Pomocí Konzola pro správu serveru Exchange zakažte místní poštovní schránku uživatele.
    • Pomocí prostředí Exchange Management Shell zakažte místní poštovní schránku uživatele. Provedete to spuštěním následujícího příkazu prostředí Exchange Management Shell:
    Disable-Mailbox <UserMailbox>
    

    Další informace o této rutině naleznete v tématu Zakázání poštovní schránky.

  3. Převeďte místní poštovní schránku uživatele na poštovní schránku vzdáleného uživatele. Provedete to spuštěním následující rutiny prostředí Exchange Management Shell:

    Enable-RemoteMailbox -Identity <UserName> -RemoteRoutingAddress <UserName@domain.mail.onmicrosoft.com>
    
  4. Po zřízení vzdálené poštovní schránky upravte všechny atributy vlastní poštovní schránky (například legacyExchangeDN atribut), které chcete a které nebyly přiřazeny zásadami e-mailové adresy k uživatelskému účtu.

Další informace

Poznámka

V Microsoft Exchange 2010 se vzdálená poštovní schránka skládá z uživatele s povolenou poštou, který existuje v místní Active Directory, a přidružené poštovní schránky, která existuje v cloudové službě.

Další informace o rutinách, které jsou uvedeny v tomto článku, najdete v tématu:

Stále potřebujete pomoc? Přejděte na web Microsoft Community.