Poradce při potížích s importem a registrací zařízení autopilota

Platí pro:

  • Windows 11
  • Windows 10

Informace o problémech, ke kterým může dojít při importu a registraci zařízení do Intune, najdete v následujících částech.

Kód chyby 0x80180014 při opětovné registraci pomocí režimu vlastního nasazení nebo předběžného zřizování

Po prvním nasazení Autopilota se zařízení s cílovým režimem automatického nasazení nebo profilem režimu předběžného zřízení nesmět automaticky znovu zaregistrovat pomocí autopilota. Pokud se pokusíte zařízení znovu nasadit, vrátí se 0x80180014 kód chyby:

Stránka stavu registrace zobrazuje 0x80180014 chybový kód na zařízeních s režimem vlastního nasazení nebo režimem předběžného zřizování.

Stránka předběžného zřizování zobrazuje 0x80180014 chybový kód na zařízeních s režimem vlastního nasazení nebo režimem předběžného zřizování.

V protokolech ETW se může zobrazit následující chybová zpráva:

MDM Enroll: Server Returned Fault/Code/Subcode/Value=(DeviceNotSupported) Fault/Reason/Text=(Enrollment blocked for AP device by SDM One Time Limit Check)

Příčina A

Microsoft Endpoint Manager režim automatického nasazení Windows autopilota (Public Preview) a režim předběžného zřizování (dříve označované jako bílá rukavice) v prostředí Public Preview. Pokud chcete zařízení znovu použít, musíte odstranit záznam zařízení vytvořený Intune.

Tato změna má vliv na všechna nasazení Autopilota, která používají režim vlastního nasazení nebo předběžného zřizování. Tato změna ovlivní zařízení, když se znovu použije, resetuje nebo při opětovném nasazení profilu.

Řešení A

Opětovné nasazení zařízení pomocí autopilota:

  1. Odstraňte záznam zařízení v Intune. Konkrétní postup najdete v tématu Odstranění zařízení z centra Endpoint Manager správy.
  2. Znovu nasaďte profil nasazení Autopilota.

Příčina B

Windows registrace MDM je ve vašem tenantovi Intune zakázaná.

Rozlišení B

Pokud chcete tento problém vyřešit v samostatném prostředí Intune, postupujte takto:

  1. V centru Microsoft Endpoint Manager správy zvolte DevicesEnrollment restrictions (Omezení zápisu > zařízení) a pak zvolte omezení typu zařízení.
  2. Zvolte VlastnostiEdit > vedle nastavení platformy. Pak vyberte Povolit Windows (MDM)..
  3. Vyberte Revize a pak Uložit.

Problémy s importem zařízení

Chyba hash zařízení nelze převést.

Popis

  • Kliknutí na Importovat po výběru csv neprokauje nic
  • V trasování sítě se zobrazí chyba 400 s textem chyby "Nelze převést literál [DEVICEHASH]" na očekávaný typ Edm.Binary.

Příčina

Tato chyba odkazuje na nesprávně formátovaný algoritmus hash zařízení. Příčinou této chyby může být všechno, co poškodí shromážděnou hodnotu hash. Jednou z možností je, že samotná hodnota hash (i když je platná) se nekóduje.

Vysvětlení

Hodnota hash zařízení je Base64. Na úrovni zařízení je kódovaný jako nenapadovaný base64, ale Autopilot očekává, že je základna Base64 vycpána. Datová část obvykle nevyžaduje odsazení a proces funguje. Někdy se ale datová část neskládá čistě a výplň je nutná. V takovém případě se zobrazí výše uvedená chyba. Dekodér Base64 v PowerShellu také očekává, že je base64 vycpaný, takže tento dekodér můžeme použít k ověření, jestli je hodnota hash správně polstrovaná.

Znaky "A" na konci hodnoty hash jsou efektivně prázdná data. Každý znak v base64 je 6 bitů, A v base64 je 6 bitů rovno 0. Odstraněním nebo přidáním As na konci se nezmění skutečná data datové části.

Řešení

Pokud chcete tento problém vyřešit, budeme muset změnit hodnotu hash a potom otestovat novou hodnotu, dokud PowerShell nebude dekódování hodnoty hash úspěšné. Výsledek je většinou nečitelný, což je v pořádku. Jenom hledáme, aby nevyhodil chybu "Neplatná délka pro matici nebo řetězec znaků typu Base-64".

K otestování base64 můžete použít následující PowerShell:

[System.Text.Encoding]::ascii.getstring( [System.Convert]::FromBase64String("DEVICE HASH"))

Takže jako příklad (to není hodnota hash zařízení, ale je špatně zarovnáná, takže je to dobré pro testování):

[System.Text.Encoding]::ascii.getstring( [System.Convert]::FromBase64String("Q29udG9zbwAAA"))

Teď platí pravidla odsazení. Znak odsazení je "=". Znak odsazení může být jenom na konci hodnoty hash a může být maximálně dva znaky odsazení. Tady je základní logika.

  • Nefunguje dekódování hodnoty hash?
  • Ano: Jsou poslední dva znaky "="?
    • Ano: Nahraďte oba znaky "=" jedním znakem "A" a pak to zkuste znovu.
    • Ne: Přidejte na konec další znak =, pak to zkuste znovu.
  • Ne: Tato hodnota hash je platná.

Opakováním logiky výše u hodnoty hash předchozího příkladu se zobrazí následující permutace:

  • Q29udG9zbwAAA
  • Q29udG9zbwAAA=
  • Q29udG9zbwAAA==
  • Q29udG9zbwAAAAA
  • Q29udG9zbwAAAA=
  • Q29udG9zbwAAAA== (Tahle má platné odsazení)

Nahraďte shromažďované hodnoty hash touto novou hodnotou hash a zkuste ho znovu importovat.

Problémy s registrací Intune

Pomoc s problémy s registrací Intune najdete v tomto článku znalostní báze. Běžné problémy mohou zahrnovat"

  • nesprávné nebo chybějící licence přiřazené uživateli.
  • příliš mnoho zařízení zaregistrovaná pro uživatele.

Kód chyby 80180018 se obvykle hlásí na chybové stránce s názvem "Něco se pokazilo". Tato chyba znamená, že registrace MDM se nezdařila.

Pokud automatické resetování selže okamžitě s chybou Došlo k potížím. Přihlaste se prosím pomocí účtu správce a podívejte se, proč a resetujte ho ručně, najdete další nápovědu v tématu Poradce při potížích s automatickým resetováním .

Windows Autopilot – známé problémy
Diagnostika chyb MDM v Windows 10