CMTrace

Platí pro: Správce konfigurace (aktuální větev)

CMTrace je jedním z Správce konfigurace nástrojů. Umožňuje zobrazit a sledovat soubory protokolu, včetně následujících typů:

  • Soubory protokolu ve Správce konfigurace nebo ve formátu CCM (Client Component Manager)

  • Prosté textové soubory ASCII nebo Unicode, například protokoly Windows instalačního programu

Nástroj pomáhá analyzovat soubory protokolu zvýrazněním, filtrováním a vyhledáváním chyb.

Poznámka

Funkce CMTrace není automaticky zaregistrovaná u Windows k otevření přípony souboru .log. Další informace najdete v tématu Přidružení souborů.

Správce konfigurace verze 2107 obsahuje několik vylepšení výkonu v prohlížeči protokolů CMTrace.

Umístění

Správce konfigurace cmTrace automaticky nainstaluje v následujících umístěních:

  • Adresář nástrojů webového serveru Příklad: cd.latest\SMSSETUP\Tools\CMTrace.exe
  • Instalační adresář bodu správy Příklad: C:\SMS_CCM\CMTrace.exe
  • Instalační adresář klienta. Příklad: C:\Windows\CCM\CMTrace.exe
  • Spouštěcí bitové kopie nasazení operačního systému Příklad: X:\sms\bin\x64\CMTrace.exe

Pokud máte kopii nástroje CMTrace na jiném místě, zvažte její odebrání a použití kopie v jedné z výchozích cest. Pokud je ve vlastním umístění, které splňuje vaše obchodní požadavky, ujistěte se, že máte proces, který bude aktuální. Pokud by vaše vlastní umístění mohlo být přínosné pro ostatní zákazníky, zpětnou vazbu k produktu.

Skript je k dispozici v centru Community, který vám pomůže najít a aktualizovat verze nástroje CMTrace na nejnovější verzi: CMTraceUpdate. Další informace najdete v tématu Přímé odkazy na Community centrálních položek.

Použití

Spusťte CMTrace.exe. Při prvním spuštění nástroje se zobrazí výzva k přidružení souborů. Další informace najdete v tématu Přidružení souborů.

Většinu akcí v nástroji CMTrace můžete provádět z následujících nabídek:

Nabídka Soubor

V nabídce Soubor jsou k dispozici následující akce:

Nabídka Soubor obsahuje také posledních osm posledních souborů. Jeden z těchto protokolů můžete rychle znovu otevřít tak, že ho vyberete z nabídky Soubor.

Otevřít

Zobrazí dialogové okno Otevřít a vyhledejte soubor protokolu.

Filtrování zobrazení pro soubory následujících typů:

  • Soubory protokolu ( * .log)
  • Staré soubory protokolu ( * .lo_)
  • Všechny soubory ( * . * )

Ve výchozím nastavení nejsou vybrané následující dvě možnosti:

  • Ignorovat existující řádky: Pokud je tato možnost vybraná, funkce CMTrace ignoruje existující obsah vybraného souboru protokolu a zobrazí nové řádky jenom po jejich přidání. Pomocí této možnosti můžete sledovat jenom nové akce, když nepotřebujete úplnou historii souboru protokolu.

  • Sloučit vybrané soubory: Pokud tuto možnost povolíte a vyberete více než jeden soubor protokolu, nástroj CMTrace sloučí vybrané protokoly v zobrazení. Zobrazí je jako jeden soubor protokolu. Sloučený protokol se aktualizuje stejně a podporuje všechny ostatní funkce CMTrace, jako by se jednaly o jeden soubor protokolu.

Otevřít na serveru

Pomocí standardního dialogového okna Procházet můžete procházet složku Správce konfigurace protokoly na počítači se systémem webu. Můžete také procházet síť pro vzdálený počítač.

Když vyberete vzdálený počítač, který chcete procházet, nástroj CMTrace vyhledá Správce konfigurace sdílení. Pokud nemůžete najít sdílení se soubory Správce konfigurace protokolu, zobrazí se chybová zpráva.

Pokud se chcete připojit přímo k známému počítači bez procházení, použijte akci Otevřít. Potom zadejte název serveru a sdílejte ho ve formátu UNC.

Tisk

Zobrazení standardního Windows Tisk Tato akce odešle aktuální soubor protokolu na tiskárnu. Formátuje výstup podle nastavení na kartě Tisk v předvolbách CMTrace.

Předvolby

Nakonfigurujte nastavení nástroje CMTrace. Dostupné jsou následující možnosti:

  • Karta Obecné

    • Interval aktualizace: Určuje, jak často nástroj CMTrace kontroluje změny souborů protokolu a načte nové řádky. Ve výchozím nastavení je tato hodnota 500 milisekund.

    • Zvýraznění: Nastaví barvu, kterou nástroj CMTrace použije při zvýraznění řádků protokolu, které vyberete. Ve výchozím nastavení je tato barva základní žlutá (červená: 255, zelená: 255, modrá: 0).

    • Sloupce: Nakonfiguruje sloupce, které jsou viditelné v zobrazení protokolu, a pořadí, ve kterém se zobrazují. Ve výchozím nastavení se zobrazí text protokolu, součást, datum a čas a vlákno.

  • Karta Tisk

    • Sloupce: Nakonfigurujte sloupce, které se používají při tisku souborů protokolu, a pořadí, ve kterém se zobrazují. Ve výchozím nastavení se vytisknou stejné sloupce, které se zobrazí.

    • Orientace: Nastaví výchozí orientaci tisku při tisku souborů protokolu. Toto nastavení v dialogovém okně Tisk přepište. Ve výchozím nastavení používá orientaci na výšku.

  • Karta Upřesnit

    • Interval aktualizace: Vynutí nástroj CMTrace aktualizovat zobrazení protokolu v zadaném intervalu při načítání velkého počtu řádků. Ve výchozím nastavení je tato možnost zakázaná s nulovou hodnotou.

      Poznámka

      Obecně platí, že interval aktualizace neupravujte. Může výrazně zvětšit dobu, kterou trvá otevření velkých souborů protokolu.

Nabídka Nástroje

V nabídce Nástroje jsou dostupné následující akce:

Najít

V otevřeném souboru protokolu vyhledejte zadaný textový řetězec.

Najít další

Vyhledá další odpovídající řetězec, jak jste dříve zadali v dialogovém okně Najít.

Kopírování do schránky

Zkopíruje vybrané řádky jako prostý text do Windows schránky. Pokud zkoumáte soubory protokolu Správce konfigurace CCM, zkopíruje sloupce ve stejném pořadí jako zobrazení. Odděluje každý sloupec znakem tabulátoru. Tuto akci použijte při kopírování protokolů do e-mailových zpráv nebo jiných dokumentů.

Zvýraznění

Zadejte řetězec, který CMTrace používá k hledání textu jednotlivých hledaní. Potom zvýrazní text protokolu, který odpovídá zadanému řetězci.

  • Zvýraznění používá barvu, kterou jste zadali v předvolbách.

  • Pokud chcete zvýraznění vypnout, zrušením zaškrtnutí řetězce z tohoto pole.

  • Pokud zadáte desetinné číslo nebo šestnáctkové číslo, pokusí se funkce CMTrace shodovat s hodnotou sloupce Vlákno. Pomocí tohoto chování můžete zvýraznit zpracování jednoho vlákna bez filtrování dalších vláken, která s ním můžou pracovat.

  • Pokud chcete porovnat řetězce podle písmen, povolte možnost Rozlišovat malá a velká písmena .

Filtrovat

Zobrazení nebo skrytí řádků protokolu na základě zadaných kritérií Filtry můžete použít u libovolného ze čtyř sloupců bez ohledu na to, jestli jsou viditelné. Tato nastavení platí pro každý otevřený soubor protokolu.

Příklady:

  • Vyfiltrujte smsts.log při zadávání textu obsahujícího "akci" nebo "skupinu".
  • Filtrovat InventoryAgent.log, kde text položky obsahuje "cíl".

Vyhledávání chyb

Pokud chcete zobrazit popis, zadejte nebo vložte kód chyby v desítkovém nebo šestnáctkovém formátu. Mezi možné zdroje chyb patří: Windows, WMI nebo Winhttp.

Pozastavit

Pozastavení nebo restartování sledování protokolu Následující případy použití jsou některé z možných důvodů použití této akce:

  • Když nástroj CMTrace zobrazuje informace o souboru protokolu příliš rychle

  • Když sledování protokolu pozastavíte, informace, které cmTrace zobrazí, se neztratí, pokud se aktuální soubor vrátí do nového protokolu.

  • Pokud chcete, aby funkce CMTrace při kontrole souboru protokolu přestala zobrazovat nová data

Zobrazení nebo skrytí podrobností

Zobrazení nebo skrytí všech sloupců kromě textu protokolu Rozšíří se také textový sloupec protokolu na šířku okna. Tuto akci použijte, když si prohlížíte protokoly na počítači s nízkým rozlišením zobrazení. Zobrazí víc textu protokolu.

Poznámka

Při prohlížení souborů ve formátu prostého textu nástroj CMTrace automaticky skryje podrobnosti, protože jsou vždy prázdné.

Zobrazení nebo skrytí podokna informací

Zobrazení nebo skrytí podokna Informace Tuto akci použijte, když si prohlížíte protokoly na počítači s nízkým rozlišením zobrazení. Zobrazí další podrobnosti protokolování.

Podokno Protokolu

Podokno protokolu je v horní části okna CMTrace. Zobrazuje řádky ze souborů protokolu.

Když vyberete čáru, dočasně se zvýrazní pomocí barevného schématu Windows výběru.

Zvýrazněné čáry odpovídají kritériím, která definujete, pomocí možnosti Zvýraznit v nabídce Nástroje. Zvýraznění používá barvu, kterou zadáte v předvolbách.

Funkce CMTrace zobrazuje čáry s chybami pomocí červeného pozadí a žluté barvy textu. V protokolech formátu CCM mají položky protokolu explicitní hodnotu typu, která označuje položku jako chybu. U jiných formátů protokolu nástroj CMTrace hledá v každé položce malá a velká písmena pro libovolný textový řetězec odpovídající chybě.

Zobrazuje čáry s upozorněními pomocí žlutého pozadí. V protokolech formátu CCM mají položky protokolu explicitní hodnotu typu, která označuje položku jako upozornění. U jiných formátů protokolu nástroj CMTrace hledá v každé položce malá a velká písmena pro libovolný textový řetězec, který odpovídá "upozornit".

Informační podokno

Podokno Informace je v dolní části okna CMTrace. Obsahuje následující funkce:

  • Podrobnosti o aktuálně vybrané položce protokolu

  • Textové pole zobrazující text protokolu

  • Zobrazí konce řádku, aby byl formátovaný text snadněji čitelný.

  • Snadnější čtení dlouhých položek, které nejsou plně viditelné v podokně Protokolu

Zobrazení nebo skrytí podokna Informace s možností Zobrazit nebo skrýt podokno informací v nabídce Nástroje Pokud podokno Informace zabírá víc než polovinu okna protokolu, nástroj CMTrace ho automaticky skryje.

Indikátor průběhu

Při prvním otevření souboru protokolu nahradí nástroj CMTrace podokno Informace indikátorem průběhu. Tento postup označuje, kolik obsahu existujícího souboru je načteno. Průběh dosáhne 100 procent, funkce CMTrace odebere indikátor průběhu a nahradí ho podoknem Informace. Když načítáte velké soubory, toto chování vám poskytne informace o tom, jak dlouho může zatížení trvat.

Stavový řádek

U Správce konfigurace souborů protokolu ve formátu CCM a FORMÁTU CCM se na stavovém řádku zobrazí uplynulý čas pro vybrané položky protokolu. Pokud vyberete jednu položku, zobrazí nástroj čas od první položky protokolu k vybrané položce. Pokud vyberete více položek, vypočítá se čas od nejvíce vybrané položky k nejspodnější vybrané položce. Funkce CMTrace tyto informace naformátuje takto:

Elapsed time is <hours>h <minutes>m <seconds>s <milliseconds>ms (<seconds+milliseconds> seconds)

Windows prostředí

NÁSTROJ CMTrace podporuje přidružení souborů a přetahování .

Přidružení souborů

CmTrace se může přidružit k příponě .log a .lo_ názvů souborů. Když se program spustí, zkontroluje registr a zjistí, jestli už je přidružený k těmto příponám názvů souborů. Pokud funkce CMTrace ještě není přidružená k žádným příponě názvů souborů, zobrazí se výzva k přidružení přípon názvů souborů k nástroji CMTrace. Pokud vyberete Možnost Nezeptat se mě na toto znovu , funkce CMTrace tuto kontrolu přeskočí při každém spuštění na tomto počítači.

Přetažení

Nástroj CMTrace podporuje základní funkce přetažení. Přetáhněte soubor protokolu z Windows Průzkumníka do nástroje CMTrace a otevřete ho.

Další tipy

Klíč registru Poslední adresář

Ve výchozím nastavení ukládá funkce CMTrace poslední umístění protokolu, které jste otevřeli. Toto chování je užitečné na serveru webu, protože se pokaždé používá jako výchozí cesta k protokolům.

Při prvním spuštění v klientovi se ve výchozím nastavení spustí aktuální pracovní adresář. Toto umístění může být cesta, kam jste uložili CMTrace nebo cestu jako %userprofile%\Desktop .

Hodnota Poslední adresář v klíči registru určuje toto výchozí HKEY_CURRENT_USER\Software\Microsoft\Trace32 umístění. Pokud nastavíte tuto hodnotu na klienty, cmTrace otevře soubory v umístění protokolu klienta při %windir%\CCM\Logs prvním spuštění.

Další kroky

OneTrace je prohlížeč protokolů s Centrem podpory. Funguje podobně jako CMTrace s vylepšeními. Další informace najdete v tématu Centrum podpory OneTrace.