Issue with UI flows UIAElementNotFound error

This article provides steps to solve the UIAElementNotFound error that occurs when running UI flows.

Applies to:   Power Automate
Original KB number:   4555804

Symptoms

When trying to run UI flows, you may see this error:

UIAElementNotFound.

Screenshot of the error message when running the U I flows.

Verifying issue

This error occurs if your UI flows has the property Use coordinates set to true and UI flows is unable to locate the element using coordinates and the display resolution and scale on your playback machine does not match the scale and resolution of the machine on which the UI flows was recorded. The issue can be verified by following these steps:

  1. Select and expand the Launch <Application Name> step in your UI flow.

  2. Select the Show more link.

    Screenshot to select the Show more link in the Launch Instrumented WinForms window.

  3. Verify that the properties Screen width, Screen height, Screen scale matches the display settings in your PC (shown in next step).

    Screenshot to check that the Screen width, Screen height, Screen scale match the display settings in your PC.

  4. Display Settings in your PC View display settings in Windows 10

    Screenshot to check the Display Settings in your PC.

Solving steps

  1. If your UI flows has the property Use coordinates set to true, it is required that the screen resolution & scale while recording should be the same as the screen resolution & scale during playback.
  2. Keep the app maximized while recording to get an optimum performance.