Analýza potíží s výkonem uživatelského rozhraní

Problém

Je pravděpodobné, že se v uživatelském rozhraní Azure Databricks pracuje pomalu.

Příčina

K problémům s výkonem uživatelského rozhraní obvykle dochází v důsledku latence sítě nebo databázového dotazu, který trvá déle, než se očekávalo.

Aby bylo možné tento typ problému vyřešit, je třeba shromáždit síťové protokoly a analyzovat je, abyste viděli, na jaký síťový provoz se má vliv.

Ve většině případů budete potřebovat pomoc s podporou datacihly k identifikaci a řešení problémů s výkonem uživatelského rozhraní datacihly, ale můžete také analyzovat protokoly sami pomocí nástroje, jako je například sada Har Analyzer sady nástrojů G Suite. Tento nástroj vám pomůže analyzovat protokoly a identifikovat přesné rozhraní API a dobu trvání jednotlivých požadavků.

Postup řešení potíží

Toto je postup pro Google Chrome. Další prohlížeče najdete v tématu Har Analyzer sady G Suite.

  1. Otevřete Google Chrome a pokračujte na stránku, kde k problému dochází.
  2. V panelu nabídek Chrome vyberte zobrazit > vývojářem > vývojářské nástroje.
  3. Na panelu v dolní části obrazovky vyberte kartu síť .
  4. Vyhledejte tlačítko kulatého záznamu v levém horním rohu karty síť a ujistěte se, že je červená. Pokud je šedá, klikněte na ni a začněte nahrávat.
  5. Zaškrtněte políčko u pole zachovat protokol.
  6. Kliknutím na Vymazat vymažete všechny existující protokoly na kartě síť .
  7. Reprodukování problému při zaznamenávání síťových požadavků.
  8. Po reprodukování a zaznamenání problému klikněte pravým tlačítkem myši kdekoli v mřížce síťových požadavků a otevřete místní nabídku, vyberte Uložit vše jako Har s obsahema uložte soubor do počítače.
  9. Analyzujte soubor pomocí nástroje HAR Analyzer. Pokud tato analýza problém nevyřeší, otevřete lístek podpory a nahrajte soubor HAR nebo ho připojte k e-mailu, aby ho datacihly mohli analyzovat.

Příklad výstupu z analyzátoru HAR

bez alternativního textu