Chyba "klient WinRM nemůže zpracovat žádost, když se připojujete k Exchangi Online přes vzdálené prostředí Windows PowerShell

Problém

Když se pokusíte použít vzdálené prostředí Windows PowerShell pro připojení k Microsoft Exchange Online v Microsoft Office 365, zobrazí se tato chybová zpráva:

[outlook.office365.com] Connecting to remote server failed with the following error message:
The "WinRM client cannot process the request because the server name cannot be resolved. For more information, see the about_Remote_Troubleshooting Help topic.

+ CategoryInfo : OpenError:
(System.Manageme....RemoteRunspace:RemoteRunspace) [].
PSRemotingTransportException

+ FullyQualifiedErrorId : PSSessionOpenedFailed

Příčina

Tento problém nastane, když nebyla spuštěna interní brána firewall nebo služba vzdálené správy Windows.

Řešení

Tento problém vyřešíte tak, že zkontrolujete, jestli je služba Vzdálená správa systému Windows nainstalovaná a spuštěná. Postupujte takto:

  1. Udělejte jedno z následujícího:

    • Ve Windows 8 otevřete dialogové okno Spustit stisknutím klávesy s logem Windows + R, zadejte Services. msc a stiskněte ENTER.
    • Ve Windows 7 nebo Windows Vista klikněte na Starta zadejte Services. mscin (* * Start Search * *) a stiskněte ENTER.
    • V systému Windows XP klikněte na Start, klikněte na Spustit, zadejte Services. msc a stiskněte ENTER.
  2. V okně služby poklikejte na Vzdálená správa systému Windows.

  3. Nastavte typ spouštění na ručněa pak klikněte na OK.

  4. Klikněte pravým tlačítkem myši na službu a potom klikněte na příkaz Spustit.

  5. Spuštění služby

    Poznámka

    Pokud už byla služba spuštěná, ale nereaguje, možná budete muset kliknout na restartovat.

  6. Zkuste se znovu připojit k Exchangi Online.

Další informace

Další informace o tom, jak se připojit k Exchangi Online pomocí vzdáleného PowerShellu, najdete v tématu připojení k Exchangi Online pomocí vzdáleného PowerShellu.

Stále potřebujete pomoc? Přejděte na web Microsoft Community.