Uživatelé se nemohou připojit k protokolu POP3 nebo IMAP4

Původní číslo KB:   3025138

Příznak 1

Uživatelé, kteří mají poštovní schránku na Exchange Serveru 2016 nebo Exchange Server 2013, mohou zjistit, že jejich připojení k protokolu POP3 nebo IMAP4 přestane fungovat. Navíc se mohou zobrazit následující chybová zpráva:

Microsoft. Exchange. Monitoring. ProtocolException: ověřování se nezdařilo.
Připojení se zavře. Nelze číst data z přenosového připojení:
stávající připojení bylo nuceně zavřeno vzdáleným hostitelem. Odpověď serveru při provádění
připojení: []. ---> System. IO. IOException: nejde číst data z přenosu.
připojení: stávající připojení bylo nuceně zavřeno vzdáleným hostitelem. --->
System .NET. Sockets. SocketException: existující připojení je nuceně zavřené.
Vzdálená služba hostThe se spouští, žádné události chyb a upozornění v systému nebo
Protokol aplikací.

Příznak 2

Uživatelé mohou Telnet na port POP3 nebo IMAP pomocí plně kvalifikovaného názvu domény serveru. Nezobrazují se ale. Místo toho vidí jenom prázdnou obrazovku.

Příčina

K tomuto problému dochází, protože PopProxy a nepřibližné součásti jsou v neaktivním stavu.

Pomocí Get-ServerComponentState <ServerName> příkazu můžete zkontrolovat stav součástí.

Řešení

Tento problém vyřešíte tak, že PopProxy a nepřibližné součásti budou aktivní. Postupujte takto:

  1. Pomocí následujícího příkazu Zjistěte, kterého žadatele PopProxy neaktivní:

    Get-ServerComponentState-identity <ServerName> -Component PopProxy). LocalStates

    V následujícím příkladu HealthAPI se zobrazí žadatel, který změnil stav PopProxy na neaktivní.

    snímek obrazovky Get-ServerComponentState

  2. Pomocí následujícího příkazu PopProxy aktivní:

    Set-ServerComponentState-identity <ServerName> -součást PopProxy – stav aktivní – žadatel HealthAPI

    Příklad:

    snímek obrazovky set-ServerComponentState