Email zprávy jsou nesprávně v karanténě v hybridních nasazeních Exchange, která používají centralizované řízení pošty

Původní číslo KB: 3079142

Poznámka

Průvodce hybridní konfigurací, který je součástí Konzola pro správu serveru Exchange v Microsoft Exchange Server 2010, už není podporovaný. Proto byste již neměli používat starého průvodce hybridní konfigurací. Místo toho použijte průvodce hybridní konfigurací Microsoftu 365. Další informace najdete v tématu Průvodce hybridní konfigurací Microsoftu 365 pro Exchange 2010.

Problém

Máte hybridní nasazení místních Exchange Server a Exchange Online v Microsoftu 365. V tomto nasazení použijete centralizované řízení pošty. To vynutí směrování zpráv na místní poštovní server před jejich doručením do Exchange Online poštovních schránek. V tomto scénáři se setkáte s jedním nebo více z následujících příznaků:

  • Spamová oznámení uživatelům jsou umístěna do karantény.
  • Email zprávy v seznamu povolených jsou v karanténě.
  • Email zprávy uvolněné z karantény se přerovnají.
  • Kontroly SPF (Sender Policy Framework) při druhém průchodu selžou.

Příčina

K tomuto problému dochází, pokud organizace Exchange Online nebo místní organizace není nastavená tak, aby propagovala hlavičky e-mailů mezi různými místy (to znamená z Exchange Online na místní server do Microsoftu 365).

Řešení

  1. Ověřte, že je povolené centralizované řízení pošty, které je nastavené na zvýšení úrovně záhlaví v Microsoftu 365. Postupujte takto:

    1. Připojte se k Exchange Online pomocí vzdálené relace Windows PowerShell. Další informace najdete v tématu Připojení k Exchange Online pomocí vzdáleného PowerShellu.

    2. Podívejte se na informace o konfiguraci hybridního odchozího konektoru v organizaci Exchange Online. Uděláte to spuštěním tohoto příkazu:

      Get-OutboundConnector "Contoso Outbound Connector" | Format-List
      

      Ověřte, že je hodnota vlastnosti nastavená RouteAllMessagesViaOnPremises na $true.

    3. Zobrazte informace o konfiguraci hybridního příchozího konektoru v organizaci Exchange Online. Uděláte to spuštěním tohoto příkazu:

      Get-InboundConnector "Contoso Inbound Connector" | Format-List
      

      Ověřte, že je hodnota vlastnosti nastavená CloudServicesMailEnabled na $true.

    4. V záhlavích vyhledejte následující řádek:

      X-MS-Exchange-Organization-Cross-Premises-Headers-Promoted: <Microsoft 365 Server Name>

      Například server.contoso.com.

      Poznámka

      RouteAllMessagesViaOnPremises Pokud jsou vlastnost a CloudServicesMailEnabled vlastnost nastaveny na $false a X-MS-Exchange-Organization-Cross-Premises-Headers-Promoted: <Microsoft 365 Server Name> hlavička se nenašla, toto řešení se nevztahuje na konfiguraci vaší organizace.

  2. Odešlete příchozí testovací zprávu do poštovní schránky Exchange Online tak, že zprávu nejprve směrujte přes místní server. V záhlaví zprávy vyhledejte následující řádky záhlaví X. To pomáhá naznačovat, že zpráva byla při přenosu dvakrát zkontrolována.

    • X-Forefront-Antispam-Report-Untrusted: Toto je první průchod. Dojde k tomu při prvním přijetí zprávy v Microsoftu 365. Propojovací IP adresa (CIP) na tomto řádku bude internetová IP adresa.
    • X-Forefront-Antispam-Report: Toto je druhý průchod. Dojde k tomu, když je zpráva vrácena místním serverem a je přijata podruhé v Microsoft 365. Připojující se IP adresa bude IP adresa místního serveru vaší organizace.

    Poznámka

    Pokud existuje pouze jedna hlavička X-Forefront, toto řešení se nevztahuje na konfiguraci vaší organizace.

  3. Pokud chcete zvýšit úroveň hlaviček z místního prostředí zpět na Microsoft 365, postupujte takto:

    1. Ověřte, že hlavičky nejsou aktuálně povýšené. Chcete-li to provést, zkontrolujte, jestli v hlavičce chybí následující řádek:

      X-MS-Exchange-Organization-Cross-Premises-Headers-Promoted: <On-premises Server Name>

      Například název místního serveru je contoso_on_premises.contoso.com.

    2. Vyhledejte X-OriginatorOrg v záhlavích. Bude ve formátu contoso.onmicrosoft.com.

    3. Otevřete prostředí Exchange Management Shell v Systému Exchange 2013 nebo Exchange 2010 a spusťte následující příkazy:

      • New-RemoteDomain -Name 'Hybrid Domain - contoso.onmicrosoft.com' -DomainName 'contoso.onmicrosoft.com'
        
      • Set-RemoteDomain 'Hybrid Domain - contoso.onmicrosoft.com' -TrustedMailOutboundEnabled $true -TrustedMailInboundEnabled $true
        
    4. Ověřte, že je problém opravený. Odešlete novou zprávu a pak ověřte, že v hlavičce je následující řádek:

      X-MS-Exchange-Organization-Cross-Premises-Headers-Promoted: <On-premises Server Name>

      Například název místního serveru je contoso_on_premises.contoso.com.

Další informace

Další informace naleznete v následujících zdrojích informací společnosti Microsoft: