Poštovní schránka se nezdaří s chybou "Error: MigrationPermanentException: Cílový uživatel Uživatel ' již má primární poštovní schránku."

Příznaky

Předpokládejme, že se v hybridním prostředí Microsoft Exchange. Při pokusu o připojení poštovních schránek Exchange Online do místní organizace pomocí dávky migrace v Centru pro správu Office 365 Exchange (EAC) se pokus nezdaří a zobrazí se chybová zpráva podobná následující:

'Error: MigrationPermanentException: Target user ‎'User‎' already has a primary mailbox.'.

Příčina

K tomuto problému dochází, protože HomeMDB a HomeMTA atributy jsou k dispozici na objekt uživatele v místní službě Active Directory a obsahují hodnoty.

Řešení

Chcete-li tento problém vyřešit, postupujte takto:

Krok 1: Nainstalujte modul Prostředí PowerShell služby Active Directory a spusťte jeden z následujících příkazů prostředí PowerShell a zkontrolujte hodnoty atributů homeMDB a homeMTA v objektu uživatele.

Možnost příkazu 1

Get-ADUser -Filter {userprincipalname -eq 'user@contoso.com'} -properties homemdb,homemta

Možnost příkazu 2

Get-ADUser -Identity 'SAMAccountName of the user' -properties homemdb,homemta

Krok 2: Vymazání hodnot atributů homemdb a homemta. Chcete-li to provést, spusťte některý z následujících příkazů prostředí PowerShell:

Možnost příkazu 1

Get-ADUser -Filter {userprincipalname -eq 'user@contoso.com'} -properties homemdb,homemta | Set-ADObject -clear homemdb,homemta

Možnost příkazu 2

Get-ADUser -Identity 'SAMAccountName of the user' -properties homemdb,homemta | Set-ADobject -clear homemdb,homemta

Krok 3: Vyberte ovlivněné uživatele v dávce migrace a spusťte dávku přesunout uživatele znovu. V tomto kroku můžete také použít následující příkaz prostředí PowerShell:

Start-MigrationUser -Identity user@contoso.com