Supported platforms for Machine Learning Server and Microsoft R Server

Machine Learning Server runs on-premises on Windows, Linux, Hadoop Spark, and SQL Server. It is also in multiple cloud offerings, such as Azure Machine Learning Server VMs, SQL Server VMs, Data Science VMs, and on Azure HDInsight for Hadoop and Spark. In Public Preview, you can get Machine Learning Server on Azure SQL DB, Azure Machine Learning, and Azure Data Lake Analytics.

This article specifies the operating systems and platforms for on-premises installations of Machine Learning Server and Microsoft R Server.

Note

64-bit operating systems with x86-compatible Intel architecture (commonly known as AMD64, Intel64, x86-64, IA-32e, EM64T, or x64 chips) are required on all platforms. Itanium-architecture chips (also known as IA-64) are not supported. Multiple-core chips are recommended.

Machine Learning Server 9.3

In this release, R support includes Microsoft R Open 3.4.3, based on R-3.4.3. Python support is based on Anaconda 4.2 over Python 3.5. We support Apache Spark 2.0 and 2.4 through a Hadoop distribution on CDH, HDP, or MapR.

Operationalization is available on server platforms, on operating systems supporting .NET Core, version 2.0. MicrosoftML (R) has a .NET Core dependency for scoring, but runs on both client and server operating systems. These requirements affect feature availability on some platforms.

Operating system or platform SKU Operationalization? MicrosoftML for R?
Windows 10
Windows 8.1
Windows 7 SP1
Machine Learning Server for Windows
(developer edition)
No Yes
Windows Server 2016
Windows Server 2012 R2
Machine Learning Server for Windows Yes Yes
CentOS/ RedHat 6.x - 7.x Machine Learning Server for Linux 6.x - No
7.x - Yes
6.x - No
7.x - Yes
Ubuntu 14.04
Ubuntu 16.04
Machine Learning Server for Linux Yes Yes
SUSE Linux Enterprise Server 11 SP3 and above Machine Learning Server for Linux No No
Cloudera CDH 5.7-5.12 Cloudera Manager installation Edge nodes only All nodes
Hortonworks HDP 2.4-2.6 Machine Learning Server for Hadoop Edge nodes only All nodes
MapR 5.0-5.2 Machine Learning Server for Hadoop Edge nodes only All nodes

You can install Machine Learning Server on open-source Apache Hadoop from http://hadoop.apache.org but we can only offer support for commercial distributions.

Machine Learning Server 9.2.1

R support includes Microsoft R Open 3.4.1, which is based on R-3.4.1. Python support is based on Anaconda 4.2 over Python 3.5.

SKU Platforms
Machine Learning
Server for Hadoop
Hadoop Distributions: Cloudera CDH 5.7-5.11, Hortonworks HDP 2.4-2.6, MapR 5.0-5.2
You can install Machine Learning Server on open-source Apache Hadoop from http://hadoop.apache.org but we can only offer support for commercial distributions.

Operating Systems: Red Hat Enterprise Linux 6.x and 7.x, SUSE Linux Enterprise Server 11 1, Ubuntu 14.04 and 16.04

Spark 2.0 and 2.4 through a Hadoop distribution on CDH, HDP, or MapR.

Machine Learning Server can be configured on CentOS/RHEL 7.x or Ubuntu to operationalize on edge nodes only.
Machine Learning
Server for Linux
Red Hat Enterprise Linux and CentOS 6.x 1 and 7.x
SUSE Linux Enterprise Server 11 1
Ubuntu 14.04 and 16.04
Machine Learning
Server for Windows
Windows 7 SP1 1,2, Windows 8.1 1,2, Windows 10 1,2
Windows Server 2012 R2, Windows Server 2016

1 .NET Core 1.1 platform dependency: Certain features like the machine learning algorithms in the MicrosoftML R package and configuring to operationalize your analytics are NOT supported on the marked (1) platforms since they require .NET Core.

2 Use a server OS for operationalizing analytics. We do NOT recommend that you operationalize your analytics on non-server platforms such as these marked (2). While some might work, only server platforms are supported. See the full list of supported platforms for operationalizing here.

Microsoft R Server 9.1

All SKUs include Microsoft R Open 3.3.3, based on R-3.3.3, and require 64-bit operating systems with x86-compatible Intel architecture.

SKU Platforms
R Server for Hadoop Hadoop 1, 5 Distributions:
Cloudera CDH 5.5-5.9, Hortonworks HDP 2.3-2.5, MapR 5.0-5.2
Operating Systems:
RHEL 6.x and 7.x, SUSE Linux Enterprise Server 11 (SLES11) (2, 4), Ubuntu 14.04 (2)
Spark 3:
Versions 1.6 and 2.0.
R Server for Linux Red Hat Enterprise Linux (RHEL) and CentOS 6.x(4) and 7.x
SLES11(4)
Ubuntu 14.04 and 16.04
R Server for Windows Windows 7 SP1(4), Windows 8.1(4), Windows 10(4)
Windows Server 2012 R2, Windows Server 2016
R Server for Teradata Teradata Database 14.10, 15.00, 15.10 on SUSE Linux Enterprise Server 11(4)

Hardware and software requirements for SQL Server Machine Learning Services and R Server (Standalone) in SQL Server can be found in SQL Server production documentation.

1 You can install R Server for Hadoop on open-source Apache Hadoop from http://hadoop.apache.org but we can only offer support for R Server on CDH, HDP, or MapR.

2 Cloudera installation using the built-in parcel generator script for 9.1 requires CentOS/RHEL 7.0 as the operating system. The parcel generator excludes any R Server features that it cannot install. For more information, see Install R Server 9.1 on CDH.

3 Spark integration is supported only through a Hadoop distribution on CDH, HDP, or MapR. Not all supported versions of Hadoop include a supported level of Spark. Specifically, HDP must be at least 2.3.4 to get a supported level of Spark.

4.NET Core 1.1 platform dependency: Several features in R Server have a .NET Core dependency. These features include Overview of MicrosoftML algorithms bundled in the MicrosoftML package as well as the ability to configure R Server to operationalize your R analytics. Due to the .Net Core dependency, these features are NOT available on these platforms.

5To operationalize your analytics or use the MicrosoftML package on R Server for Hadoop, you must deploy on edge nodes in a Hadoop cluster, if the underlying operating system is CentOS/RHEL 7.x or Ubuntu 14.04. It is not supported on SUSE SLES11.

Microsoft R Server 9.0.1

This release of R Server is built atop Microsoft R Open 3.3.2, which is based on R-3.3.2.

Microsoft R Server (Windows or Linux)

  • Windows 7 SP1, Windows 8.1, Windows 10, Windows Server 2012 R2, and Windows Server 2016
  • Red Hat Enterprise Linux (RHEL) and CentOS 6.x and 7.x
  • SUSE Linux Enterprise Server 11 (SLES11)
  • Ubuntu 14.04 and 16.04

Microsoft R Server for Teradata

  • Teradata Database 14.10, 15.00, 15.10
  • Operating System: SLES11

SQL Server R Services or R Server (Standalone)

Microsoft R Server for Hadoop

  • Hadoop Distributions: Cloudera CDH 5.5-5.9, Hortonworks HDP 2.3-2.5, MapR 5.0-5.2
  • Operating Systems: RHEL 6.x and 7.x, SUSE SLES11, Ubuntu 14.04 (excluding Cloudera Parcel install on Ubuntu)
  • Spark versions: 1.6 and 2.0. Not all supported versions of Hadoop include a supported level of Spark. Specifically, HDP must be at least 2.3.4 to get a supported level of Spark.

Operationalization and mrsdeploy

After installation, you can configure R Server to operationalize your R analytics. Due to an ASP .Net Core dependency, operationalization is currently supported only on:

  • Windows: Windows Server 2012 R2, Windows Server 2016
  • Linux: CentOS/RHEL 7.x, Ubuntu 14.04 and 16.04 Note: Projected availability on SLES in 2017
  • Hadoop: Linux-based edge nodes on CentOS/RHEL 7.x, Ubuntu 14.04

Note

R Server operationalization is not available on Windows if you use the SQL Server installer. You must use the standalone Windows installer to get operationalization functionality.

Microsoft R Server 8.0.5

This release of R Server is built atop Microsoft R Open 3.3.2, which is based on R-3.3.2.

Operating Systems (64-Bit only)

  • Red Hat Enterprise Linux (RHEL) 6.x and 7.x, or CentOS
  • SUSE Linux Enterprise Server 11 (SLES11)

Microsoft R Server for Teradata

  • Teradata Database 14.10, 15.00, 15.10
  • Operating System: SLES11

Microsoft R Server for Hadoop

  • Hadoop Distributions: Cloudera CDH 5.5-5.7, Hortonworks HDP 2.3-2.4, MapR 5.0-5.1
  • Operating Systems: RHEL 6.x and 7.x, SUSE SLES11
  • Spark version: 1.5.0-1.6.1 (if using Spark). Not all supported versions of Hadoop include a supported level of Spark. Specifically, HDP must be at least 2.3.4 to get a supported level of Spark.

DeployR

End of Life versions

For R Server 8.0, support ended on 1/1/2018. Please contact Microsoft if you have questions about alternatives. This version is no longer available for support.