"Heslo tohoto uživatele nejde resetovat", když správce resetuje heslo uživatele člena domény

Problém

Zvažte následující scénář: Uživatel se nemůže přihlásit ke cloudové službě Microsoftu, jako je Microsoft 365, Microsoft Azure nebo Microsoft Intune pomocí ID uživatele, který je členem domény cloudové služby, která byla dříve nastavena pro jednotné přihlašování (SSO). V tomto scénáři se správce cloudové služby pokusí resetovat heslo uživatele pomocí portálu cloudové služby nebo modulu Azure Active Directory pro Windows PowerShell, zobrazí se správci následující chybová zpráva:

Heslo tohoto uživatele nejde resetovat. Zkuste to znovu později.

Příčina

K tomuto problému dochází, pokud je uživatel členem domény cloudové služby, která byla dříve povolena jednotné přihlašování (SSO) a pokud ID uživatele nebylo převedeno na použití standardního ověřování.

K tomuto problému může například dojít, pokud byla použita následující rutina Windows PowerShell:

convert-MSOLDomainToStandard –skipuserconversion:$true 

Řešení

Pokud chcete tento problém vyřešit, převeďte ID uživatele na standardní typ (nefederovaný). Postupujte takto:

  1. Ve stejné konzole Windows PowerShell, kterou jste použili k ověření problému, zadejte následující rutinu a stiskněte Enter:
    Convert-MsolFederatedUser -userprincipalname < user ID > 
    

    Poznámka

    V této rutině zástupný symbol <ID uživatele ,> představuje ID uživatele.

  2. Zadejte uživateli dočasné heslo. Při příštím přihlášení uživatele ke cloudové službě musí před přístupem k prostředkům cloudové služby změnit dočasné heslo.

Další informace

Poznámka

Rutiny Windows PowerShell v tomto článku vyžadují modul Azure Active Directory pro Windows PowerShell.

Stále potřebujete pomoc? Přejděte na stránku Komunita Microsoft nebo Azure Active Directory Forums.