Změněné informace o objektu služby Active Directory se v adresáři ve službě Office 365/ITAR ne aktualizují.

Poznámka

Office 365 ProPlus se přejmenuje na Microsoft 365 Apps for enterprise. Pro další informace o této změně si přečtěte tento blog.

Příznaky

Když změníte nebo aktualizujete informace o objektu služby Active Directory, zjistíte, že informace nejsou aktualizovány v adresáři v Microsoft Office 365 dedicated/ITAR.

Příčina

K tomuto problému obvykle dochází, když platí jedna nebo více z následujících podmínek:

  1. Objekt není zřizovaná nebo aktualizovaná na spravovaném webu služby Active Directory službou Microsoft Online Services Identity and Provisioning Service (MMSSPP).
  2. Offline adresář (OAB) není aktuální. Klient Microsoft Outlook proto nemá nejnovější verzi, když používá Outlook v režimu cached.

Řešení

Pokud chcete tento problém vyřešit, vyhledejte nový objekt nebo aktualizované informace z aplikace Microsoft Office Outlook Web Appu (Outlook Web App) nebo Microsoftu Outlook online režimu. Oba Outlook Web App a Outlook v online režimu odkazují na informace přímo ze spravovaného webu služby Active Directory. To vám pomůže určit příslušnou další akci.

Pokud se objekt nebo aktualizované informace v aplikaci Outlook Web App, přečtěte si následující článek znalostní báze Microsoft Knowledge Base, který vám pomůže vyřešit problémy se zřizováním MMSSPP:

2615447 MMSSPP nesynchronuje Exchange poštovní schránky a poštovních objektů s vyhrazeným spravovaným Office 365 prostředím

Pokud se objekt nebo aktualizované informace zobrazují správně v aplikaci Outlook Web App, ale při použití Outlook v režimu mezipaměti, musíte určit počet uživatelů, kterých se to týká. Pokud je problém omezený na malou skupinu uživatelů, vyřešte klienta takto:

  1. Zkontrolujte Outlook, jestli je potřeba nový nástroj OAB. Postupujte takto:

    1. V nabídce Tools (Nástroje) přejděte na Send/Receive(Odeslat a přijmout) a potom klikněte na Download Address Book (Stáhnout adresář).
    2. V části Informace ke stažení klikněte na Úplné podrobnosti.
  2. Přinutit Outlook klienta ke stažení úplného OAB. Postupujte takto:

    1. Ukončete Outlook, Microsoft Lync a všechny další aplikace, které mohou mít připojení k Outlook.
    2. Otevřete Windows Průzkumníka.
    3. Změňte možnost zobrazení skrytých položek.
    4. Vyhledejte C:\Users \ <user alias> \AppData\Local\Microsoft\Outlook\Offline adresáře. (AppData je skrytá složka.)
    5. Odstraňte obsah složky Offline adresáře.
    6. Restartujte aplikaci Outlook.

    Poznámka: Tento krok byste měli použít jenom k řešení potíží, abyste zjistili, jestli v klientovi Outlook problém.

Pokud se problém týká všech uživatelů, zjistěte, jestli pro aktualizaci OAB uplynulo dost času.

Exchange servery v Office 365 vyhrazených/ITAR jsou nastavené tak, aby vygenerovaly rozdílový soubor OAB každých osm hodin. Tyto soubory spolu s mnohem větším úplným souborem OAB se distribuují na servery klientského přístupu (CAS) v prostředí zákazníka. Klient Outlook v režimu mezipaměti bude každých 24 hodin kontrolovat nový rozdílový soubor OAB. Pokud má rozdílový soubor poloviční velikost plného souboru OAB nebo větší, klient si stáhne celý soubor OAB.

Pokud chcete změnit přístup k klientskému počítači na webu služby Active Directory, musí dojít k následujícím událostem:

  • Změny na webu služby Active Directory zákazníka se replikují na upřednostňovaný řadič domény MMSSPP.
  • Uplynulo dost času, aby se změna úspěšně synchronizovala se spravovaným webem služby Active Directory procesem synchronizace PROTOKOLU MMSSPP. Obvykle to trvá 30 až 60 minut.
  • Dost času uplynulo, aby se změna dosáhnou na server generování OAB a aby se zahrnuli do nového rozdílového souboru. Obvykle to trvá 8 hodin.
  • Dost času uplynulo, aby Outlook klient pro kontrolu rozdílového nebo úplného stahování OAB. Obvykle to trvá 24 hodin.