Chyba při pokusu o povolení nebo zakázání archivační poštovní schránky pro uživatele Exchange Online nebo přesunutí poštovní schránky do místního prostředí

Poznámka

Office 365 ProPlus se přejmenuje na Microsoft 365 Apps for enterprise. Pro další informace o této změně si přečtěte tento blog.

Původní číslo KB:   3050691

Problém

Když se pokusíte povolit nebo zakázat archivační poštovní schránku pro existujícího uživatele Exchange Online nebo když se pokusíte přesunout poštovní schránku z Exchange Online do místního prostředí, zobrazí se chybová zpráva podobná jedné z následujících akcí:

Chyba: UserAlreadyBeingMigratedException: Uživatel <User Email Address> ' ' už má čekající žádost. Odeberte prosím stávající žádost a obnovte aktuální dávku nebo spusťte novou dávku pro tohoto uživatele.

K poštovní <User Display Name> schránce je přidružená dokončená žádost o přesunutí. Před vytvořením nové žádosti o přesunutí poštovní schránky spusťte rutinu Remove-MoveRequest a zrušte tak dokončenou žádost o přesunutí.

Poštovní <User Display Name> schránka ' má stav přesunutí <move status> . Během přesunu poštovní schránky nemůžete archiv povolit ani zakázat.

Když spustíte příkaz pro kontrolu žádosti o přesunutí, ověřte, že se žádost týká žádosti o přesunutí Get-MoveRequest | fl datacentra Office 365. Tento příznak je označený příznakem IntraOrg.

Příčina

K tomuto problému dochází, protože neúspěšné žádosti o přesunutí nejsou ze systému ještě odebrány.

Exchange Online pravidelně přesouvá poštovní schránky mezi různými servery, aby zachoval stav služby. Dokončené žádosti o přesunutí datacentra Office 365 se velmi rychle vyčistí. Neúspěšné žádosti o přesunutí datacentra Office 365 mohou zůstat poněkud delší, ale po určité době se vyčistí. Tyto neúspěšné žádosti o přesunutí nemají vliv na uživatele. Pokud je to potřeba, služba to v budoucnu zkusí znovu.

Řešení

Obecně platí, že pokud interní přesun datacentra nemá vliv na vaši schopnost provádět úkoly správy, můžete chybové zprávy bezpečně ignorovat.

Pokud žádosti o přesunutí mají vliv na úkoly správy, postupujte takto:

  1. Připojte se k Exchange Online pomocí vzdáleného Windows PowerShellu. Další informace najdete v tématu Připojení k Exchange Online pomocí vzdáleného PowerShellu.

  2. Ověřte, že se poštovní schránka přesouvala. Uděláte to spuštěním tohoto příkazu:

    Get-MoveRequest | fl Status, Protect, "Display Name", Identity
    

    Pokud zástupný symbol "Zobrazovaný název" odpovídá poštovní schránce, pro kterou chcete povolit nebo zakázat archivaci, probíhá přesunutí poštovní schránky. Přesunutí brání v tom, aby se změny provedly.

  3. Zkontrolujte výstup a podle potřeby proveďte jednu z následujících akcí:

    • Pokud je stav ve frontě nebo inprogre, počkejte, až se přesun dokončí. K tomu by mělo dojít za jeden nebo dva dny. Pokud nemůžete čekat tak dlouho, odeberte žádost o přesunutí spuštěním následujícího příkazu:

      Remove-MoveRequest -Identity IdentityOfFailedRequest
      
    • Pokud se stav nezdařil, odeberte žádost o přesunutí spuštěním následujícího příkazu:

      Remove-MoveRequest -Identity IdentityOfFailedRequest
      

Tato operace by neměla mít vliv na přístup uživatelů ani by neměla způsobovat žádné problémy. Navíc nemusíte upozorňovat Společnost Microsoft ani vlastníka poštovní schránky, že tuto akci chcete provést.

Další informace

Stále potřebujete pomoc? Přejděte na web Microsoft Community.