V centru Správa Microsoftu 365 nemůžete uživateli přiřadit federovanou doménu.

Problém

V centru Správa Microsoftu 365 vytvoříte nového uživatele. Když se ale pokusíte přiřadit federovanou doménu novému uživateli, není federovaná doména uvedená v seznamu domén uživatele.

Následuje příklad scénáře toho, co se stane, když narazíte na tento problém:

  • Na portálu Microsoft 365 je povolená synchronizace jednotného přihlašování (SSO) a Active Directory.
  • Při zobrazení vlastností domény na stránce vlastností domény se typ domény zobrazí jako federované nebo jednotné přihlašování. Například adatum.com je federovaná doména.
  • Když vytvoříte nového uživatele, uvidíte, že výchozí doména poskytovaná Microsoftem 365 je uvedená jako první možnost v rozevíracím seznamu. Výchozí doména je například contoso.onmicrosoft.com.
  • Když kliknutím na rozevírací seznam zobrazíte seznam domén, nebude federovaná doména uvedená. Například adatum.com není uvedený.

Příčina

Toto chování je v Microsoftu 365 záměrně. Federované uživatele nemůžete vytvářet prostřednictvím portálu. Všichni federovaná uživatelé musí být vytvořená místně a musí se synchronizovat pomocí synchronizačního nástroje Microsoft Azure Active Directory.

Poznámka

Federovanou doménu také nemůžete nastavit jako výchozí doménu v Microsoftu 365.

Řešení

Chcete-li toto chování obejít, vytvořte odpovídající uživatelský účet v prostředí místní Active Directory Doménové služby (AD DS), nastavte správně hlavní název uživatele (UPN) a pak synchronizujte účet a Microsoft Entra ID pomocí synchronizace adresářů. Uděláte to takto:

  1. Následujícím postupem získejte primární adresu SMTP uživatelského účtu Microsoft 365:

    1. Přihlaste se k portálu Microsoft 365 jako globální správce.
    2. Výběrem Správa>Exchange otevřete Exchange Správa Center.
    3. Vyhledejte uživatelský účet a poklikejte na něj.
    4. V levém navigačním podokně vyberte Email Adresa a poznamenejte si primární adresu SMTP uživatelského účtu.
  2. Spusťte Uživatelé a počítače služby Active Directory a pak v místní doméně vytvořte uživatelský účet, který odpovídá uživatelskému účtu Microsoft 365. Další informace najdete v tématu Vytvoření uživatelského účtu v Uživatelé a počítače služby Active Directory.

  3. Ujistěte se, že je hlavní název uživatele (UPN) uživatelského účtu aktualizovaný na název federované domény. Další informace najdete v tématu Řešení potíží s uživatelskými účty Active Directory, které jsou pilotovány jako ID uživatelů s povoleným jednotným přihlašováním Microsoft 365.

  4. Pomocí rozhraní ADSI (Active Directory Service Interfaces) Edit upravte atribut proxyAddresses objektu uživatele tak, aby odpovídal primární adrese SMTP, kterou jste si poznamenali v kroku 1D. Uděláte to takto:

    Poznámka

    Další informace o tom, jak nainstalovat ADSI Edit, najdete v tématu Instalace editoru ADSI.

    1. Vyberte Spustit>, zadejte ADSIEdit.msc a pak vyberte OK.

    2. Klikněte pravým tlačítkem na ADSI Upravit, vyberte Připojit k a pak výběrem OK načtěte oddíl domény.

    3. V navigačním podokně vyhledejte objekt uživatele, který chcete změnit, klikněte na něj pravým tlačítkem a vyberte Vlastnosti.

    4. V seznamu Atributy vyberte atribut proxyAddresses a pak vyberte Upravit.

    5. Do pole Hodnota, kterou chcete přidat zadejte odpovídající adresu SMTP a pak vyberte Přidat.

      Poznámka

      Hodnota primární adresy SMTP pro objekt uživatele by měla být předem označena velkými písmeny SMTP: pro hodnotu adresy, která má být správně naformátována pro atribut proxyAddressesattribute. Například "SMTP:username@contoso.com" je přijatelná hodnota a "username@contoso.com" není přijatelná hodnota.

    6. Dvakrát vyberte OK a pak ukončete funkci ADSI Edit.

    Další informace o použití editoru ADSI k úpravě atributů služby Active Directory najdete v tématu Použití editoru ADSI Edit.

  5. Vynutit synchronizaci adresářů

Další informace

Další informace najdete v tématu Řešení potíží s uživatelským jménem, ke kterým dochází u federovaných uživatelů při přihlášení k Microsoftu 365, Azure nebo Intune.

Stále potřebujete pomoc? Přejděte na web Microsoft Community.