Federovanou doménu nemůžete přiřadit uživateli v centru Správa Microsoftu 365.

Poznámka

Office 365 ProPlus se přejmenuje na Microsoft 365 Apps for enterprise. Pro další informace o této změně si přečtěte tento blog.

Problém

V centru Správa Microsoftu 365 v Office 365 vytvoříte nového Office 365. Když se ale pokusíte přiřadit federovanou doménu novému uživateli, federovaná doména není uvedená v seznamu domén uživatele.

Tady je příklad scénáře toho, co se stane, když nastane tento problém:The following is an example scenario of what happens when you experience this issue:

  • Na Office 365 portálu jsou povolené jednotné přihlašování (SSO) a synchronizace služby Active Directory.
  • Při zobrazení vlastností domény na stránce vlastností domény je typ domény uvedený jako Federované nebo Jednotné přihlašování. Například adatum.com federovaná doména.
  • Když vytvoříte nového uživatele, uvidíte, že výchozí doména poskytovaná společností Office 365 je v rozevíracím seznamu uvedená jako první možnost. Například výchozí doména je contoso.onmicrosoft.com.
  • Když kliknete na rozevírací seznam a zobrazíte seznam domén, federovaná doména nebude uvedená. Například adatum.com není uvedený.

Příčina

Toto chování je v aplikaci Office 365. Federovaní uživatelé se přes portál neschová. Všichni federovaní uživatelé musí být vytvořeni místně a musí být synchronizovaní pomocí nástroje Microsoft Azure Active Directory Synchronizace.

Poznámka

Federovanou doménu taky nemůžete nastavit jako výchozí doménu v Office 365.

Řešení

Pokud chcete toto chování vyřešit, vytvořte odpovídající uživatelský účet v místním prostředí služba Active Directory Domain Services (služba AD DS), nastavte odpovídajícím způsobem hlavní uživatelské jméno (UPN) a synchronizujte účet a Azure Active Directory pomocí synchronizace adresářů. Uděláte to takto:

  1. Získejte primární adresu SMTP uživatelského Office 365 pomocí následujících kroků:

    1. Přihlaste se k Office 365 jako globální správce.
    2. Vyberte Správce > Exchange a otevřete Exchange Centrum pro správu.
    3. Vyhledejte uživatelský účet a poklikejte na něj.
    4. V levém navigačním podokně vyberte E-mailová adresa a poznamenejte si primární adresu SMTP uživatelského účtu.
  2. Spusťte Active Directory Users and Computers a potom vytvořte uživatelský účet v místní doméně, který odpovídá Office 365 účtu. Další informace najdete v tématu Vytvoření uživatelského účtu v active directory Users and Computers.

  3. Ujistěte se, že hlavní název uživatele uživatelského účtu je aktualizován na název federované domény. Další informace najdete v tématu Poradce při potížích s uživatelskými účty služby Active Directory,které jsou pilotní Office 365 ID uživatelů s povolenou jednotného přihlašování.

  4. Pomocí úpravy rozhraní ADSI (Active Directory Service Interfaces) upravte atribut proxyAddresses uživatelského objektu tak, aby odpovídal primární adrese SMTP, kterou jste si v kroku 1D všimli. Uděláte to takto:

    Poznámka

    Další informace o tom, jak nainstalovat úpravy rozhraní ADSI, najdete v článku Instalace editoru ROZHRANÍ ADSI.

    1. Vyberte Spustit > spustit, zadejte ADSIEdit.msc a pak vyberte OK.

    2. Klikněte pravým tlačítkem myši na úpravy rozhraní ADSI, vyberte Připojení na a potom kliknutím na OK načtěte oddíl domény.

    3. V navigačním podokně vyhledejte objekt uživatele, který chcete změnit, klikněte na něj pravým tlačítkem myši a pak vyberte Vlastnosti.

    4. V seznamu Atributy vyberte atribut proxyAddresses a pak vyberte Upravit.

    5. Do pole Přidat hodnotu zadejte příslušnou adresu SMTP a pak vyberte Přidat.

      Poznámka

      Primární hodnota adresy SMTP pro objekt uživatele by měla být předpřipravována velkými písmeny SMTP: pro atribut proxyAddresses by měla být hodnota adresy správně formátovaná. Například " SMTP:username@contoso.com " je přijatelná hodnota a " " není username@contoso.com přijatelná hodnota.

    6. Dvakrát vyberte OK a potom ukončete úpravy rozhraní ADSI.

    Další informace o použití funkce ADSI Edit k úpravám atributů služby Active Directory najdete v tématu Použití editoru ROZHRANÍ ADSI.

  5. Vynutí synchronizaci adresářů.

Další informace

Další informace najdete v článku Řešení problémů s uživatelským jménem, ke kterým dochází u federovaných uživatelů při přihlášení Office 365, Azure nebo Intune.

Stále potřebujete pomoc? Přejděte na web Microsoft Community.