"Tuto doménu nelze odebrat", když se pokusíte odebrat doménu z Office 365

Poznámka

Office 365 ProPlus se přejmenuje na Microsoft 365 Apps for enterprise. Pro další informace o této změně si přečtěte tento blog.

Problém

Když se pokusíte odebrat doménu z Microsoft Office 365 pomocí Windows PowerShell, zobrazí se následující chybová zpráva:

Remove-MsolDomain : Unable to remove this domain. Use Get-MsolUser -DomainName<domain name> to retrieve a list of objects that are blocking removal.
At line:1 char:18
+ Remove-MsolDomain <<<< -DomainName <DomainName>
+ CategoryInfo : OperationStopped: (:) [Remove-MsolDomain], MicrosoftOnlineException
+ FullyQualifiedErrorId : Microsoft.Online.Administration.Automation.DomainNotEmptyException,Microsoft.Online.Administration.Automation.RemoveDomain

Příčina

K tomuto problému dochází, pokud platí jedna nebo více z následujících podmínek:

  • K doméně jsou přidružené uživatelské účty nebo skupiny.
  • Názvy domén, které odpovídají doméně pro všechny uživatele s licencí pošty a pro všechny skupiny s podporou pošty, se odebrané nebudou. Office 365 blokuje odstranění domény, dokud se nez odebere názvy, které odpovídají této doméně.
  • Skype pro firmy domény používají adresy SIP (Online) (dřív Lync Online).

Řešení

Pomocí Centrum pro správu Microsoftu 365 doménu odeberte. Správce domény v Office 365 pomůže správcům odebrat všechny závislosti, které blokují odebrání domény, aniž by museli Windows PowerShell.

Další informace o tom, jak odebrat doménu v Centrum pro správu Microsoftu 365, najdete v tématu Odebrání domény.

Poradce při potížích s odebráním domény pomocí Windows PowerShell

Poznámka

Následující postup vyžaduje, aby správci Windows PowerShell.

Krok 1: Zkontrolujte, jestli uživatelská jména obsahují název domény.

Poznámka

Můžete taky vytvořit zobrazení uživatele a potom nastavit doménu na doménu, kterou chcete odebrat. V tomto zobrazení si poznamenejte uživatelská jména a změňte uživatelská jména tak, aby ádná doména není součástí uživatelského jména.

Pokud chcete zkontrolovat, jestli uživatelská jména obsahují název domény, postupujte takto:

  1. Připojení Microsoft Azure Active Directory pomocí modulu Azure Active Directory pro Windows PowerShell. Pokud to chcete udělat, otevřete Azure Active Directory moduly pro Windows PowerShell, zadejte následující rutinu a stiskněte Enter.
    Connect-MsolService
    
    Až se zobrazí výzva, zadejte přihlašovací údaje správce.
  2. Spusťte následující rutinu:
    Get-MsolUser -DomainName [Domain] | fl UserPrincipalName  
    
    Spusťte třeba následující příkaz, ve kterém zástupný contoso.com představuje doménu:
    Get-MsolUser -DomainName contoso.com | fl UserPrincipalName
    
  3. Zkontrolujte výsledky a změňte hlavní uživatelské jméno (UPN), aby se doména nepoužíla. Hlavní název uživatele je stejný jako uživatelské jméno a vlastnost ID uživatele. Hlavní název uživatele můžete Office 365 nebo Windows PowerShell změnit. Cílem je, aby se nevrátily žádné výsledky.

Krok 2: Kontrola e-mailových adres

Poznámka

  • Tento krok platí jenom v případě, že máte předplatné, které zahrnuje Exchange Online.
  • Pokud používáte nástroj Azure Active Directory synchronizace, můžete aktualizovat e-mailové adresy z místního prostředí.

Pokud chcete zkontrolovat e-mailové adresy, postupujte takto:

  1. Připojte se k Exchangi Online pomocí vzdáleného PowerShellu. Další informace o tom, jak to udělat, najdete v tématu Připojení k Exchange Online pomocí vzdáleného PowerShellu.

  2. Najděte všechny uživatele a skupiny, které používají doménu, kterou chcete odebrat. Pokud to chcete udělat, spusťte následující rutinu. (V této rutině contoso.com představuje doménu.

    get-recipient | where {$_.EmailAddresses -match "contoso.com"} | fl Name, RecipientType, EmailAddresses
    
  3. Ve výstupu si poznamenejte hodnotu vlastnosti EmailAddresses a Vlastnosti RecipientType. Například výstup může vypadat takto:

    Name : John Smith RecipientType : UserMailbox EmailAddresses : {SIP:john@contoso.com, SMTP:john@contoso.com,   smtp:john@contoso.onmicrosoft.com}
    
  4. Podle situace proveďte jednu z těchto akcí:

    • Pokud je možnost RecipientType nastavená na UserMailbox, můžete pomocí Set-Mailboxcmdlet společně s parametrem EmailAddresses změnit adresy smtp, SMTP a SIP. Další informace o této rutině najdete v tématu Nastavení poštovní schránky.

      Nebo můžete uživatele nebo licenci odebrat. Nedoporučujeme to ale dělat.

      Poznámka

      Pokud se jedná o posledního uživatele správce, vytvořte nového globálního správce, přihlaste se a odeberte problémové uživatele.

    • Pokud je možnost RecipientType nastavená na MailUniversalDistributionGroupor MailUniversalSecurityGroup, můžete pomocí rutiny Set-DistributionGroup společně s parametrem EmailAddresses změnit adresy smtp a SMTP. Další informace o této rutině najdete v tématu Set-Distribution Group.)

      Nebo můžete skupinu odebrat. Nedoporučujeme to ale dělat. Pokud skupinu nemůžete odebrat, postupujte podle pokynů v části "Nemáte dostatečná oprávnění" při pokusu o odebrání nebo změnu distribuční skupiny v Office 365".

    • Pokud je možnost RecipientType nastavená na DynamicDistributionGroup, můžete pomocí rutiny Set-DynamicDistributionGroup společně s parametrem EmailAddresses změnit adresy smtp a SMTP. Další informace o této rutině najdete v tématu Set-DynamicDistributionGroup.

      Nebo můžete skupinu odebrat. Nedoporučujeme to ale dělat. Pokud skupinu nemůžete odebrat, postupujte podle pokynů v části "Nemáte dostatečná oprávnění" při pokusu o odebrání nebo změnu distribuční skupiny v Office 365".

Další informace

Další informace najdete v článku Při pokusu o odebrání domény z Office 365 se zobrazí chybová zpráva.

Stále potřebujete pomoc? Přejděte na web Microsoft Community.