Začínáme s Power BI DesktopemGetting started with Power BI Desktop

Vítá vás příručka Začínáme s Power BI Desktopem.Welcome to the Power BI Desktop Getting Started Guide. V této krátké prohlídce se seznámíte s tím, jak Power BI Desktop funguje, zjistíte, jaké úlohy v něm zvládnete, a naučíte se rychle vytvářet robustní datové modely – a v nich působivé sestavy – které vám pomůžou rozšířit vaše aktivity v oblasti business intelligence.This short tour of Power BI Desktop gets you acquainted with how it works, demonstrates what it can do, and accelerates your ability to build robust data models — along with amazing reports — that amplify your business intelligence efforts.

Chcete se místo čtení radši dívat?Prefer to watch instead of read? Beze všeho: pusťte si naše úvodní video.Feel free to take a look at our getting started video. A jestli si chcete podle videa rovnou vyzkoušet postupy se stejnými ukázkovými daty, stáhněte si tento ukázkový sešit v Excelu.And if you want to follow along with the video with matching sample data, you can download this sample Excel workbook.

Power BI Desktop umožňuje vytvářet kolekce dotazů, datová připojení a sestavy, které můžete jednoduše sdílet s ostatními.Power BI Desktop lets you create a collection of queries, data connections, and reports that can easily be shared with others. Power BI Desktop integruje osvědčené technologie Microsoft – výkonný dotazovací modul, modelování dat a vizualizace – a hladce spolupracuje s online službou Power BI.Power BI Desktop integrates proven Microsoft technologies – the powerful Query engine, data modeling, and visualizations – and works seamlessly with the online Power BI service.

Spojení Power BI Desktopu (kde můžou analytici i ostatní uživatele vytvářet výkonná datová připojení, modely a sestavy) a služby Power BI (kde se sestavy z Power BI Desktopu dají sdílet, takže je můžou zobrazit a pracovat s nimi další uživatelé) usnadňuje modelování, sestavování, sdílení a rozšiřování nových analytických informací vycházejících z dat.With the combination of Power BI Desktop (where analysts and others can create powerful data connections, models and reports) and the Power BI service (where Power BI Desktop reports can be shared so users can view and interact with them), new insights from the world of data are easier to model, build, share, and extend.

Datové analytiky Power BI Desktop osloví jako účinný, flexibilní a velmi dostupný nástroj umožňující připojení k velkému množství dat a jejich tvarování, vytváření robustních modelů a dobře strukturovaných sestav.Data analysts will find Power BI Desktop a powerful, flexible, and a highly accessible tool to connect with and shape the world of data, build robust models, and craft well-structured reports.

Jak pracovat s touto příručkouHow to use this guide

Tuto příručku můžete využít několika způsoby – rychle si ji projít a získat základní přehled nebo si prostudovat jednotlivé části a do hloubky porozumět fungování Power BI Desktopu.You can use this guide in a couple of ways – scan it for a quick overview, or read through each section for a strong understanding of how Power BI Desktop works.

Jestli nemáte moc času, můžete si velmi rychle prohlédnout hlavně obrázky. Během pár minut si tak uděláte dobrou představu, jak Power BI Desktop funguje a jak ho můžete využít.If you’re in a hurry you can do a visual sweep of this guide in just a couple minutes, and come away with a good sense of how Power BI Desktop operates, and how to use it. Příručka se skládá převážně ze snímků obrazovek, které názorně ukazují fungování Power BI Desktopu.Most of this guide consists of screens that visually show how Power BI Desktop works.

Pokud chcete získat důkladnější znalost, můžete si jednotlivé části přečíst a vyzkoušet si popisované postupy. Na konci tak budete mít vlastní soubor v Power BI Desktopu, který můžete publikovat ve službě Power BI a sdílet s ostatními.For a more thorough understanding you can read through each section, perform the steps, and walk away with your own Power BI Desktop file that’s ready to post onto the Power BI service, and share with others.

Poznámka

Existuje také samostatná a specializovaná verze Power BI, která se nazývá Server sestav Power BI. Je určená zákazníkům, kteří potřebují data a vytváření sestav uchovávat místně.There is also a separate and specialized version of Power BI called Power BI Report Server, which is for customers who need their data and reporting to remain on-premises. Pro tuto specializovanou verzi je také k dispozici samostatná a specializovaná verze Power BI Desktopu, která se nazývá Power BI Desktop pro Server sestav Power BI. Funguje pouze s verzí Power BI Server sestav.For use with that specialized version, there's also a separate and specialized version of Power BI Desktop called Power BI Desktop for Power BI Report Server, which works only with the Report Server version of Power BI. Tento článek popisuje standardní Power BI Desktop.This article describes the standard Power BI Desktop.

Jak Power BI Desktop fungujeHow Power BI Desktop works

S Power BI Desktop se můžete připojit k datům (obvykle z několika datových zdrojů), tvarovat je (pomocí dotazů umožňujících sestavit názorné a poutavé datové modely) a ze vzniklých modelů vytvářet sestavy (které můžou využívat, rozvíjet a sdílet i ostatní).With Power BI Desktop, you connect to data (usually multiple data sources), shape that data (with queries that build insightful, compelling data models), and use that model to create reports (which others can leverage, build upon, and share).

Jakmile budete s výsledkem všech kroků – připojení, tvarování a vytvoření sestavy – spokojeni, můžete si práci uložit ve formátu souboru Power BI Desktopu, který má příponu .pbix.When the steps are completed to your satisfaction – connect, shape, and report – you can save that work in Power BI Desktop file format, which is the .pbix extension. Soubory Power BI Desktopu se dají sdílet jako jakékoli jiné soubory, nejšikovnější ale je nahrát je (sdílet) do služby Power BI.Power BI Desktop files can be shared like any other file, but the most compelling way to share Power BI Desktop files is to upload them (share them) on the Power BI service.

Power BI Desktop centralizuje, zjednodušuje a zpřehledňuje často roztříštěný, nepropojený a namáhavý proces návrhu a budování úložišť a sestav z oblasti business intelligence.Power BI Desktop centralizes, simplifies, and streamlines what can otherwise be a scattered, disconnected, and arduous process of designing and creating business intelligence repositories and reports.

Jste připravení si ho vyzkoušet?Ready to give it a try? Pusťme se do toho.Let’s get started.

Instalace a spuštění Power BI DesktopuInstall and run Power BI Desktop

Power BI Desktop si můžete stáhnout ze služby Power BI tak, že vyberete ikonu ozubeného kola a pak vyberete Power BI Desktop.You can download Power BI Desktop from the Power BI service, by selecting the gear icon, then select Power BI Desktop.

Power BI Desktop se nainstaluje jako aplikace, která se spouští na vašem počítači.Power BI Desktop is installed as an application, and runs on your desktop.

Při spuštění Power BI Desktopu se zobrazí úvodní obrazovka.When you run Power BI Desktop, a Welcome screen is displayed.

Přímo z úvodníobrazovky můžete pomocí odkazů v levém podokně načíst data, prohlédnout si poslední zdroje nebo otevřít další sestavy.You can Get Data, see Recent Sources, or Open Other Reports directly from the Welcome screen (from the links in the left pane). Když tuto obrazovku zavřete (pomocí x v pravém horním rohu), otevře se v Power BI Desktopu zobrazení sestavy.If you close the screen (select the x in the top right corner), the Report view of Power BI Desktop is displayed.

Power BI Desktop používá tři zobrazení: Sestava, Data a Relace.There are three views in Power BI Desktop: Report view, Data view, and Relationships view. Dále Power BI Desktop obsahuje Editor dotazů, který se otevírá v samostatném okně.Power BI Desktop also includes Query Editor, which opens in a separate window. V Editoru dotazů sestavujete dotazy a transformujete data a poté takto upřesněný datový model načtete do Power BI Desktopu, kde můžete vytvářet sestavy.In Query Editor, you can build queries and transform data, then load that refined data model into Power BI Desktop, and create reports.

Na následující obrazovce jsou na levé straně vidět tři ikony zobrazení Power BI Desktopu: shora dolů jsou to Sestava, Data a Relace.The following screen shows the three view icons along the left of Power BI Desktop: Report, Data, and Relationships, from top to bottom. Aktuálně použité zobrazení označuje žlutý pruh na levé straně.The currently displayed view is indicated by the yellow bar along the left. V našem případě je právě otevřeno zobrazení Sestava.In this case, Report view is currently displayed. Zobrazení můžete měnit výběrem některé z těchto tří ikon.You can change views by selecting any of those three icons.

Pokud jste nainstalovali Power BI Desktop, můžete se začít připojovat k datům, tvarovat je a vytvářet sestavy (obvykle v tomto pořadí).With Power BI Desktop installed you’re ready to connect to data, shape data, and build reports (usually in that order). V následujících částech se s každou z těchto úloh seznámíte podrobněji.In the next few sections, we take a tour through each in turn.

Připojení k datůmConnect to data

Když máte nainstalovaný Power BI Desktop, můžete se snadno připojit k neustále se zvětšujícímu množství dat.With Power BI Desktop installed, you’re ready to connect to the ever expanding world of data. V okně Dotaz jsou dostupné nejrůznější zdroje dat.There are all sorts of data sources available in the Query window. Následující obrázek ukazuje, jak se připojit k datům: stačí vybrat kartu Domů a možnosti Načíst data > Více.The following image shows how to connect to data, by selecting the Home ribbon, then Get Data > More.

V tomto stručném úvodu se připojíme k několika různým webovým datovým zdrojům.For this quick tour, we'll connect to a couple different Web data sources.

Představte si, že se chystáte do důchodu a rádi byste ho prožili někde, kde je slunečno, platí se přijatelné daně a zdravotnictví je na dobré úrovni. Nebo možná jste datoví analytici a chcete tyto informace zjistit pro své zákazníky.Imagine you’re retiring – you want to live where there’s lots of sunshine, preferable taxes, and good health care – or perhaps you’re a data analyst, and you want that information to help your customers. Mohli byste třeba chtít pomoct prodejci slunečních brýlí se zacílením prodeje tam, kde nejčastěji svítí slunce.For example, perhaps you want to help your sunglasses retailer target sales where the sun shines most frequently.

Následující webový zdroj v každém případě obsahuje zajímavá data o těchto (a dalších tématech):Either way, the following Web resource has interesting data about those topics, and more:

http://www.bankrate.com/finance/retirement/best-places-retire-how-state-ranks.aspxhttp://www.bankrate.com/finance/retirement/best-places-retire-how-state-ranks.aspx

Vyberte Načíst data > Web a vložte adresu zdroje.Select Get Data > Web and paste the address.

Když vyberete OK, spustí se funkce Dotaz Power BI Desktopu.When you select OK, the Query functionality of Power BI Desktop goes to work. Funkce Dotaz kontaktuje webový prostředek a okno Navigátoru vrátí výsledky nalezené na dané webové stránce.Query contacts the Web resource, and the Navigator window returns what it found on that Web page. V tomto případě byla nalezena tabulka (Table 0) a celý webový dokument.In this case, it found a table (Table 0) and the overall Web Document. Nás zajímá tabulka, takže ji v seznamu vybereme.We’re interested in the table, so we select it from the list. Okno Navigátor zobrazí náhled.The Navigator window displays a preview.

V tuto chvíli můžeme před načtením tabulky dotaz upravit tak, že v dolní části okna vybereme Upravit. Nebo můžeme tabulku rovnou načíst.At this point we can edit the query before loading the table, by selecting Edit from the bottom of the window, or we can load the table.

Když vybereme Upravit, spustí se Editor dotazů a zobrazí se reprezentativní pohled na tabulku.When we select Edit, Query Editor launches and a representative view of the table is presented. Zobrazí se podokno Nastavení dotazů. (Pokud se nezobrazí, můžete ho zobrazit výběrem Zobrazení na pásu karet a potom možností Zobrazit > Nastavení dotazů.)The Query Settings pane is displayed (if it’s not, you can select View from the ribbon, then Show > Query Settings to display the Query Settings pane). Vypadá to takto.Here’s what that looks like.

Další informace o připojování k datům najdete v článku Připojení k datům v Power BI Desktopu.For more information about connecting to data, see Connect to Data in Power BI Desktop.

V další části upravíme data tak, aby vyhovovala našim potřebám.In the next section, we adjust the data so it meets our needs. Procesu úprav připojených dat se říká tvarování dat.The process of adjusting connected data is called shaping data.

Tvarování a kombinování datShape and combine data

Teď, když jsme se připojili ke zdroji dat, je potřeba data upravit tak, aby nám to vyhovovalo.Now that we’ve connected to a data source, we need to adjust the data to meet our needs. Někdy úprava dat znamená jejich transformování – například přejmenování sloupců nebo tabulek, změnu textu na čísla, odebrání řádků, nastavení prvního řádku jako záhlaví a tak dále.Sometimes adjusting means transforming the data – such as renaming columns or tables, changing text to numbers, removing rows, setting the first row as headers, and so on.

V Editoru dotazů v Power BI Desktopu se vedle úloh dostupných na pásu karet dá hojně využívat také nabídek zobrazených po kliknutí pravým tlačítkem myši.The Query editor in Power BI Desktop makes ample use of right-click menus, in addition to having tasks available on the ribbon. Většina toho, co můžete vybrat na pásu karet Transformace, je dostupná také kliknutím pravým tlačítkem myši na položku (třeba na sloupec) a výběrem z nabídky, která se zobrazí.Most of what you can select in the Transform ribbon is also available by right-clicking an item (such as a column) and choosing from the menu that appears.

Tvarování datShape data

Když tvarujete data v Editoru dotazů, zadáváte podrobné pokyny (které za vás Editor dotazů provede) k upravení dat, která Editor dotazů načítá a prezentuje.When you shape data in the Query Editor, you’re providing step-by-step instructions (that Query Editor carries out for you) to adjust the data as Query Editor loads and presents it. Na původní zdroj dat to nemá vliv. Upraví neboli tvaruje se jenom toto konkrétní zobrazení dat.The original data source is not affected; only this particular view of the data is adjusted, or shaped.

Kroky, které zadáte (třeba přejmenování tabulky, transformace datového typu nebo odstranění sloupců), Editor dotazů zaznamená a pokaždé, když se tento dotaz připojí ke zdroji dat, se kroky provedou, aby data byla vždycky tvarovaná zadaným způsobem.The steps you specify (such as rename a table, transform a data type, or delete columns) are recorded by Query Editor, and each time this query connects to the data source those steps are carried out so that the data is always shaped the way you specify. Tento proces se provádí při každém použití dotazu v Power BI Desktopu nebo každému uživateli, který použije váš sdílený dotaz, třeba ve službě Power BI.This process occurs whenever you use the query in Power BI Desktop, or for anyone who uses your shared query, such as in the Power BI service. Tyto kroky se zaznamenají v zadaném pořadí v podokně Nastavení dotazu v Použitém postupu.Those steps are captured, sequentially, in the Query Settings pane under Applied Steps.

Na následujícím obrázku je vidět podokno Nastavení dotazu pro dotaz, který prošel tvarováním – jednotlivým krokům se budeme věnovat v dalších několika odstavcích.The following image shows the Query Settings pane for a query that has been shaped – we’ll go through each of those steps in the next few paragraphs.

Pojďme se vrátit k datům o důchodech, která jsme našli po připojení k webovému zdroji dat, a vytvarovat si je podle našich potřeb.Let’s get back to our retirement data, which we found by connecting to a Web data source, and shape that data to fit our needs.

Pro začátek si všimneme, že většina hodnocení se do Editoru dotazů přenesla jako celá čísla, neplatí to ale pro všechna (jeden sloupec obsahoval text a čísla, takže se nepřevedl automaticky).For starters, most ratings were brought into Query Editor as whole numbers, but not all of them (one column contained text and numbers, so it wasn't automatically converted). Potřebujeme, aby data měla číselnou podobu.We need the data to be numbers. Žádný problém – stačí kliknout pravým tlačítkem myši na záhlaví sloupce a vybrat Změnit typ > Celé číslo. Tím typ dat změníme.No problem – just right-click the column header, and select Change Type > Whole Number to change the data type. Pokud je potřeba vybrat více sloupců, nejdřív vybereme jeden a pak se stisknutou klávesou SHIFT vybereme další sousedící sloupce. Pak můžeme kliknutím pravým tlačítkem na záhlaví změnit všechny vybrané sloupce.If we needed to choose more than one column, we could first select a column then hold down SHIFT, select additional adjacent columns, and then right-click a column header to change all selected columns. Sloupce, které spolu nesousedí, se dají vybrat se stisknutou klávesou CTRL.You can also use CTRL to select non-adjacent columns.

Z pásu karet Transformace můžete také sloupce změnit neboli transformovat z textu na záhlaví.You can also change, or transform, those columns from text to header by using the Transform ribbon. Tady je pás karet Transformace se šipkou k tlačítku Datový typ, které umožňuje transformovat aktuální datový typ na jiný.Here’s the Transform ribbon, with an arrow pointing toward the Data Type button, which lets you transform the current data type to another.

Všimněte si, že v části Použitý postup v Nastavení dotazů se promítají změny, které jsme udělali.Note that in Query Settings, the Applied Steps reflect the changes that were made. Pokud bychom chtěli kterýkoli krok z procesu tvarování odebrat, stačí ho jednoduše vybrat a potom vybrat X nalevo od kroku.If I want to remove any step from the shaping process, I simply select that step, and then select the X to the left of the step.

Abychom dostali dotaz do podoby, jako potřebujeme, musíme udělat ještě pár změn:We need to make a few more changes to get the query where we want it:

  • Odebrat první sloupec – ten nepotřebujeme, obsahuje jenom nadbytečné řádky s textem „Check out how your state ranks for retirement“ (Zjistěte, jak si váš stát vede z hlediska důchodu). Je to pozůstatek toho, že zdrojem dat je webová tabulka.Remove the first column – we don’t need it, it just includes redundant rows that say “Check out how your state ranks for retirement” which is an artifact of this being a Web based table
  • Opravit několik chyb – na webové stránce byl v jednom sloupci vedle čísel i text (některé státy měly v této kategorii stejný počet bodů).Fix a few Errors – on the Web page, one column had text mixed in with the numbers (some states tied in one category). Na webu taková kombinace funguje, v datové analýze ale ne.That works well in the website, but not for our data analysis. V tomto případě se to dá jednoduše napravit – a ještě se při tom ukážou některé skvělé funkce a možnosti Editoru dotazů s Použitým postupemIt's easy (in this case) to fix, and shows some cool features and capabilities of Query Editor and its Applied Steps
  • Změnit název tabulky – stávající název Table 0 (Tabulka 0) není zrovna užitečný popis, ale snadno ho změníme.Change the Table Name – that Table 0 is not a useful descriptor, but changing it simple

Všechny tyto kroky jsou popsané v článku Tvarování a kombinování dat v Power BI Desktopu.Each of these steps is demonstrated in Shape and Combine Data in Power BI Desktop. Podle potřeby si tento článek projděte, nebo dál pokračujte ve čtení tohoto dokumentu a zjistěte, jak s daty naložíme dál.Feel free to check out that page, or keep going in this document to see what you would do next. V následující části už počítáme s tím, že jsme provedli výše uvedené změny.The next section picks up after the changes above are applied.

Zkombinování datCombine data

Zajímavá data, která máme o různých státech, budou užitečná při vytváření dalších analýz a dotazů.That data about various states is interesting, and will be useful for building additional analysis efforts and queries. Máme ale jeden problém: většina dat nepoužívá celé názvy států, ale dvoupísmenné zkratky pro jejich kódy.But there’s one problem: most data out there uses a two-letter abbreviation for state codes, not the full name of the state. Potřebujeme způsob, jak spojit názvy států s jejich zkratkami.We need some way to associate state names with their abbreviations.

Máme štěstí: existuje další veřejný zdroj dat, který právě tohle dělá, ale před připojením k naší důchodové tabulce potřebuje pořádně vytvarovat.We’re in luck: there’s another public data source that does just that, but it needs a fair amount of shaping before we can connect it to our retirement table. Webový zdroj pro zkratky států je tady:Here’s the Web resource for state abbreviations:

http://en.wikipedia.org/wiki/List_of_U.S._state_abbreviationshttp://en.wikipedia.org/wiki/List_of_U.S._state_abbreviations

Na pásu karet Domů v Editoru dotazů vybereme Načíst data > Web a zadáme adresu. Pak vybereme OK a v okně Navigátoru uvidíme, co se na webové stránce našlo.From the Home ribbon in Query Editor, we select Get Data > Web and type the address, select OK, and the Navigator window shows what it found on that Web page.

Vybereme tabulku Table[edit], protože ta obsahuje data, která hledáme. Bude ale potřeba hodně tvarování, abychom data zredukovali pro naše potřeby.We select Table[edit] because it includes the data we want, but it’s going to take quite a bit of shaping to pare that table’s data down. Jednotlivé kroky jsou podrobně popsané také v článku Tvarování a kombinování dat v Power BI Desktopu.Each of these steps is also demonstrated in Shape and Combine Data in Power BI Desktop. Tady je krátce shrneme:To summarize those steps, here's what we do:

Vybereme Upravit a potom:We select Edit, then:

  • Odebereme horní dva řádky – ty souvisejí s tím, jak byla vytvořena tabulka webové stránky, a nepotřebujeme je.Remove the top two rows – they’re a result of the way that Web page’s table was created, and we don’t need them.
  • Odebereme spodních 26 řádků – jsou to všechna teritoria Spojených států, která do analýzy nebudeme zahrnovat.Remove the bottom 26 rows – they’re all the territories, which we don’t need to include.
  • Odfiltrujeme území Washington DC – tabulka statistik o důchodech ho neobsahuje, takže ho ze seznamu vyloučíme.Filter out Washington DC – the retirement stats table doesn't include DC, so we'll exclude it from our list.
  • Odebereme pár nepotřebných sloupců – chceme jen namapovat státy na jejich oficiální dvoupísmenné zkratky, ostatní sloupce tedy můžeme odebrat.Remove a few unneeded columns – we only need the mapping of state to its official two-letter abbreviation, so we can remove the other columns.
  • První řádek použijeme jako záhlaví – protože jsme odebrali první tři řádky, aktuální první řádek představuje záhlaví, které chceme.Use the first row as headers – since we removed the top three rows, the current top row is the header we want.

    Poznámka

    Teď je vhodný okamžik na to upozornit, že pořadí použitých kroků v Editoru dotazů je důležité a může ovlivnit, jak se budou data tvarovat.This is a good time to point out that the sequence of applied steps in Query Editor is important, and can affect how the data is shaped. Je také důležité vzít v úvahu, jak může jeden krok ovlivnit jiný následný krok. Pokud odeberete některý krok z Použitého postupu, ty další nemusí vzhledem k pořadí kroků v dotazu fungovat podle původního záměru.It’s also important to consider how one step may impact another subsequent step; if you remove a step from the Applied Steps, subsequent steps may not behave as originally intended, because of the impact of the query’s sequence of steps.

  • Přejmenujeme sloupce a samotnou tabulku – jak už jsme zvyklí, přejmenovat sloupec se dá několika způsoby. Můžete si podle libosti vybrat ten, který se vám zamlouvá.Rename the columns, and the table itself – as usual, there are a couple ways to rename a column, you can choose whichever you prefer.

Když máme tabulku StateCodes vytvarovanou podle našich představ, sloučíme obě tabulky (nebo dotazy) do jedné. Protože jsou tabulky v aktuální podobě výsledkem dotazů, které jsme na data použili, často se označují jako dotazy.With the StateCodes table shaped, we can combine these two tables, or queries, into one; since the tables we now have are a result of the queries we applied to the data, they’re often referred to as queries.

Dotazy se dají kombinovat dvěma základními způsoby – slučováním a připojováním.There are two primary ways of combining queries – merging and appending.

Pokud chcete k jinému dotazu přidat jeden nebo více sloupců, můžete dotazy sloučit.When you have one or more columns that you’d like to add to another query, you merge the queries. Pokud chcete do existujícího dotazu přidat další řádky dat, dotaz připojte.When you have additional rows of data that you’d like to add to an existing query, you append the query.

V tomto případě chceme dotazy sloučit.In this case we want to merge queries. Začneme tak, že vybereme dotaz, do kterého chceme dotazy sloučit, a pak na kartě Domů na pásu karet vybereme Sloučit dotazy.To get started, we select the query into which we want the other query to merge, then select Merge Queries from the Home tab on the ribbon.

Zobrazí se okno Sloučit s výzvou k výběru tabulky, kterou chceme sloučit do vybrané tabulky, a pak odpovídajících sloupců, které chceme při sloučení použít.The Merge window appears, prompting us to select which table we’d like merged into the selected table, and then, the matching columns to use for the merge. Z tabulky (dotazu) RetirementStats vyberte sloupec State, pak vyberte dotaz StateCodes (v tomto případě je to jednoduché, protože existuje jenom jeden další dotaz – při připojování k mnoha zdrojům dat existuje mnoho dotazů na výběr).Select State from the RetirementStats table (query), then select the StateCodes query (easy in this case, since there’s only one other query – when you connect to many data sources, there are many queries to choose from). Když vybereme správné odpovídající sloupce – State z RetirementStats a State Name ze StateCodes – vypadá okno Sloučit jako na dalším obrázku a je k dispozici tlačítko OK.When we select the correct matching columns – State from RetirementStats, and State Name from StateCodes – the Merge window looks like the following, and the OK button is enabled.

Na konci dotazu se vytvoří NewColumn (NovýSloupec), který je obsahem tabulky (dotazu) sloučené s existujícím dotazem.A NewColumn is created at the end of the query, which is the contents of the table (query) that was merged with the existing query. Všechny sloupce ze sloučeného dotazu jsou do NewColumn sbalené, ale můžete tabulku Rozbalit a zahrnout všechny sloupce, které chcete.All columns from the merged query are condensed into the NewColumn, but you can select to Expand the table, and include whichever columns you want. Uděláte to ikonou rozbalení ().To expand the merged table, and select which columns to include, select the expand icon (). Zobrazí se okno Rozbalit.The Expand window appears.

V tomto případě nás zajímá jenom sloupec State Code, takže vybereme jenom ten a pak OK.In this case, we only want the State Code column, so we select only that column and then select OK. Zrušíme zaškrtnutí políčka Používat původní název sloupce jako předponu, protože to se nám nehodí. Pokud bychom políčko nechali zaškrtnuté, sloučený sloupec by se pojmenoval NewColumn.StateCode (původní název sloupce, tedy NewColumn, pak tečka a pak název sloupce přidávaného do dotazu).We clear the checkbox from Use original column name as prefix because we don’t need or want that; if we leave that selected, the merged column would be named NewColumn.State Code (the original column name, or NewColumn, then a dot, then the name of the column being brought into the query).

Poznámka

Chcete si pohrát s tím, jak tabulku NewColumn přidáte?Want to play around with how to bring in that NewColumn table? Můžete trochu experimentovat, a pokud se vám výsledky nelíbí, stačí příslušný krok odstranit ze seznamu Použitý postup v podokně Nastavení dotazu. Váš dotaz se vrátí do stavu před použitím kroku Rozbalit.You can experiment a bit, and if you don’t like the results, just delete that step from the Applied Steps list in the Query Settings pane; your query returns to the state prior to applying that Expand step. To můžete opakovat, kolikrát chcete, dokud proces rozbalení nevypadá podle vašich představ.It’s like a free do-over, which you can do as many times as you like until the expand process looks the way you want it.

Teď máme jeden dotaz (tabulku) kombinující dva zdroje dat, které jsme si předtím vytvarovali podle našich potřeb.We now have a single query (table) that combined two data sources, each of which has been shaped to meet our needs. Tento dotaz může sloužit jako základ pro spoustu dalších, zajímavých připojení dat – třeba statistiky nákladů na bydlení, demografická data nebo pracovní příležitosti v libovolném státu.This query can serve as a basis for lots of additional, interesting data connections – such as housing cost statistics, demographics, or job opportunities in any state.

Podrobnější popis každého z těchto kroků při tvarování a kombinování dat najdete v článku Tvarování a kombinování dat v Power BI Desktopu.For a more complete description of each of these shape and combine data steps, see Shape and Combine Data in Power BI Desktop.

Teď ale máme dostatek dat k vytvoření několika šikovných sestav. Všechno zvládneme v Power BI Desktopu.For now, we have enough data to create a few interesting reports, all within Power BI Desktop. Dospěli jsme k důležitému milníku, tak si soubor v Power BI Desktopu uložíme – pojmenujeme ho Začínáme s Power BI Desktopem.Since this is a milestone let’s save this Power BI Desktop file – we’ll call it Getting Started with Power BI Desktop. Abychom použili změny provedené v Editoru dotazů a načetli je do Power BI Desktopu, vybereme na pásu karet Domů příkaz Zavřít a použít.To apply the changes in Query Editor and load them into Power BI Desktop, select Close & Apply from the Home ribbon.

Vytváření sestavBuild reports

Po načtení tabulky můžete provést další změny a pak model znovu načíst, aby se projevily.Additional changes can be made after the table is loaded, and you can reload a model to apply any changes you make. Teď nám ale tabulka stačí tak, jak je.But for now this will do. S vytvářením sestav v Power BI Desktopu můžete začít v zobrazení Sestava.In Power BI Desktop Report view, you can begin to build reports.

Zobrazení Sestava má pět hlavních oblastí:The Report view has five main areas:

  1. Pás karet, kde se zobrazují běžné úlohy spojené se sestavami a vizualizacemiThe ribbon, which displays common tasks associated with reports and visualizations
  2. Zobrazení Sestava, neboli plátno, kde se vytvářejí a sestavují vizualizaceThe Report view, or canvas, where visualizations are created and arranged
  3. Oblast s kartami stránek podél dolního okraje, která umožňuje vybrat nebo přidat stránku sestavyThe Pages tab area along the bottom, which lets you select or add a report page
  4. Podokno Vizualizace, kde můžete měnit vizualizace, přizpůsobovat barvy nebo osy, používat filtry, přetahovat pole a nastavovat další věciThe Visualizations pane, where you can change visualizations, customize colors or axes, apply filters, drag fields, and more
  5. Podokno Pole, odkud můžete přetahovat elementy dotazu a filtry do zobrazení Sestava nebo do oblasti Filtry podokna VizualizaceThe Fields pane, where query elements and filters can be dragged onto the Report view, or dragged to the Filters area of the Visualizations pane

Podokna Vizualizace a Pole si můžete sbalit pomocí malých šipek u jejich okrajů, abyste měli v zobrazení Sestava více místa pro sestavování působivých vizualizací.The Visualizations and Fields pane can be collapsed by selecting the small arrow along the edge, providing more space in the Report view to build cool visualizations. Při úpravách vizualizací také uvidíte tyto dvě šipky směřovat nahoru nebo dolů, což znamená, že danou sekci můžete rozbalit nebo sbalit.When modifying visualizations, you'll also see these arrows pointing up or down, which means you can expand or collapse that section, accordingly.

Když chcete vytvořit vizualizaci, stačí přetáhnout pole ze seznamu Pole do zobrazení Sestava.To create a visualization, just drag a field from the Fields list onto the Report view. V našem příkladu přetáhneme pole State (Stát) z tabulky RetirementStats a uvidíme, co se stane.In this case, let’s drag the State field from RetirementStats, and see what happens.

Podívejte se na to… Aplikace Power BI Desktop automaticky vytvořila mapovou vizualizaci, protože rozpoznala, že pole State obsahuje geografická data.Look at that... Power BI Desktop automatically created a map-based visualization, because it recognized that the State field contained geolocation data.

Všimněte si, že v podokně Vizualizace můžeme vybrat různé typy vizualizací a v oblasti pod jejich ikonami přetáhnout pole do různých oblastí a použít tak legendu, případně vizualizaci jinak upravit.Notice that in the Visualizations pane, I can select different types of visualizations, and in the area below those icons, I can drag fields to different areas to apply a Legend, or otherwise modify the visualization.

Pojďme se teď posunout trochu dál a podívat se, jak zobrazení Sestava vypadá po přidání několika vizualizací a nových stránek sestavy.Let’s fast-forward a bit, and see what the Report view looks like after a handful of visualizations have been added, as well as a few new Report pages. Další informace o sestavách najdete v tématu Zobrazení sestavy v Power BI Desktopu.For more information about reports, see Report View in Power BI Desktop.

První stránka sestavy nabízí celkový pohled na data vycházející z celkového pořadí (Overall rank).The first Report page provides a perspective of the data based on Overall rank. Když vybereme některou z vizualizací, v podokně Pole a filtry se zobrazí pole, která jsou vybraná, a struktura celé vizualizace (tj. která pole se použijí u sdílené osy, hodnot ve sloupcích, a hodnot v řádcích).When we select one of the visualizations, the Fields and Filters pane shows which fields are selected, and the structure of the visualization (which fields are applied to the Shared Axis, Column Values, and Line Values).

Tato sestava obsahuje šest stránek – každá z nich vizualizuje některé prvky našich dat.There are six Pages in this Report, each visualizing certain elements of our data.

  1. První stránka, kterou vidíte výše, uvádí všechny státy v celkovém pořadí (Overall rank).The first page, shown above, shows all states based on Overall rank.
  2. Druhá stránka se zaměřuje na prvních deset států v celkovém pořadí.The second page focuses on the top ten states based on Overall rank.
  3. Na třetí stránce najdeme přehled prvních 10 států z hlediska nákladů na živobytí (a související data).For the third page, the best 10 states for cost of living (and associated data) are visualized.
  4. Čtvrtá stránka se věnuje počasí a je na ní vyfiltrováno 15 nejslunnějších států.Weather is the focus of the fourth page, filtered to the 15 sunniest states.
  5. Na páté stránce jsou grafy a vizualizace zachycující nejlepších 15 států z hlediska prosperity v komunitě.On the fifth page, Community well-being is charted and visualized for the top 15 states.
  6. Na závěrečné stránce jsou vizualizovány statistiky zločinnosti pro desítku nejlepších států (a také pro deset nejhorších).Lastly, crime statistics are visualized, showing the best (and well, the last) ten states.

Takhle vypadá stránka sestavy zaměřená na životní náklady.Here’s what the cost of living-focused Report page looks like.

Podobně můžete vytvářet nejrůznější zajímavé sestavy a vizualizace.There are all sorts of interesting reports and visualizations you can create.

Sdílení hotových výtvorůShare your work

Když teď máme v Power BI Desktopu sestavu s přiměřeně ucelenými informacemi, můžeme ji ve službě Power BI sdílet s ostatními.Now that we have a Power BI Desktop report that’s reasonably complete, we can share it with others on the Power BI service. Při sdílení práce v Power BI Desktopu máte několik možností.There are a few ways to share your work in Power BI Desktop. Můžete sestavu publikovat ve službě Power BI, nahrát si soubor .pbix přímo ze služby Power BI nebo soubor .pbix uložit a poslat ho jako jakýkoli jiný soubor.You can publish to the Power BI service, you can upload the .pbix file directly from the Power BI service, or you can save the .pbix file and send it like any other file.

Jako první prozkoumáme publikování do služby Power BI přímo z Power BI Desktopu.First, let's look at publishing to the Power BI service directly from Power BI Desktop. Na pásu karet Domů vyberte Publikovat.On the Home ribbon, select Publish.

Možná se zobrazí výzva, abyste se přihlásili k Power BI.You may be prompted to sign in to Power BI.

Po přihlášení a dokončení procesu publikování se zobrazí následující dialogové okno.When you've signed in and the publish process is complete, you see the following dialog.

Po přihlášení k Power BI uvidíte soubor Power BI Desktopu, který jste právě načetli, v oddílech Řídicí panely, Sestavy a Datové sady.When you sign in to Power BI, you'll see Power BI Desktop file you just loaded in the Dashboards, Reports, and Datasets sections of the service.

Další možností sdílení práce je načíst ji z prostředí služby Power BI.Another way to share your work is to load it from within the Power BI service. Pomocí následujícího odkazu spustíte službu Power BI v prohlížeči:The following link brings up the Power BI service in a browser:

https://app.powerbi.com

Volbou Načíst data zahájíte proces načítání sestavy Power BI Desktopu.Select Get Data to start the process of loading your Power BI Desktop report.

Zobrazí se stránka Načíst data, kde můžete určit, odkud se data načtou.The Get Data page appears, from which you can select where to get your data from. V našem případě vybereme Načíst v poli Soubory.In this case, we select Get from the Files box.

Objeví se zobrazení Soubory.The Files view appears. V tomto případě vybereme Místní soubor.In this case, we select Local File.

Power BI nahraje vybraný soubor.When you select the file, Power BI uploads the file.

Po nahrání souboru ho můžete vybrat v části Sestavy v levém podokně služby Power BI.Once the file is uploaded, you can select the file from the Reports in the left pane of the Power BI service.

Ve službě Power BI se zobrazí první stránka sestavy.The Power BI service displays the first page of the report. V dolní části okna můžete pomocí karet zobrazit další stránky sestavy.Along the bottom of the page, you can select any tab to display that page of the report.

Změny v sestavě můžete ve službě Power BI provádět, když v horní části plátna sestavy vyberete Upravit sestavu.You can make changes to a report in the Power BI service by selecting Edit Report from the top of the report canvas.

Sestavu ve službě uložíte volbou Soubor> Uložit jako.To save your report, select File > Save As from the service. Ve službě Power BI můžete ze sestavy vytvořit celou řadu zajímavých vizuálů, které se dají připnout na řídicí panel.There are all sorts of interesting visuals you can create in the Power BI service from your report, which you can pin to a dashboard. Další informace o řídicích panelech ve službě Power BI najdete v části Tipy pro návrh působivého řídicího panelu.To learn about dashboards in the Power BI service, see Tips for designing a great dashboard.

Po uložení vyberte na hlavní stránce ikonu Sdílet.Once saved, select the Share icon on the main page.

Teď můžete odeslat e-mail kolegům, s kterými byste řídicí panel rádi sdíleli.From here, you can send an email to colleagues with whom you’d like to share the dashboard.

Další informace o vytváření, sdílení a úpravách řídicích panelů najdete v článku Sdílení řídicího panelu.For more information about creating, sharing, and modifying dashboards, see Share a dashboard.

V Power BI Desktopu a ve službě Power BI se dají připravit nejrůznější integrované datové analýzy a působivé vizualizace.There are all sorts of compelling data-related mash-ups and visualizations you can do with Power BI Desktop, and with the Power BI service. Více informací se dočtete v další části.Check out the next section for more information.

Další krokyNext steps

S Power BI Desktopem můžete dělat nejrůznější věci.There are all sorts of things you can do with Power BI Desktop. Další informace o jeho schopnostech najdete v těchto článcích:For more information on its capabilities, check out the following resources: