Základní informace o dotazech v Power BI DesktopuQuery overview in Power BI Desktop

Je tato stránka užitečná?

S Power BI Desktopem se můžete připojit k různým datům, vytvářet poutavé a podkladové sestavy a sdílet výsledky svého úsilí s ostatními, aby mohli stavět na vaší práci a rozšiřovat své aktivity v oblasti business intelligence.With Power BI Desktop you can connect to the world of data, create compelling and foundational reports, and share your efforts with others – who can then build on your work, and expand their business intelligence efforts.

Power BI Desktop zahrnuje tři zobrazení:Power BI Desktop has three views:

  • Sestava – zobrazení, ve kterém můžete pomocí dotazů vytvářet působivé vizualizace uspořádané podle vašich představ, které můžou mít více stran a které můžete sdílet s ostatními.Report view – where you use queries you create to build compelling visualizations, arranged as you want them to appear, and with multiple pages, that you can share with others
  • Data – zobrazení dat v sestavě ve formátu datového modelu, ve kterém můžete přidávat míry, vytvářet nové sloupce a spravovat relace.Data view – see the data in your report in data model format, where you can add measures, create new columns, and manage relationships
  • Relace – zobrazení poskytující grafické znázornění relací vytvořených v datovém modelu a umožňující jejich správu a úpravy podle potřeby.Relationships view – get a graphical representation of the relationships that have been established in your data model, and manage or modify them as needed.

K těmto zobrazením získáte přístup výběrem jedné ze tří ikon na levé straně Power BI Desktopu.These views are accessed by selecting one of the three icons along the left side of Power BI Desktop. Na následujícím obrázku je vybráno zobrazení Sestava, což je indikováno žlutým proužkem vedle ikony.In the following image, Report view is selected, indicated by the yellow band beside the icon.

Součástí Power BI Desktopu je také Editor dotazů, ve kterém se můžete připojit k jednomu nebo k mnoha zdrojům dat. Data můžete tvarovat a transformovat podle potřeby a model pak načíst do Power BI Desktopu.Power BI Desktop also comes with Query Editor, where you can connect to one or many data sources, shape and transform the data to meet your needs, then load that model into Power BI Desktop.

Tento dokument poskytuje přehled práce s daty v Editoru dotazů.This document provides an overview of the work with data in the Query Editor. To není samozřejmě všechno, co se můžete naučit, proto na konci tohoto dokumentu najdete odkazy na podrobné informace o podporovaných datových typech, připojování k datům, modelování dat, vytváření relací a tom, jak začít.There's more to learn, of course, so at the end of this document you’ll find links to detailed guidance about supported data types, connecting to data, shaping data, creating relationships, and how to get started.

Ale nejprve se seznámíme s Editorem dotazů.But first, let’s see get acquainted with Query Editor.

Editor dotazůThe Query Editor

K Editoru dotazů se dostanete tak, že v Power BI Desktopu vyberete možnost Upravit dotazy na kartě Domů.To get to Query Editor, select Edit Queries from the Home tab of Power BI Desktop.

Bez připojení k datům vypadá Editor dotazů jako prázdné podokno připravené na data.With no data connections, Query Editor appears as a blank pane, ready for data.

Po načtení dotazu se zobrazení Editoru dotazů stane zajímavějším.Once a query is loaded, Query Editor view becomes more interesting. Pokud se připojíme k následujícímu webovému zdroji dat, načte Editor dotazů informace o těchto datech, která pak můžete začít tvarovat.If we connect to the following Web data source, Query Editor loads information about the data, which you can then begin to shape.

http://www.bankrate.com/finance/retirement/best-places-retire-how-state-ranks.aspx

Takto Editor dotazů vypadá po připojení k datům:Here’s how Query Editor appears once a data connection is established:

  1. Na pásu karet je teď mnoho tlačítek aktivních a můžete je používat k práci s daty v dotazu.In the ribbon, many buttons are now active to interact with the data in the query

  2. V levém podokně je seznam dotazů, které můžete vybírat, zobrazovat a modelovat.In the left pane, queries are listed and available for selection, viewing, and shaping

  3. V prostředním podokně se zobrazují data z vybraného dotazu, která můžete modelovat.In the center pane, data from the selected query is displayed and available for shaping

  4. Zobrazí se okno Nastavení dotazů s výpisem vlastností dotazu a použitých kroků.The Query Settings window appears, listing the query’s properties and applied steps

V následujících částech se podíváme na každou z těchto čtyř oblastí – pás karet, podokno dotazů, zobrazení dat a podokno Nastavení dotazů.We’ll look at each of these four areas – the ribbon, the queries pane, the data view, and the Query Settings pane – in the following sections.

Pás karet pro dotazyThe query ribbon

Pás karet v Editoru dotazů se skládá ze čtyř karet – Domů, Transformace, Přidat sloupce a Zobrazení.The ribbon in Query Editor consists of four tabs – Home, Transform, Add Column, and View.

Karta Domů obsahuje běžné úlohy dotazů včetně prvního kroku každého dotazu, kterým je získání dat.The Home tab contains the common query tasks, including the first step in any query, which is Get Data. Pás karet Domů je znázorněn na následujícím obrázku.The following image shows the Home ribbon.

Když se chcete připojit k datům a zahájit proces vytváření dotazu, vyberte tlačítko Získat data.To connect to data and begin the query building process, select the Get Data button. Zobrazí se nabídka s nejběžnějšími zdroji dat.A menu appears, providing the most common data sources.

Další informace o dostupných zdrojích dat najdete v článku Zdroje dat.For more information about available data sources, see Data Sources. Informace o připojování k datům včetně příkladů a postupů najdete v článku Připojení k datům.For information about connecting to data, including examples and steps, see Connect to Data.

Karta Transformace poskytuje přístup k běžným úlohám transformace dat, jako je například přidávání nebo odebírání sloupců, změna datových typů, rozdělování sloupců a další úlohy práce s daty.The Transform tab provides access to common data transformation tasks, such as adding or removing columns, changing data types, splitting columns, and other data-driven tasks. Karta Transformace je znázorněna na následujícím obrázku.The following image shows the Transform tab.

Další informace o transformaci dat včetně příkladů najdete v článku Kombinování a tvarování dat.For more information about transforming data, including examples, see Combine and Shape Data.

Na kartě Přidat sloupce najdete další úlohy související s přidáváním sloupců, formátováním sloupců dat a přidáváním vlastních sloupců.The Add Column tab provides additional tasks associated with adding a column, formatting column data, and adding custom columns. Karta Přidat sloupce je znázorněna na následujícím obrázku.The following image shows the Add Column tab.

Na kartě Zobrazení na pásu karet můžete určit, jestli budou určitá podokna nebo okna zobrazena.The View tab on the ribbon is used to toggle whether certain panes or windows are displayed. Slouží také k zobrazení Rozšířeného editoru.It’s also used to display the Advanced Editor. Karta Zobrazení je znázorněna na následujícím obrázku.The following image shows the View tab.

Je dobré vědět, že mnoho úloh, které jsou dostupné na pásu karet, je také dostupných po kliknutí pravým tlačítkem na sloupec nebo na jiná data v prostředním podokně.It’s useful to know that many of the tasks available from the ribbon are also available by right-clicking a column, or other data, in the center pane.

Levé podoknoThe left pane

V levém podokně se zobrazuje počet aktivních dotazů a také jejich názvy.The left pane displays the number of active queries, as well as the name of the query. Když v levém podokně vyberete dotaz, zobrazí se data dotazu v prostředním podokně, kde je můžete tvarovat a transformovat tak, aby odpovídala vašim potřebám.When you select a query from the left pane, its data is displayed in the center pane, where you can shape and transform the data to meet your needs. Na následujícím obrázku je znázorněno levé podokno s více dotazy.The following image shows the left pane with multiple queries.

Prostřední podokno (podokno dat)The center (data) pane

V prostředním podokně, neboli v podokně Data, se zobrazují data z vybraného dotazu.In the center pane, or Data pane, data from the selected query is displayed. Tady se provádí velká část práce v zobrazení dotazu.This is where much of the work of the Query view is accomplished.

Na následujícím obrázku je zobrazeno připojení k webovým datům, které jsme vytvořili dříve, je vybrán sloupec s celkovým skóre a jsou zobrazeny dostupné položky v nabídce, která se zobrazila po kliknutí pravým tlačítkem na záhlaví sloupce.In the following image, the Web data connection established earlier is displayed, the Overall score column is selected, and its header is right-clicked to show the available menu items. Všimněte si, že mnoho z těchto položek v nabídce, která se zobrazila po kliknutí pravým tlačítkem, odpovídá tlačítkům na pásu karet.Notice that many of these right-click menu items are the same as buttons in the ribbon tabs.

Když vyberete položku v nabídce zobrazené po kliknutí pravým tlačítkem (nebo kliknete na tlačítko na pásu karet), použije dotaz příslušný krok u dat a uloží ho jako součást dotazu.When you select a right-click menu item (or a ribbon button), Query applies the step to the data, and saves it as part of the query itself. Kroky se zaznamenávají v podokně Nastavení dotazů v postupném pořadí tak, jak je popsáno v následující části.The steps are recorded in the Query Settings pane in sequential order, as described in the next section.

Podokno Nastavení dotazůThe query settings pane

V podokně Nastavení dotazů se zobrazují všechny kroky přidružené k dotazu.The Query Settings pane is where all steps associated with a query are displayed. Například na následujícím obrázku odráží část Použitý postup v podokně Nastavení dotazů skutečnost, že jsme právě změnili typ sloupce s celkovým skóre.For example, in the following image, the Applied Steps section of the Query Settings pane reflects the fact that we just changed the type of the Overall score column.

Zatímco budete u dotazu používat další kroky modelování dat, budou tyto kroky zaznamenávány v části Použitý postup.As additional shaping steps are applied to the query, they are captured in the Applied Steps section.

Je důležité vědět, že podkladová (zdrojová) data se nemění, ale že Editor dotazů upravuje a modeluje zobrazení těchto dat a že všechny interakce s podkladovými daty probíhají na základě zobrazení těchto dat, které jste tvarovali a upravovali v Editoru dotazů.It’s important to know that the underlying data is not changed; rather, Query Editor adjusts and shapes its view of the data, and any interaction with the underlying data occurs based on Query Editor’s shaped and modified view of that data.

V podokně Nastavení dotazů můžete kroky přejmenovávat, odstraňovat nebo měnit jejich pořadí podle potřeby.In the Query Settings pane, you can rename steps, delete steps, or reorder the steps as you see fit. To můžete udělat tak, že kliknete pravým tlačítkem na krok v části Použitý postup a zvolíte možnost v nabídce, která se zobrazí.To do so, right-click the step in the Applied Steps section, and choose from the menu that appears. Všechny kroky dotazu se provádějí v pořadí, v jakém jsou uvedeny v podokně Použitý postup.All query steps are carried out in the order they appear in the Applied Steps pane.

Rozšířený editorThe Advanced Editor

Pokud chcete zobrazit kód, který Editor dotazů vytváří u každého kroku, nebo chcete vytvořit vlastní kód pro modelování dat, můžete použít Rozšířený editor.If you want to see the code that Query Editor is creating with each step, or want to create your own shaping code, you can use the Advanced Editor. Rozšířený editor spustíte tak, že na pásu karet vyberete Zobrazení a pak vyberete Rozšířený editor.To launch the advanced editor, select View from the ribbon, then select Advanced Editor. Zobrazí se okno s kódem stávajícího dotazu.A window appears, showing the existing query code.

Kód můžete v okně Rozšířený editor přímo upravovat.You can directly edit the code in the Advanced Editor window. Když chcete okno zavřít, vyberte tlačítko Hotovo nebo Zrušit.To close the window, select the Done or Cancel button.

Ukládání práceSaving your work

Jakmile dotaz odpovídá vašim potřebám, můžete v Editoru dotazů změny použít u datového modelu v Power BI Desktopu a Editor dotazů zavřít.When your query is where you want it, you can have Query Editor apply the changes to the data model into Power BI Desktop, and close Query Editor. To uděláte tak, že v Editoru dotazů vyberete v nabídce Soubor možnost Zavřít a použít.To do that, select Close & Apply from Query Editor's File menu.

Zatímco tato operace probíhá, zobrazuje se v Power BI Desktopu dialogové okno se stavem.As progress is made, Power BI Desktop provides a dialog to display its status.

Jakmile dotaz odpovídá vašim potřebám nebo pokud se chcete jen ujistit, že je vaše práce uložena, můžete v Power BI Desktopu svou práci uložit v podobě souboru .pbix.Once you have your query where you want it, or if you just want to make sure your work is saved, Power BI Desktop can save your work in the form of a .pbix file.

Když chcete práci uložit, vyberte Soubor> Uložit (nebo Soubor > Uložit jako), jak je znázorněno na následujícím obrázku.To save your work, select File > Save (or File > Save As), as shown in the following image.

Další krokyNext steps

S Power BI Desktopem můžete dělat nejrůznější věci.There are all sorts of things you can do with Power BI Desktop. Další informace o jeho schopnostech najdete v těchto článcích:For more information on its capabilities, check out the following resources: