Vytváření exportovatelných formátovaných datových tabulek v služba Power BI

PLATÍ PRO: ✔️ služba Power BI Power BI Desktop ❌

V tomto článku se dozvíte, jak snadno exportovat všechna data z datové sady Power BI a zároveň zachovat formáty dat a stylů. Tato funkce umožňuje rychle vytvořit stránkovanou sestavu na webu a použít styly. Pak ho můžete exportovat pomocí bohaté funkce exportu stránkovaných sestav.

Pomocí funkce formátované tabulky můžete vytvářet stránkované sestavy v libovolném "novém" pracovním prostoru, včetně pracovních prostorů, které nejsou v kapacitě Power BI Premium. Přečtěte si o nových a klasických pracovních prostorech.

Požadavky

Začínáme

Pokud chcete vytvořit formátovanou tabulku z služba Power BI, můžete začít na třech různých místech.

V zobrazení seznamu

  1. Přejděte na zobrazení seznamu u libovolného pracovního prostoru, jako je Můj pracovní prostor.

  2. Vyberte Další možnosti (...) pro datovou sadu Power BI a pak vyberte Vytvořit formátovanou tabulku.

    Screenshot of Create a formatted table in the Power BI service.

V zobrazení centra datových sad

  1. V služba Power BI přejděte do zobrazení Centra datových sad.

  2. Vyberte Další možnosti (...) vedle datové sady >Vytvořit formátovanou tabulku.

    Screenshot of Create formatted table in the Data hub.

Na stránce s podrobnostmi datové sady

  1. Vyberte datovou sadu v zobrazení centra datových sad služba Power BI.

  2. V části Vizualizovat tato data vyberte Vytvořit sestavu>jako formátovanou tabulku.

    Screenshot of Create a report as formatted table on the Dataset details page.

Otevře se nové prostředí pro online úpravy stránkované sestavy bez ohledu na to, kde začnete. Označuje se jako formátovaná tabulka.

Vytvoření tabulky

Pokud chcete vytvořit první tabulku, vyberte názvy polí v podokně Pole vpravo. Toto podokno poskytuje zobrazení vybrané datové sady založené na tabulce a sloupci. Když najdete sloupec, který chcete přidat do tabulky, vyberte sloupec nebo ho přetáhněte do části Hodnoty v podokně Sestavení .

Screenshot of selecting fields.

Dejte editoru chvilku, abyste spustili nový dotaz na datovou sadu. Formátovaná tabulka se zobrazí v prohlížeči stránkovaných sestav na levé straně stránky.

Screenshot of formatted table preview.

Tento prohlížeč zobrazuje náhled aktuálně neuložené stránkované sestavy. V tomto podokně se ujistěte, že všechno v sestavě vypadá dobře, než sestavu upravíte nebo uložíte.

Pokud jsou sloupce v nesprávném pořadí v podokně Sestavení , nedělejte si starosti. Sloupce v podokně Sestavení můžete snadno přeřadit přetažením sloupců do požadovaného pořadí.

Screenshot of dragging items.

Když vyberete pole, použijeme výchozí agregační sadu v poli. Agregační chování můžete změnit. Vyberte šipku vedle položky pole v podokně Sestavení .

Screenshot of possible aggregations.

Formátování tabulky

Teď, když máte požadované sloupce, můžete tabulku naformátovat pomocí předdefinovaných možností formátu.

  1. V podokně Sestavení vyberte kartu Formát .

  2. V poli Styl vyberte šipku rozevíracího seznamu a experimentujte s dostupnými styly.

    Screenshot of styling options.

Úprava formátované tabulky

Pokud přejdete na libovolnou formátovanou tabulku, kterou jste vytvořili online, můžete sestavu upravit v prostředí prohlížeče stránkovaných sestav. Tato možnost je dostupná na panelu nástrojů nad prohlížečem.

Screenshot of Edit button.

Tato možnost vás vrátí do prostředí formátovaného editoru tabulek, kde můžete v sestavě provádět změny.

Poznámka

Toto tlačítko Upravit není stejné jako tlačítko Upravit v nabídce Soubor . Místo toho se otevře tlačítko Upravit Power BI Report Builder. Pokud tuto sestavu upravíte v Report Builder, už ji nebudete moct upravovat v online formátované tabulkovém prostředí.

Export tabulky

Tabulku můžete exportovat před uložením nebo po jejím uložení. Stránkované sestavy mají bohaté možnosti exportu do libovolného podporovaného formátu, který zachovává plnou věrnost. Exportovaná sestava se uloží do výchozí složky Stažené soubory.

Screenshot of list of export formats available.

Uložit sestavu

Sestavu můžete uložit do libovolného "nového" pracovního prostoru, včetně pracovních prostorů, které nejsou v kapacitě Power BI Premium.

  1. V nabídce Soubor uložte, stáhněte nebo vytiskněte sestavu.

    Screenshot of File menu.

  2. V části Uložit sestavu pojmenujte sestavu a vyberte pracovní prostor.

    Screenshot of Save menu.

Po uložení sestavy se v pravém horním rohu editoru zobrazí oznámení o úspěchu nebo selhání.

  • Pokud už sestava existuje tam, kde jste se rozhodli uložit, zeptá se vás, jestli chcete existující sestavu přepsat.
  • Pokud se to podaří, zobrazí se odkaz na sestavu. Můžete postupovat podle tohoto odkazu nebo pokračovat v úpravách.

Po uložení sestavy si ji můžete zobrazit. V editoru vyberte režim čtení na horním panelu. Opustíte prostředí editoru a zadáte normální prostředí prohlížeče stránkovaných sestav.

Screenshot of Reading View button.

Poznámka

Pokud jste sestavu ještě neuložili nebo nemáte neuložené změny, zobrazí se výzva, abyste změny uložili nebo zahodili před tím, než přejdete do zobrazení pro čtení.

Důležité informace a omezení

  • Formátovanou tabulku můžete vytvořit v libovolném novém pracovním prostoru. Nemusí být v pracovním prostoru Premium. Přečtěte si o nových a klasických pracovních prostorech.
  • Formátovanou tabulku nemůžete vytvořit v klasických Power BI pracovních prostorech.
  • Formátovanou tabulku nemůžete vytvořit z datových sad Power BI na základě živého připojení.

Další kroky