Přímé zadání dat do stránkované sestavy v Tvůrci sestav – Power BIEnter data directly in a paginated report in Report Builder - Power BI

V tomto článku se dozvíte o funkci nové verze Tvůrce sestav Microsoft Power BI, která umožňuje zadat data přímo do sestavy RDL jako vloženou datovou sadu.In this article, you learn about a feature in the new version of Microsoft Power BI Report Builder that lets you enter data directly into an RDL report as an embedded dataset. Tato funkce se podobá Power BI Desktopu.This feature is similar to Power BI Desktop. Data můžete zadat přímo do datové sady v sestavě nebo je můžete vložit z jiné aplikace, třeba z Microsoft Excelu.You can type the data directly in a dataset in your report, or paste it from another program like Microsoft Excel. Jakmile zadáte data a vytvoříte datovou sadu, můžete ji používat úplně stejně jako jiné vložené datové sady, které jste vytvořili.After you've created a dataset by entering data, you can use it just like you would any other embedded dataset you've created. Navíc můžete přidat několik tabulek a pak jednu z nich použít jako filtr druhé tabulky.Plus you can add more than one table and use one as a filter for the other. Tato funkce je užitečná hlavně u malých statických datových sad, které potřebujete v sestavě použít jako její parametry.This feature is especially useful for small, static datasets you might need to use in your report, like report parameters.

PožadavkyPrerequisites

Vytvoření zdroje dat a datové sadyCreate a data source and dataset

Po stažení a instalaci Tvůrce sestav použijte stejný postup jako při přidání vloženého zdroje dat a datové sady do sestavy.After you’ve downloaded and installed Report Builder, you follow the same workflow you use to add an embedded data source and dataset to your report. V následujícím postupu se v části Zdroje dat zobrazí nová možnost: Zadat data.In the following procedure, under Data Sources you see a new option: Enter Data. Zdroj dat stačí v sestavě nastavit jen jednou.You only need to set up this data source once in a report. Potom můžete ze zadaných dat vytvořit několik tabulek, které představují samostatné datové sady a všechny používají jediný zdroj dat.After that, you can create multiple tables of entered data as separate datasets, all using that single data source.

  1. V podokně Data sestavy vyberte Nová > Datová sada.In the Report Data pane, select New > Dataset.

    Snímek obrazovky Nové datové sady v Tvůrci sestav

  2. V dialogovém okně Vlastnosti datové sady vyberte Použít datovou sadu vloženou v sestavě.In the Dataset Properties dialog box, select Use a dataset embedded in my report.

  3. Vedle Zdroj dat vyberte Nový.Next to Data source, select New.

    Snímek obrazovky s novým vloženým zdrojem dat

  4. V dialogovém okně Vlastnosti zdroje dat vyberte Použít připojení vložené v sestavě.In the Data Source Properties dialog box, select Use a connection embedded in my report.

  5. V poli Vyberte typ připojení vyberte ZADAT DATA > OK.In the Select connection type box, select ENTER DATA > OK.

    Snímek obrazovky zdroje dat ZADAT DATA

  6. V dialogovém okně Vlastnosti datové sady vyberte Návrhář dotazů.Back in the Dataset Properties dialog box, select Query Designer.

  7. V podokně Návrhář dotazů klikněte pravým tlačítkem a vložte data do tabulky.In the Query Designer pane, right-click and paste your data in the table.

    Snímek obrazovky zadání dat v návrháři dotazů

  8. Pokud chcete nastavit názvy sloupců, poklikejte na každou položku NewColumn a zadejte název sloupce.To set the column names, double-click each NewColumn and type the column name.

    Snímek obrazovky s nastavením názvů sloupců

  9. Pokud první řádek obsahuje názvy sloupců, které byly v původních datech, klikněte na ně pravým tlačítkem a odstraňte je.If the first row contains column headings from the original data, right-click and delete it.

  10. Každý sloupec má datový typ automaticky nastavený na řetězec.By default, the data type for each column is String. Pokud chcete datový typ změnit, klikněte na záhlaví sloupce pravým tlačítkem > Změnit typ a nastavte jiný datový typ, třeba Datum nebo Plovoucí.To change the data type, right-click the column header > Change Type, and set it to another data type, such as Date or Float.

    Snímek obrazovky se změnou datového typu

  11. Po vytvoření tabulky vyberte OK.When you’ve finished creating the table, select OK.

    Vytvořený dotaz je stejný jako v případě zdroje dat XML.The query that’s generated is the same as you’d see with an XML data source. Uvnitř jako poskytovatele dat používáme XML.Under the covers, we’re using XML as the data provider. Změnili jsme účel i pro tento scénář.We’ve repurposed it to enable this scenario as well.

    Snímek obrazovky struktury dat XML

  12. V dialogovém okně Vlastnosti datové sady vyberte OK.In the Dataset Properties dialog box, select OK.

  13. V podokně Data sestavy se zobrazí zdroj dat a datová sada.You see your data source and dataset in the Report Data pane.

    Snímek obrazovky datové sady v podokně Data sestavy

Z této datové sady můžete vycházet při vizualizacích dat v sestavě.You can use your dataset as the basis for data visualizations in your report. Můžete také přidat další datovou sadu založenou na stejném zdroji dat.You can also add another dataset and use the same data source for it.

Návrh sestavyDesign the report

Teď, když máte zdroj dat a datovou sadu, jste připraveni vytvořit sestavu.Now that you have a data source and dataset, you're ready to create your report. Následující postup vytvoří jednoduchou sestavu založenou na datech v předchozí části.The following procedure creates a simple report based on the data in the previous section.

  1. V nabídce Vložení vyberte Tabulka > Průvodce tabulkou.On the Insert menu, select Table > Table Wizard.

    Snímek obrazovky s výběrem možnosti Průvodce tabulkou

  2. Vyberte datovou sadu, kterou jste právě vytvořili > Další.Select the dataset you just created > Next.

    Snímek obrazovky s dialogovým oknem s volbou datové sady

  3. Na stránce Uspořádat pole přetáhněte pole, která chcete seskupit, z oblasti Pole k dispozici do oblasti Skupiny řádků.In the Arrange fields page, drag fields you want to group by from the Available fields box to the Row groups box. V tomto příkladu:In this example:

    • CountryRegionCountryRegion
    • SalesYearSalesYear
  4. Přetáhněte pole, která chcete agregovat, z oblasti Pole k dispozici do oblasti Hodnoty.Drag the fields you want to aggregate from the Available fields box to the Values box. V tomto příkladu:In this example:

    • SalesAmountSalesAmount

    Ve výchozím nastavení Tvůrce sestav sčítá pole v oblasti Hodnoty, můžete ale zvolit jinou agregaci.By default, Report Builder sums the fields in the Values box, but you can choose another aggregation.

    Snímek obrazovky různých agregací, ze kterých lze volit

  5. Vyberte Další.Select Next.

  6. Na stránce Zvolte rozložení ponechejte veškeré výchozí nastavení, ale zrušte zaškrtnutí možnosti Rozbalit či sbalit skupiny.In the Choose the layout page, keep all the default settings, but clear Expand/collapse groups. Obecně platí, že rozbalování a balení skupin je skvělé, ale tentokrát chceme vidět všechna data.In general, expanding and collapsing groups is great, but this time we want to see all the data.

  7. Vyberte Další > Dokončit.Select Next > Finish. Tabulka se zobrazí na návrhové ploše.The table is displayed on the design surface.

    Snímek obrazovky sestavy v zobrazení Návrh

Spuštění sestavyRun the report

Jestli chcete vidět aktuální hodnoty a zobrazit náhled sestavy, spusťte ji.To see the actual values and preview the report, you run it.

  1. Na pásu karet Domů vyberte Spustit.Select Run in the Home ribbon.

    Snímek obrazovky s výběrem možnosti Spustit na pásu karet Domů

    Teď se hodnoty zobrazují.Now you see the values. Matice má více řádků, než jste viděli v návrhovém zobrazení.The matrix has more rows than you saw in Design view! Stránku můžete buď naformátovat, nebo se před uložením do místního počítače nebo publikováním do služby rozhodnout použít výchozí nastavení.You can either format the page or decide to use the default settings before saving to your local computer or publishing to the service.

  2. Pokud chcete zjistit, jak bude sestava vypadat po vytištění, vyberte Rozložení při tisku.To see how your report will look when you print it, select Print Layout.

    Snímek obrazovky s výběrem rozložení při tisku

    Teď se zobrazí tak, jak bude vypadat na vytištěné stránce.Now you see it as it will look on a printed page.

    Snímek obrazovky sestavy v zobrazení rozložení při tisku

Nahrání stránkované sestavy do služby Power BIUpload the paginated report to the Power BI service

Služba Power BI nyní podporuje stránkované sestavy, které můžete nahrát do kapacity Premium.Now that paginated reports are supported in the Power BI service, you can upload your paginated report to a Premium capacity. Podrobnosti najdete v části Nahrání stránkované sestavy.See Upload a paginated report for details.

Nahrání stránkované sestavy na server sestavUpload the paginated report to a report server

Stránkovanou sestavu také můžete nahrát na Server sestav Power BI, do systému SQL Server Reporting Services 2016 nebo na server sestav 2017.You can also upload your paginated report to a Power BI Report Server or SQL Server Reporting Services 2016 or 2017 report server. Ještě předtím ale musíte do souboru RsReportServer.config přidat následující položku jako další rozšíření dat.Before you do, you need to add the following item to your RsReportServer.config as an additional data extension. Než budete soubor RsReportServer.config měnit, zazálohujte ho pro případ, že by se vyskytly problémy.Back up your RsReportServer.config file before you make the change, in case you run into any issues.

<Extension Name="ENTERDATA" Type="Microsoft.ReportingServices.DataExtensions.XmlDPConnection,Microsoft.ReportingServices.DataExtensions">
    <Configuration>
        <ConfigName>ENTERDATA</ConfigName>
    </Configuration>
</Extension>

Upravený seznam poskytovatelů dat by měl v konfiguračním souboru vypadat takto:After you've edited it, here's what the list of data providers in the config file should look like:

Snímek obrazovky s konfiguračním souborem RsReportServer

To je všechno. Teď můžete na serveru sestav publikovat sestavy, které používají tuto novou funkci.That’s it – you can now publish reports that use this new functionality to your report server.

Další krokyNext steps