Provádění běžných úloh s dotazy v Power BI DesktopuPerform common query tasks in Power BI Desktop

V okně Editor Power Query v Power BI Desktopu se nejčastěji využívá několik úloh.In the Power Query Editor window of Power BI Desktop, there are a handful of commonly used tasks. Tento článek tyto běžné úlohy představuje a nabízí odkazy na další informace.This article demonstrates those common tasks and provides links for additional information.

Běžné úlohy s dotazy, které v tomto článku vysvětlujeme:The common query tasks demonstrated here are:

  • Připojení k datůmConnect to data
  • Tvarování a kombinování datShape and combine data
  • Seskupení řádkůGroup rows
  • Kontingenční sloupcePivot columns
  • Vytváření vlastních sloupcůCreate custom columns
  • Vzorce dotazůQuery formulas

U těchto úloh využijeme několik datových připojení.We’ll use a few data connections to complete these tasks. Pokud si chcete úlohy projít sami, můžete si tato data stáhnout nebo se k nim připojit.The data is available for you to download or connect to, in case you want to step through these tasks yourself.

První datové připojení představuje excelový sešit, který si můžete stáhnout a uložit místně.The first data connection is an Excel workbook, which you can download and save locally. Druhé je webový prostředek, který se používá také v jiných článcích o Power BI Desktopu:The other is a Web resource that's also used in other Power BI Desktop articles:

https://www.bankrate.com/retirement/best-and-worst-states-for-retirement/

Běžné úlohy s dotazy začínají provedením kroků potřebných k připojení obou daných zdrojů dat.Common query tasks begin at the steps necessary to connect to both of those data sources.

Připojení k datůmConnect to data

Pokud se chcete připojit k datům v Power BI Desktopu, vyberte Domovská stránka a pak Načíst data.To connect to data in Power BI Desktop, select Home and then Get Data. Power BI Desktop obsahuje nabídku s nejběžnějšími zdroji dat.Power BI Desktop presents a menu with the most common data sources. Úplný seznam zdrojů dat, k nimž se z Power BI Desktopu dá připojit, zobrazíte vybráním možnosti Další na konci nabídky.For a complete list of data sources to which Power BI Desktop can connect, select More at the end of the menu. Další informace najdete v tématu Zdroje dat v Power BI Desktopu.For more information, see Data sources in Power BI Desktop.

Nabídka nejběžnějších zdrojů dat, tlačítko Načíst data, Power BI Desktop

Pokud chcete začít, vyberte Excel, zadejte excelový sešit uvedený výše a potom vyberte Otevřít.To start, select Excel, specify the Excel workbook mentioned earlier, and then select Open. Funkce dotazu sešit zkontroluje a nalezená data po vybrání tabulky zobrazí v dialogovém okně Navigátor.Query inspects the workbook, then presents the data it found in the Navigator dialog box after you select a table.

Excelový zdroj dat, dialogové okno Navigátor, Načíst data, Power BI Desktop

Před načtením do Power BI Desktopu můžete data upravit, přizpůsobit nebo zformovat vybráním možnosti Transformovat data.You can select Transform Data to edit, adjust, or shape, the data before you load it into Power BI Desktop. Úpravy jsou zvlášť užitečné, když pracujete s velkými datovými sadami, které chcete před načtením zredukovat.Editing is especially useful when you work with large datasets that you want to pare down before loading.

Připojení k jiným typům dat je stejně jednoduché.Connecting to different types of data is as easy. Chcete se připojit také k webovému prostředku.You also want to connect to a Web resource. Zvolte Načíst data > Další a pak vyberte Další > Web > Připojit.Choose Get Data > More, and then select Other > Web > Connect.

Webový zdroj dat, dialogové okno Načíst data, Power BI Desktop

Zobrazí se dialogové okno Z webu, kam můžete zadat URL požadované webové stránky.The From Web dialog box appears, where you can type in the URL of the Web page.

Dialogové okno Z webu, webový zdroj dat, Načíst data, Power BI Desktop

Vyberte OK.Select OK. Podobně jako předtím Power BI Desktop zkontroluje data webové stránky a zobrazí možnosti náhledu v dialogovém okně Navigátor.Like before, Power BI Desktop inspects the Web page data and shows preview options in the Navigator dialog box. Po vybrání tabulky se zobrazí náhled dat.When you select a table, it displays a preview of the data.

Další datová připojení fungují obdobně.Other data connections are similar. Pokud se pro připojení k datům vyžaduje ověření, v Power BI Desktopu se zobrazí výzva k zadání příslušných údajů.If authentication is required to make a data connection, Power BI Desktop prompts you for the appropriate credentials.

Ukázku, jak se připojit k datům v Power BI Desktopu krok za krokem, najdete v tématu Připojení k datům v Power BI Desktopu.For a step-by-step demonstration of connecting to data in Power BI Desktop, see Connect to data in Power BI Desktop.

Tvarování a kombinování datShape and combine data

Pomocí Editoru Power Query můžete data snadno tvarovat a kombinovat.You can easily shape and combine data with Power Query Editor. Tato část obsahuje několik příkladů, jak se data dají tvarovat.This section includes a few examples of how you can shape data. Ucelenější ukázku tvarování a kombinování dat najdete v tématu Tvarování a kombinování dat v Power BI Desktopu.For a more complete demonstration of shaping and combining data, see Shape and combine Data with Power BI Desktop.

V předchozí části jste se připojili k dvěma sadám dat: k excelovému sešitu a k webovému prostředku.In the previous section, you connected to two sets of data: an Excel workbook and a Web resource. Po načtení dat v Editoru Power Query vyberte dotaz na webovou stránku z dostupných dotazů v podokně Dotazy, jak je znázorněno zde:After the data is loaded in Power Query Editor, select the Web page query from the available queries in the Queries pane, as shown here:

Podokno Dotazy, Editor Power Query, Power BI Desktop

Při tvarování dat transformujete zdroj dat do podoby a formátu podle svých potřeb.When you shape data, you transform a data source into the form and format that meets your needs.

V Editoru Power Query lze mnoho příkazů najít na pásu karet a v místních nabídkách.In Power Query Editor, many commands can be found in the ribbon, and in context menus. Když například kliknete pravým tlačítkem na sloupec, v místní nabídce můžete sloupec odebrat.For example, when you right-click a column, the context menu lets you remove the column. Můžete také vybrat sloupec a pak vybrat Odebrat sloupce na kartě Domovská stránka na pásu karet.You may also select a column and then select the Remove Columns button from the Home tab in the ribbon.

Příkaz Odebrat sloupce, Editor Power Query, Power BI Desktop

V tomto dotazu můžete data tvarovat mnoha dalšími způsoby.You can shape the data in many other ways in this query. Můžete odebrat libovolný počet řádků shora nebo zdola.You may remove any number of rows from the top or bottom. Můžete také přidat sloupce, rozdělit sloupce, nahradit hodnoty a provádět další úlohy tvarování.Or you may add columns, split columns, replace values, and do other shaping tasks. Díky těmto funkcím můžete Editor Power Query využít k získání dat podle svých potřeb.With these features, you can direct Power Query Editor to get the data how you want it.

Seskupení řádkůGroup rows

V Editoru Power Query můžete seskupit hodnoty z více řádků do jediné hodnoty.In Power Query Editor, you can group the values from many rows into a single value. Tato funkce se může hodit, když potřebujete sečíst počet nabízených produktů, celkový prodej nebo počet studentů.This feature can be useful when summarizing the number of products offered, the total sales, or the count of students.

V našem příkladu seskupíte řádky v sadě dat o zápisech do vzdělávacích institucí.In this example, you group rows in an education enrollment dataset. Data pocházejí z excelového sešitu.The data is from the Excel workbook. Jsou zformovaná v Editoru Power Query, abyste mohli načíst jenom ty sloupce, které potřebujete, přejmenovat tabulku a provést několik dalších transformací.It's been shaped in Power Query Editor to get just the columns you need, rename the table, and make a few other transforms.

Pojďme zjistit, kolik úřadů (Agencies) má každý stát.Let’s find out how many Agencies each state has. (Úřady můžou zahrnovat školské obvody, jiné vzdělávací organizace, jako jsou oblastní obvody služeb a další.) Vyberte sloupec Agency ID - NCES Assigned [District] Latest available year a potom tlačítko Seskupit podle na kartě Transformace nebo na kartě Domovská stránka na pásu karet.(Agencies can include school districts, other education agencies such as regional service districts, and more.) Select the Agency ID - NCES Assigned [District] Latest available year column, then select the Group By button in the Transform tab or the Home tab of the ribbon. (Seskupit podle je k dispozici na obou kartách.)(Group By is available in both tabs.)

Snímek obrazovky ukazuje, jak seskupit řádky v tabulce.

Zobrazí se dialogové okno Seskupit podle.The Group By dialog box appears. Když Editor Power Query seskupí řádky, vytvoří nový sloupec, kam umístí výsledky operace Seskupit podle.When Power Query Editor groups rows, it creates a new column into which it places the Group By results. Operaci Seskupit podle můžete upravit následujícími způsoby:You can adjust the Group By operation in the following ways:

  1. Rozevírací seznam bez popisku určuje sloupec, který se má seskupit.The unlabeled dropdown list specifies the column to be grouped. Editor Power Query nastaví tuto hodnotu na vybraný sloupec, ale můžete ji změnit na libovolný sloupec v tabulce.Power Query Editor defaults this value to the selected column, but you can change it to be any column in the table.
  2. Nový název sloupce: Editor Power Query navrhne název pro nový sloupec podle operace, která se uplatňuje na seskupený sloupec.New column name: Power Query Editor suggests a name for the new column, based on the operation it applies to the column being grouped. Nový sloupec ale můžete pojmenovat jakkoli chcete.You can name the new column anything you want, though.
  3. Operace: Můžete zvolit operaci, kterou používá Editor Power Query, například Součet, Medián nebo Počet jedinečných řádků.Operation: You may choose the operation that Power Query Editor applies, such as Sum, Median, or Count Distinct Rows. Výchozí hodnota je Počet řádků.The default value is Count Rows.
  4. Přidat seskupení a Přidat agregaci: Tato tlačítka jsou k dispozici pouze v případě, že vyberete možnost Upřesnění.Add grouping and Add aggregation: These buttons are available only if you select the Advanced option. V rámci jedné operace můžete provádět operace seskupení (akce Seskupit podle) na mnoha sloupcích a pomocí těchto tlačítek vytvořit několik agregací.In a single operation, you can make grouping operations (Group By actions) on many columns and create several aggregations using these buttons. Na základě vašich výběrů v tomto dialogovém okně Editor Power Query vytvoří nový sloupec, který bude fungovat na více sloupcích.Based on your selections in this dialog box, Power Query Editor creates a new column that operates on multiple columns.

Vyberte možnost Přidat seskupení nebo Přidat agregaci a přidejte do operace Seskupit podle další seskupení nebo agregace.Select Add grouping or Add aggregation to add more groupings or aggregations to a Group By operation. Chcete-li odebrat seskupení nebo agregaci, vyberte ikonu tří teček ( ) napravo od řádku a potom možnost Odstranit.To remove a grouping or aggregation, select the ellipsis icon (...) to the right of the row, and then Delete. Pokračujte dál a vyzkoušejte operaci Seskupit podle s použitím výchozích hodnot, abyste viděli, co se stane.Go ahead and try the Group By operation using the default values to see what occurs.

Snímek obrazovky zobrazuje dialogové okno Seskupit podle se zvýrazněnými položkami Přidat seskupení a Přidat agregaci.

Když stisknete OK, funkce dotazu provede operaci Seskupit podle a vrátí výsledky.When you select OK, Query does the Group By operation and returns the results. To je zajímavé – v každém ze států Ohio, Illinois, Texas a Kalifornie je teď přes tisíc úřadů.Whew, look at that – Ohio, Illinois, Texas, and California now each have over a thousand agencies!

Sloupec Počet, operace Seskupit podle, Editor Power Query, Power BI Desktop

S Editorem Power Query můžete vždycky odebrat poslední operaci tvarování.And with Power Query Editor, you can always remove the last shaping operation. V podokně Nastavení dotazů v části Použitý postup vyberte X vedle kroku, který jste nedávno dokončili.In the Query Settings pane, under Applied Steps, just select the X next to the step recently completed. Začněte experimentovat.So go ahead and experiment. Pokud se vám výsledky nelíbí, opakujte daný krok, dokud Editor Power Query nezformuje data podle vašich potřeb.If you don’t like the results, redo the step until Power Query Editor shapes your data the way you want.

Kontingenční sloupcePivot columns

Můžete využít kontingenční sloupce a vytvořit tabulku obsahující agregované hodnoty pro každou jedinečnou hodnotu ve sloupci.You can pivot columns and create a table that contains aggregated values for each unique value in a column. Například pokud chcete zjistit, kolik různých produktů je v každé kategorii produktů, můžete k tomu rychle vytvořit tabulku.For example, to find out how many different products are in each product category, you can quickly create a table to do that.

Podívejme se na příklad.Let’s look at an example. Následující tabulka Products_by_Categories byla vytvarována tak, aby zobrazovala jenom jedinečné produkty (podle názvu) a kategorii, kam každý z nich spadá.The following Products_by_Categories table has been shaped to only show each unique product (by name), and which category each product falls under. Pokud chcete vytvořit novou tabulku, která zobrazuje počet produktů pro jednotlivé kategorie (na základě sloupce CategoryName), vyberte sloupec a pak vyberte Transformovat > Kontingenční sloupec.To create a new table that shows a count of products for each category (based on the CategoryName column), select the column, then select Transform > Pivot Column.

Příkaz kontingenčního sloupce, Editor Power Query, Power BI Desktop

Zobrazí se dialogové okno Kontingenční sloupec, ve kterém zjistíte, které hodnoty ve sloupci se použijí k vytvoření nových sloupců (1).The Pivot Column dialog box appears, letting you know which column’s values will be used to create new columns (1). (Pokud není zobrazen požadovaný název sloupce CategoryName, vyberte ho z rozevíracího seznamu.) Když rozbalíte Upřesnit možnosti (2), můžete vybrat funkci, která se použije na agregované hodnoty (3).(If the wanted column name of CategoryName isn't shown, select it from the dropdown list.) When you expand Advanced options (2), you can select the function that will be applied to the aggregated values (3).

Dialogové okno Kontingenční sloupec, Editor Power Query, Power BI Desktop

Jakmile vyberete OK, funkce dotazu zobrazí tabulku podle pokynů pro transformaci, které jste zadali v dialogovém okně Kontingenční sloupec.When you select OK, Query displays the table according to the transform instructions provided in the Pivot Column dialog box.

Výsledek kontingenčního sloupce, Editor Power Query, Power BI Desktop

Vytváření vlastních sloupcůCreate custom columns

V Editoru Power Query můžete vytvořit vlastní vzorce, které budou fungovat na více sloupcích v tabulce.In Power Query Editor, you can create custom formulas that operate on multiple columns in your table. Pak můžete výsledky těchto vzorců umístit do nového (vlastního) sloupce.Then you may place the results of such formulas into a new (custom) column. V Editoru Power Query je vytváření vlastních sloupců snadné.Power Query Editor makes it easy to create custom columns.

V Editoru Power Query, který používá data z excelového sešitu, otevřete na pásu karet kartu Přidání sloupce a pak vyberte Vlastní sloupec.With the Excel workbook data in Power Query Editor, go to the Add Column tab on the ribbon, and then select Custom Column.

Příkaz přidání vlastního sloupce, Editor Power Query, Power BI Desktop

Zobrazí se následující dialogové okno.The following dialog box appears. V tomto příkladu vytvořte vlastní sloupec s názvem Percent ELL, kde se z celkového počtu studentů vypočítá procento těch, kteří se učí anglicky (ELL).In this example, create a custom column called Percent ELL that calculates the percentage of total students that are English Language Learners (ELL).

Dialogové okno Vlastní sloupec, Editor Power Query, Power BI Desktop

Stejně jako u všech ostatních použitých kroků v Editoru Power Query platí, že pokud nový vlastní sloupec neposkytne data, která hledáte, můžete tento krok odstranit.As with any other applied step in Power Query Editor, if the new custom column doesn’t provide the data you’re looking for, you can delete the step. V podokně Nastavení dotazů v části Použitý postup vyberte X vedle kroku Přidané: Vlastní.In the Query Settings pane, under Applied Steps, just select the X next to the Added Custom step.

Použitý postup, podokno Nastavení dotazů, Editor Power Query, Power BI Desktop

Vzorce dotazůQuery formulas

Můžete upravit kroky, které Editor Power Query generuje.You can edit the steps that Power Query Editor generates. Můžete také vytvořit vlastní vzorce, které vám umožní přesně se připojit k datům a zformovat je.You can also create custom formulas, which let you connect to and shape your data more precisely. Pokaždé, když Editor Power Query provede akci s daty, zobrazí se na řádku vzorců vzorec přidružený k akci.Whenever Power Query Editor does an action on data, the formula associated with the action is displayed in the formula bar. Chcete-li zobrazit řádek vzorců, na pásu karet klikněte na kartu Zobrazení a pak vyberte Řádek vzorců.To view the formula bar, go to the View tab of the ribbon, and then select Formula Bar.

Možnost Řádek vzorců, Editor Power Query, Power BI Desktop

Editor Power Query uchová všechny kroky použité v jednotlivých dotazech jako text, který můžete zobrazit nebo upravit.Power Query Editor keeps all applied steps for each query as text that you can view or modify. Můžete zobrazit nebo upravit text pro libovolný dotaz pomocí Rozšířeného editoru.You can view or modify the text for any query using the Advanced Editor. Stačí vybrat Zobrazení a pak Rozšířený editor.Just select View and then Advanced Editor.

Příkaz Rozšířený editor, Editor Power Query, Power BI Desktop

Tady vidíte Rozšířený editor s postupem přidruženým k dotazu USA_Zápisy_studentů.Here's a look at the Advanced Editor, with the query steps associated with the USA_StudentEnrollment query displayed. Kroky postupu jsou vytvořené v jazyce vzorců Power Query, který se často označuje jako M. Další informace najdete v tématu Seznámení se vzorci Power Query.These steps are created in the Power Query Formula Language, often referred to as M. For more information, see Learn about Power Query formulas. Pokud chcete zobrazit samotnou specifikaci jazyka, přečtěte si téma Specifikace jazyka Power Query M.To view the language specification itself, see Power Query M language specification.

Dialogové okno Rozšířený editor, Editor Power Query, Power BI Desktop

Power BI Desktop nabízí rozsáhlou sadu kategorií vzorců.Power BI Desktop provides an extensive set of formula categories. Další informace a kompletní popis všechny vzorců Editoru Power Query najdete v tématu Referenční informace o funkcích jazyka Power Query M.For more information, and a complete reference of all Power Query Editor formulas, see Power Query M function reference.

Další krokyNext steps

Pomocí Power BI Desktopu můžete provádět nejrůznější akce.You can do all sorts of things with Power BI Desktop. Další informace o jeho funkcích najdete v těchto článcích:For more information on its capabilities, see the following resources: