Základní informace o dotazech v Power BI DesktopuQuery overview in Power BI Desktop

S Power BI Desktopem se můžete připojit k různým datům, vytvářet poutavé a podkladové sestavy a sdílet výsledky svého úsilí s ostatními, aby mohli stavět na vaší práci a rozšiřovat své aktivity v oblasti business intelligence.With Power BI Desktop you can connect to the world of data, create compelling and foundational reports, and share your efforts with others – who can then build on your work, and expand their business intelligence efforts.

Power BI Desktop zahrnuje tři zobrazení:Power BI Desktop has three views:

  • Sestava – zobrazení, ve kterém můžete pomocí dotazů vytvářet působivé vizualizace uspořádané podle vašich představ, které můžou mít více stran a které můžete sdílet s ostatními.Report view – where you use queries you create to build compelling visualizations, arranged as you want them to appear, and with multiple pages, that you can share with others
  • Data – zobrazení dat v sestavě ve formátu datového modelu, ve kterém můžete přidávat míry, vytvářet nové sloupce a spravovat relace.Data view – see the data in your report in data model format, where you can add measures, create new columns, and manage relationships
  • Relace – zobrazení poskytující grafické znázornění relací vytvořených v datovém modelu a umožňující jejich správu a úpravy podle potřeby.Relationships view – get a graphical representation of the relationships that have been established in your data model, and manage or modify them as needed.

K těmto zobrazením získáte přístup výběrem jedné ze tří ikon na levé straně Power BI Desktopu.Access these views by selecting one of the three icons along the left side of Power BI Desktop. Na následujícím obrázku je vybráno zobrazení Sestava, což je indikováno žlutým proužkem vedle ikony.In the following image, Report view is selected, indicated by the yellow band beside the icon.

Snímek obrazovky Power BI Desktopu s vybraným zobrazením Sestava

Součástí Power BI Desktopu je také Editor Power Query.Power BI Desktop also comes with Power Query Editor. Pomocí Editoru Power Query se můžete připojit k jednomu nebo k mnoha zdrojům dat, strukturovat a transformovat data podle svých potřeb a pak tento model načíst do Power BI Desktopu.Use Power Query Editor to connect to one or many data sources, shape and transform the data to meet your needs, then load that model into Power BI Desktop.

Tento dokument poskytuje přehled práce s daty v Editoru Power Query, ale k učení toho zbývá ještě dost.This document provides an overview of the work with data in the Power Query Editor, but there's more to learn. Na konci tohoto dokumentu najdete odkazy na podrobné informace o podporovaných datových typech.At the end of this document, you'll find links to detailed guidance about supported data types. Najdete tam také informace o připojení k datům, strukturování dat, vytváření relací a pokyny, které vám pomohou začít.You'll also find guidance about connecting to data, shaping data, creating relationships, and how to get started.

Nejprve se ale seznámíme s Editorem Power Query.But first, let's see get acquainted with Power Query Editor.

Editor Power QueryPower Query Editor

K Editoru Power Query se dostanete tak, že v Power BI Desktopu vyberete Upravit dotazy na kartě Domovská stránka.To get to Power Query Editor, select Edit Queries from the Home tab of Power BI Desktop.

Snímek obrazovky Power BI Desktopu s Editorem Power Query a kartou Domů

Bez datových připojení vypadá Editor Power Query jako prázdné podokno připravené na data.With no data connections, Power Query Editor appears as a blank pane, ready for data.

Snímek obrazovky Power BI Desktopu s Editorem Power Query bez datových připojení

Po načtení dotazu se zobrazení Editoru Power Query stane zajímavějším.Once a query is loaded, Power Query Editor view becomes more interesting. Pokud se připojíme k následujícímu webovému zdroji dat, načte Editor Power Query informace o těchto datech, která pak můžete začít strukturovat:If we connect to the following Web data source, Power Query Editor loads information about the data, which you can then begin to shape:

https://www.bankrate.com/retirement/best-and-worst-states-for-retirement/

Takto vypadá Editor Power Query po připojení k datům:Here's how Power Query Editor appears once a data connection is established:

  1. Na pásu karet je teď aktivních mnoho tlačítek pro interakci s daty v dotazu.In the ribbon, many buttons are now active to interact with the data in the query.

  2. V levém podokně jsou vypsané dotazy, které můžete použít k výběru, zobrazení a strukturování.In the left pane, queries are listed and available for selection, viewing, and shaping.

  3. V prostředním podokně se zobrazují data z vybraného dotazu, která je možné strukturovat.In the center pane, data from the selected query is displayed and available for shaping.

  4. V podokně Nastavení dotazů se zobrazuje seznam vlastností dotazu a použité kroky.The Query Settings pane appears, listing the query's properties and applied steps.

    Snímek obrazovky Power BI Desktopu s podoknem Nastavení dotazů v Editoru Power Query

Podíváme se na každou z těchto čtyř oblastí: pás karet, podokno Dotazy, zobrazení Data a podokno Nastavení dotazů.We'll look at each of these four areas: the ribbon, the Queries pane, the Data view, and the Query Settings pane.

Pás karet pro dotazyThe query ribbon

Pás karet se v Editoru Power Query skládá ze čtyř karet: Domovská stránka, Transformace, Přidání sloupce a Zobrazení.The ribbon in Power Query Editor consists of four tabs: Home, Transform, Add Column, and View.

Karta Domovská stránka obsahuje běžné úlohy týkající se dotazů.The Home tab contains the common query tasks.

Snímek obrazovky Power BI Desktopu s pásem karet pro dotazy v Editoru Power Query

Když se chcete připojit k datům a zahájit proces vytváření dotazu, vyberte Nový zdroj.To connect to data and begin the query building process, select New Source. Zobrazí se nabídka s nejběžnějšími zdroji dat.A menu appears, providing the most common data sources.

Snímek obrazovky Power BI Desktopu s tlačítkem Nový zdroj

Další informace o dostupných zdrojích dat najdete v článku Zdroje dat.For more information about available data sources, see Data Sources. Informace o připojování k datům včetně příkladů a postupů najdete v článku Připojení k datům.For information about connecting to data, including examples and steps, see Connect to Data.

Karta Transformace poskytuje přístup k běžným úlohám transformace dat, mezi které patří:The Transform tab provides access to common data transformation tasks, such as:

  • Přidání nebo odebrání sloupcůAdding or removing columns
  • Změna datových typůChanging data types
  • Rozdělení sloupcůSplitting columns
  • Jiné úlohy související s datyOther data-driven tasks

Snímek obrazovky Power BI Desktopu s kartou Domů

Další informace o transformaci dat včetně příkladů najdete v článku Kurz: Strukturování a kombinování dat v Power BI Desktopu.For more information about transforming data, including examples, see Tutorial: Shape and combine data in Power BI Desktop.

Na kartě Přidat sloupce najdete další úlohy související s přidáváním sloupců, formátováním sloupců dat a přidáváním vlastních sloupců.The Add Column tab provides additional tasks associated with adding a column, formatting column data, and adding custom columns. Karta Přidat sloupce je znázorněna na následujícím obrázku.The following image shows the Add Column tab.

Snímek obrazovky Power BI Desktopu s kartou Přidat sloupce

Na kartě Zobrazení na pásu karet můžete určit, jestli budou určitá podokna nebo okna zobrazena.The View tab on the ribbon is used to toggle whether certain panes or windows are displayed. Můžete ho také použít k zobrazení Rozšířeného editoru.It's also used to display the Advanced Editor. Karta Zobrazení je znázorněna na následujícím obrázku.The following image shows the View tab.

Snímek obrazovky Power BI Desktopu s kartou Zobrazení

Je dobré vědět, že mnoho úloh, které jsou dostupné na pásu karet, je také dostupných v prostředním okně po kliknutí pravým tlačítkem na sloupec nebo na jiná data.It's useful to know that many of the tasks available from the ribbon are also available by right-clicking a column, or other data, in the center pane.

Levé podokno (Dotazy)The left (Queries) pane

V levém podokně Dotazy se zobrazuje počet aktivních dotazů a také jejich názvy.The left pane, or Queries pane, displays the number of active queries and the name of the query. Když v levém podokně vyberete dotaz, zobrazí se data dotazu v prostředním podokně, kde je můžete tvarovat a transformovat tak, aby odpovídala vašim potřebám.When you select a query from the left pane, its data is displayed in the center pane, where you can shape and transform the data to meet your needs. Na následujícím obrázku je znázorněno levé podokno s dotazem.The following image shows the left pane with a query.

Snímek obrazovky Power BI Desktopu s levým podoknem Dotazy

Prostřední podokno (Data)The center (Data) pane

V prostředním podokně Data se zobrazují data z vybraného dotazu.In the center pane, or Data pane, data from the selected query is displayed. V tomto podokně probíhá většina práce v zobrazení Dotaz.This pane is where much of the work of the Query view is accomplished.

Na následujícím obrázku je znázorněno dříve vytvořené připojení k datům z webu.In the following image shows the Web data connection established earlier. Je vybraný sloupec Product, na jehož záhlaví je kliknuto pravým tlačítkem, aby se zobrazily dostupné položky nabídky.The Product column is selected, and its header is right-clicked to show the available menu items. Všimněte si, že mnoho z těchto položek v nabídce, která se zobrazila po kliknutí pravým tlačítkem, odpovídá tlačítkům na pásu karet.Notice that many of these right-click menu items are the same as buttons in the ribbon tabs.

Snímek obrazovky Power BI Desktopu s prostředním podoknem Data

Když vyberete položku nabídky vyvolané kliknutím pravým tlačítkem (nebo kliknete na tlačítko na pásu karet), aplikuje dotaz tento krok na data.When you select a right-click menu item (or a ribbon button), the query applies the step to the data. Zároveň tento krok uloží jako součást samotného dotazu.It also saves step as part of the query itself. Kroky se zaznamenávají v podokně Nastavení dotazů v postupném pořadí tak, jak je popsáno v následující části.The steps are recorded in the Query Settings pane in sequential order, as described in the next section.

Pravé podokno (Nastavení dotazů)The right (Query Settings) pane

V pravém podokně Nastavení dotazů se zobrazují všechny kroky přidružené k dotazu.The right pane, or Query Settings pane, is where all steps associated with a query are displayed. Například na následujícím obrázku odráží část Použitý postup v podokně Nastavení dotazů skutečnost, že jsme právě změnili typ sloupce s celkovým skóre.For example, in the following image, the Applied Steps section of the Query Settings pane reflects the fact that we just changed the type of the Overall score column.

Snímek obrazovky Power BI Desktopu s pravým podoknem Nastavení dotazů

Další kroky strukturování dat aplikované na dotaz se zaznamenávají v části Použitý postup.As additional shaping steps are applied to the query, they're captured in the Applied Steps section.

Je důležité vědět, že podkladová data se přitom nemění.It's important to know that the underlying data isn't changed. Editor Power Query místo toho upravuje a strukturuje zobrazení těchto dat.Rather, Power Query Editor adjusts and shapes its view of the data. Zároveň strukturuje a upravuje zobrazení všech prováděných interakcí s podkladovými daty, a to na základě strukturovaného a upraveného zobrazení dat v Editoru Power Query.It also shapes and adjusts the view of any interaction with the underlying data that occurs based on Power Query Editor's shaped and modified view of that data.

V podokně Nastavení dotazů můžete kroky přejmenovávat, odstraňovat nebo měnit jejich pořadí podle potřeby.In the Query Settings pane, you can rename steps, delete steps, or reorder the steps as you see fit. To můžete udělat tak, že kliknete pravým tlačítkem na krok v části Použitý postup a zvolíte možnost v nabídce, která se zobrazí.To do so, right-click the step in the Applied Steps section, and choose from the menu that appears. Všechny kroky dotazu se provádějí v pořadí, v jakém jsou uvedeny v podokně Použitý postup.All query steps are carried out in the order they appear in the Applied Steps pane.

Snímek obrazovky Power BI Desktopu s filtry vlastností nastavených dotazů a použitých kroků

Rozšířený editorAdvanced Editor

Rozšířený editor umožňuje zobrazit kód, který Editor Power Query vytváří s každým krokem.The Advanced Editor lets you see the code that Power Query Editor is creating with each step. Umožňuje také vytvořit vlastní kód pro strukturování dat.It also lets you create your own shaping code. Rozšířený editor spustíte tak, že na pásu karet vyberete Zobrazení a pak vyberete Rozšířený editor.To launch the advanced editor, select View from the ribbon, then select Advanced Editor. Zobrazí se okno s kódem stávajícího dotazu.A window appears, showing the existing query code.
Snímek obrazovky Power BI Desktopu s dialogovým oknem Rozšířený editorScreenshot of Power B I Desktop showing Advanced Editor dialog box.

Kód můžete v okně Rozšířený editor přímo upravovat.You can directly edit the code in the Advanced Editor window. Když chcete okno zavřít, vyberte tlačítko Hotovo nebo Zrušit.To close the window, select the Done or Cancel button.

Ukládání práceSaving your work

Jakmile dotaz vyhovuje vašim potřebám, vyberte Zavřít a použít v nabídce Soubor Editoru Power Query.When your query is where you want it, select Close & Apply from Power Query Editor's File menu. Tato akce aplikuje změny a zavře editor.This action applies the changes and closes the editor.
Snímek obrazovky Power BI Desktopu s možností Zavřít a použít na kartě SouborScreenshot of Power B I Desktop showing Close and Apply option under File tab.

Zatímco tato operace probíhá, zobrazuje se v Power BI Desktopu dialogové okno se stavem.As progress is made, Power BI Desktop provides a dialog to display its status.
Snímek obrazovky Power BI Desktopu s potvrzovacím dialogovým oknem Použít změny dotazů

Až budete připraveni, může Power BI Desktop vaši práci uložit ve formě souboru .pbix.When you're ready, Power BI Desktop can save your work in the form of a .pbix file.

Práci uložíte tak, že vyberete Soubor > Uložit (nebo Soubor > Uložit jako), jak je znázorněno na následujícím obrázku.To save your work, select File > Save (or File > Save As), as shown in the following image.
Snímek obrazovky Power BI Desktopu s kartou Soubor v Editoru Power QueryScreenshot of Power B I Desktop showing Power Query Editor File tab.

Další krokyNext steps

S Power BI Desktopem můžete dělat nejrůznější věci.There are all sorts of things you can do with Power BI Desktop. Další informace o jeho schopnostech najdete v těchto článcích:For more information on its capabilities, check out the following resources: