Vytvoření zcela nové aplikaceCreate an app from scratch

Vytvořte si vlastní, zcela novou aplikaci, která využívá některý z mnoha zdrojů dat. Pokud budete chtít, můžete další zdroje přidat později.Create your own app from scratch using any one of a variety of data sources, adding more sources later if you want. Definujte vzhled a chování každého prvku uživatelského rozhraní, abyste dosáhli optimálního výsledku, který přesně odpovídá vašim cílům a pracovním postupům.Specify the appearance and behavior of each UI element so that you can optimize the result for your exact goals and workflow. Tento přístup je časově mnohem náročnější než automatické generování aplikace, ale zkušení tvůrci aplikací mohou vytvořit tu nejlepší aplikaci odpovídající jejich potřebám.This approach is much more time-intensive than generating an app automatically, but experienced app makers can build the best app for their needs.

Poznámka: Toto téma bylo napsáno pro PowerApps Studio pro Windows, ale postup je stejný, i když otevřete PowerApps v prohlížeči.Note: This topic was written for PowerApps Studio for Windows, but the steps are similar if you open PowerApps in a browser.

Podle tohoto kurzu vytvoříte aplikaci se dvěma obrazovkami.By following this tutorial, you'll create an app that contains two screens. Na první obrazovce mohou uživatelé procházet sadu záznamů:On one screen, users can browse through a set of records:

Obrazovka, na které může uživatel procházet sadu dat

Na druhé obrazovce mohou uživatelé vytvořit záznam, aktualizovat jedno nebo více polí záznamu nebo celý záznam odstranit.On the other screen, users can create a record, update one or more fields in a record, or delete an entire record:

Obrazovka, na které může uživatel přidávat nebo aktualizovat data

PožadavkyPrerequisites

Tento kurz můžete použít k získání všeobecného přehledu nebo podle něj můžete přesně provést tyto kroky:You can review this tutorial for general concepts only, or you can follow it exactly if you complete these steps.

  1. Tato data zkopírujte a vložte je do souboru aplikace Excel.Copy this data, and then paste it into an Excel file.

    Start DayStart Day Start TimeStart Time Volunteer 1Volunteer 1 Volunteer 2Volunteer 2
    SaturdaySaturday 10–1210am-noon VasquezVasquez KumashiroKumashiro
    SaturdaySaturday 12–14noon-2pm IceIce SinghalSinghal
    SaturdaySaturday 14–162pm-4-pm MykMyk MuellerMueller
    SundaySunday 10–1210am-noon LiLi AdamsAdams
    SundaySunday 10–1210am-noon SinghSingh MorganMorgan
    SundaySunday 10–1210am-noon BatyeBatye NguyenNguyen
  2. Data formátujte jako tabulku s názvem Schedule, aby PowerApps mohla informace analyzovat.Format that data as a table, named Schedule, so that PowerApps can parse the information.

    Další informace najdete v tématu Vytvoření tabulky aplikace Excel na listu.For more information, see Create an Excel table in a worksheet.

  3. Soubor uložte pod názvem eventsignup.xls a pak ho nahrajte do účtu cloudového úložiště, jako je například OneDrive.Save the file under the name eventsignup.xls, and then upload it to a cloud-storage account, such as OneDrive.
  4. Pokud s PowerApps teprve začínáte:If you're new to PowerApps:

Vytvoření prázdné aplikace a připojení k datůmCreate a blank app, and connect to data

  1. V PowerApps Studiu v nabídce Soubor (u levého okraje obrazovky) klikněte nebo klepněte na Nový.In PowerApps Studio, click or tap New on the File menu (near the left edge of the screen).

    Možnost Nová v nabídce Soubor

  2. Na dlaždici Prázdná aplikace klikněte nebo klepněte na Rozložení pro telefon.On the Blank app tile, click or tap Phone layout.

    Možnost vytvoření aplikace z dat

  3. Pokud se zobrazí výzva, projděte si úvodní prohlídku, abyste pochopili hlavní oblasti PowerApps (případně klikněte nebo klepněte na Přeskočit).If prompted, take the intro tour to understand the main areas of PowerApps (or click or tap Skip).

    Rychlá prohlídka

    Prohlídku si můžete spustit i kdykoli později, když kliknete nebo klepnete na ikonu otazníku v pravém horním rohu a pak kliknete nebo klepnete na Vydat se na úvodní prohlídku.You can always take the tour later by clicking or tapping the question-mark icon near the upper-left corner of the screen and then clicking or tapping Take the intro tour.

  4. V levém navigačním panelu klikněte nebo klepněte na ikonu v pravém horním rohu, abyste se přepnuli do zobrazení miniatur.In the left navigation bar, click or tap an icon in the upper-right corner to switch to the thumbnail view.

    Přepnutí zobrazení

  5. V pravém podokně klikněte nebo klepněte na Přidat zdroj dat.In the right-hand pane, click or tap Add data source.

    Přidání zdroje dat

  6. Proveďte některý z těchto kroků:Perform either of these steps:

    • Pokud máte připojení k účtu cloudového úložiště, klikněte nebo klepněte na něj.If you already have a connection to your cloud-storage account, click or tap it.
    • Pokud nemáte připojení k účtu cloudového úložiště, klikněte nebo klepněte na Přidat připojení, klikněte nebo klepněte na typ účtu, klikněte nebo klepněte na Připojit, a pokud se zobrazí výzva, zadejte přihlašovací údaje.If you don't have a connection to your cloud-storage account, click or tap Add Connection, click or tap your account type, click or tap Connect, and then (if prompted) provide your credentials.
  7. V části Zvolit excelový soubor přejděte k souboru eventsignup.xlsx a klikněte nebo klepněte na něj.Under Choose an Excel file, browse to eventsignup.xlsx, and then click or tap it.

    Výběr excelového souboru, který chcete použít

  8. V části Zvolit tabulku zaškrtněte políčko Schedule (Plán) a pak klikněte nebo klepněte na Připojit.Under Choose a table, select the Schedule check box, and then click or tap Connect.

    Výběr excelové tabulky, kterou chcete použít

    Karta Zdroje dat v pravém podokně zobrazuje zdroje dat, které jste přidali do aplikace.The Data sources tab of the right-hand pane shows which data sources you've added to your app.

    Zobrazení připojených zdrojů dat

    Tento kurz vyžaduje jen jeden zdroj dat. Další zdroje dat můžete přidat později.This tutorial requires only one data source, but you can add more data sources later.

Zobrazení datShow the data

  1. Na kartě Domů klikněte nebo klepněte na Nová obrazovka a pak klikněte nebo klepněte na Obrazovka se seznamem.In the Home tab, click or tap New screen and then click or tap List screen.

    Přidání rozložení s nadpisem, podnadpisem a textem prvku

    Přidá se obrazovka s několika výchozími ovládacími prvky, jako je třeba vyhledávací pole a Galerie.A screen is added with several default controls, such as a search box and a Gallery control. Galerie zabírá celou obrazovku pod vyhledávacím polem.The gallery covers the entire screen under the search box.

  2. Klikněte nebo klepněte na libovolné místo v galerii (kromě šipky), například přímo pod vyhledávací pole.Click or tap anywhere in the gallery except an arrow, such as directly under the search box.

    Výběr galerie

  3. V pravém podokně otevřete seznam Rozložení a potom klikněte nebo klepněte na možnost, která zobrazuje název, titulek a text.In the right-hand pane, open the Layouts list, and then click or tap the option that shows a title, a subtitle and body.

    Výběr galerie

  4. V seznamu vlastností klikněte nebo klepněte na Items (Položky), zkopírujte tento vzorec a vložte ho do řádku vzorců:In the property list, click or tap Items, copy this formula, and paste it into the formula bar:

    SortByColumns(Search(Schedule; TextSearchBox1.Text; "Volunteer_x0020_1"); "Volunteer_x0020_1"; If(SortDescending1; SortOrder.Descending; SortOrder.Ascending))SortByColumns(Search(Schedule, TextSearchBox1.Text, "Volunteer_x0020_1"), "Volunteer_x0020_1", If(SortDescending1, SortOrder.Descending, SortOrder.Ascending))

    Pokud si nejste jistí, kde seznam vlastností najít, podívejte se na téma Přidání a konfigurace ovládacích prvků.If you're not sure where the property list is, see Add and configure controls.

    Poznámka: V případě excelových nebo sharepointových zdrojů dat obsahujících názvy sloupců s mezerami zobrazí PowerApps mezery jako _x0020_.Note: For Excel or SharePoint data sources that contain column names with spaces, PowerApps shows the spaces as "_x0020_". V tomto příkladu se sloupec Volunteer 1 zobrazí ve vzorci jako Volunteer_x0020_1.In this example, the column "Volunteer 1" appears in a formula as "Volunteer_x0020_1".

    V této galerii se zobrazují data z tabulky Schedule (Plán).This gallery shows the data from the Schedule table.

    Výchozí data z tabulky Schedule v galerii

    Vyhledávací pole umožňuje filtrovat galerii na základě textu zadaného uživatelem.A search box can filter the gallery based on text that the user types. Pokud uživatel do vyhledávacího pole napíše alespoň jedno písmeno, zobrazí se v galerii jen takové záznamy, které mají v poli Volunteer 1 zadaný text.If a user types at least one letter in the search box, the gallery shows only those records for which the Volunteer 1 field contains the text that the user typed.

    Tlačítko řazení seřadí záznamy podle dat ve sloupci Volunteer 1.The sort button can sort the records based on data in the Volunteer 1 column. Pokud uživatel na tlačítko klikne nebo klepne, přepne mezi vzestupným a sestupným řazením záznamů.If a user clicks or taps that button, the sort order toggles between ascending and descending.

    Tento vzorec obsahuje funkce Sort, If, IsBlank, Filter a Text.That formula contains the Sort, If, IsBlank, Filter, and Text functions. Více informací o těchto a dalších funkcích najdete v referenčních informacích ke vzorcům.For more information about these and other functions, see the formula reference

  5. Do vyhledávacího pole zadejte i a jednou (nebo několikrát – počet musí být lichý) klikněte nebo klepněte na tlačítko řazení.Type an i in the search box, and click or tap the sort button once (or an odd number of times).

    Galerie zobrazí tyto výsledky.The gallery shows these results.

    Řazení a filtrování galerie

    Přečtěte si další informace o řazení, filtrování a jiných funkcích.More information about the Sort, Filter, and other functions

  6. Vyberte ovládací prvek Popisek nahoře na obrazovce tím, že na něj kliknete nebo klepnete.Select the Label control at the top of the screen by clicking or tapping the control.

    Výběr záhlaví

  7. V seznamu vlastností klikněte nebo klepněte na Text, zkopírujte následující text a vložte ho do řádku vzorců:In the property list, click or tap Text, copy this text, and then paste it in the formula bar.
    View Records "View Records"

    Změna záhlaví

Vytvoření obrazovky ChangeScreen a jejího banneruCreate the ChangeScreen and its banner

  1. Odstraňte Screen1 a přejmenujte Screen2 na ViewScreen.Delete Screen1, and rename Screen2 to ViewScreen.

    Přejmenování obrazovky

  2. Přidejte obrazovku a přejmenujte ji na ChangeScreen.Add a screen, and rename it ChangeScreen.

    Přidání a přejmenování obrazovky

  3. Na kartě Vložení klikněte nebo klepněte na Text a pak klikněte nebo klepněte na Popisek.On the Insert tab, click or tap Text, and then click or tap Label.
  4. Nakonfigurujte ovládací prvek Popisek, který jste právě přidali:Configure the Label control that you just added:

    • Nastavte jeho vlastnost Text na tento vzorec:Set its Text property to this formula:
      Change record"Change record"
    • Nastavte jeho vlastnost Fill na tento vzorec:Set its Fill property to this formula:
      RGBA(62; 96; 170; 1)RGBA(62, 96, 170, 1).
    • Nastavte jeho vlastnost Color na tento vzorec:Set its Color property to this formula:
      RGBA(255; 255; 255; 1)RGBA(255, 255, 255, 1)
    • Vlastnost Align nastavte na Center.Set its Align property to Center.
    • Vlastnost X nastavte na 0.Set its X property to 0.
    • Vlastnost Width nastavte na 640.Set its Width property to 640.

      Změny se odrazí v ovládacím prvku Popisek.The Label control reflects your changes.

      Obrazovka ChangeScreen se záhlavím

Přidání a konfigurace formulářeAdd and configure a form

  1. Na kartě Vložení klikněte nebo klepněte na Formuláře a pak klikněte nebo klepněte na Upravit.On the Insert tab, click or tap Forms, and then click or tap Edit.
  2. Přesuňte formulář a změňte jeho velikost, aby pokrýval většinu obrazovky.Move and resize the form to cover most of the screen.

    Přidání formuláře

    Výchozí název formuláře je Form1, pokud jste nějaký formulář už nepřidali nebo neodebrali.The form is named Form1 by default unless you already added and removed a form. V takovém případě formulář přejmenujte na Form1.In that case, rename the form to Form1.

  3. Vlastnost DataSource formuláře Form1 nastavte na Schedule.Set DataSource property of Form1 to Schedule.
  4. Vlastnost Item formuláře Form1 nastavte na tento výraz:Set the Item property of Form1 to this expression:
    BrowseGallery1.SelectedBrowseGallery1.Selected
  5. V pravém podokně klikněte nebo klepněte zaškrtávací políčko u každého pole, které chcete zobrazit.In the right-hand pane, click or tap the checkbox for each field to show it.

    Zobrazení polí ve formuláři

  6. V dolní části formuláře klikněte nebo klepněte na Přidat vlastní kartu.Near the bottom of the form, click or tap Add a custom card.

    Přidání vlastní karty

  7. Na nové kartě přidejte ovládací prvek Popisek.Add a Label control in the new card.
  8. Vlastnost AutoHeight nového ovládacího prvku nastavte na true a jeho vlastnost Text nastavte na tento vzorec:Set the AutoHeight property of the new control to true, and set its Text property to this formula:
    Form1.ErrorForm1.Error

    V popisku se zobrazí případné chyby ve formuláři.The label will show any errors from the form.

  9. Na navigačním panelu vlevo klikněte nebo klepněte na miniaturu pro ChangeScreen a vyberte ji.In the left navigation bar, click or tap the thumbnail for the ChangeScreen to select it.
  10. Na kartě Vložení klikněte nebo klepněte na Ikony, klikněte nebo klepněte na možnost pro přidání šipky vzad a pak šipku přesuňte do levého dolního rohu obrazovky.On the Insert tab, click or tap Icons, click or tap the option to add a Back arrow, and then move the arrow to the lower-left corner of the screen.
  11. Vlastnost OnSelect šipky nastavte na tento vzorec:Set the arrow's OnSelect property to this formula:

    ResetForm(Form1);Navigate(ViewScreen;ScreenTransition.None)ResetForm(Form1);Navigate(ViewScreen,ScreenTransition.None)

    Když uživatel na šipku klikne nebo klepne, funkce Navigate otevře obrazovku ViewScreen.When the user clicks or taps the arrow, the Navigate function opens the ViewScreen.

  12. Pod formulář přidejte ovládací prvek Button (Tlačítko) a nastavte jeho vlastnost Text na "Save" (Uložit).Add a Button control under the form, and set the button's Text property to "Save".

    Přidání tlačítka pro uložení záznamu

  13. Do vlastnosti OnSelect tlačítka nastavte tento vzorec:Set the OnSelect property of the button to this formula::

    SubmitForm(Form1); If(Form1.ErrorKind = ErrorKind.None; Navigate(ViewScreen; ScreenTransition.None))SubmitForm(Form1); If(Form1.ErrorKind = ErrorKind.None, Navigate(ViewScreen, ScreenTransition.None))

    Když uživatel na tlačítko klikne nebo klepne, funkce SubmitForm uloží změny do zdroje dat a znovu se zobrazí obrazovka ViewScreen.When the user clicks or taps the button, the SubmitForm function saves any changes to the data source, and the ViewScreen reappears.

  14. Dolů na obrazovku přidejte další tlačítko a nastavte jeho vlastnost Text na "Remove" a do jeho vlastnosti OnSelect nastavte tento vzorec:At the bottom of the screen, add another button, set its Text property to "Remove", and set its OnSelect property to this formula:

    Remove(Schedule;BrowseGallery1.Selected);
    If(IsEmpty(Errors(Schedule));Navigate(ViewScreen;ScreenTransition.None))
    Remove(Schedule,BrowseGallery1.Selected);
    If(IsEmpty(Errors(Schedule)),Navigate(ViewScreen,ScreenTransition.None))

    Když uživatel na tlačítko klikne nebo klepne, funkce Odebrat záznam odebere a znovu se zobrazí obrazovka ViewScreen.When the user clicks or taps this button, the Remove function removes the record, and the ViewScreen reappears.

  15. Do vlastnosti Visible tlačítka Odebrat nastavte tento vzorec:Set the Visible property of the Remove button to this formula:
    Form1.Mode=FormMode.EditForm1.Mode=FormMode.Edit

    Tento krok skryje tlačítko Odebrat, když uživatel vytváří záznam.This step hides the Remove button when the user is creating a record.

    Obrazovka ChangeScreen odpovídající tomuto příkladu:The ChangeScreen matches this example:

    Konečná obrazovka ChangeScreen

Nastavení navigace z obrazovky ViewScreenSet navigation from ViewScreen

  1. Na navigačním panelu vlevo klikněte nebo klepněte na miniaturu pro obrazovku ViewScreen.In the left navigation bar, click or tap the thumbnail for the ViewScreen.

    Otevření obrazovky ViewScreen

  2. Klikněte nebo klepněte na šipku vpřed u prvního záznamu v galerii.Click or tap the Next arrow for the first record in the gallery.

    Šipka Další

  3. Do vlastnosti OnSelect šipky nastavte tento vzorec:Set the OnSelect property of that arrow to this formula:

    Navigate(ChangeScreen;ScreenTransition.None)Navigate(ChangeScreen,ScreenTransition.None)

  4. V pravém horním rohu klikněte nebo klepněte na ikonu plus.In the upper-right corner, click or tap the plus icon.

    Přidání záznamu

  5. Do vlastnosti OnSelect vybrané ikony nastavte tento vzorec:Set the OnSelect property of the selected icon to this formula:

    NewForm(Form1);Navigate(ChangeScreen;ScreenTransition.None)`NewForm(Form1);Navigate(ChangeScreen,ScreenTransition.None)`

    Když uživatel na tuto ikonu klikne nebo klepne, zobrazí se obrazovka ChangeScreen s prázdnými poli, aby uživatel mohl jednoduše vytvořit záznam.When the user clicks or taps this icon, ChangeScreen appears with each field empty, so that the user can create a record more easily.

Spuštění aplikaceRun the app

Při úpravách aplikace si změny můžete otestovat tím, že aplikaci spustíte v režimu náhledu podle postupu, který je popsaný v této části.As you customize the app, test your changes by running the app in Preview mode, as the steps in this section describe.

  1. Na navigačním panelu vlevo klikněte nebo klepněte na miniaturu a vyberte obrazovku ViewScreen.In the left navigation bar, click or tap the top thumbnail to select the ViewScreen.

    Výběr obrazovky ViewScreen

  2. Stisknutím F5 otevřete režim náhledu (nebo klikněte či klepněte na ikonu Náhled v pravém horním rohu).Open Preview mode by pressing F5 (or clicking or tapping the Preview icon near the upper-right corner).

    Otevření režimu náhledu

  3. Když kliknete nebo klepnete na šipku Další, zobrazí se jeho podrobnosti.Click or tap the Next arrow for a record to show details about that record.
  4. Na obrazovce ChangeScreen změňte informace v jednom nebo více polích a uložte změny tím, že kliknete nebo klepnete na Uložit. Pokud chcete záznam odebrat, klikněte nebo klepněte na Odebrat.On the ChangeScreen, change the information in one or more fields, and then save your changes by clicking or tapping Save, or remove the record by clicking or tapping Remove.
  5. Stisknutím klávesy Esc zavřete režim náhledu (můžete také kliknout nebo klepnout na ikonu Zavřít pod záhlavím).Close Preview mode by pressing Esc (or by clicking or tapping the close icon under the title bar).

    Zavření režimu náhledu

Další krokyNext steps