Vývoj s Q # +C#Develop with Q# + C#

Nainstalujte QDK pro vývoj C# hostitelských programů pro volání Q # Operations.Install the QDK to develop C# host programs to call Q# operations.

Q # je sestavený tak, aby se dobře hrál s jazyky C#.NET – konkrétně.Q# is built to play well with .NET languages--specifically C#. S tímto párováním můžete pracovat v různých vývojových prostředích:You can work with this pairing inside different development environments:

Vývoj pomocí Q # + C# pomocí sady Visual Studio Develop with Q# + C# using Visual Studio

Visual Studio nabízí bohatá prostředí pro vývoj programů Q #.Visual Studio offers a rich environment for developing Q# programs. Rozšíření Visual Studio Q # obsahuje šablony pro soubory a projekty Q # a také zvýrazňování syntaxe, dokončování kódu a podporu technologie IntelliSense.The Q# Visual Studio extension contains templates for Q# files and projects as well as syntax highlighting, code completion and IntelliSense support.

  1. PožadavkyPre-requisites

    • Visual Studio 16.3 s povolenými úlohami vývoje pro různé platformy pomocí rozhraní .NET CoreVisual Studio 16.3, with the .NET Core cross-platform development workload enabled
  2. Nainstalujte rozšíření sady Visual Studio pro jazyk Q#.Install the Q# Visual Studio extension

  3. Ověřte instalaci vytvořením aplikace Hello World.Verify the installation by creating a Hello World application

    • Vytvořte novou aplikaci v jazyku Q#.Create a new Q# application

      • Přejděte do části Soubor -> Nový -> Projekt.Go to File -> New -> Project
      • Do vyhledávacího pole zadejte Q#.Type Q# in the search box
      • Vyberte Aplikace Q# .Select Q# Application
      • Vyberte Další.Select Next
      • Vyberte název a umístění aplikace.Choose a name and location for your application
      • Vyberte Vytvořit.Select Create
    • Prozkoumejte projekt.Inspect the project

      Měli byste zjistit, že byly vytvořeny dva soubory: Driver.cs, což je hostitelská aplikace C#, a Operation.qs, což je program v jazyku Q#, který definuje jednoduchou operaci zobrazení zprávy na konzole.You should see that two files have been created: Driver.cs, which is the C# host application; and Operation.qs, which is a Q# program that defines a simple operation to print a message to the console.

    • Spuštění aplikaceRun the application

      • Vyberte Ladit -> Spustit bez ladění.Select Debug -> Start Without Debugging
      • V okně konzoly by se měl zobrazit text Hello quantum world!.You should see the text Hello quantum world! printed to a console window.

Poznámka

  • Pokud řešení sady Visual Studio obsahuje více projektů, musí se všechny projekty obsažené v řešení nacházet ve stejné složce jako řešení nebo v jedné z jejích podsložek.If you have multiple projects within one Visual Studio solution, all projects contained in the solution need to be in the same folder as the solution, or in one of its subfolders.

Vývoj pomocí Q # + C# pomocí Visual Studio Code Develop with Q# + C# using Visual Studio Code

Visual Studio Code (VS Code) nabízí bohatý prostředí pro vývoj programů Q # v systémech Windows, Linux a Mac.Visual Studio Code (VS Code) offers a rich environment for developing Q# programs on Windows, Linux and Mac. Rozšíření Q # VS Code zahrnuje podporu zvýrazňování syntaxe Q #, dokončování kódu a fragmentů kódu Q #.The Q# VS Code extension includes support for Q# syntax highlighting, code completion, and Q# code snippets.

  1. PožadavkyPre-requisites

  2. Nainstalujte rozšíření VS Code pro kvantové programování.Install the Quantum VS Code extension

  3. Nainstalujte šablony kvantového projektu:Install the Quantum project templates:

    • Přejděte do části Zobrazit -> Paleta příkazů.Go to View -> Command Palette
    • Vyberte Q #: Instalace šablon projektůSelect Q#: Install project templates

    Teď máte sadu Quantum Development Kit nainstalovanou a připravenou k používání ve vašich vlastních aplikacích a knihovnách.You now have the Quantum Development Kit installed and ready to use in your own applications and libraries.

  4. Ověřte instalaci vytvořením aplikace Hello World.Verify the installation by creating a Hello World application

    • Vytvořte nový projekt:Create a new project:

      • Přejděte do části Zobrazit -> Paleta příkazů.Go to View -> Command Palette
      • Vyberte Q #: vytvořit nový projekt.Select Q#: Create New Project
      • Vybrat samostatnou konzolovou aplikaciSelect Standalone console application
      • Přejděte do umístění v systému souborů, ve kterém chcete aplikaci vytvořit.Navigate to the location on the file system where you would like to create the application
      • Po vytvoření projektu klikněte na tlačítko Otevřít nový projekt.Click on the Open new project... button, once the project has been created
    • Pokud ještě nemáte nainstalované C# rozšíření pro vs Code, zobrazí se automaticky otevírané okno.If you don't already have the C# extension for VS Code installed, a pop-up will appear. Nainstalujte rozšíření.Install the extension.

    • Spusťte aplikaci:Run the application:

      • Přejít na terminál -> nový terminálGo to Terminal -> New Terminal
      • Zadejte dotnet runEnter dotnet run
      • V okně s výstupem by se měl zobrazit tento text: Hello quantum world!You should see the following text in the output window Hello quantum world!

Poznámka

  • Rozšíření Visual Studio Code aktuálně nepodporuje pracovní prostory s více kořenovými složkami.Workspaces with multiple root folders are not currently supported by the Visual Studio Code extension. Pokud máte víc projektů v rámci jednoho pracovního prostoru VS Code, musí se všechny projekty nacházet ve stejné kořenové složce.If you have multiple projects within one VS Code workspace, all projects need to be contained within the same root folder.

Vývoj pomocí Q # + C# pomocí nástroje příkazového řádku dotnetDevelop with Q# + C# using the dotnet command-line tool

Samozřejmě můžete programy v Q# také sestavovat a spouštět z příkazového řádku. Stačí nainstalovat .NET Core SDK a šablony projektů QDK.Of course, you can also build and run Q# programs from the command line by simply installing the .NET Core SDK and the QDK project templates.

  1. PožadavkyPre-requisites

  2. Nainstalujte šablony kvantového projektu pro rozhraní .NET.Install the Quantum project templates for .NET

    dotnet new -i Microsoft.Quantum.ProjectTemplates
    

    Teď máte sadu Quantum Development Kit nainstalovanou a připravenou k používání ve vašich vlastních aplikacích a knihovnách.You now have the Quantum Development Kit installed and ready to use in your own applications and libraries.

  3. Ověřte instalaci vytvořením aplikace Hello World.Verify the installation by creating a Hello World application

    • Vytvoření nové aplikaceCreate a new application

      dotnet new console -lang "Q#" -o runSayHello
      
    • Přejděte do adresáře nové aplikace.Navigate to the new application directory

      cd runSayHello
      

    Spolu se soubory projektu aplikace by se měly zobrazovat dva vytvořené soubory: soubor v jazyku Q# (Operation.qs) a soubor hostitele v jazyku C# (Driver.cs).You should see that two files have been created, along with the project files of the application: a Q# file (Operation.qs) and a C# host file (Driver.cs).

    • Spuštění aplikaceRun the application

      dotnet run
      

      Měl by se zobrazit následující výstup: Hello quantum world!You should see the following output: Hello quantum world!

Co dále?What's next?

Teď máte sadu Quantum Development Kit nainstalovanou v upřednostňovaném prostředí a můžete napsat a spustit svůj první kvantový program.Now that you have installed the Quantum Development Kit in your preferred environment, you can write and run your first quantum program.