Instalace sady Microsoft Quantum Development Kit (QDK)Install the Microsoft Quantum Development Kit (QDK)

Naučte se nainstalovat sadu Microsoft Quantum Development Kit (QDK), abyste mohli začít s kvantovým programováním.Learn how to install the Microsoft Quantum Development Kit (QDK), so that you can get started with quantum programming. Sada QDK obsahuje tyto komponenty:The QDK consists of:

  • Programovací jazyk Q#the Q# programming language
  • Sada knihoven s abstraktními komplexními funkcemi v jazyku Q#a set of libraries that abstract complex functionality in Q#
  • Hostitelská aplikace (napsaná v Pythonu nebo v jazyku .NET), která spouští kvantové operace napsané v jazyku Q#a host application (written in Python or a .NET language) that runs quantum operations written in Q#
  • Nástroje pro usnadnění vývojetools to facilitate your development

V závislosti na zvoleném vývojovém prostředí se provádějí rozdílné kroky instalace.Depending on your chosen development environment, there are different installation steps. V následujících částech vyberte požadované prostředí.Choose your environment from the sections below.

Vývoj v PythonuDevelop with Python

Balíček qsharp pro Python usnadňuje simulaci operací a funkcí jazyka Q# v rámci Pythonu.The qsharp package for Python makes it easy to simulate Q# operations and functions from within Python. IQ# (anglicky se vyslovuje i-q-sharp) je rozšíření primárně využívané Jupyterem a Pythonem, které poskytuje základní funkce pro kompilaci a simulaci operací v jazyce Q#.IQ# (pronounced i-q-sharp) is an extension primarily used by Jupyter and Python that provides the core functionality for compiling and simulating Q# operations.

  1. PožadavkyPre-requisites

  2. Nainstalujte balíček qsharp.Install the qsharp package

    pip install qsharp
    
  3. Nainstalujte balíček iqsharp.Install the iqsharp package

    dotnet tool install -g Microsoft.Quantum.IQSharp
    dotnet iqsharp install
    
  4. Ověřte instalaci vytvořením aplikace Hello World.Verify the installation by creating a Hello World application

    • Vytvořte minimální operaci v jazyku Q# tím, že vytvoříte soubor s názvem Operation.qs a do něj přidáte následující kód:Create a minimal Q# operation, by creating a file called Operation.qs, and adding the following code to it:

      namespace HelloWorld
      {
          open Microsoft.Quantum.Intrinsic;
          open Microsoft.Quantum.Canon;
      
          operation SayHello() : Result {
              Message("Hello from quantum world!");
              return Zero;
          }
      }
      
    • Vytvořte program v Pythonu s názvem hello_world.py, který bude volat operaci SayHello() jazyka Q#:Create a Python program called hello_world.py to call the Q# SayHello() operation:

      import qsharp
      
      from HelloWorld import SayHello
      
      SayHello.simulate()
      
    • Spusťte program:Run the program:

      python hello_world.py
      
    • Ověřte výstup.Verify the output. Výstupem programu by měly být následující řádky:Your program should output the following lines:

      Hello from quantum world!
      0
      

Vývoj s využitím poznámkových bloků JupyterDevelop with Jupyter notebooks

Poznámkové bloky Jupyter, které jsou oblíbené v akademickém prostředí, vědeckých laboratořích a také v rámci programování založeného na online spolupráci, nabízejí kromě pokynů, poznámek a dalšího obsahu také možnost místního spouštění kódu, nově včetně kódu v jazyce Q#.A favorite of academic settings, scientific labs, and online-based collaborative programming, Jupyter Notebooks offer in-place code execution—now including Q# code—along with instructions, notes, and other content. Podívejte se, co všechno k vytváření vlastních poznámkových bloků v Q# potřebujete.Here's what you need to do to start creating your own Q# notebooks.

IQ# (anglicky se vyslovuje i-q-sharp) je rozšíření sady .NET Core SDK primárně využívané Jupyterem a Pythonem, které poskytuje základní funkce pro kompilaci a simulaci operací v jazyce Q#.IQ# (pronounced i-q-sharp) is an extension primarily used by Jupyter and Python to the .NET Core SDK that provides the core functionality for compiling and simulating Q# operations.

  1. PožadavkyPre-requisites

  2. Nainstalujte balíček iqsharp.Install the iqsharp package

    dotnet tool install -g Microsoft.Quantum.IQSharp
    dotnet iqsharp install
    
  3. Ověřte instalaci vytvořením aplikace Hello World.Verify the installation by creating a Hello World application

    • Spusťte následující příkaz, kterým se spustí server poznámkového bloku:Run the following command to start the notebook server:

      jupyter notebook
      
    • Přejděte na adresu URL zobrazenou na příkazovém řádku.Browse to the URL shown on the command line. Příklad: [http://localhost:8888/?token=c790a52ba54f0cf77465c3c8983d776348285b0280d91b85 ]For example: [http://localhost:8888/?token=c790a52ba54f0cf77465c3c8983d776348285b0280d91b85]

    • Vytvořte poznámkový blok Jupyter s použitím jádra Q# a do první buňky poznámkového bloku přidejte následující kód:Create a Jupyter notebook with a Q# kernel, and add the following code to the first notebook cell:

      operation SayHello () : Unit {
          Message("Hello from quantum world!");
      }
      
    • Spusťte tuto buňku poznámkového bloku:Run this cell of the notebook:

      Buňka poznámkového bloku Jupyter s využitím kódu Q#

      Ve výstupu buňky by se měl zobrazit text SayHello.You should see SayHello in the output of the cell. Při spouštění v poznámkových blocích Jupyter se kompiluje kód v jazyku Q# a výstupem poznámkového bloku jsou názvy nalezených operací.When running in jupyter notebooks, the Q# code is compiled, and the notebook outputs the name of the operation(s) that it finds.

    • V nové buňce simulujte spuštění právě vytvořené operace v kvantovém počítači, a to pomocí příkazu magic %simulate:In a new cell, simulate the execution in a quantum computer of the operation you just created by using the %simulate magic:

      Buňka poznámkového bloku Jupyter s využitím příkazu magic %simulate

      Měla by se zobrazit zpráva na obrazovce spolu s výsledkem operace, kterou jste vyvolali (v tomto případě prázdným).You should see the message printed on the screen along with the result of the operation you invoked (in this case, empty).

Vývoj v jazyku C# ve Windows s použitím sady Visual StudioDevelop with C# on Windows, using Visual Studio

Visual Studio nabízí bohaté prostředí pro vývoj programů v Q# se skvělými funkcemi, jako je dokončování kódu a zvýrazňování syntaxe, které vývojářům pomáhají při vytváření aplikací.Visual Studio offers a rich environment for developing Q# programs, offering great features like code completion and syntax highlighting that guide the developer in building their applications. Rozšíření Q# Visual Studio obsahuje šablony pro projekty a soubory v Q# a také zvýrazňování syntaxe a podporu technologie IntelliSense.The Q# Visual Studio extension contains templates for Q# files and projects as well as syntax highlighting and IntelliSense support.

  1. PožadavkyPre-requisites

    • Visual Studio 16.3 s povolenými úlohami vývoje pro různé platformy pomocí rozhraní .NET CoreVisual Studio 16.3, with the .NET Core cross-platform development workload enabled
  2. Nainstalujte rozšíření sady Visual Studio pro jazyk Q#.Install the Q# Visual Studio extension

  3. Ověřte instalaci vytvořením aplikace Hello World.Verify the installation by creating a Hello World application

    • Vytvořte novou aplikaci v jazyku Q#.Create a new Q# application

      • Přejděte do části Soubor -> Nový -> Projekt.Go to File -> New -> Project
      • Do vyhledávacího pole zadejte Q#.Type Q# in the search box
      • Vyberte Aplikace Q# .Select Q# Application
      • Vyberte Další.Select Next
      • Vyberte název a umístění aplikace.Choose a name and location for your application
      • Vyberte Vytvořit.Select Create
    • Prozkoumejte projekt.Inspect the project

      Měli byste zjistit, že byly vytvořeny dva soubory: Driver.cs, což je hostitelská aplikace C#, a Operation.qs, což je program v jazyku Q#, který definuje jednoduchou operaci zobrazení zprávy na konzole.You should see that two files have been created: Driver.cs, which is the C# host application; and Operation.qs, which is a Q# program that defines a simple operation to print a message to the console.

    • Spuštění aplikaceRun the application

      • Vyberte Ladit -> Spustit bez ladění.Select Debug -> Start Without Debugging
      • V okně konzoly by se měl zobrazit text Hello quantum world!.You should see the text Hello quantum world! printed to a console window.

Poznámka

  • Pokud řešení sady Visual Studio obsahuje více projektů, musí se všechny projekty obsažené v řešení nacházet ve stejné složce jako řešení nebo v jedné z jejích podsložek.If you have multiple projects within one Visual Studio solution, all projects contained in the solution need to be in the same folder as the solution, or in one of its subfolders.

Vývoj s využitím C# v editoru Visual Studio CodeDevelop with C#, using Visual Studio Code

Visual Studio Code (VS Code) nabízí bohaté prostředí pro vývoj programů v Q# napříč různými výpočetními prostředími, včetně systémů Windows, Linux a Mac, a poskytuje skvělé funkce, jako je dokončování kódu a zvýrazňování syntaxe, které vývojářům pomáhají při vytváření aplikací.Visual Studio Code (VS Code) offers a rich environment for developing Q# programs across many multiple computer environments, including Windows, Linux and Mac, offering great features like code completion and syntax highlighting that guide the developer in building their applications. Rozšíření Q# VS Code obsahuje zvýrazňování syntaxe a fragmenty kódu v Q#.The Q# VS Code extension contains syntax highlighting, and Q# code snippets.

  1. PožadavkyPre-requisites

  2. Nainstalujte rozšíření VS Code pro kvantové programování.Install the Quantum VS Code extension

  3. Nainstalujte šablony kvantového projektu:Install the Quantum project templates:

    • Přejděte do části Zobrazit -> Paleta příkazů.Go to View -> Command Palette
    • Vyberte Q#: Nainstalovat šablony projektu.Select Q#: Install project templates

    Teď máte sadu Quantum Development Kit nainstalovanou a připravenou k používání ve vašich vlastních aplikacích a knihovnách.You now have the Quantum Development Kit installed and ready to use in your own applications and libraries.

  4. Ověřte instalaci vytvořením aplikace Hello World.Verify the installation by creating a Hello World application

    • Vytvořte nový projekt:Create a new project:

      • Přejděte do části Zobrazit -> Paleta příkazů.Go to View -> Command Palette
      • Vyberte Q#: Vytvořit nový projekt.Select Q#: Create New Project
      • Přejděte do umístění v systému souborů, ve kterém chcete aplikaci vytvořit.Navigate to the location on the file system where you would like to create the application
      • Po vytvoření projektu klikněte na tlačítko Otevřít nový projekt.Click on the Open new project... button, once the project has been created
    • Spusťte aplikaci:Run the application:

      • Přejděte do části Ladit -> Spustit bez ladění.Go to Debug -> Start Without Debugging
      • V okně s výstupem by se měl zobrazit tento text: Hello quantum world!You should see the following text in the output window Hello quantum world!

Poznámka

    • Rozšíření Visual Studio Code aktuálně nepodporuje pracovní prostory s více kořenovými složkami.Workspaces with multiple root folders are not currently supported by the Visual Studio Code extension. Pokud máte víc projektů v rámci jednoho pracovního prostoru VS Code, musí se všechny projekty nacházet ve stejné kořenové složce.If you have multiple projects within one VS Code workspace, all projects need to be contained within the same root folder.

Vývoj v jazyku C# s použitím nástroje pro příkazový řádek dotnetDevelop with C#, using the dotnet command-line tool

Samozřejmě můžete programy v Q# také sestavovat a spouštět z příkazového řádku. Stačí nainstalovat .NET Core SDK a šablony projektů QDK.Of course, you can also build and run Q# programs from the command line by simply installing the .NET Core SDK and the QDK project templates.

  1. PožadavkyPre-requisites

  2. Nainstalujte šablony kvantového projektu pro rozhraní .NET.Install the Quantum project templates for .NET

    dotnet new -i Microsoft.Quantum.ProjectTemplates
    

    Teď máte sadu Quantum Development Kit nainstalovanou a připravenou k používání ve vašich vlastních aplikacích a knihovnách.You now have the Quantum Development Kit installed and ready to use in your own applications and libraries.

  3. Ověřte instalaci vytvořením aplikace Hello World.Verify the installation by creating a Hello World application

    • Vytvoření nové aplikaceCreate a new application

      dotnet new console -lang Q# -o runSayHello
      
    • Přejděte do adresáře nové aplikace.Navigate to the new application directory

      cd runSayHello
      

    Spolu se soubory projektu aplikace by se měly zobrazovat dva vytvořené soubory: soubor v jazyku Q# (Operation.qs) a soubor hostitele v jazyku C# (Driver.cs).You should see that two files have been created, along with the project files of the application: a Q# file (Operation.qs) and a C# host file (Driver.cs).

    • Spuštění aplikaceRun the application

      dotnet run
      

      Měl by se zobrazit následující výstup: Hello quantum world!You should see the following output: Hello quantum world!

Co dále?What's next?

Teď máte sadu Quantum Development Kit nainstalovanou v upřednostňovaném prostředí a můžete napsat a spustit svůj první kvantový program.Now that you have installed the Quantum Development Kit in your preferred environment, you can write and run your first quantum program.