Začínáme s C++ v sadě Visual StudioGet started with C++ in Visual Studio

Dokončete tento rychlý start, abyste se seznámili s řadu nástrojů a dialogových oken, které můžete použít při vývoji aplikací v jazyce C++ pomocí sady Visual Studio.Complete this quickstart to become familiar with many of the tools and dialog boxes that you can use when you develop applications in C++ with Visual Studio. Vytvoření "Hello, World" – styl konzolovou aplikaci, zatímco další informace o práci v integrované vývojové prostředí (IDE).Create a "Hello, World"-style console application while you learn more about working in the integrated development environment (IDE).

PožadavkyPrerequisites

Nemusíte se seznamte s C++ dokončete tento rychlý start, ale měli byste se seznámit s některé obecné programování a ladění koncepty.You don't need to be familiar with C++ to complete this quickstart, but you should be familiar with some general programming and debugging concepts. Programování v jazyce C++ nepodporuje naučit dokumentaci sady Visual Studio.The Visual Studio documentation doesn't teach you how to program in C++. Je dobré Průvodce C++ studijních materiálů Začínáme na webu ISO C++.A good guide to C++ learning resources is the Get started page on the ISO C++ website.

Pokud chcete sledovat, musíte kopie Visual Studio 2017 verze 15.3 nebo novější s vývoj aplikací s jazykem C++ zatížení nainstalována.To follow along, you need a copy of Visual Studio 2017 version 15.3 or later, with the Desktop development with C++ workload installed. Rychlé informace k instalaci najdete v tématu podpory nainstalovat C++ v sadě Visual Studio.For a fast guide to installation, see Install C++ support in Visual Studio.

Vytvořte aplikaci konzolyCreate a console app

Pokud ještě není spuštěná, spusťte Visual Studio.If it's not running yet, start Visual Studio.

IDE s Visual C+ + nastaveníIDE with Visual C++ settings applied

Po otevření sady Visual Studio, zobrazí se tři základní součásti rozhraní IDE: nástroj windows, nabídek a panelů nástrojů a místo hlavní okno.After you open Visual Studio, you can see the three basic parts of the IDE: tool windows, menus and toolbars, and the main window space. Nástroje systému windows jsou ukotveno na levé a pravé straně okna aplikace.Tool windows are docked on the left and right sides of the app window. Snadné spuštění pole řádku nabídek a standardním panelu nástrojů se nacházejí v horní části.The Quick Launch box, the menu bar, and the standard toolbar are found at the top. Obsahuje centru okna – úvodní stránka.The center of the window contains the Start Page. Když otevřete řešení nebo projektu, editory a návrhářů, zobrazí se v tento prostor.When you open a solution or project, editors and designers appear in this space. Při vývoji aplikace je většinu času stráví v této oblasti centrální.When you develop an app, most of your time is spent in this central area.

Visual Studio použije projekty k uspořádání kódu pro aplikace, a řešení k uspořádání vašich projektů.Visual Studio uses projects to organize the code for an app, and solutions to organize your projects. Projekt obsahuje možnosti, konfigurace a pravidel použitý k sestavení aplikace.A project contains all the options, configurations, and rules used to build your apps. Spravuje taky vztah mezi soubory všechny projektu a externí soubory.It also manages the relationship between all the project's files and any external files. Pokud chcete vytvořit aplikaci, nejprve vytvoříte nový projekt a řešení.To create your app, first, you create a new project and solution.

Vytvoření projektu aplikace konzolyTo create a console app project

  1. Na řádku nabídek zvolte soubor > Nový > projekt otevřete nový projekt dialogové okno.On the menu bar, choose File > New > Project to open the New Project dialog box.

    V řádku nabídek zvolte Soubor > Nový > projektOn the menu bar, choose File > New > Project

  2. V nový projekt dialogovém okně, vyberte nainstalovaná > Visual C++ Pokud ještě není zaškrtnuto.In the New Project dialog, select Installed > Visual C++ if it isn't selected already. V prostředním podokně, vyberte konzolové aplikace pro Windows šablony.In the center pane, select the Windows Console Application template. V název textové pole, zadejte HelloApp.In the Name edit box, enter HelloApp.

    Použití dialogového okna Nový projekt pro vytvoření projektu aplikaceUse the New Project dialog to create your app project

    Dialogové okno vaší může mít různé možnosti, v závislosti na sadě Visual Studio úlohy a součástí, které jste nainstalovali.Your dialog box may have different choices, depending on the Visual Studio workloads and components you've installed. Pokud nevidíte šablony projektů Visual C++, budete muset znovu spustit instalační program sady Visual Studio a nainstalovat vývoj aplikací s jazykem C++ zatížení.If you don't see Visual C++ project templates, you need to run the Visual Studio installer again and install the Desktop development with C++ workload. Můžete to provést přímo z nový projekt dialogové okno.You can do this directly from the New Project dialog. Chcete-li spustit instalační program, zvolte otevřete instalační program Visual Studio odkaz v dialogovém okně.To launch the installer, choose the Open Visual Studio Installer link on the dialog.

  3. Vyberte OK tlačítko vytvořte projekt aplikace a řešení.Choose the OK button to create your app project and solution.

    HelloApp projektu a řešení, se základní soubory pro konzolovou aplikaci systému Windows, se vytváří a automaticky načíst do Průzkumníku řešení.The HelloApp project and solution, with the basic files for a Windows console app, are created and automatically loaded into Solution Explorer. HelloApp.cpp otevření souboru v editoru kódu.The HelloApp.cpp file is opened in the code editor. Tyto položky se zobrazí v Průzkumníku řešení:These items appear in Solution Explorer:

    Soubory v Průzkumníku řešeníFiles for the solution in Solution Explorer

Přidejte kód do aplikaceAdd code to the app

Dál přidejte kód, který zobrazí slovo "Hello" v okně konzoly.Next, add code to display the word "Hello" in the console window.

Chcete-li upravit kód v editoruTo edit code in the editor

  1. V HelloApp.cpp souboru, zadejte prázdný řádek před řádek return 0; a pak zadejte tento kód:In the HelloApp.cpp file, enter a blank line before the line return 0; and then enter this code:

    cout << "Hello\n";
    

    Red vlnovkou řádku se zobrazí pod cout.A red squiggly line appears under cout. Pokud při umístění ukazatele nad ním, zobrazí se chybová zpráva.If you hover the pointer over it, an error message appears.

    Text Chyba coutError text for cout

    Chybová zpráva se zobrazí také v seznam chyb okno.The error message also appears in the Error List window. V tomto okně můžete zobrazit výběrem zobrazení > Seznam chyb v řádku nabídek.You can display this window by choosing View > Error List on the menu bar.

    Došlo k chybě v okně Seznam chybError in Error List window

    Váš kód chybí deklarace pro std::cout, který se nachází v <iostream > soubor hlaviček.Your code is missing a declaration for std::cout, which is found in the <iostream> header file.

  2. Zahrnout iostream záhlaví, zadejte tento kód po #include "stdafx.h":To include the iostream header, enter this code after #include "stdafx.h":

    #include <iostream>
    using namespace std;
    

    Pravděpodobně si všimli, že se nezobrazují pole jako jste zadali kód.You probably noticed that a box appeared as you entered code. Toto pole obsahuje návrhy automatické dokončování znaků, které zadáte.This box contains auto-completion suggestions for the characters that you enter. To je součástí C++ IntelliSense, která poskytuje kódování výzvy, včetně členů třídy nebo rozhraní a informace o parametrech.It's part of C++ IntelliSense, which provides coding prompts, including class or interface members and parameter information. Můžete taky fragmenty kódu, které jsou předdefinované bloky kódu.You can also use code snippets, which are pre-defined blocks of code. Další informace najdete v tématu pomocí IntelliSense a výstřižky kódu.For more information, see Using IntelliSense and Code snippets.

    Opravené kódu v editoruThe fixed code in the editor

    Red vlnovkou řádku pod cout zmizí při opravte chybu.The red squiggly line under cout disappears when you fix the error.

  3. Chcete-li uložit změny do souboru, stiskněte Ctrl + S.To save the changes to the file, press Ctrl+S.

Sestavení aplikaceBuild the app

Je snadné sestavení vašeho kódu.It's easy to build your code. Na řádku nabídek zvolte sestavení > Sestavit řešení.On the menu bar, choose Build > Build Solution. Visual Studio vytvoří řešení HelloApp a sestavy průběhu v výstup okno.Visual Studio builds the HelloApp solution, and reports progress in the Output window.

Sestavte řešení HelloAppBuild the HelloApp solution

Ladění a testování aplikaceDebug and test the app

Můžete ladit HelloApp zobrazíte, zda se v okně konzoly zobrazí slovo "Hello".You can debug HelloApp to see whether the word "Hello" appears in the console window.

K ladění aplikaceTo debug the app

Chcete-li spuštění ladicího programu, zvolte ladění > Spustit ladění v řádku nabídek.To start the debugger, choose Debug > Start Debugging on the menu bar.

Spuštění ladění příkazu v nabídce laděníStart Debugging command on the Debug menu

Ladicí program spustí a spouští kód.The debugger starts and runs the code. V okně konzoly (samostatném okně, které vypadá příkazového řádku) se zobrazí na několik sekund, ale zavře rychle, když se zastaví ladicí program.The console window (a separate window that looks like a command prompt) appears for a few seconds but closes quickly when the debugger stops running. Chcete-li zobrazit text, musíte nastavit zarážky pro zastavení spuštění programu.To see the text, you need to set a breakpoint to stop program execution.

Chcete-li přidat zarážkyTo add a breakpoint

  1. V editoru, umístěte kurzor na řádku return 0;.In the editor, put the cursor on the line return 0;. Na řádku nabídek zvolte ladění > Přepnout zarážku.On the menu bar, choose Debug > Toggle Breakpoint. Můžete také kliknutím na levém okraji nastavit zarážky.You can also click in the left margin to set a breakpoint.

    Přepnout zarážku – příkaz v nabídce laděníToggle Breakpoint command on the Debug menu

    Na levém okraji okna editoru se vedle řádku kódu zobrazí červený kruh.A red circle appears next to the line of code in the far left margin of the editor window.

    Breakpoint – uvedené v okně okrajBreakpoint indicated in window margin

  2. Chcete-li začít, ladění, stiskněte F5.To start debugging, press F5.

    Ladicí program spustí, a zobrazí se okno konzoly s slovo Hello.The debugger starts, and a console window appears showing the word Hello.

    Hello text v okně konzolyHello text in the console window

  3. Chcete-li zastavit, ladění, stiskněte Shift + F5.To stop debugging, press Shift+F5.

Další informace o ladění projektu v konzole najdete v tématu konzole projekty.For more information about console project debugging, see Console projects.

Sestavení prodejní verze aplikaceBuild a release version of the app

Teď, když ověříte, že vše funguje, můžete připravit sestavení pro vydání aplikace.Now that you've verified that everything works, you can prepare a release build of the application. Verze sestavení ponechejte informace o ladění a možnosti optimalizace kompilátoru použijte k vytvoření menších, rychlejší kódu.Release builds leave out the debugging information, and use compiler optimization options to create smaller, faster code.

Vyčištění souborů řešení a sestavení verze pro vydáníTo clean the solution files and build a release version

  1. Na řádku nabídek zvolte sestavení > Vyčistit řešení odstranit zprostředkující soubory a výstupní soubory, které byly vytvořeny během předchozí sestavení.On the menu bar, choose Build > Clean Solution to delete intermediate files and output files that were created during previous builds.

    Příkaz Vyčistit řešení v nabídce sestaveníThe Clean Solution command on the Build menu

  2. Chcete-li změnit konfiguraci řešení pro HelloApp z ladění k verze, na panelu nástrojů vyberte ovládacího prvku konfigurace řešení v rozevírací nabídce a potom zvolte verze.To change the solution configuration for HelloApp from Debug to Release, in the toolbar, select the dropdown on the Solution Configurations control and then choose Release.

    Sestavení verzi aplikaceBuild a release version of the application

  3. Sestavte řešení.Build the solution. Na řádku nabídek zvolte sestavení > Sestavit řešení.On the menu bar, choose Build > Build Solution.

Po dokončení tohoto buildu jste vytvořili aplikaci, která můžete zkopírovat a spustit v libovolném okně příkazového řádku.When this build completes, you've created an app that you can copy and run in any command prompt window. Hodně postup, ale je bránu a větší věcí.It may not do much, but it's the gateway to greater things.

Blahopřejeme k dokončení tento rychlý start!Congratulations on completing this quickstart! Pokud chcete prozkoumat další příklady, přečtěte si téma Visual Studio – ukázky.If you want to explore more examples, see Visual Studio samples.

Viz takéSee also