Funkce editoru kóduFeatures of the code editor

Editor sady Visual Studio poskytuje mnoho funkcí, které usnadňují zápis a správu vašeho kódu a text.The Visual Studio editor provides many features that make it easier for you to write and manage your code and text. Můžete rozbalit nebo sbalit různé bloky kódu pomocí osnovy.You can expand and collapse different blocks of code by using outlining. Další informace o kódu pomocí technologie IntelliSense, prohlížeče objektůa hierarchii volání.You can learn more about the code by using IntelliSense, the Object Browser, and the Call Hierarchy. Kód můžete najít pomocí funkcí přejít na, přejít k definici, a najít všechny odkazy.You can find code by using features such as Go To, Go To Definition, and Find All References. Můžete vložit bloky kódu pomocí fragmentů kódu a může generovat kód pomocí funkcí Generovat z využití.You can insert blocks of code with code snippets, and you can generate code by using features such as Generate From Usage. Pokud jste ještě nikdy nepoužívali Editor sady Visual Studio, přečtěte si téma informace o použití editoru kódu.If you have never used the Visual Studio editor before, see Learn to use the code editor.

Note

Toto téma se vztahuje k sadě Visual Studio ve Windows.This topic applies to Visual Studio on Windows. Visual Studio pro Mac, najdete v části Editor zdrojového kódu (Visual Studio for Mac).For Visual Studio for Mac, see Source editor (Visual Studio for Mac).

Zobrazí se váš kód v několika různými způsoby.You can view your code in a number of different ways. Ve výchozím nastavení Průzkumníka řešení zobrazuje váš kód uspořádané podle souborů.By default, Solution Explorer shows your code organized by files. Můžete kliknout na zobrazení tříd karta v dolní části okna, chcete-li zobrazit kód uspořádané podle třídy.You can click on the Class View tab at the bottom of the window to view your code organized by classes.

Můžete vyhledat a nahradit text v jedné nebo více souborů.You can search and replace text in single or multiple files. Další informace najdete v tématu najít a nahradit text.For more information, see Find and replace text. Regulární výrazy můžete použít k vyhledání a nahrazení textu.You can use regular expressions to find and replace text. Další informace najdete v tématu použití regulárních výrazů v sadě Visual Studio.For more information, see Use regular expressions in Visual Studio.

Různé jazyky Visual Studio nabízí různé sady funkcí a v některých případech se funkce chovají odlišně v různých jazycích.The different Visual Studio languages offer different sets of features, and in some cases the features behave differently in different languages. Mnohé z těchto rozdílů jsou uvedeny v popisech funkcí, ale pro další informace najdete v částech na konkrétní jazyky sady Visual Studio.Many of these differences are specified in the descriptions of the features, but for more information you can see the sections on specific Visual Studio languages.

Funkce editoruEditor features

Barevné zvýrazňování syntaxeSyntax Coloring Některé prvky syntaxe kódu a kódu souborů jsou různě barevně odlišeny abychom je odlišili.Some syntax elements of code and markup files are colored differently to distinguish them. Například klíčová slova (například using v jazyce C# a Imports v jazyce Visual Basic) jsou jednu barvu, ale typy (například Console a Uri) mají jinou barvu.For example, keywords (such as using in C# and Imports in Visual Basic) are one color, but types (such as Console and Uri) are another color. Ostatní prvky syntaxe jsou také obarveny, jako je například řetězcové literály a komentáře.Other syntax elements are also colorized, such as string literals and comments. C++ používá barvy k rozlišení mezi typy, výčty a makry, mezi další tokeny.C++ uses color to differentiate among types, enumerations, and macros, among other tokens.

Můžete zobrazit výchozí barvy pro každý typ a můžete změnit barvu libovolného elementu syntaxe v písma a barvy, prostředí, dialogové okno Možnosti, které můžete otevřít z nástroje nabídky.You can see the default color for each type, and you can change the color for any specific syntax element in the Fonts and Colors, Environment, Options dialog box, which you can open from the Tools menu.
Značky chyba a varováníError and Warning Marks Jak přidat kód a sestavte řešení, může se zobrazit podtržení vlnovkou (a) různé barvy (známé jako squiggles) nebo (b) návrhy ve vašem kódu.As you add code and build your solution, you may see (a) different-colored wavy underlines (known as squiggles) or (b) light bulbs appearing in your code. Chyby syntaxe jsou označené červenou vlnovkou, modrá označuje chybu kompilátoru, zelená značí upozornění a nachová označuje jiných typů chyb.Red squiggles denote syntax errors, blue denotes compiler errors, green denotes warnings, and purple denotes other types of errors. Rychlé akce navrhnout opravy problémů a usnadňují použití opravy.Quick Actions suggest fixes for problems and make it easy to apply the fix.

Můžete zobrazit výchozí barvy pro každé chyby a varování vlnovku v nástroje > možnosti > prostředí > Písma a barvy dialogové okno.You can see the default color for each error and warning squiggle in the Tools > Options > Environment > Fonts and Colors dialog box. Vyhledejte Chyba syntaxe, Chyba kompilátoru, upozornění, a jiná chyba.Look for Syntax Error, Compiler Error, Warning, and Other Error.
Párování závorekBrace Matching Když je kurzor umístěn na levou složenou závorku v souboru kódu, jsou zvýrazněny ho a pravou složenou závorku.When the insertion point is placed on an open brace in a code file, both it and the closing brace are highlighted. Tato funkce poskytuje okamžitou zpětnou vazbu na nesprávně umístěné nebo chybějící závorky.This feature gives you immediate feedback on misplaced or missing braces. Můžete zapnout závorky zapnutí nebo vypnutí se automatické zvýraznění oddělovače nastavení (nástroje > možnosti > Textový Editor).You can turn brace matching on or off with the Automatic Delimiter Highlighting setting (Tools > Options > Text Editor). Můžete změnit barvu zvýraznění v písma a barvy nastavení (nástroje > možnosti > prostředí).You can change the highlight color in the Fonts and Colors setting (Tools > Options > Environment). Vyhledejte závorky (zvýraznit) nebo závorky (obdélník) .Look for Brace Matching (Highlight) or Brace Matching (Rectangle).
Vizualizér strukturStructure Visualizer Tečkované čáry připojení odpovídající složené závorky v kódu soubory usnadnit zobrazíte levá a pravá složená závorka dvojice.Dotted lines connect matching braces in code files, making it easier to see opening and closing brace pairs. To může pomoct najít kód vašeho základu kódu rychleji.This can help you find code in your codebase more quickly. Tyto řádky může zapnout nebo vypnout pomocí zobrazit strukturu pokyny v zobrazení část nástroje > možnosti > Textový Editor > Obecné stránky.You can turn these lines on or off with the Show structure guidelines in the Display section of the Tools > Options > Text Editor > General page.
Čísla řádkůLine Numbers Čísla řádků lze zobrazit na levém okraji okna kódu.Line numbers can be displayed in the left margin of the code window. Ve výchozím nastavení nejsou zobrazeny.They are not displayed by default. Můžete zapnout tuto možnost všechny jazyky textového editoru nastavení (nástroje > možnosti > textový Editor > Všechny jazyky).You can turn this option on in the Text Editor All Languages settings (Tools > Options > Text Editor > All Languages). Čísla řádků pro jednotlivé programovací jazyky můžete zobrazit tak, že změníte nastavení pro tyto jazyky (nástroje > možnosti > textový Editor > <jazyk > ).You can display line numbers for individual programming languages by changing the settings for those languages (Tools > Options > Text Editor > <language>). Čísla řádků k tisku, musíte vybrat zahrnutí čísel řádků v tisk dialogové okno.For line numbers to print, you must select Include line numbers in the Print dialog box.
Sledování změnChange Tracking Barva levého okraje umožňuje sledovat, změny, které jste provedli v souboru.The color of the left margin allows you to keep track of the changes you have made in a file. Změny, které jste provedli, protože soubor byl otevřen, ale nebyl uložen, jsou označeny žlutým pruhem na levý okraj (známé jako okraj výběru).Changes you have made since the file was opened but not saved are denoted by a yellow bar on the left margin (known as the selection margin). Po uložení změn (ale před zavřením souboru), se panel zbarví zeleně.After you have saved the changes (but before closing the file), the bar turns green. Pokud vrátíte zpět změnu po uložení souboru, na panelu oranžově.If you undo a change after you have saved the file, the bar turns orange. Chcete-li tuto funkci vypnout a znovu zapnout, změňte sledovat změny možnost textový Editor nastavení (nástroje > možnosti > Textový Editor).To turn this feature off and on, change the Track changes option in the Text Editor settings (Tools > Options > Text Editor).
Vyberte kód a TextSelecting Code and Text Text můžete vybrat v režimu standardního souvislého datového toku nebo v režimu pole, ve kterém vyberete obdélníkovou část textu místo sady řádků.You can select text either in the standard continuous stream mode or in box mode, in which you select a rectangular portion of text instead of a set of lines. Chcete-li provést výběr v režimu pole, stiskněte Alt tažení myší přes výběr (nebo stiskněte klávesu Alt+Shift + <šipka > ).To make a selection in box mode, press Alt as you drag the mouse over the selection (or press Alt+Shift+<arrow key>). Výběr zahrnuje všechny znaky v obdélníku definovaném prvním znakem a posledním znakem ve výběru.The selection includes all of the characters within the rectangle defined by the first character and the last character in the selection. Libovolná hodnota zadaná nebo vložit do vybrané oblasti bude vložena na stejné místo na každém řádku.Anything typed or pasted into the selected area is inserted at the same point on each line.
LupaZoom Můžete provést přiblížení nebo navýšení kapacity v jakékoli okno kódu stisknutím a podržením Ctrl klíč a přesunutím kolečka myši (nebo Ctrl+Shift + .You can zoom in or out in any code window by pressing and holding the Ctrl key and moving the scroll wheel on the mouse (or Ctrl+Shift+. pro zvýšení a Ctrl+Shift+ , snížení).to increase and Ctrl+Shift+, to decrease). Můžete také použít přiblížení pole v levém dolním rohu okna kódu k nastavení konkrétního procenta zvětšení.You can also use the Zoom box in the lower left corner of the code window to set a specific zoom percentage. Funkce Lupa nefunguje v oknech nástrojů.The zoom feature does not work in tool windows.
Virtuální prostorVirtual Space Ve výchozím nastavení, řádky v end editory sady Visual Studio po poslední znak tak, aby šipka vpravo klíč na konci řádku přesunula kurzor na začátek dalšího řádku.By default, lines in Visual Studio editors end after the last character, so that the Right Arrow key at the end of a line moves the cursor to the beginning of the next line. V některých jiných editorech řádek nekončí za posledním znakem a můžete umístit kurzor kamkoliv na řádek.In some other editors a line does not end after the last character, and you can place your cursor anywhere on the line. Můžete povolit virtuální prostor v editoru v nástroje > možnosti > textový Editor > všechny Jazyky nastavení.You can enable virtual space in the editor in the Tools > Options > Text Editor > All Languages settings. Všimněte si, že můžete povolit buď virtuální prostor nebo zalamování, ale ne obojí.Note that you can enable either Virtual Space or Word Wrap, but not both.
TiskPrinting Můžete použít možnosti v tisk dialogové okno pro zahrnutí čísel řádků nebo skrytí sbalených oblasti kódu při tisku souboru.You can use the options in the Print dialog box to include line numbers or hide collapsed regions of code when you print a file. V vzhled stránky dialogové okno, můžete také vytisknout úplnou cestu a název souboru výběrem záhlaví stránky.In the Page Setup dialog box, you can also choose to print the full path and the name of the file by choosing Page header.

Možnosti tisku barev můžete nastavit nástroje > možnosti > prostředí > písma a Barvy dialogové okno.You can set color printing options in the Tools > Options > Environment > Fonts and Colors dialog box. Zvolte tiskárny v zobrazit nastavení pro seznamu přizpůsobit barevný tisk.Choose Printer in the Show settings for list to customize color printing. Můžete určit různé barvy pro tisk souboru než pro úpravy souboru.You can specify different colors for printing a file than for editing a file.
Globální akce zpět a znovuGlobal Undo and Redo Vrátit zpět poslední globální akci a znovu provést poslední globální akci příkazy na upravit nabídky vrátit zpět nebo opětovnému provedení globálních akcí, které ovlivňují více souborů.The Undo Last Global Action and Redo Last Global Action commands on the Edit menu undo or redo global actions that affect multiple files. Globální akce zahrnují přejmenování třídy nebo oboru názvů, vykonání operace hledání a nahrazení napříč celým řešení, refaktoringu databáze nebo jakoukoli jinou akci, která se mění více souborů.Global actions include renaming a class or namespace, performing a find-and-replace operation across a solution, refactoring a database, or any other action that changes multiple files. Můžete použít globální akce zpět a znovu příkazy, které akce v aktuální relaci aplikace Visual Studio, dokonce i po zavření řešení, ve kterém byla použita akce.You can apply the global undo and redo commands to actions in the current Visual Studio session, even after you close the solution in which an action was applied.

Pokročilé funkce pro úpravyAdvanced editing features

Najdete řadu pokročilých funkcí na upravit > Upřesnit nabídka na panelu nástrojů.You can find a number of advanced features on the Edit > Advanced menu on the toolbar. Všechny tyto funkce jsou dostupné pro všechny typy souborů s kódem.Not all of these features are available for all types of code files.

Formátovat dokumentFormat Document Nastaví správné odsazení řádků kódu a přesune složené závorky do samostatných řádků v dokumentu.Sets the proper indentation of lines of code and moves curly braces to separate lines in the document.
Příkaz Formátovat výběrFormat Selection Nastaví správné odsazení řádků kódu a přesune složené závorky do samostatných řádků ve výběru.Sets the proper indentation of lines of code and moves curly braces to separate lines in the selection.
Vybrané řádky posunout tabulátoremTabify Selected Lines Změny úvodních mezer na karty, kde je to vhodné.Changes leading spaces to tabs where appropriate.
Zrušit posunutí tabulátorem u vybraných řádkůUntabify Selected Lines Změny úvodních karet na mezery.Changes leading tabs to spaces. Pokud chcete převést všechny mezery v souboru na tabulátory (nebo všechny tabulátory na mezery), můžete použít Edit.ConvertSpacesToTabs a Edit.ConvertTabsToSpaces příkazy.If you want to convert all the spaces in your file to tabs (or all the tabs to spaces), you can use the Edit.ConvertSpacesToTabs and Edit.ConvertTabsToSpaces commands. Tyto příkazy se nezobrazují v nabídkách aplikace Visual Studio, ale můžete je z volat rychlý přístup okna nebo příkazové okno.These commands do not appear in Visual Studio menus, but you can call them from the Quick Access window or the command window.
Převést na velká písmenaMake Uppercase Změní všechny znaky ve výběru na velká písmena, nebo pokud není nic vybráno, znak na pozici kurzoru na velká písmena se změní.Changes all characters in the selection to uppercase, or if there is no selection, changes the character at the insertion point to uppercase. Zástupce: Ctrl+SHIFT+U.Shortcut: Ctrl+Shift+U.
Nastavit jako malé písmenoMake Lowercase Změní všechny znaky ve výběr na malá písmena, nebo pokud není nic vybráno, znak na pozici kurzoru změní na malá písmena.Changes all characters in the selection to lowercase, or if there is no selection, changes the character at the insertion point to lowercase. Zástupce: Ctrl+U.Shortcut: Ctrl+U.
Přesunout vybrané řádky nahoruMove selected Lines Up Posune vybraný řádek jeden řádek nahoru.Moves the selected line up one line. Místní: Alt+šipka nahoru.Shortcut: Alt+Up Arrow.
Přesunout vybrané řádky dolůMove Selected Lines Down Posune vybraný řádek jeden řádek dolů.Moves the selected line down one line. Místní: Alt+šipka dolů.Shortcut: Alt+Down Arrow.
Odstranit vodorovné prázdné znakyDelete Horizontal White Space Odstraní tabulátory nebo mezery na konci aktuálního řádku.Deletes tabs or spaces at the end of the current line. Zástupce: ctrl+K, CTRL+ \Shortcut: Ctrl+K, Ctrl+\
Zobrazit prázdné znakyView White Space Zobrazí mezery jako zvýšené tečky a karty jako šipky.Displays spaces as raised dots, and tabs as arrows. Konec souboru se zobrazí jako obdélníkový glyf.The end of a file is displayed as a rectangular glyph. Pokud nástroje > možnosti > textový Editor > všechny jazyky > Zalamování > zobrazit viditelné piktogramy pro zalamování řádků je vybráno, že zobrazí se také piktogram.If Tools > Options > Text Editor > All Languages > Word Wrap > Show visible glyphs for word wrap is selected, that glyph is also displayed.
Zalamování řádkůWord Wrap Způsobí, že všechny řádky v dokumentu mají být zobrazeny v okně kódu.Causes all the lines in a document to be visible in the code window. Zalamování slov můžete vypnout nebo zapnout v všechny jazyky textového editoru nastavení (nástroje > možnosti > textový Editor > Všechny jazyky).You can turn word wrap off and on in the Text Editor All Languages settings (Tools > Options > Text Editor > All Languages).
Zakomentovat výběrComment Selection Přidá znaky komentáře do výběru nebo aktuálního řádku.Adds comment characters to the selection or the current line. Zástupce: ctrl+K, CTRL+CShortcut: Ctrl+K, Ctrl+C
Odkomentovat výběrUncomment Selection Odebere znaky komentáře z výběru nebo aktuálního řádku.Removes comment characters from the selection or the current line. Zástupce: ctrl+K, CTRL+UShortcut: Ctrl+K, Ctrl+U
Zvětšit odsazení řádkuIncrease Line Indent Přidá kartu (nebo ekvivalentní mezery) do vybraných řádků nebo aktuálního řádku.Adds a tab (or the equivalent spaces) to the selected lines or the current line.
Zmenšit odsazení řádkuDecrease Line Indent Odebere kartu (nebo ekvivalentní mezery) z vybraných řádků nebo aktuálního řádku.Removes a tab (or the equivalent spaces) from the selected lines or the current line.
Vybrat značkuSelect Tag V dokumentu, který obsahuje značky (například XML nebo HTML) vybere značku.In a document that contains tags (for example, XML or HTML), selects the tag.
Vybrat obsah značkySelect Tag Content V dokumentu, který obsahuje značky (například XML nebo HTML) vybere obsah.In a document that contains tags (for example, XML or HTML), selects the content.

Můžete pohybovat v editoru kódu v několika různými způsoby, včetně zpětné navigace a předává do předchozích bodů vložení, zobrazování definice typu nebo členu a přechod na konkrétní metodu, pomocí navigačního panelu.You can move around in the code editor in several different ways, including navigating backwards and forwards to previous insertion points, viewing the definition of a type or member, and jumping to a specific method using the navigation bar. Další informace najdete v části vyhledání kódu.For more information see Navigate code.

Hledání odkazů v vašeho základu kóduFind references in your code base

Chcete-li zjistit, kde se v rámci základu kódu odkazuje na konkrétní prvky kódu, můžete použít příkaz Najít všechny odkazy nebo stiskněte klávesu SHIFT+F12.To find where particular code elements are referenced throughout your codebase, you can use the Find All References command or press Shift+F12. Také, když kliknete na typ nebo člen, zvýraznění odkazů funkce automaticky zvýrazní všechny odkazy na tento typ nebo člen.Also, when you click on a type or member, the reference highlighting feature automatically highlights all references to that type or member. Další informace najdete v tématu najít odkazy ve vašem kódu.For more information, see Find references in your code.

Přizpůsobení editoruCustomize the editor

Můžete sdílet nastavení sady Visual Studio s jiným vývojářem, aby vaše nastavení bylo v souladu s normou nebo pomocí vraťte do výchozího nastavení sady Visual Studio Průvodce importem a exportem nastavení příkaz Nástroje nabídky.You can share your Visual Studio settings with another developer, have your settings conform to a standard, or return to Visual Studio default settings by using the Import and Export Settings Wizard command on the Tools menu. V Průvodce importem a exportem nastavení, můžete změnit obecné nastavení nebo jazyk a nastavení specifická pro projekt.In the Import and Export Settings Wizard, you can change selected general settings or language and project-specific settings.

Pokud chcete definovat nové klávesové zkratky nebo změnit existujícího klávesové zkratky, přejděte na nástroje > možnosti > prostředí > Klávesnice.To define new hotkeys or redefine existing hotkeys, go to Tools > Options > Environment > Keyboard. Další informace o klávesových zkratkách naleznete v tématu výchozí klávesové zkratky.For more information about hotkeys, see Default keyboard shortcuts.

Možnosti editoru jazyka JavaScript specifické najdete v tématu možnosti editoru jazyka JavaScript.For JavaScript-specific editor options, see JavaScript editor options.

Viz také:See also