Zpráva k vydání verze pro Visual Studio 2017 verze 15.3 Visual Studio 2017 version 15.3 Release Notes

Komunita vývojářů | Požadavky na systém | Kompatibilita | Distribuovatelný kód | Licenční podmínky | Blogy | Známé problémyDeveloper Community | System Requirements | Compatibility | Distributable Code | License Terms | Blogs | Known Issues


Poznámka

Nejedná se o nejnovější verzi sady Visual Studio 2017.This is not the latest version of Visual Studio 2017. Pokud chcete zobrazit informace o nejnovější verzi sady Visual Studio 2017, navštivte prosím aktuální stránku Zpráva k vydání verze.To see information on the latest version of Visual Studio 2017, please visit the current Release Notes page.

Tip

Jazyk stránky můžete přepnout v dolní části této stránky.You can switch the page language at the bottom of this page. Klikněte naClick the ikonu a vyhledejte svůj jazyk, nebo si vyberte ze seznamu dostupných jazyků. icon, search for your language, or select from the list of available languages.


Tento článek obsahuje informace o vydaných verzích pro Visual Studio 2017 verze 15.3.This article contains information about releases for Visual Studio 2017 version 15.3.

Zpětná vazbaFeedback

Chceme znát váš názor.We’d love to hear from you! O problémech nás můžete informovat pomocí možnosti Ohlásit problém v instalačním programu nebo samotném integrovaném vývojovém prostředí sady Visual Studio.You can report a problem from the Report a Problem option in either the installer or the Visual Studio IDE itself. RozhraníThe Feedback Icon Ikona se nachází v pravém horním rohu.icon is located in the upper right hand corner. Svou zpětnou vazbu sledujte na portálu komunity vývojářů.You can track your feedback in the Developer Community portal. Pokud máte nějaké návrhy, dejte nám vědět prostřednictvím webu UserVoice.For suggestions, let us know through the UserVoice site.

Historie verzíRelease History

Tip

Další informace o tom, jak dodáváme naše vydané verze, najdete v dokumentu Frekvence vydávání nových verzí sady Visual Studio 2017.You can learn more about how we ship our releases in the Visual Studio 2017 Release Rhythm document.

Stažení aktuální verze sady Visual Studio 2017Download the Current Release of Visual Studio 2017

Nejnovější verzi sady Visual Studio 2017 stáhnete kliknutím na tlačítko.Click the button to download the latest version of Visual Studio 2017. Pokyny najdete v článku o instalaci sady Visual Studio 2017.For instructions, see Install Visual Studio 2017.

Poznámka: Velikost instalačního balíčku se bude lišit v závislosti na vaší aktuální konfiguraci sady Visual Studio.Note: Installation package size will vary depending on your current Visual Studio configuration.


Datum vydání: 19. září 2017 – Visual Studio 2017 verze 15.3.5Release Date: September 19, 2017 - Visual Studio 2017 version 15.3.5

Problémy opravené ve verzi vydané 19. září 2017Issues Fixed in September 19, 2017 Release

Toto jsou problémy oznámené zákazníky a vyřešené v této verzi:These are the customer-reported issues addressed in this version:

  • Zavedena podpora pro Xcode 9, iOS 11, tvOS 11 a watchOS 4 společnosti AppleIntroduced support for Apple's Xcode 9, iOS 11, tvOS 11 and watchOS 4

Datum vydání: 12. září 2017 – Visual Studio 2017 verze 15.3.4Release Date: September 12, 2017 - Visual Studio 2017 version 15.3.4

Problémy opravené ve verzi vydané 12. září 2017Issues Fixed in September 12, 2017 Release

Toto jsou problémy oznámené zákazníky a vyřešené v této verzi:These are the customer-reported issues addressed in this version:


Datum vydání: 29. srpna 2017 – Visual Studio 2017 verze 15.3.3Release Date: August 29, 2017 - Visual Studio 2017 version 15.3.3

Problémy opravené ve verzi z 29. srpna 2017Issues Fixed in August 29, 2017 Release

Toto jsou problémy oznámené zákazníky a vyřešené v této verzi:These are the customer-reported issues addressed in this version:


Datum vydání: 22. srpna 2017 – Visual Studio 2017 verze 15.3.2Release Date: August 22, 2017 - Visual Studio 2017 version 15.3.2

Problémy opravené ve verzi z 22. srpna 2017Issues Fixed in August 22, 2017 Release

Toto jsou problémy oznámené zákazníky a vyřešené v této verzi:These are the customer-reported issues addressed in this version:

Další opravy zahrnuté v této verzi:Additional fixes included in this release:

  • Aktualizace nástrojů Service Fabricu.Service Fabric tooling update.
  • Při instalaci nebo odinstalaci VSIX se upgrade sady Visual Studio nezdaří s chybou AccessDenied.Visual Studio upgrade fails with AccessDenied failure during VSIX install / uninstall.
  • Problém s generováním projektů na Unity verze <= 5.5.Project generation issue on Unity version <= 5.5.
  • Zachycení výpisu paměti u propojených souborů.Dump capture for linked files.
  • Nesprávné generování kódu v tichém režimu z důvodu optimalizace smyčky.Silent bad codegen due to loop optimization.

Datum vydání: 18. srpna 2017 – Visual Studio 2017 verze 15.3.1Release Date: August 18, 2017 - Visual Studio 2017 version 15.3.1

Chyby opravené v této verziIssues Fixed in this Release

Toto jsou problémy oznámené zákazníky a vyřešené v této verzi:These are the customer-reported issues addressed in this version:


Datum vydání: 14. srpna 2017 – Visual Studio 2017 verze 15.3Release Date: August 14, 2017 - Visual Studio 2017 version 15.3

Souhrn: Novinky v této verziSummary: What's New in this Release

  • Vylepšení přístupnosti nabízejí vyšší přístupnost sady Visual Studio než kdy dřív.Accessibility Improvements make Visual Studio more accessible than ever.
  • Nástroje Azure Function jsou součástí vývojové úlohy Azure.Azure Function Tools are included in the Azure development workload. Můžete vyvíjet aplikace Azure Function místně a publikovat je přímo do Azure.You can develop Azure Function applications locally and publish directly to Azure.
  • Nyní můžete vytvářet aplikace v sadě Visual Studio 2017, které běží ve službě Azure Stack a ve státních cloudech, například Azure v Číně.You can now build applications in Visual Studio 2017 that run on Azure Stack and government clouds, like Azure in China.
  • Vylepšili jsme podporu pro vývoj v .NET Core o .NET Core 2.0 a kontejnery Windows Nano Server.We improved .NET Core development support for .NET Core 2.0, and Windows Nano Server containers.
  • V rozhraní IDE sady Visual Studio jsme vylepšili přihlašování a identitu, úvodní stránku, zjednodušené načtení řešení a instalační rozhraní příkazového řádku.In Visual Studio IDE, we improved Sign In and Identity, the start page, Lightweight Solution Load, and setup CLI. Vylepšili jsme také refaktoring, generování kódu a Rychlé akce.We also improved refactoring, code generation and Quick Actions.
  • Editor sady Visual Studio má lepší přístupnost díky novému modrému motivu s vysokým kontrastem a vylepšené podpoře čtečky obrazovky.The Visual Studio Editor has better accessibility due to the new ‘Blue (Extra Contrast)’ theme and improved screen reader support.
  • Vylepšili jsme prostředí ladicího programu a diagnostiky.We improved the Debugger and diagnostics experience. Mezi tato vylepšení patří i možnost nastavení dalšího příkazu pomocí ukázání a kliknutí.This includes Point and Click to Set Next Statement. Aktualizovali jsme také všechny vnořené hodnoty v okně proměnných a vylepšili ladění otevřené složky.We've also refreshed all nested values in variable window, and made Open Folder debugging improvements.
  • Xamarin má nový samostatný editor pro úpravy oprávnění aplikací.Xamarin has a new standalone editor for editing app entitlements.
  • Je aktualizované prostředí nástrojů otevřené složky a CMake .The Open Folder and CMake Tooling experience is updated. Nyní můžete používat CMake 3.8.You can now use CMake 3.8.
  • Vylepšili jsme modul IntelliSense a průvodce projektem a kódem pro služby jazyka C++.We made improvements to the IntelliSense engine, and to the project and the code wizards for C++ Language Services.
  • Sada nástrojů Visual C++ podporuje cílení inicializace z příkazového řádku.Visual C++ Toolset supports command-prompt initialization targeting.
  • Přidali jsme možnost používat funkce jazyka C# 7.1.We added the ability to use C# 7.1 Language features.
  • Můžete nainstalovat verze TypeScriptu nezávisle na aktualizacích sady Visual Studio.You can install TypeScript versions independent of Visual Studio updates.
  • Přidali jsme podporu ladění Node 8.We added support for Node 8 debugging.
  • NuGet přidal podporu pro nové TFM (netcoreapp2.0, netstandard2.0, Tizen), Semantic Versioning 2.0.0 a integraci upozornění a chyb správce balíčků NuGet do platformy MSBuild.NuGet has added support for new TFMs (netcoreapp2.0, netstandard2.0, Tizen), Semantic Versioning 2.0.0, and MSBuild integration of NuGet warnings and errors.
  • Visual Studio nyní nabízí nástroje pro vývoj .NET Framework 4.7 pro podporované platformy se zahrnutým modulem runtime 4.7.Visual Studio now offers .NET Framework 4.7 development tools to supported platforms with 4.7 runtime included.
  • Přidali jsme clustery souvisejících událostí do výsledků hledání v nástroji pro hledání Application Insights.We added clusters of related events to the search query results in the Application Insights Search tool.
  • Vylepšili jsme podporu syntaxe pro SQL Server 2016 v nástroji SQL Search od Redgate.We improved syntax support for SQL Server 2016 in Redgate SQL Search.
  • Povolili jsme podporu pro rozhraní API pro Microsoft Graph v Připojených službách.We enabled support for Microsoft Graph APIs in Connected Services.

Nejzávažnější chyby opravené v této verziTop Issues Fixed in this Release

Komunita vývojářů promluvila a my jsme naslouchali.The Developer Community spoke and we listened. Tento seznam obsahuje 10 problémů s nejvyšším počtem hlasů, které jsme opravili v této verzi.This list provides the 10 highest voted issues fixed in this release.

The Developer Community PortalPřečtěte si další informace o problémech oznámených zákazníky vyřešených v sadě Visual Studio 2017 verze 15.3. Learn more about customer-reported issues addressed in Visual Studio 2017 version 15.3.


Podrobnosti: Novinky v této verziDetails: What's New in this Release

Přístupnost Accessibility

V této verzi je vyřešených více než 1 700 problémů týkajících se přístupnosti a přístupnost v sadě Visual Studio je zatím nejlepší za celou její historii.We addressed over 1,700 accessibility issues in this release and made Visual Studio more accessible than ever. Můžete používat nový motiv Modrý (zvláště kontrastní) (obrázek 1).You have access to the new “Blue (Extra Contrast)” theme (Figure 1). Tento motiv nabízí vyšší kontrast než běžný modrý motiv pro ty, kdo nechtějí nebo nepotřebují plný režim s vysokým kontrastem.This theme offers you more contrast than the regular "Blue" theme if you don't want or need the full High Contrast mode.

Blue (Extra Contrast) theme
(Obrázek 1) Motiv Modrý (zvláště kontrastní)(Figure 1) Blue (Extra Contrast) theme

Pokud používáte editor sady Visual Studio, můžete objevovat grafické doplňky textu a procházet mezi nimi prostřednictvím nové sady příkazů Zobrazit poznámky k řádkům.With Visual Studio Editor, you can discover and navigate between text adornments via the new "Show Line Annotations" command set. Tuto novou funkci najdete v místní nabídce editoru (obrázek 2).You can find the new feature on the Editor context menu (Figure 2). Další informace najdete v části týkající se editoru sady Visual Studio.See the Visual Studio Editor section for more information.

Show Line Annotations
(Obrázek 2) Zobrazení poznámek k řádkům(Figure 2) Show Line Annotations

Další informace o novinkách v přístupnosti najdete v příspěvku na blogu o vylepšení přístupnosti v sadě Visual Studio 2017 verze 15.3 .For more accessibility news, visit the Accessibility improvements in Visual Studio 2017 version 15.3 blog post.


Azure Stack a Azure Government Clouds Azure Stack and Azure Government Clouds

Používejte stejné nástroje v sadě Visual Studio —, jako jsou Průzkumník cloudu, Připojené služby a ASP.NET Publish —, pro propojení služby Azure Stack a státních cloudů.Use all the same tools in Visual Studio — like Cloud Explorer, Connected Services and ASP.NET Publish — to connect Azure Stack and government clouds. Vyberte existující státní cloud, jako je například Azure v Číně (obrázek 3), nebo zadejte koncový bod zjišťování pro Azure Stack vaší organizace.Pick an existing government cloud, like Azure in China (Figure 3), or enter the discovery endpoint for your organization’s Azure Stack.

Azure Stack
(Obrázek 3) Azure Stack(Figure 3) Azure Stack

Nástroje funkce AzureAzure Function Tools

  • Nástroje pro vývoj funkcí C# Azure jsou zahrnuté jako součást sady funkcí pro vývoj v Azure.Tools for developing C# Azure Functions are included as part of the “Azure development” workload.
  • Můžete vyvíjet funkce Azure použitím předem kompilovaných knihoven tříd C# a atributů k určení aktivačních událostí.You can develop Azure functions by using pre-compiled C# class libraries, and attributes to specify triggers.
  • Můžete sestavovat, spouštět a ladit na místním vývojovém počítači.You can build, run, and debug on your local development machine.
  • Můžete publikovat ze sady Visual Studio přímo do Azure.You can publish directly to Azure from Visual Studio.

Další podrobnosti najdete v příspěvku na blogu o nástrojích sady Visual Studio 2017 pro Azure Functions.For more details, see the Visual Studio 2017 Tools for Azure Functions blog post.


.NET Core a ASP.NET Core .NET Core and ASP.NET Core

  • Můžete si nainstalovat sadu .NET Core 2.0 SDK prostřednictvím samostatně staženého souboru a získat tak možnost vyvíjet přes .NET Core 2.0 v sadě Visual Studio 2017 verze 15.3.You can install .NET Core 2.0 SDK via a separate download to enable .NET Core 2.0 development in Visual Studio 2017 version 15.3. Visual Studio teď umožňuje souběžnou podporu více sad .NET Core SDK.Visual Studio now provides side-by-side support of multiple .NET Core SDKs. Můžete experimentovat s nejnovějšími každodenními sestaveními sady .NET Core SDK a současně vyvíjet s použitím nejnovější veřejné verze sady SDK.You can experiment with the latest daily build of the .NET Core SDK while you develop with the latest public release of the SDK. Podrobnosti najdete na blogu .NET.See .NET blog for details.
  • Díky podpoře Visual Basicu nyní můžete vytvářet konzolové aplikace .NET Core a knihovny tříd .NET Core a .NET Standard ve Visual Basicu.With Visual Basic support, you now have the ability to create .NET Core console applications, and .NET Core, and .NET Standard class libraries in Visual Basic.
  • Interoperabilita rozhraní .NET Framework a .NET Standard/Core umožňuje odkazovat z projektů .NET Framework na knihovny .NET Core/.NET Standard a naopak..NET Framework and .NET Standard/Core interop allows you to refer to .NET Core/.NET Standard libraries from .NET Framework projects and vice versa. Není potřeba ručně přidávat balíčky NuGet pro interoperabilitu – Visual Studio to pro vás zařídí automaticky.No need to manually add interop NuGet packages – Visual Studio does this for you automatically.
  • Několik rozšíření podpory cílového rozhraní umožňuje vytvářet projekt pro více cílových rozhraní (TFM) a použít nástroj pro výběr TFM při ladění nebo spuštění k výběru TFM ke spuštění.Multiple target framework support enhancement allows you to build your project for multiple target frameworks (TFM), and use the TFM picker in Debug/Run to pick the TFM to run.
  • Přidali jsme podporu pro image Windows Nano Serveru, aby bylo možné vytvořit z aplikací ASP.NET Core kontejnery jako image Windows Nano Serveru.We added Windows Nano Server image support for containerizing ASP.NET Core apps as Windows Nano Server images. Jako platformu pro kontejnery nyní můžete vybrat Windows Nano Server.You can now select Windows Nano Server as the container platform. Akci můžete provést pro projekty ASP.NET Core příkazem Soubor->Nový projekt.You can do this under File->New Project for ASP.NET Core projects. U existujících projektů ji můžete přidat pomocí místní nabídky Projekt.For your existing projects, it can be added using the Project Context Menu.
  • Místní podpora služby IIS: Teď můžete vyvíjet a ladit pomocí služby IIS ze sady Visual Studio.Local IIS support: You can now develop and debug using IIS from Visual Studio.
  • ASP.NET Core na rozhraní .NET Framework – Pokud vytvoříte projekt ASP.NET Core, který cílí na úplné rozhraní .NET Framework (jenom Windows), použijte rozevírací seznam v dialogovém okně One ASP.NET.ASP.NET Core on .NET Framework – When you create an ASP.NET Core project targeting the full .NET Framework (Windows only), you will use the dropdown on the One ASP.NET dialog.
  • Funkci Live Unit Testing je možné povolit pro projekty .NET Standard, .NET Core a ASP.NET Core.The Live Unit Testing feature can be enabled for your .NET Standard, .NET Core, and ASP.NET Core projects.

Nástroje Service FabricuService Fabric Tools

Tato vydaná verze obsahuje novou stavovou šablonu projektu ASP.NET Core, podporu sad SDK 2.5 i 2.6 (a odpovídajících modulů runtime) Service Fabricu, jakož i několik oprav chyb.This release provides a new stateful ASP.NET Core project template, support for both 2.5 and 2.6 SDK's (and corresponding runtimes) of Service Fabric, as well as several bug fixes.

Nástroje pro průběžné doručováníContinuous Delivery Tools

Tyto funkce jsme přesunuli z rozšíření CD4VS (Microsoft Continuous Delivery Tools for Visual Studio) do sady Visual Studio:We moved these features from the CD4VS (Microsoft Continuous Delivery Tools for Visual Studio) extension into Visual Studio:

  • Nakonfigurujte průběžné doručování pro řešení obsahující projekty ASP.NET, které jsou zacílené na Azure App Service.Configure continuous delivery for solutions that contain ASP.NET projects targeting an Azure App Service.
  • Nakonfigurujte průběžné doručování pro řešení obsahující projekty ASP.NET Core, které jsou zacílené na Azure App Service.Configure continuous delivery for solutions that contain ASP.NET Core projects targeting an Azure App Service.

Integrované vývojové prostředí sady Visual Studio Visual Studio IDE

  • Do nabídky Nápověda jsme přidali příkaz Přístupnost přes klávesnici.We added the Keyboard Accessibility menu command under the "Help" menu. Díky tomu máte zkratku k online dokumentaci s radami a tipy k přístupnosti.This provides you with a shortcut to online documention about Accessibility Tips and Tricks.
  • Diagnostický systém vás informuje přes informační panel o rozšířeních, která by mohla mít podíl na neočekávaném ukončení sady Visual Studio (obrázek 4).The diagnostic system informs you via the InfoBar about extensions that might have been involved in an unexpected termination of Visual Studio (Figure 4). Na informačním panelu se zobrazí informace o ukončení a dotaz, jestli byste chtěli podezřelé rozšíření zakázat.The InfoBar provides this information about the termination and asks if you would like to disable the suspected extension.
InfoBar notification
(Obrázek 4) Oznámení na informačním panelu(Figure 4) InfoBar notification
  • Když máte otevřenou složku, můžete si vybrat požadovaný ladicí program prostřednictvím vyhrazeného uživatelského rozhraní.In open folder scenarios, you can select your desired debugger via dedicated UI.
  • Ukončili jsme sdílení některých nastavení, jako je třeba rozložení okna nástrojů, mezi různými souběžnými instalacemi sady Visual Studio 2017.We’ve stopped sharing certain settings, like tool window layout, between different side-by-side installations of Visual Studio 2017. Další informace najdete v dokumentaci týkající se synchronizace nastavení v sadě Visual Studio.For more information, see the Synchronize your settings in Visual Studio documentation.
  • Vyřešili jsme chybu se skrytým oknem. Kvůli této chybě to vypadalo, že sada Visual Studio přestala reagovat, než se objevilo její hlavní okno.We fixed the "hidden window" bug that made Visual Studio appear to hang before its main window appeared.
  • Zvětšili jsme cílovou oblast pro kliknutí, aby se snadněji zavíraly tipy s oznámením.We increased the clickable target area to make it easier to dismiss notification tips.

Integrované vývojové prostředí .NET.NET IDE

  • Přidali jsme několik nových refaktoringů a rychlých oprav, jako například Vyřešte konflikt sloučení, Přidejte kontroly hodnoty null, Přidejte parametr a mnoho dalších.We added several new refactorings and quick fixes, like "Resolve merge conflicts", "Add null checks", "Add parameter", and many more. Úplný seznam najdete na naší stránce s informacemi o refaktoringu, generování kódu a rychlých akcích v sadě Visual Studio.Take a look at our Refactoring, Code Generation and Quick Actions in Visual Studio page to see the full list.
  • Navrhujeme názvy proměnných v technologii IntelliSense, abychom vám pomohli zadávat názvy proměnných rychle, například Person person.We suggest variable names in IntelliSense to help you name your variables quickly, for example, Person person.
  • Příkaz Upravit a pokračovat podporuje funkce C# 7.0 (s výjimkou lokálních funkcí).Edit and Continue supports C# 7.0 features (except local functions).
  • Přidali jsme podporu zástupných znaků pro názvy souborů mimo složku projektu pro .NET Core.We added support for file globbing outside of your project folder for .NET Core.

Přihlašování a identitaSign In and Identity

Opravili jsme ovládací prvek pro výběr účtu, aby možnost Zadejte znovu přihlašovací údaje fungovala spolehlivěji.We fixed the account picker control so "Re-enter credentials" works more reliably. V některých případech výběr účtu mazal účty při opětovném zadávání přihlašovacích údajů.In some cases, the account picker would clear accounts upon re-entering credentials.

Úvodní stránkaStart Page

Zvýšili jsme cílovou oblast na úvodní stránce, na které můžete kliknutím připnout naposledy použité položky.We increased the clickable target area on Start Page MRU “pins”. Zjednodušilo se tím připnutí relevantních položek na začátek seznamu naposledy použitých položek.It's easier to pin items you care about to the top of the MRU.

Zjednodušené načtení řešeníLightweight Solution Load

  • Zvýšili jsme rychlost sestavení a stabilitu.We increased build speed and stability.
  • Snížili jsme počet načtených projektů.We reduced the number of loaded projects.
  • Přidali jsme novou možnost (obrázek 5), která sadě Visual Studio umožňuje zvolit nejvhodnější variantu pro vaše řešení.We added a new option (Figure 5) that allows Visual Studio to decide what’s best for your solution.
Lightweight Solution Load Options
(Obrázek 5) Možnosti zjednodušeného načtení řešení(Figure 5) Lightweight Solution Load Options
  • Přidali jsme řešení pro výsledky hledání souborů pro hledání odložených projektů (nikoliv jenom načtených projektů).We added file search results solutions to search for deferred projects, instead of just loaded projects.
    • Když načtete projekt, aktualizují se všechna existující hledání a přidají průběžné výsledky.When you load a project, all existing searches are refreshed to add progression results.
    • Má to ale tato omezení:There are limits to this:
      • Hledání se nerozšiřuje dovnitř souboru a nezahrnuje progresivní výsledky, tj. třídy, metody atd.Search does not extend within the file and does not include progressive results, i.e. classes, methods, etc.
      • Soubory, které patří do projektu, se zobrazí jako plochý seznam.Files that belong to a project are shown as a flat list. Když soubory patří do složky, zobrazí se relativní cesta, ne jenom název souboru.When files belong to a folder, the relative path is shown instead of just the file name.
      • V zobrazení vyhledávání neexistují žádné kontextové nabídky pro položky souboru.There are no context menus for the file items in the search view.
  • GoTo All a GoTo Files v pracovním prostoru zobrazují obsah z externích položek.GoTo All and GoTo Files show content from external items in the workspace.
  • Vylepšili jsme dávkové sestavení v projektech, které používají zjednodušené načtení řešení.We improved Batch build in projects that use Lightweight Solution Load.

InstalaceSetup

  • Instalační program pro Visual Studio teď podporuje změnu velikosti při vysokých hodnotách DPI na méně než 150 %.Visual Studio Installer now supports high-DPI scaling at levels less than 150%.
  • Spustitelný soubor vswhere.exe byl aktualizován tak, aby ve výchozím nastavení vyloučil instance ve verzi Preview, a zahrnul je v případě, že příkazový řádek obsahuje --prerelease.The vswhere.exe executable file has been updated to exclude preview instances by default, and includes them when --prerelease is included on the command line.
  • Rozhraní příkazového řádku umí zpracovat --verify, --fix a --clean.CLI is able to handle --verify, --fix and --clean.
    • --verify ověří rozložení a informuje o chybějících a neplatných datových částech.--verify verifies layout and informs you of missing and invalid payloads.
    • --fix ověří rozložení a znovu stáhne balíčky, které chybí nebo jsou neplatné.--fix verifies the layout and re-downloads packages that are either missing or invalid.
    • --clean odstraní zastaralé balíčky a umožní oříznout rozložení na rozsah konkrétní verze.--clean deletes obsolete packages and allows you to trim layout to a specific version range.
  • Na stránku podrobností instalace jsme přidali podrobnosti, které zobrazí čistou změnu velikosti na jednotlivých jednotkách.We added details that show the net size impact per drive to the installation details page. (Obrázek 6).(Figure 6).
Drive Sizes listed in the Installer
(Obrázek 6) Velikosti jednotek uvedené v instalačním programu(Figure 6) Drive Sizes listed in the Installer

Editor sady Visual Studio Visual Studio Editor

  • Při přidávání velkého počtu chyb už není obtížné ruční posouvání a výběr.Manual scroll and selection are no longer difficult when a large numbers of errors are being added.
  • Přidali jsme novou variantu modrého motivu určeného speciálně pro uživatele, kteří v editoru sady Visual Studio potřebují vyšší kontrast.We added a new variant of the "Blue" theme, which caters specifically to users who need more contrast in the Visual Studio Editor. Tento motiv nabízí vyšší kontrast než běžný modrý motiv pro ty, kdo nechtějí nebo nepotřebují plný režim s vysokým kontrastem.This theme offers you more contrast than the regular "Blue" theme if you don't want or need the full High Contrast mode. Můžete ho vyzkoušet přes Nástroje -> Možnosti -> Prostředí -> Obecné.You can try it out via Tools -> Options -> Environment -> General.
  • Pokud používáte čtečku obrazovky, můžete nyní procházet grafické doplňky prostřednictvím nového příkazu Zobrazit poznámky k řádkům.If you use a screen-reader, you can now navigate between adornments by using the new "Show Line Annotations" command.
    • Pokud si ho chcete aktivovat, vyberte v místní nabídce editoru Zobrazit poznámky k řádkům (Ctrl+K, Ctrl+M).To activate, select "Show Line Annotations" (Ctrl+K, Ctrl+M) on the Editor context menu. V editoru se otevře automaticky otevírané okno s popisem grafických doplňků na daném řádku.A popup will appear in the editor describing the adornments on that line.
    • Procházejte více poznámek na řádku pomocí kombinace kláves Ctrl+K, Ctrl+ Right/Left Arrow.Navigate through multiple annotations on the line using Ctrl+K, Ctrl+ Right/Left Arrow.
    • Jednoduše také najdete kontext v kódu pomocí příkazu Zobrazit strukturu (Ctrl+K, Ctrl+G).You can also easily find context in code through the "Show Structure" command Ctrl+K, Ctrl+G. V automaticky otevřeném okně, kde se nachází blikající kurzor, se zobrazí strukturální kontext řádku kódu, který dokáže přečíst čtečka obrazovky.This shows the structural context of the line of code in the popup where the caret is located, and can be read by the screen reader.

Ladění a diagnostika Debugging and Diagnostics

Podpora ladicího programu pro servery symbolů Visual Studio Team ServicesDebugger Support for Visual Studio Team Services Symbol Servers

  • Můžete zadávat dotazy na symboly a stahovat je (obrázek 7) ze serverů symbolů služby Visual Studio Team Services.You can query and download symbols (Figure 7) from Visual Studio Team Services Symbol Servers. Můžete vybrat a přidat cesty symbolů Visual Studio Team Services k prostředí Visual Studio pomocí stránky Nástroje->Možnosti->Ladicí program->Symboly.You can select and add Visual Studio Team Services symbol paths to your Visual Studio environment using the Tools->Options->Debugger->Symbols page. Pokud chcete nainstalovat server symbolů služby Visual Studio Team Services, podívejte se na stránku o použití serverů symbolů v Team Services.To set up a Visual Studio Team Services Symbol Server, see the Use Symbol Server in Team Services page.
Add VSTS Symbol Server
(Obrázek 7) Přidání serveru symbolů služby VSTS(Figure 7) Add VSTS Symbol Server
  • SetThreadDescription API se podporuje při ladění, když použijete příkaz Spustit ladění (F5) nebo Připojit k procesu (Ctrl+Alt+P).The SetThreadDescription API is supported while debugging when you use Start Debugging (F5) or Attach to Process (Ctrl+Alt+P). Názvy vláken, které jsou nastavené přes toto rozhraní API, se teď zobrazují v okně Vlákna a v rozevírací nabídce Vlákno na panelu nástrojů Umístění ladění.The thread names that are set via this API now show up in the Threads window and in the Thread dropdown in the Debug Location toolbar. Aktuálně to není podporováno při ladění výpisu.This is not currently supported while dump debugging.
  • V okně Výstup se teď zobrazuje výstup konzoly aplikace běžící v rámci kontejneru Windows při ladění.The Output Window now shows you the console output of an application running inside a Windows Container while debugging.
  • Přidali jsme novou podporu pro ladění aplikací .NET Core, které spustíte v kontejnerech Windows podle Windows Nano Serveru.We added new support for debugging .NET Core apps you run inside Windows Containers based on Windows Nano Server.

Nastavení dalšího příkazu pomocí ukázání a kliknutíPoint and Click to Set Next Statement

Při zastavení na zarážce při ladění můžete podržet klávesu Ctrl.You can hold down the Ctrl key while stopped at a breakpoint when debugging. Ikona Run to Click (Běžet do tohoto místa) vedle vašeho řádku kódu se změní na funkci Nastavit další příkaz (obrázek 8).The Run to Click (Run execution to here) icon next to your line of code changes to “Set Next Statement” functionality (Figure 8). Klikněte na ikonu a žlutý ukazatel instrukce se přesune na daný řádek a nastaví se další příkaz, který ladicí program provede.Click the icon to move the yellow instruction pointer to that line and set the next statement for the debugger to execute.

Click to set Next Statement
(Obrázek 8) Nastavení dalšího příkazu kliknutím(Figure 8) Click to set Next Statement

Zdrojový odkaz se teď podporuje pro formát souborů Windows PDB (navíc k souborům Portable PDB).Source Link is now supported for Windows PDB file format (in addition to Portable PDBs). Kompilátory, které ho podporují, můžou vložit potřebné informace do formátu souboru Windows PDB a ladicí program může na základě těchto informací načíst zdrojové soubory.Compilers that support it can put the necessary information in the Windows PDB file format and the debugger can retrieve source files based on that information.

Ladění otevřené složkyOpen Folder Debugging

Usnadnili jsme vám ladění, když použijete naše nové šablony pro otevřenou složku.We have made your debugging experience easier when you use our new templates for Open Folder. Pokud máte nainstalovaný ladicí program jádra, naše nové šablony vám umožní zvolit typ ladicího programu, který chcete použít.If you have the core debugger installed, our new templates allow you to choose the type of debugger you want to use. V dialogovém okně Vybrat ladicí program v Průzkumníkovi řešení, které otevřete příkazem nabídky Nastavení ladění a spouštění, můžete zvolit Spravovaný, Nativní nebo Smíšený.Managed, Native, or Mixed can be chosen from the "Select a Debugger" dialog in the "Debug and Launch Settings" menu option in Solution Explorer. Pokud máte nainstalované prostředí C++ MDD (Android C++, Linux Debugging atd.), zobrazí se vám teď možnosti pro podporu MinGW a Cygwin pomocí GDB pro připojení a spuštění v rámci stejné možnosti nabídky.If you have a C++ MDD experience installed (Android C++, Linux Debugging, etc.), you now see options for MinGW and Cygwin support by using GDB for attach and launch within the same menu option.

Aktualizace všech vnořených hodnot v oknech proměnnýchRefresh All Nested Values in Variable Windows

Když kliknete na tlačítko Aktualizovat pro nadřazený uzel proměnné nebo výrazu v oknech Sledovat, Automatické hodnoty a Místní hodnoty, aktualizují se také a znovu vyhodnotí všechny viditelné proměnné a výrazy, které jsou podřízené tomuto uzlu.When you click the refresh button for the parent node of a variable or expression in the Watch, Autos, and Locals windows, all visible variables and expressions that are children of that node also refresh and re-evaluate. Už nemusíte klikat na tlačítko Aktualizovat pro každou podřízenou položku.You no longer need to click on the refresh button for each of the children.

Podpora Live Unit Testing pro .NET CoreLive Unit Testing Support for .NET Core

Funkci Live Unit Testing můžete povolit pro projekty .NET Standard, .NET Core a ASP.NET Core.You can enable the Live Unit Testing feature for .NET Standard, .NET Core, and ASP.NET Core projects.


Xamarin Xamarin

  • Stránky vlastností a změny návrhu manifestu aplikace – Pracovali jsme dále na zjednodušení používání stránek vlastností pro projekty pro iOS a Android.Property Pages & App Manifest Redesigns - We have continued our work on making property pages for iOS and Android projects easier to use.
  • Nový Editor oprávnění – Přidali jsme samostatný editor pro úpravy oprávnění aplikací.New Entitlements Editor - We added a standalone editor for editing app entitlements.

Úplný přehled změn a další podrobnosti najdete na stránce developer.xamarin.com.For a complete overview of changes, be sure to check out developer.xamarin.com for more details.


Otevření složky a nástrojů CMake Open Folder and CMake Tools

  • Vylepšili jsme stabilitu pro přepínání mezi složkou a řešením.We improved stability for toggling between folder and solution.
  • Rozšiřující ovládací prvky pro otevřenou složku můžou do složek přidat ikonu správy zdrojového kódu.Open folder extenders can add a source control icon to your folders. Díky tomu budete moct rychle zobrazit stav správy zdrojového kódu svých souborů v Průzkumníku řešení, což je aktuálně implementováno prostřednictvím SVN.This allows you to quickly see the source control state of your files in Solution Explorer, which is currently implemented by SVN.
  • Prostředí CMake v sadě Visual Studio je upgradované na CMake 3.8.The CMake experience in Visual Studio is upgraded to CMake 3.8.
  • Vylepšili jsme podporu úprav, sestavování a ladění pro otevřenou složku u projektů C++, které používají MinGW nebo Cygwin.We improved editing, building, and debugging support in "Open Folder" for C++ projects that use MinGW or Cygwin.
  • Přidali jsme podporu definování globálních proměnných prostředí a proměnných prostředí určených pro konfigurace v souboru CppProperties.json a CMakeSettings.json.We added support to define global and configuration-specific environment variables in "CppProperties.json" and "CMakeSettings.json". Tyto proměnné prostředí se dají využít v konfiguracích ladění definovaných v souboru launch.vs.json a úkolech v souboru tasks.vs.json.These environment variables can be consumed by debug configurations defined in "launch.vs.json" and tasks in "tasks.vs.json".
  • Rozšířili jsme nástroje CMake pro Visual Studio, abyste měli k dispozici podporu pro integraci CTest.We enhanced CMake tools for Visual Studio to provide you with support for CTest integration.
  • Nyní můžete používat generátor Ninja CMake a snadno cílit na 64bitové platformy, sestavovat, ladit a upravovat pomocí IntelliSense.You can now use the CMake's Ninja generator to easily target 64-bit platforms, build, debug, and edit with IntelliSense.

Služba jazyka C++ C++ Language Services

Možnost Povolit rychlejší načítání projektů v části Experimentální možnosti je přejmenovaná na Povolit ukládání projektů do mezipaměti a přesunutá do části nastavení projektu VC++.The “Enable Faster Project Load” option under Experimental options has been renamed “Enable Project Caching” and moved under VC++ Project Settings. Původní hodnota vlastnosti se nerozšíří do nové možnosti.The old property value is not propagated to the new option.

Modul IntelliSenseIntelliSense Engine

  • C++ IntelliSense podporuje nové funkce C++17 odpovídající vydané verzi dávkového kompilátoru.C++ IntelliSense supports new C++17 features matching the batch compiler release.
  • Přidali jsme možnost místní nabídky v editoru C++ pro opětovné prohledání souboru, která se dá použít, pokud nepracuje správně IntelliSense.Added context menu option in C++ editor to Rescan File, which can be used if IntelliSense is not working correctly.
  • Snížilo se využití procesoru při spuštění příkazu Najít všechny odkazy nebo Hierarchie volání pro kód C++.Reduced CPU usage when running Find All References or Call Hierarchy for C++ code.
  • Vylepšili jsme celkové prostředí modulu C++ IntelliSense.We've improved the overall C++ IntelliSense engine experience.

Průvodce projektu a kóduProject and Code Wizard

  • Přepsali jsme několik průvodců projektů a kódu ve stylu dialogu podpisu.We have rewritten several project and code wizards in the signature dialogue style.
  • Příkaz Přidat třídu přímo spustí průvodce Přidat třídu.Add Class launches the Add Class wizard directly. Všechny ostatní položky, které byly dříve tady, jsou v části Přidat > Nová položka.All of the other items that were previously here are available under "Add > New Item".
  • Projekty Win32 jsou v kategorii Desktop Windows v dialogu Nový projekt.Win32 projects are under the Windows Desktop category in the New Project dialog.
  • Šablony Konzola Windows a Desktopová aplikace teď vytvoří projekty bez zobrazení průvodce.The Windows Console and Desktop Application templates now create the projects without displaying a wizard. K dispozici je nový Desktopový průvodce pro Windows v rámci stejné kategorie, kde se zobrazí stejné možnosti jako předtím.There's a new Windows Desktop Wizard under the same category that displays the same options as before.

Sada nástrojů a knihovny pro Visual C++Visual C++ Toolset and Libraries

  • Developer Command Prompt pro sadu Visual Studio (a příkazový řádek Visual C++) mají doplněnou podporu pro inicializaci prostředí příkazového řádku, které cílí na sadu nástrojů Visual C++ 2015 (v140) prostřednictvím argumentu -vcvars_ver=14.0.The Developer Command Prompt for Visual Studio (and the Visual C++ Command Prompt) have added support for initializing a command-prompt environment targeting the Visual C++ 2015 Toolset (v140) via the -vcvars_ver=14.0 argument.
  • Souborové adresáře Visual C++ Redist jsou přejmenované na Microsoft.VC141.*, aby odpovídaly verzím sady nástrojů (14.1x).Visual C++ Redist file directories have been renamed to Microsoft.VC141.* to match versioning with the toolset (14.1x). V sadě Visual Studio 2017 RTM byly tyto adresáře nesprávně pojmenované Microsoft.VC150.*.In Visual Studio 2017 RTM, these directories were incorrectly named Microsoft.VC150.*.
  • Verze souboru a adresáře Visual C++ (Visual Studio 2017 15.3):Visual C++ File Version and Directories (Visual Studio 2017 15.3) :
    • Verze souboru sady nástrojů VC++ : 14.11.25506.0 nebo 19.11.25506.0VC++ Toolset File Version : 14.11.25506.0 or 19.11.25506.0
    • Adresář nástrojů VC++ : VC\Tools\MSVC\14.11.25503 (umístění adresáře byl uzamčeno ve verzi Preview)VC++ Tools Directory : VC\Tools\MSVC\14.11.25503 (directory location was locked in a Preview release)
    • Adresář VC++ Redist [a] : VC\Redist\MSVC\14.11.25325 (všechny moduly runtime s výjimkou MFC a OneCore)VC++ Redist Directory [a] : VC\Redist\MSVC\14.11.25325 (All runtimes except for MFC and OneCore)
    • Adresář VC++ Redist [b] : VC\Redist\MSVC\14.11.25415 (moduly runtime MFC a OneCore)VC++ Redist Directory [b] : VC\Redist\MSVC\14.11.25415 (MFC and OneCore runtimes)

Podpora jazyka C# 7.1C# 7.1 Language Support


JavaScript a TypeScriptJavaScript & TypeScript

  • Při spuštění tsserveru jsme přešli ze 64bitového uzlu na 32bitový a snížili jsme spotřebu paměti u jazykové služby na polovinu.We switched from 64-bit node to 32 bit-node when launching tsserver and cut language service memory consumption in half.
  • Cesta k souboru IntelliSense v příkazech importu je nyní rychlejší.File path IntelliSense in import statements is now faster.
  • Verze TypeScriptu se dají nainstalovat nezávisle na aktualizacích sady Visual Studio a vybrat podle jednotlivých projektů.TypeScript versions can be installed independent of Visual Studio updates and selected on a per project basis. Další informace najdete v dokumentaci k aktualizaci TypeScriptu v sadě Visual Studio 2017.For more information see the Updating TypeScript in Visual Studio 2017 documentation.

Node.jsNode.js

  • Přidali jsme podporu ladění Node 8.We added support for Node 8 debugging.
  • Rozšířili jsme možnosti výkonu pro test runner jednotek.We made unit test runner performance enhancements.
  • Zjednodušili jsme uživatelské rozhraní instalačního programu balíčku npm.We simplified the npm package installer UI.

NuGet NuGet

  • Doplnili jsme podporu pro následující TFM – netcoreapp2.0, netstandard2.0 a Tizen.We have added support for the following TFMs - netcoreapp2.0, netstandard2.0, and Tizen.
  • Integrovali jsme upozornění a chyby správce balíčků NuGet do platformy MSBuild, takže můžete používat existující vlastnosti platformy MSBuild k potlačení určitých upozornění nebo jejich povýšení na chyby.We have integrated NuGet warnings and errors with MSBuild so you can use existing MSBuild properties to suppress certain warnings or elevate them to errors.
  • Přidali jsme podporu pro Semantic Versioning 2.0.0.We have added support for Semantic Versioning 2.0.0.

Další podrobnosti o těchto vylepšeních a úplný seznam oprav chyb můžete najít ve zprávě k vydání verze NuGet.You can find more details about these improvements and the complete list of bug fixes in the NuGet release notes.


.NET Framework 4.7 .NET Framework 4.7

Visual Studio 2017 verze 15.3 teď nabízí nástroje pro vývoj .NET Framework 4.7 pro všechny podporované platformy se zahrnutým modulem runtime 4.7.Visual Studio 2017 version 15.3 now offers the .NET Framework 4.7 development tools to all supported platforms with the 4.7 runtime included. .NET Framework 4.7 nabízí několik nových funkcí a vylepšení, jakož i četné opravy v oblasti spolehlivosti, stability, zabezpečení a výkonu.The .NET Framework 4.7 offers several new features and improvements as well as numerous reliability, stability, security, and performance fixes.

Další podrobnosti o .NET 4.7 najdete v těchto článcích:You can find more details about .NET 4.7 in these articles:

Kontejnerové vývojové nástrojeContainer Development Tools

Visual Studio 2017 veze 15.3 teď podporuje řadu kontejnerových vývojových nástrojů v existujících aplikacích pro .NET Framework s kontejnery Windows až po .NET Core s Windows a Linux Support.Visual Studio 2017 version 15.3 now supports the breadth of container development across existing .NET Framework apps with Windows Containers, to .NET Core with Windows, and Linux Support. Mezi nedávno přidanými funkcemi je podpora aplikací .NET Core v kontejnerech s Windows Nano Serverem i vylepšení ladění pro aplikace .NET Framework v kontejnerech.Recent additions include support for your .NET Core applications in containers running Windows Nano Server, as well as debugging improvements for .NET Framework applications in containers.


Přidali jsme clustery souvisejících událostí do výsledků hledání v nástroji pro hledání Application Insights.We added clusters of related events to the search query results in the Application Insights Search tool. Tyto clustery vám můžou pomoct odhalit překvapivé vzory v chování vaší aplikace, jako například velký objem výjimek pocházejících z jedné země nebo verze nebo od jednoho uživatele.These clusters can help you discover surprising patterns in your application's behavior, like a large volume of exceptions coming from a single country, version, or user.


Nástroje SQL Server Data Tools (SSDT) SQL Server Data Tools (SSDT)

Visual Studio 2017 verze 15.3 se nyní dodává s nástroji SQL Server Data Tools, které plně podporují SQL Server 2017 běžící na Windows, Linuxu a Dockeru v systému macOS.Visual Studio 2017 version 15.3 now ships with SQL Server Data Tools that fully supports SQL Server 2017 running on Windows, Linux and Docker in macOS. Nástroje SSDT teď podporují všechny verze SQL Serveru, SQLDB a datového skladu v Azure.SSDT now supports all versions of SQL Server, SQLDB and DW on Azure.

Opravy problémů, které zákazníci hlásí nejčastěji:Fixes for top customer reported issues:

  • Přidali jsme možnost Ignorovat pořadí sloupců, která umožňuje zabránit zbytečným přesunům dat tabulky z důvodu změny pořadí sloupců.We added Ignore Column Order option to prevent unnecessary table data movement due to a column order change.
  • Opravili jsme chybu buildu ESENT a zvýšili stabilitu a výkon buildu databázového projektu v sadě Visual Studio 2017.We fixed ESENT build error and increased the database project build stability and performance in Visual Studio 2017.
  • Vyřešili jsme mnoho dalších problémů nahlášených zákazníky.We addressed many more customer reported issues. Další podrobnosti o vyřešených problémech najdete v tématu o protokolu změn SSDT.See SSDT changelog for more details of fixed issues.

Datové nástroje Redgate. Redgate Data Tools

Všechny datové nástroje RedgateAll Redgate Data Tools

Odebrali jsme úvodní dialogové okno, které se zobrazovalo při prvním použití Datových nástrojů Redgate.We removed the introduction dialog that appeared upon first use of Redgate Data Tools.

Redgate SQL PromptRedgate SQL Prompt

Vylepšili jsme formátování.We made formatting improvements.

Redgate ReadyRollRedgate ReadyRoll

  • Přepracovali jsme okno otevřeného projektu ReadyRoll.The ReadyRoll open project window has been redesigned.
  • Zkrátili jsme dobu načítání vlastností projektu.We improved the loading time of Project Properties.
  • Widget stavu skriptu jsme nahradili panelem akcí.We replaced the script status widget with an action bar.
  • Vyřešili jsme potíže s připojením k Azure.We fixed the connectivity problems with Azure.
  • Vylepšili jsme podporu syntaxe pro SQL Server 2016.We improved the syntax support for SQL Server 2016.

PythonPython

  • Vylepšili jsme přístupnost u čteček obrazovky, navigace pomocí kláves a vysokého kontrastu.We improved accessibility in screen readers, keyboard navigation and high contrast.
  • Vylepšili jsme lokalizaci a uživatelům, kteří nepoužívají angličtinu, se tak bude v uživatelském rozhraní zobrazovat méně anglického textu.We improved localization so that non-English users will see less English text in the UI.

R ToolsR Tools

  • Vylepšili jsme prostředí IntelliSense.The IntelliSense experience is improved.
  • Máte lepší možnosti připojení Azure ke svým počítačům, které blokují příkaz ping.You have better Azure connectivity to your machines that are blocking ping.
  • Při provádění vzdálené instalace služeb už nemusíte mít práva pro správu služby.When you perform a remote services install, you are no longer required to have service management rights.
  • Celkově jsme vylepšili přístupnost a lokalizaci.We improved overall accessibility, and localization.

Zprostředkovatel Microsoft Graph ve Službách připojeníMicrosoft Graph Provider in Connected Services

Povolili jsme podporu pro rozhraní API pro Microsoft Graph v Připojených službách.We have enabled support for Microsoft Graph APIs in Connected Services. Zjednodušili jsme instalaci.We've made Installation easier. K získání přístupu a instalaci stačí otevřít dialogové okno Připojené služby (obrázek 9).Just open the Connected Services dialog to access and install (Figure 9).

Install Microsoft Graph provider
(Obrázek 9) Instalace poskytovatele Microsoft Graph(Figure 9) Install Microsoft Graph provider

Známé problémyKnown Issues

Visual Studio 2017 Known Issues Podívejte se na všechny dosud známé problémy a možná alternativní řešení v sadě Visual Studio 2017 verze 15.3. See all existing known issues and available workarounds in Visual Studio 2017 version 15.3.

Vašim připomínkám a názorům nasloucháme a plně se jim věnujeme.We are fully committed to listening to your feedback. Navštivte web komunity vývojářů, kde můžete hledat nejnovější problémy, zaznamenat nové a podpořit svým hlasem stávající problémy.Visit the Developer Community site to find the latest issues, log new issues, and upvote existing issues.


Historie zpráv k vydání verze pro Visual Studio 2017Visual Studio 2017 Release Notes History

Podívejte se na stránku Historie zpráv k vydání verzí pro Visual Studio 2017.Please see the Visual Studio 2017 Release Notes History page.


Na začátek stránky
Top of Page