Visual Studio Icon Zpráva k vydání verze pro Visual Studio 2017 verze 15.6


Komunita vývojářů | Požadavky na systém | Kompatibilita | Distribuovatelný kód | Licenční podmínky | Blogy | Známé problémy



Poznámka

Nejedná se o nejnovější verzi sady Visual Studio. Pokud si chcete stáhnout nejnovější verzi, přejděte prosím na aktuální zprávu k vydání verze pro Visual Studio 2019.


Pokud si chcete stáhnout Visual Studio 2017, klikněte na tlačítko Stáhnout a po zobrazení výzvy se přihlaste pomocí svého předplatného sady Visual Studio. Pokud nemáte předplatné sady Visual Studio, můžete si ho zdarma vytvořit kliknutím na Vytvořit nový účet Microsoft na přihlašovací stránce. K získání nejnovějších funkcí a oprav chyb doporučujeme použít Visual Studio 2019.

Jiné produkty sady Visual Studio 2017 si můžete stáhnout ze stránky se staršími verzemi.


Novinky ve verzi 15.6

Vydané verze sady Visual Studio 2017 15.6


Krátký přehled zajímavých nových funkcí ve verzi 15.6

Hlavní chyby opravené ve verzi 15.6

Toto jsou problémy oznámené zákazníky a vyřešené ve verzi 15.6:

Podívejte se na všechny problémy nahlášené zákazníky, které jsou opravené v sadě Visual Studio 2017 verze 15.6.

The Developer Community Portal


Podrobnosti o novinkách ve verzi 15.6

Release Notes Icon Visual Studio 2017 verze 15.6.0

vydané 5. března 2018

Nové funkce ve verzi 15.6

Výkon

Ve verzi 15.6 pokračujeme ve zlepšování výkonu při načítání řešení, konkrétně pro scénáře, ve kterých se výsledky návrhových sestavení ukládají do mezipaměti. Velká řešení C# a Visual Basic se načítají dvakrát rychleji než dříve (pokud již bylo řešení v počítači otevřeno).

Načtení řešení .NET Core

Zaměřili jsme se na .NET Core a na základě našich testovacích měření mohou zákazníci očekávat v průměru o 20 % rychlejší načítání řešení.

Oznámení ohledně rychlosti odezvy UI

Za účelem vyšší transparentnosti týkající se dopadu rozšíření na výkon a spolehlivost provádí Visual Studio analýzu v reálném čase pro zjištění toho, zda je pravděpodobné, aby rozšíření způsobilo zablokování. Pokud se zjistí, že rozšíření může zablokování způsobit, zobrazí Visual Studio oznámení, které uživateli umožní zakázat podezřelé rozšíření nebo potlačit budoucí oznámení pro toto rozšíření (obrázek 1).

UI Responsiveness notification with option to disable
(Obrázek 1) Možnost oznámení odezvy UI pro zakázání rozšíření nebo potlačení budoucích oznámení

Instalace a nastavení

  • V této verzi mohou uživatelé bez oprávnění pro správu vytvářet rozložení sady Visual Studio umožňující uživatelům, kteří nejsou správci, vytvářet offline síťové instalace.
  • Při první instalaci sady Visual Studio nebo její aktualizace z webu uvidíte nové, transparentnější prostředí instalačního programu pro Visual Studio. Uvnitř se nic nezměnilo, ale nové prostředí vás podrobně informuje o probíhajících akcích (obrázek 2).
Improved transparency setup for Visual Studio Installer
(Obrázek 2) Transparentnější nastavení instalačního programu pro Visual Studio
Přidali jsme podporu pro pozastavení instalace (obrázek 3) a její pozdější obnovení (obrázek 4).
Pause your installation
(Obrázek 3) Pozastavení instalace
Resume your installation
(Obrázek 4) Obnovení instalace
Podrobnosti instalace

Díky novým podrobnostem instalace (obrázek 5) můžete vidět velikost souboru ke stažení, procenta dokončení stahování a rychlost stahování. Můžete také zobrazit celkový počet instalovaných balíčků a počet zbývajících balíčků.

Poznámka

Pokud instalaci pozastavíte a později obnovíte, průběh se bude zobrazovat pro zbývající položky ke stažení a instalaci a nespustí se od předchozího počtu.

Installation details
(Obrázek 5) Podrobnosti instalace
Nastavení integrovaného vývojového prostředí (IDE)
  • Proces aktualizace jsme zjednodušili tím, že oznámení aktualizace v sadě Visual Studio vás teď přesměrují přímo do instalačního programu, nikoli na Rozšíření a aktualizace.

  • Úlohy „Vývoj pro ASP.NET a web“ a „Vývoj multiplatformních aplikací pomocí rozhraní .NET Core“ byly aktualizovány tak, aby obsahovaly „Cloudové nástroje pro vývoj pro web“. Tato komponenta obsahuje vše potřebné pro využívání služby Azure Functions v rámci sady Visual Studio.

    Poznámka

    Při aktualizaci z verze 15.6 Preview 3 na Preview 4 nebo vyšší se může počítač bez upozornění nebo potvrzení uživatele automaticky restartovat.

Vylepšení editoru
  • Do výchozího mapování klávesnice jsme přidali klávesovou zkratku Ctrl+D pro Edit.Duplicate. Předchozí kombinace kláves (Ctr+E, V) stále funguje a je k dispozici ve všech schématech mapování klávesnice.
  • Přidali jsme příkaz Rozbalit výběr, který umožňuje úspěšně rozbalit výběr do dalšího logického bloku. K rozbalení aktuálního výběru můžete použít klávesovou zkratku Shift+Alt+= a k jeho sbalení pak Shift+Alt+- .

Vylepšení jazyka F# a jeho nástrojů

Tato verze obsahuje množství vylepšení jazyka F# a jeho nástrojů. Nejvýznamnější z nich souvisí s projekty .NET Core SDK. Významným podílem jako vždy přispěla i komunita.

Vylepšení kompilátoru a základní knihovny jazyka F#
  • Opravy chyb a vylepšení výkonu – ncave, Vasily Kirichenko a Microsoft.
  • Kolekce F# nyní implementují IReadonlyList a IReadonlyDictionarySaul Rennison.
  • Byla přidána podpora pro NativePtr.ByRefmjmckp.
  • Byla přidána podpora pro Async.StartImmediateAsTaskOnur Gumus.
  • Byla přidána podpora pro Seq.transpose, Array.transpose, List.transposePatrick McDonald.
  • Byla opravena regrese v typech System.Tuple definovaných v kódu F# nepodporující .Item1/.Item2/atd. Vzhledem k tomu, že jsou nyní tyto typy řazené kolekce členů 100% synonymem syntaxe řazené kolekce členů F#, představili jsme upozornění na použití těchto vlastností. Další podrobnosti najdete u propojených žádostí o přijetí změn.
  • Byla opravena regrese a další chyba v pořadí odvozování pro statisticky vyřešené parametry typu – Gustavo Leon a Microsoft.
  • Byla povolena vlastnost IsSerializable pro typy jazyka F# v FSharp.Core pro .NET Standard. Typy jazyka F#, jako Option a Async, jsou nyní serializovatelné pro .NET Standard a .NET Core.
  • Balíček FSharp.Core byl aktualizován na verzi 4.3.4 a obsahuje všechny změny v FSharp.Core pro tuto verzi.
Vylepšení nástrojů jazyka F#
  • Bylo implementováno řazení souborů pro projekty .NET Core SDK, včetně možností Přidat výše/níže, podpory složek a aktualizace uživatelského rozhraní sady Visual Studio bez nutnosti opakovaného načítání projektu.
  • Byla implementována podpora cílení na více verzí projektů .NET Core SDK.
  • V projektech .NET Core SDK se nyní podporují sdílené soubory.
  • Na projekty .NET Standard teď mohou odkazovat projekty F# / .NET Framework.
  • Vylepšení zasílání zpráv o chybách – Vasily Kirichenko a Eugene Auduchinok.
  • Vylepšení výkonu – Vasily Kirichenko, Eugene Auduchinok, Daniel Wedelich a Microsoft.
  • Přesnější automatické dokončování s mnoha opravami chyb – Vasily Kirichenko a Microsoft.
  • Statické členy v neotevřených oborech názvů jsou k dispozici v dokončení – Vasily Kirichenko.
  • Symboly oboru názvů se zobrazují ve zvýraznění dokumentu a příkazu Najít všechny odkazy – Vasily Kirichenko.
  • Kód strukturovaných pokynů byl zpřístupněn pro jiné editory (VSCode, VS pro Mac, Rider) – Eugene Auduchinok.
  • Lepší sbalování a strukturované pokyny pro konstruktory jazyka F# – Eugene Auduchinok.
  • V analyzátoru Zjednodušit názvy se už nedají zjednodušit otevřené příkazy – Vasily Kirichenko.
  • Zobrazení polí IL sbyte a byte v QuickInfo se teď podporuje – Vasily Kirichenko.
  • Oprava kódu nepoužívané deklarace se už nespouští u nevolaných funkcí a metod jazyka F# – Vasily Kirichenko.
  • Přetažení napříč složkami se nyní podporuje v projektech .NET Framework – Paulo Nobre.
  • Opravu analyzátoru a kódu nepoužívaných deklarací teď můžete přepínat.
  • Opravy chyb a vylepšení výkonu – Eugene Auduchinok a Microsoft.
  • Kód obklopený #if INTERACTIVE teď definuje podporu funkcí IDE, které nevyžadují kontrolu typů – Eugene Auduchinok.
  • Byla opravena neúmyslná reverze opravy prázdného okna „Nový soubor“ u starších projektů F#/ASP.NET (.NET Framework) – Loïc Denuzière.
Vylepšení infrastruktury jazyka # a Open Sourcu
  • Byla implementována aktualizace správy verzí RFC.
  • Všechny soubory lokalizace použité v kompilátoru a nástrojích jsou k dispozici na GitHubu a jsou schopny přijímat příspěvky komunity.
  • Noční sestavení je možné vytvořit za hodinu (dříve to bylo možné za 4 a více hodin).
  • Odebrali jsme závislost na sadě Windows 10 SDK, abychom podpořili open source přispěvatele.
  • Satelitní sestavení a FSharp.Core.resources.dll jsou nyní součástí sady SDK kompilátoru jazyka F#.
  • Pokud se nezměnily informace o sestavení, kompilátor sám sebe už v základním kódu Visual F# znovu nesestaví.
  • ToString() se implementuje pro FSharpSymbolUse za účelem jednoduššího zobrazení všech výsledků používání symbolů při ladění nástrojů editoru – Eugene Auduchinok.

Pokud se chcete podívat na kompletní potvrzený protokol změn pro verzi 15.6, podívejte se na naši značku.

Poznámka

Podívejte se na všechny dosud známé problémy a možná alternativní řešení v sadě Visual Studio 2017 verze 15.6.

Vylepšení Visual C++

  • Tato verze obsahuje opravu problému zabezpečení se soubory PDB popsaného v CVE-2018-1037.
  • V dialogovém okně Přidat nový projekt můžete vytvářet projekty CMake.
  • Teď můžete zvolit, jestli se při otevření nových projektů CMake v sadě Visual Studio má nebo nemá automaticky vygenerovat mezipaměť CMake.
  • Testy CTest, Google Test a Boost.Test se v projektech CMake automaticky zjišťují a uvádějí v Průzkumníku testů.
  • Testy jednotek Boost Test můžete do projektu přidat snadno pomocí šablon položek Boost.Test. Testy jednotek Boost Test nyní používají dynamickou knihovnu Boost.
  • Podporuje se garantovaná elize kopírování C++17.
  • Integrovaná podpora pro Android NDK r15c pro vývoj pro Android.
  • Nástroje sady Visual Studio pro Android podporují aplikace pro Android, které jsou sestavené pomocí sady SDK úrovně 25 a nižší, a umožňují jejich nasazení a provozování na zařízeních Oreo.
  • Postupujeme dále v implementaci standardní knihovny C++17, včetně rozhraní API, jako je stable_sort, oddílu, paralelního vložení vector::emplace_back a <memory_resource> podle standardů C++17.
  • Chybějící zahrnuté soubory se automaticky zjišťují pro otevřenou složku C++, pokud existují v kořenu pracovního prostoru, i když nejsou explicitně přidány do cesty zahrnutí.
  • Pro podporu vložené kolekce GCC technologie ARM jsou dostupné možnosti ladění. Pravým tlačítkem myši klikněte na binární soubor, vyberte Nastavení ladění a spouštění a pak vyberte mikrořadič ladění jazyka C/C++.
  • Optimalizace na základě profilu je pro ARM64 povolená a plně podporovaná.
  • Do rozšíření C++ Core Guidelines Check byla přidána další pravidla, díky kterým bude váš kód čistější, bezpečnější a lépe spravovatelný.
    • Rozšíření nástroje C++ Core Checker pro zjišťování použití indirekcí s dobou života, která je mimo rozsah.
    • 5 nových kontrol vynucujících pravidla ohledně přetečení celých čísel a další pravidla z dokumentu C++ Core Guidelines.
    • C++ Core Check teď obsahuje sadu pravidel analýzy kódu pro detekci aritmetických přetečení.
  • Podpora pro spuštění analýzy kódu jednoho souboru (nebo na výběr souborů v Průzkumníku řešení); vyčištěné nabídky Sestavit a Analyzovat. Možnost „Spustit analýzu kódu“ již negeneruje kód, čímž se zvýšila rychlost analýzy.
  • Chyby IntelliSense pro neaktivní konfigurace se v editoru zobrazují jako fialové vlnovky. Počet konfigurací, které se mají zpracovat, lze nakonfigurovat v části Nástroje > Možnosti.
  • Podstatné zkrácení doby kompilace:
    • Kompilátor optimalizuje kód tak, aby běžel rychleji ve vylepšených optimalizacích předem rozšířených smyček a vylepšené identifikaci a šíření konstantních globálních dat v LTCG.
    • Časy kompilace jsou ve srovnání s verzí 15.5 kratší. Front-end kompilátoru je u většiny vstupů o 3 až 5 % rychlejší. Optimalizátor kompilátoru je o 3 % rychlejší kvůli snížené režii základních algoritmů optimalizace. Velké kompilace LTCG jsou navíc o 10 % rychlejší z důvodu přepracovaných datových struktur.
  • Režie generování souborů mapy je ve scénářích úplného propojení omezená. Nadále doporučujeme používat místo souborů mapování soubory PDB.
  • Kompilátor MSVC podporuje přepínač /Qspectre pro každou architekturu, včetně x86, x64, ARM a ARM64.

Kompilátor C#

Kompilátor C# teď podporuje:

  • Server kompilátoru u CoreCLR pro propustnost sestavení.
  • Podepisování silným názvem u CoreCLR ( možnost /keyfile, všechny operační systémy).

Kromě mnoha oprav chyb a jedné rozbíjející změny (viz průběžný seznam rozbíjejících změn) byly provedeny dvě menší jazykové změny ve funkcích jazyků verze 7.2:

Nástroje sady Visual Studio pro Xamarin

Tato verze zahrnuje Xamarin.iOS 11.8 a Xamarin.Android 8.2.

Dynamický náhled XAML se simulátorem iOSu

Xamarin Live Player umožňuje vývojářům nepřetržitě nasazovat, testovat a ladit své aplikace a použít přitom pouze Visual Studio a zařízení s iOSem nebo Androidem. Visual Studio 2017 ve verzi 15.5 přidalo podporu umožňující vývojářům zobrazit náhled změn XAML v reálném čase přímo v emulátoru Androidu bez nutnosti opětovné kompilace nebo opětovného nasazení. Tato verze přináší tuto funkci pro vzdálený simulátor iOSu pro Windows.

Python

V této verzi není pro získání funkce IntelliSense u instalovaných balíčků potřeba databáze dokončování (obrázek 6) . To znamená, že místo abyste po instalaci balíčku museli čekat až čtyři hodiny, dokončí se oblíbené balíčky, jako jsou například numpy a pandas, za pouhých pár sekund.

Python completions for the pandas package
(Obrázek 6) Dokončování balíčku pandas v Pythonu

Přidali jsme možnost přizpůsobit barvu používanou pro řetězce doc, když se používají ve třídě nebo funkci a také vzorech regulárních výrazů zjištěných jako součást volání knihovny re (obrázek 7) . Můžete je změnit v části Nástroje > Písma > Barvy, „Dokumentace pro Python“ a „Regulární výraz Pythonu“.

Example of highlighted doc-string and regular expression
(Obrázek 7) Příklad zvýrazněného řetězce doc a regulárního výrazu

Pro uživatele programu Anaconda experimentujeme s detekcí a integrací systému conda. Po jeho povolení se budou prostředí conda zobrazovat v sadě Visual Studio automaticky a ke správě balíčků se bude místo modulu pip používat conda. Další informace najdete v blogovém příspěvku o tom, co je nového pro Python v sadě Visual Studio 15.6.

Ladění a diagnostika

Nástroj Využití CPU

Nástroj Využití CPU může zobrazit logické zásobníky volání pro asynchronní kód (neboli spojování zásobníků asynchronního volání) (obrázek 8) .

  • Pokud chcete vidět logické zásobníky volání (spojené zásobníky volání), zapněte nastavení „Spojit asynchronní kód“ v rozevírací nabídce Filtr nástroje Využití CPU.

  • Asynchronní kód spuštěný jménem nadřazené funkce nebo úkolu se ve stromu volání a zobrazeních volajících nebo volaných zobrazí jako podřízený.

  • Díky této změně jsou navigace v asynchronním kódu a pochopení charakteristik jeho výkonu jednodušší.

    Poznámka

    U některých vzorů asynchronního kódu může trvat delší dobu, než tato funkce vytvoří logické zásobníky volání. V případě potřeby můžete analýzu zrušit a nastavení vypnout. Toto chování je k dispozici pouze během následné profilace stylů pomocí spouštěcí stránky profileru výkonu ALT-F2. Pokud se během ladění použije nástroj Využití CPU, nezobrazuje logické zásobníky volání.

Logical Call Stack Tree with Call Stack Stitching in effect
(Obrázek 8) Strom logických zásobníků volání s použitým spojením zásobníků volání

Nástroj Využití CPU (dostupný během ladění F5 v okně Diagnostické nástroje a v profileru výkonu ALT-F2) nyní zobrazuje zvýraznění řádku zdroje na základě konkrétních řádků kódu využívaných procesorem (obrázek 9) .

  • Při prohlížení stromu volání nebo zobrazení volajících nebo volaných v nástroji Využití CPU se zobrazí zdroj vybrané funkce se spotřebou procesoru na každém řádku zdroje funkce.

  • Pokud je funkce náročná na výkon procesoru, můžete teď zjistit, které řádky zdroje funkce při jejím provádění konkrétně odpovídají za spotřebu procesoru.

    Poznámka

    Tato funkce vyžaduje, aby zdrojové informace byly součástí vygenerovaného souboru PDB. Toto chování se řídí nastaveními projektu. Projekty pro soubory PDB, které nemají zdrojové informace, nezobrazí určení zdroje řádku nebo zdrojový soubor.

CPU Usage tool with source line highlighting
(Obrázek 9) Nástroj Využití CPU se zvýrazněním řádku zdroje
Podpora názvu vlákna

Na základě zpětné vazby uživatelů teď ladicí program může zobrazovat názvy vláken nastavené prostřednictvím rozhraní API SetThreadDescription v ladění s výpisem. Tato funkce vyžaduje, aby se výpisy ve Windows 10 Fall Creators Update nebo novějších buildech shromažďovaly.

Snapshot Debugger

Pokud pracujete na aplikaci ASP.NET běžící ve službě Azure App Service a chcete si vyzkoušet snímkovací nebo protokolovací body, můžete v rozevíracím seznamu Cíl ladění vybrat možnost Snapshot Debugger (Azure App Service) (obrázek 10) .

Start Snapshot Debugger for ASP.NET application
(Obrázek 10) Spuštění Snapshot Debuggeru pro aplikaci ASP.NET

Produktivita platformy .NET

Ve verzi 15.6 Preview 2 jsme přidali možnost navigace na dekompilované zdroje. Pokud je tato možnost povolená, dojde při vyvolání funkce Přejít k definici nebo Náhled definice u jakéhokoli odkazovaného typu nebo člena k zobrazení jeho definice s rekonstruovanými těly metody prostřednictvím dekompilace ILSpy. Pokud chcete tuto funkci zapnout, přejděte na Nástroje > Možnosti > Textový editor > C# > Upřesnit > Povolit navigaci na dekompilované zdroje (obrázek 11) .

Navigate to decompiled sources
(Obrázek 11) Navigace na dekompilované zdroje

Přidali jsme také několik dalších možností pro .NET EditorConfig:

  • dotnet_prefer_inferred_tuple_names
  • dotnet_prefer_inferred_anonymous_type_member_names

Poznámka

Pokud chcete zobrazit všechny možnosti konvence psaní kódu .NET, podívejte se na článek Nastavení konvence psaní kódu .NET pro EditorConfig.

Visual Studio Web Tools

  • Průzkumník řešení má novou funkci pro projekty .NET Core nazvanou „vnořování souborů“. Tato funkce umožňuje uživatelům řídit způsob, jakým se související soubory zobrazují v Průzkumníku řešení.
  • Aktualizovali jsme publikování projektů.
  • V dialogovém okně Nový projekt:
    • Rozevírací nabídku, která umožňuje výběr verze rozhraní .NET Framework, jsme přesunuli do spodní části dialogového okna. Nyní už nefunguje jako filtr šablony.
    • V uzlu Web jsme přejmenovali podřízený uzel Webová stránka na Předchozí verze.
  • Rozevírací nabídka ladění pro webové formuláře a projekty MVC 5:
    • Umožňuje uživatelům vybrat Snapshot Debugger pro aplikace nasazené ve službě Azure App Service.
    • Byla aktualizována tak, aby měla stejné gesto pro výběr prohlížeče jako projekty ASP.NET Core.

Continuous Delivery Tools

Pokud chcete získat řešení v rámci správy zdrojového kódu, můžete v Team Exploreru kliknout na dlaždici Průběžné doručování a nakonfigurovat automatické sestavení a nasazení vaší aplikace.

Konfigurace nástrojů Continuous Delivery Tools
  • Přidali jsme podporu systému TFVC jako poskytovatele správy zdrojů. Průběžné doručování pro řešení v rámci správy zdrojového kódu můžete nakonfigurovat v týmovém projektu TFVC služby VSTS (obrázek 12) .
Configure Continuous Delivery for projects in a VSTS TFVC project
(Obrázek 12) Konfigurace průběžného doručování pro projekty v projektu TFVC služby VSTS
  • Přidali jsme podporu pro ověřování Git přes protokol SSH. Průběžné doručování pro řešení v rámci správy zdrojového kódu můžete nakonfigurovat ve službě VSTS nebo úložišti Git GitHubu s povoleným ověřováním SSH.

  • Zavedli jsme podporu kontejnerizovaných projektů. Průběžné doručování pro řešení můžete nakonfigurovat s projekty ASP.NET Core a podporou dockeru cílící na službu Azure App Service na Linuxu (Web App for Containers) (obrázek 13) . Dialogové okno Konfigurovat průběžné doručování ve výchozím nastavení vytvoří novou službu Azure App Service na Linuxu (Web App for Containers) a službu Azure Container Registry, pokud ještě v rámci vašeho předplatného Azure neexistuje.

Configure Continuous Delivery to Azure dialog for App Service on Linux
(Obrázek 13) Dialogové okno Konfigurovat průběžné doručování do Azure pro službu App Service na Linuxu

Team Explorer

Podpora značek Git

Přidali jsme další podporu značek Git. Značky teď můžete vytvářet, odstraňovat nebo vkládat. Na stránce Značky můžete zobrazit všechny značky ve vašem úložišti a vytvořit ze značky novou větev. Je to jedna z nejžádanějších funkcí z platformy UserVoice.

Pro uživatele Visual Studio Team Services můžete rezervovat větve žádostí o přijetí změn. Tato funkce usnadňuje kontrolu žádostí o přijetí změn, testování změn a sestavování kódu.

Nástroje pro vývojáře aplikací pro Univerzální platformu Windows

Windows 10 Insider Preview SDK (build 17095) je možné nainstalovat jako volitelnou komponentu s úlohou vývoje Univerzální platformy Windows.

Rozšiřitelnost

Verze souborů pro spustitelné soubory sady Visual Studio – devenv.exe, blend.exe, wdexpress.exe a vsga.exe – odrážejí podverzi (například 15.6.*).

Poznámka

Nemá to vliv na žádné funkce, ale může být potřeba aktualizovat externí kód, který závisí na číslech verzí spustitelných souborů.

Průzkumník testů

Nové hierarchické zobrazení

Průzkumník testů teď v sadě Visual Studio obsahuje hierarchické zobrazení (obrázek 14) , které slouží k uspořádání testů podle projektu, oboru názvů a třídy. Toto zobrazení můžete zapnout a vypnout pomocí tlačítka hierarchie umístěného vedle tlačítka Seskupit podle v horní části okna Průzkumníka testů.

Test Explorer Hierarchy View
(Obrázek 14) Hierarchické zobrazení Průzkumníka testů

Tato funkce umožňuje snadnější navigaci v testech a také poskytuje lepší okamžitou zpětnou vazbu týkající se testů.

  • „Nadřazené uzly“ (Projekt, Obor názvů a Třída) zobrazují ikonu neúspěšného testu, pokud obsahují alespoň jeden test, který nebyl úspěšný.
  • Za nadřazenými uzly následuje číslo udávají počet testů, které seskupení obsahuje. Doba trvání v milisekundách zobrazená vpravo od nadřazeného uzlu je celková doba, po kterou byly testy v dané skupině spuštěné.
Zjišťování testů v reálném čase

Testy se automaticky zjišťují pomocí zjišťování testů v reálném čase (obrázek 15) , aniž by od vás vyžadovaly vytvoření spravovaného projektu. Průzkumník testů díky tomu může zůstat synchronizovaný se změnami kódu, jako jsou například přidávání, odebírání nebo úpravy testů. Mějte na paměti, že na rozdíl od výše popsané funkce hierarchického zobrazení, která je k dispozici pro všechny typy projektů, je funkce automatického zjišťování testů dostupná pouze pro projekty C# a Visual Basic.

Xamarin Live Player
(Obrázek 15) Animace dvojice v Xamarin Live Playeru, nasazení a režimů živých úprav
Podpora testování Win10 IoT Core

Zavedli jsme podporu pro testování aplikací Win10 IoT Core. Nyní můžete testy pro tyto aplikace UWP nasadit, ladit a spustit v zařízení. Testy jsou také plně integrované v Průzkumníku testů. Podpora nasazení a spuštění je dostupná také prostřednictvím kontinuální integrace služby VSTS. Aplikace Win10 IoT Core jsou proto plně podporovány v cyklu úprav, kompilace, ladění a testování v sadě Visual Studio a pracovním postupu kontinuální integrace ve službě Visual Studio Team Services.

Win10 IoT Core Testing
(Obrázek 16) Testování Win10 IoT Core

Visual Studio Build Tools

Nástroje Visual Studio Build Tools umožňují vytvořit servery buildů bez nutnosti instalace celé sady Visual Studio. Instalační program již podporuje C++, ASP.NET a .NET Core pro desktopové projekt. Reagujeme na požadavky zákazníků a zlepšujeme nástroje Visual Studio Build Tools tak, aby podporovaly další typy projektů. V této verzi jsme přidali podporu projektů TypeScript a Node.js. Očekáváme, že v budoucích verzích přidáme podporu dalších typů projektů. Toto je umístění staženého souboru pro nástroje Visual Studio Build Tools v této verzi.

Nástroje Visual Studio ClickOnce Tools

ClickOnce je technologie nasazení, která umožňuje vytvořit automaticky se aktualizující aplikace systému Windows. Instalace a spuštění vyžadují minimální interakci uživatele. Používá certifikáty k ověření pravosti vydavatele a podepisování manifestů aplikace a nasazení za účelem ověření, zda se soubory nebylo manipulováno. V této verzi jsme přidali podporu podepisování manifestů aplikace a nasazení pomocí certifikátu Kryptografických služeb nové generace (CNG).

Trezor klíčů

Pro Visual Studio 15.6 jsme přidali in-box rozšíření ověřování služeb Azure. Díky tomu budou moci projekty používající knihovnu Microsoft.Azure.Services.AppAuthentication přistupovat k prostředkům Azure, jako je trezor klíčů, prostřednictvím svých účtů sady Visual Studio.

Automatické zřizování pro systém macOS

Vytváření aplikací pro iOS pomocí sady Visual Studio ve Windows je teď jednodušší. Tato verze přidává zcela novou funkci nazvanou automatické zřizování pro systém macOS. Sestavující počítač Mac nemusíte udržovat ručně, stačí se připojit k počítači Mac a my za vás veškerou těžkou práci ohledně instalace a konfigurace sestavujícího počítače se správnými bity Xamarin.iOS a Mono uděláme. To vše pomocí sady Visual Studio.

iOS – nasazení Wi-Fi

Vzdálený simulátor iOSu umožňující vývojářům otestovat a ladit aplikace pro iOS kompletně v sadě Visual Studio ve Windows je k dispozici pro všechny edice sady Visual Studio (od verze 15.5), včetně bezplatné edice Community Edition. Simulátor podporuje takové funkce, jako je simulace polohy, rotace, gesta, a dokonce funkce, které simulátor iOSu na počítačích Mac nepodporuje, například vícedotykové ovládání. Simulátor nabízí skvělé prostředí pro vývojáře vytvářející aplikace pro iOS ve Windows. Jak je to ale se zařízeními? Sadu Visual Studio 2017 ve verzi 15.6 můžete použít k nasazení aplikací pro iOS přes síť pomocí nasazení Wi-Fi. Nepotřebujete žádné kabely. Jakmile nastavíte bezdrátové zařízení v prostředí Xcode, zobrazí se v sadě Visual Studio jako normální cíl nasazení.


Release Notes Icon Servisní aktualizace sady Visual Studio 2017 verze 15.6.1

vydaná 8. března 2018

Hlavní chyby opravené ve verzi 15.6.1

Toto jsou problémy oznámené zákazníky a vyřešené v této verzi:


Release Notes Icon Servisní aktualizace sady Visual Studio 2017 verze 15.6.2

vydaná 13. března 2018

Souhrn aktualizací ve verzi 15.6.2

CVE-2018-0875: Informační zpravodaje zabezpečení pro .NET Core od společnosti Microsoft

Společnost Microsoft si je vědoma ohrožení zabezpečení ve veřejné verzi .NET Core, kde škodlivý soubor nebo webový požadavek mohou způsobit útok s cílem odepření služby (DoS).

Důležité

Správcům systémů doporučujeme aktualizovat moduly runtime .NET Core na verze 1.0.10, 1.1.7 nebo 2.0.6. Vývojářům doporučujeme aktualizovat sady SDK .NET Core na verzi 1.1.8 nebo 2.1.101.

Hlavní chyby opravené ve verzi 15.6.2

Toto jsou problémy oznámené zákazníky a vyřešené v této verzi:


Release Notes Icon Servisní aktualizace sady Visual Studio 2017 verze 15.6.3

vydaná 19. března 2018

Souhrn aktualizací ve verzi 15.6.3

CVE-2018-0875: Informační zpravodaje zabezpečení pro .NET Core od společnosti Microsoft

Společnost Microsoft si je vědoma ohrožení zabezpečení ve veřejné verzi .NET Core, kde škodlivý soubor nebo webový požadavek mohou způsobit útok s cílem odepření služby (DoS).

Důležité

Správcům systémů doporučujeme aktualizovat moduly runtime .NET Core na verze 1.0.10, 1.1.7 nebo 2.0.6. Vývojářům doporučujeme aktualizovat sady SDK .NET Core na verzi 1.1.8 nebo 2.1.101.

Hlavní chyby opravené ve verzi 15.6.3

Toto jsou problémy oznámené zákazníky a vyřešené v této verzi:


Release Notes Icon Servisní aktualizace sady Visual Studio 2017 verze 15.6.4

vydaná 22. března 2018

Hlavní chyby opravené ve verzi 15.6.4

Toto jsou problémy oznámené zákazníky a vyřešené v této verzi:


Release Notes Icon Servisní aktualizace sady Visual Studio 2017 verze 15.6.5

vydaná 4. dubna 2018

Hlavní chyby opravené ve verzi 15.6.5

Toto jsou problémy oznámené zákazníky a vyřešené v této verzi:


Release Notes Icon Servisní aktualizace sady Visual Studio 2017 verze 15.6.6

vydaná 10. dubna 2018

Souhrn aktualizací ve verzi 15.6.6

CVE-2018-1037: Informační zpravodaje zabezpečení od společnosti Microsoft pro ohrožení zabezpečení spočívající ve zpřístupnění informací ze sady Microsoft Visual Studio

Existuje ohrožení zabezpečení spočívající ve zpřístupnění informací, když Visual Studio nesprávně odhalí omezený obsah neinicializované paměti při kompilování souborů databáze programu (PDB). Útočník, který využil toto zpřístupnění informací, mohl zobrazit neinicializovanou paměť z instance sady Visual Studio použité ke kompilaci souboru PDB.

Aby mohl útočník využít tuto chybu zabezpečení, potřeboval by přístup k příslušnému souboru PDB vytvořenému pomocí zranitelné verze sady Visual Studio. Útočník by neměl žádný způsob, jak přinutit vývojáře k vytvoření tohoto zpřístupnění informací.

Aktualizace zabezpečení řeší tuto chybu zabezpečení tím, že opraví způsob, jakým se soubory PDB generují při kompilaci projektu.

Důležité

Další informace najdete v aktualizaci zabezpečení pro CVE-2018-1037.

Hlavní chyby opravené ve verzi 15.6.6

Toto jsou problémy oznámené zákazníky a vyřešené v této verzi:

  • Tato verze řeší problém, kdy někteří uživatelé Application Insights při prvním načtení řešení neviděli indikátory žádostí a výjimek CodeLensu.

Release Notes Icon Servisní aktualizace sady Visual Studio 2017 verze 15.6.7

Vydáno 26. dubna 2018

Souhrn aktualizací ve verzi 15.6.7

  • Sada Visual Studio lépe reaguje při spuštění operací Gitu.
  • Ladění velkých řešení se soubory PDB s možností /Debug:fastlink je robustnější. Změny v souborech PDB/DIA vedou ke snížené latenci a 30% snížení spotřeby paměti haldy v ladicím programu VS, která dříve způsobovala selhání.

Hlavní chyby opravené ve verzi 15.6.7

Toto jsou problémy oznámené zákazníky a vyřešené v této verzi:

  • Opravy chyb kompilátoru C++:
    • Opravili jsme chybu, která způsobovala, že optimalizátor SSA nesprávně vnořoval volání funkce po uložení do proměnné použité v obslužné rutině __finally.
    • Opravili jsme chybu, která způsobovala, že optimalizátor SSA občas nesprávně analyzoval zatížení paměti z umístění se zápornými posuny.
    • Opravili jsme chybu, která způsobovala, že optimalizátor nesprávně transformoval předem rozšířenou smyčku na následně rozšířenou smyčku. Toto chování se zjistilo při kompilaci projektu ICU.
  • Vydali jsme sadu Java™ Development Kit 8, aktualizace Update 172 (JDK verze 8u172).

Známé problémy

Vašim připomínkám a názorům nasloucháme a plně se jim věnujeme. Navštivte web komunity vývojářů, kde můžete hledat nejnovější problémy, zaznamenat nové a podpořit svým hlasem stávající problémy. Podívejte se na všechny dosud známé problémy a možná alternativní řešení v sadě Visual Studio 2017 verze 15.6.

Visual Studio 2017 Known Issues


Názory a návrhy

Chceme znát váš názor. O problémech nás můžete informovat prostřednictvím možnosti Nahlásit problém v pravém horním rohu instalačního programu nebo v samotném integrovaném vývojovém prostředí sady Visual Studio. Rozhraní Report a Problem Icon Ikona se nachází v pravém horním rohu. Na stránce komunity vývojářů sady Visual Studio můžete posílat návrhy k produktu a sledovat svoje nahlášené problémy. Můžete tu pokládat otázky, hledat odpovědi a navrhovat nové funkce. Naše podpora na živém chatu vám navíc poskytne bezplatnou pomoc s instalací.


Blogy

Využijte přehledů a doporučení, které najdete na webu Blogy o vývojářských nástrojích, abyste si udržovali přehled o všech nových vydaných verzích a měli k dispozici podrobné příspěvky popisující širokou škálu funkcí.

Developer Tools Blogs


Historie zpráv k vydání verze pro Visual Studio 2017

Další informace týkající se minulých verzí sady Visual Studio 2017 najdete na stránce Historie zpráv k vydání verzí pro Visual Studio 2017.


Na začátek stránky