Visual Studio Icon Zpráva k vydání verze pro Visual Studio 2019 verze 16.1



Komunita | vývojářů Požadavky | na systém Kompatibilita | Distribuovatelný kód | Licenčních podmínek | Blogy | Nejnovější verze – známé problémy | Novinky v dokumentaci k aplikaci Visual Studio


Po kliknutí na tlačítko si můžete stáhnout nejnovější verzi sady Visual Studio 2019. Pokyny k instalaci a aktualizaci sady Visual Studio 2019 najdete v článku o aktualizaci sady Visual Studio 2019 na nejnovější verzi. Podívejte se také na pokyny k instalaci offline.

Community Download Button Professional Download Button Enterprise Download Button


Novinky v sadě Visual Studio 2019 verze 16.1

Vydání sady Visual Studio 2019 verze 16.1

Blog o sadě Visual Studio 2019

Blog o sadě Visual Studio 2019 je oficiální zdroj informací o produktu, které poskytuje tým technických specialistů sady Visual Studio. Podrobné informace o vydaných verzích sady Visual Studio 2019 najdete v těchto příspěvcích:


Release Notes Icon

Vydáno 9. července 2019

Shrnutí problémů vyřešených ve verzi 16.1.6 sady Visual Studio 2019

Oznámení o informačním zpravodaji zabezpečení

CVE-2019-1077: Ohrožení zabezpečení při automatické aktualizaci rozšíření sady Visual Studio

Při určitých nesprávně provedených operacích se soubory v procesu automatické aktualizace rozšíření sady Visual Studio může být ohroženo zabezpečení z důvodu zvýšení oprávnění. Pokud útočník toto slabé místo využije, může odstraňovat soubory v umístěních podle vlastního uvážení. Útočník může ohrozit zabezpečení tím, že neoprávněně získá přístup k systému. Tato aktualizace zabezpečení řeší toto ohrožení zabezpečením míst, ve kterých automatická aktualizace rozšíření sady Visual Studio provádí operace se soubory.

CVE-2019-1075: Ohrožení zabezpečení z důvodu falšování identity v ASP.NET Core

V ASP.NET Core existuje ohrožení zabezpečení z důvodu falšování identity, které může vést k otevřenému přesměrování. Útočník, který by úspěšně zneužil toto ohrožení zabezpečení, může cílového uživatele přesměrovat na nebezpečný web. Aby útočník mohl toto slabé místo představující ohrožení zabezpečení využít, může poslat odkaz, který má speciálně vytvořenou adresou URL, a přimět uživatele, aby na tento odkaz kliknul.

Tato aktualizace zabezpečení řeší toto ohrožení zabezpečení tím, že opravuje způsob, jakým ASP.NET Core parsuje adresy URL. Podrobnosti najdete v poznámkách k verzi .NET Core.

CVE-2019-1113: Deserializace souboru XOML v Návrháři postupu provádění umožňuje provádění kódu

Soubor XOML odkazující na různé typy mohl při otevření v sadě Visual Studio způsobovat provádění náhodného kódu. Typy, které lze v souborech XOML používat, jsou nyní omezené. Při otevření souboru XOML s jedním z neoprávněných typů se nově zobrazí zpráva, která uživatele o takovém typu informuje.

Další informace najdete na https://support.microsoft.com/help/4512190/remote-code-execution-vulnerability-if-types-are-specified-in-xoml.


Release Notes Icon Visual Studio 2019 verze 16.1.5

Vydáno 2. července 2019

Shrnutí problémů vyřešených ve verzi 16.1.5 sady Visual Studio 2019


Release Notes Icon Visual Studio 2019 verze 16.1.4

Vydáno 25. června 2019

Shrnutí problémů vyřešených ve verzi 16.1.4 sady Visual Studio 2019


Release Notes Icon Visual Studio 2019 verze 16.1.3

Vydáno 11. června 2019

Shrnutí problémů vyřešených ve verzi 16.1.3 sady Visual Studio 2019


Release Notes Icon Visual Studio 2019 verze 16.1.2

Vydáno 4. června 2019

Shrnutí problémů vyřešených ve Visual Studiu 2019 verze 16.1.2


Release Notes Icon Visual Studio 2019 verze 16.1.1

Vydáno 24. května 2019

Shrnutí problémů vyřešených ve Visual Studiu 2019 verze 16.1.1


Release Notes Icon Visual Studio 2019 verze 16.1

Vydáno 21. května 2019

Shrnutí novinek v sadě Visual Studio 2019 verze 16.1

IDE – integrované vývojové prostředí

  • Technologie Visual Studio IntelliCode je teď všeobecně dostupná a instaluje se všemi sadami funkcí, které podporují C#, C++, TypeScipt/JavaScript nebo XAML.
  • Byla přidána podpora rozpoznávání monitorů.
  • Nové opravy kódu jsou dostupné pro C#.
  • Do hledání v sadě Visual Studio byl přidán seznam Naposledy použité.

Ladicí program

  • Byla implementována vylepšení ověřování odkazu na zdroj.
  • Byl přidán server symbolů nuget.org do seznamu výchozích serverů symbolů.
  • Verze Preview ladění s pohybem v čase teď zahrnuje podporu krokování výjimky.

Rozšiřitelnost

  • Byl zrušen požadavek na soubor .resx v projektech VSIX (aktualizace BuildTools).
  • Šablona projektu VSIX teď používá novou verzi sady SDK.

Výkon

  • Bylo optimalizováno uživatelské prostředí, aby se zkrátila doba načítání u velmi rozsáhlých řešení.
  • Autoři šablon můžou do svých šablon přidat vlastní značky.
  • Zajistili jsme podporu CodeLens pro vlastní uživatelské rozhraní.
  • Byla aktualizována implementace protokolu LSP (Language Server Protocol).
  • Bylo aktualizováno chování pro přepínání mezi řešeními, složkami a dalšími zobrazeními.

C++

F#

.NET

  • Nové funkce zvyšující produktivitu při práci s technologií .NET zahrnují čištění kódu u projektů a řešení jedním kliknutím, novou klávesovou zkratku pro přepnutí blokového komentáře a refaktoring pro přesunutí typů do jiných oborů názvů.
  • Prostřednictvím klonovací obrazovky v úvodním okně teď můžou uživatelé naklonovat kód z identifikátoru URI protokolu SSH.
  • Do produktivity platformy .NET přibylo doplňování kódu pomocí IntelliSense pro neimportované typy, přepínání jednořádkového komentáře / zrušení komentáře, export stylů pojmenování do souboru editorconfig a nové nastavení stylu kódu pro preferování direktiv using ve vnitřních/vnějších oborech názvů.
  • Byly implementovány doplňky nástrojů sady .NET SDK kvůli podpoře projektů WinForms a WPF pro .NET Core 3.0 a rovněž opravy chyb a vylepšení výkonu.
  • Vydali jsme Visual Studio SDK v16.0 pro NuGet.
  • Vydali jsme Preview verzi Návrháře XAML pro vývoj aplikací pro .NET Core 3.0 WPF.

Xamarin

Hlavní problémy opravené v sadě Visual Studio 2019 verze 16.1

Podrobnosti novinek v sadě Visual Studio 2019 verze 16.1

Integrované vývojové prostředí

  • Technologie IntelliCode je teď všeobecně dostupná a instaluje se všemi sadami funkcí, které podporují C#, C++, TypeScipt/JavaScript nebo XAML.
  • Funkce IntelliCode ve verzi Preview – vlastní modely, podpora jazyků C++/TS/JS a odvozování souboru Editorconfig – jsou standardně zakázané. Povolíte je tak, že přejdete na Nástroje > Možnosti > IntelliCode.
  • Z Průvodce novou položku byla odebrána šablona Editorconfig (IntelliCode). Pokud chcete vytvořit odvozený soubor Editorconfig, klikněte pravým tlačítkem na požadované místo v Průzkumníku řešení a zvolte Přidat > Nový EditorConfig (IntelliCode) .
  • Ke klonování kódu z online úložiště prostřednictvím protokolu SSH můžete použít úvodní okno.
Clone with SSH on start window
Klonování v úvodním okně pomocí protokolu SSH
  • Visual Studio IntelliCode se instaluje standardně současně s instalací úloh, které podporují C#, XAML nebo C++.
    • Základní modely C# a XAML budou standardně zapnuté.
    • Funkce Preview, jako jsou cvičení vlastního modelu a dokončení argumentů, je možné povolit v části Nástroje > Možnosti > IntelliCode.
  • Přidána podpora rozpoznávání monitorů
  • Nové opravy kódu dostupné pro C#
  • Byla přidána podpora rozpoznávání monitorů pro okno PropertyBrowser na bázi WinForms v sadě Visual Studio. Vyžaduje, aby na počítači byla nainstalována verze rozhraní .NET Framework 4.8 RTM.

Ladicí program

  • Zdrojový odkaz teď může používat ověřování systému Windows pro podporu místní správy zdrojového kódu TFS.
  • Přidán server symbolů nuget.org do seznamu výchozích serverů symbolů

Projekt

  • Tlačítko pro přepínání zobrazení Průzkumníka řešení teď bude konzistentně zobrazovat rozevírací nabídku se všemi možnými zobrazeními.
Solution switching
Přepínání zobrazení řešení
  • Vylepšili jsme dobu načítání pro velmi rozsáhlá řešení. Vylepšení závisí na velikosti řešení.

  • Odebrali jsme dialog Převést v nabídce Soubor > Převést. Tato funkce se přestala používat v sadě Visual Studio 2015.

  • Aktualizovali jsme ověřovací pravidla pro schémata task.vs.json a launch.vs.json a přidali jsme popisy vlastností.

  • Přidali jsme podporu pro vzdálené ladění Linuxu pomocí vlastního programu prostřednictvím souboru launch.vs.json.

Rozšiřitelnost

  • Uživatelé teď můžou ve svých rozšířeních pro cílení na Visual Studio 2019 použít nejnovější verzi Microsoft.VisualStudio.SDK. Je potřeba pamatovat na to, že pokud je nejnižší podporovaná verze Visual Studia verze 16.0, je nutné použít pouze tuto verzi sady SDK.
  • Vytváření nových projektů VSIX teď bude obsahovat verzi 16.0 balíčku NuGet Microsoft.VisualStudio.SDK.
  • Uživatelé teď můžou do šablon projektů přidat značky umožňující v dialogu Nový projekt v sadě Visual Studio 2019 kategorizaci a filtrování. Uživatelé také můžou vybírat z předdefinovaných značek nebo použít svoje vlastní značky pro jazyk, platformu a typ projektu.
Template tagging
Označování šablon
  • Rozšíření CodeLens teď můžou v místní nabídce s detaily CodeLens zobrazit libovolný obsah uživatelského rozhraní.

  • U aktualizovaného protokolu LSP (Language Server Protocol) je teď k dispozici:

    • Podpora pro plánované vyrovnávací paměti, aby byl pro vložené rozdíly a soubory Razor v LiveShare povolený protokol LSP
    • Podpora pro diagnostiky, které nejsou nezbytně nutné
    • Podpora pro textDocument/typeDefinition
    • Podpora pro textDocument/foldingRange (sbalení)
  • Zrušen požadavek na soubor .resx v projektech VSIX (aktualizace BuildTools)

  • Balíček NuGet Microsoft.VSSDK.BuildTools teď jako součást buildu poskytuje prázdný soubor .resx, pokud neexistuje žádný .resx s vlastností MergeWithCTO. Většina rozšíření ke sloučení nepoužívá ani nepotřebujete soubor .resx, takže projekt díky tomu zůstane čistější.

  • Změny funkce rozpoznávání monitorů můžou mít vliv na některá rozšíření. Další informace o podpoře rozpoznávání monitorů pro rozšiřující ovládací prvky sady Visual Studio

Editor

  • Hledání v sadě Visual Studio teď přednostně zobrazí tři naposledy použité akce vyvolané hledáním v sadě Visual Studio, jak můžete vidět v tomto ukázkovém modelu. (Poznámka: ikony a konkrétní položky na řádcích nebyly v tomto modelu plně aktualizovány.)
Visual Studio Search
Model hledání v sadě Visual Studio

C++

  • V sadě Visual Studio můžete používat místní instalaci Windows Subsystem for Linux (WSL) nativně s jazykem C++ bez dodatečné konfigurace nebo připojení přes protokol SSH.
Windows Subsystem for Linux
Windows Subsystem for Linux
  • AddressSanitizer je teď integrovaný do projektů Visual Studio for Linux a WSL.
ASan integration
Integrace ASan
  • Při cílení na Linux teď můžou uživatelé v projektech MSBuild i CMake oddělit vzdálený počítač s buildem od vzdáleného počítače pro ladění.
  • Rychlé informace teď obsahují odkaz k vyhledání online dokumentace s dalšími informacemi o konstrukci kódu. V případě kódu s červenou vlnovkou vyhledá odkaz v rychlých informacích příslušnou chybu online.
  • Kód v rychlých informacích má teď barvu shodnou s barvou v editoru.
Colorized code in Quick Info tooltips
Barevný kód v rychlých informacích
New Code Analysis quick fixes
Nové rychlé opravy analýzy kódu
  • Přidali jsme vylepšení pro editor nastavení CMake včetně podpory pro subsystém Windows pro Linux (WSL) a konfigurace z existujících mezipamětí, změny výchozích buildů a kořenových složek instalací a podporu pro proměnné prostředí v konfiguracích Linux CMake.
Improvements to the CMake Settings Editor
Vylepšení editoru nastavení CMake
  • Vylepšené protokolování pro vzdálená připojení umožňuje snadnější diagnostiku problémů při vývoji s použitím různých platforem.
Improved logging for remote connections
Vylepšené protokolování pro vzdálená připojení
  • Nyní můžete při cílení na Linux oddělit vzdálený počítač s buildem od vzdáleného počítače pro ladění (specifické pro projekty MSBuild, pro CMake připravujeme).
  • Panel šablon může naplnit rozevírací nabídku podle instancí dané šablony v základu kódu.
New Template Bar dropdown menu
Nová rozevírací nabídka Panel šablon
  • Integrovali jsme kód C++ IntelliCode a je možné ho povolit v nabídce Nástroje > Možnosti > IntelliCode > Obecné. Tato verze IntelliCode je přesnější a zahrnuje podporu pro bezplatné funkce.
  • Integrace CMake nyní podporuje sadu nástrojů Clang/LLVM pro projekty, které cílí na Windows nebo Linux. K dispozici je teď možnost vytvářet, upravovat a ladit projekty CMake, které používají Clang, MSVC nebo GCC.
CMake integration supports the Clang/LLVM toolchain
Integrace CMake podporuje sadu nástrojů Clang/LLVM
  • Přidali jsme upozornění na chybějící příkazy #include s možností instalace pomocí vcpkg a automatické dokončování dostupných balíčků pro direktivu CMake find_package.
Autocompletion of available packages
Automatické dokončování dostupných balíčků
  • Aktualizovali jsme verzi CMake, která se dodává se sadou Visual Studio, na verzi 3.14. Tato verze přidává integrovanou podporu pro generátory MSBuild, které cílí na projekty Visual Studio 2019 a také rozhraní API integrace integrovaného vývojového prostředí na základě souborů.

  • Revidovali jsme obecné stránky vlastností pro projekty C++ a přesunuli některé možnosti na novou stránku Upřesnit. Stránka Upřesnit obsahuje také další vlastnosti pro preferovanou architekturu sady nástrojů, knihovny ladění, vedlejší verzi sady nástrojů MSVC a buildy Unity (jumbo).

  • Do implementace standardní knihovny C++ jsme přidali následující funkce C++20 ve verzi Preview. Dostupné jsou v rámci /std:c++latest:

    • starts_with() a ends_with() pro basic_string/basic_string_view.
    • contains() pro asociativní kontejnery.
    • remove(), remove_if() a unique() pro list a forward_list teď vrací size_type.
    • Přidali jsme shift_left() a shift_right() k <algorithm>.
  • V kompilátoru C++ jsme implementovali následující funkce C++20 ve verzi Preview. K dispozici jsou v rámci /std:c++latest:

    • Vylepšili jsme schopnost najít šablony funkcí prostřednictvím vyhledávání závislého na argumentech pro výrazy volání funkce s explicitními argumenty šablon (P0846R0).
    • Určili jsme inicializaci (P0329R4), která umožňuje vybrat v agregované inicializaci určité členy, například ty, které používají syntaxi Type t { .member = expr }.
  • Udělali jsme důkladnou revizi podpory Lambda, která řeší celou řadu starých chyb. Tato změna je povolená standardně při použití /std:c++latest. V jiných režimech jazyka /std:c++* a výchozím režimu je možné povolit nový analyzátor prostřednictvím /experimental:newLambdaProcessor, například /std:c++17 /experimental:newLambdaProcessor.

  • Dokumentace v editoru pro CMake

  • Dokončování a rychlé informace pro integrované příkazy, proměnné a vlastnosti CMake usnadňují úpravy souborů CMakeLists.txt.

Tooltip info for add_subdirectory CMake command
Informace v popisu příkazu CMake add_subdirectory

F# a nástroje F#

Jedná se o poměrně dílčí verzi pro jazyk F# a nástroje jazyka F#, ale najdete zde několik opravdu užitečných funkcí! Stejně jako u aktualizace VS 16.0 se tato verze také zaměřuje na výkon nástrojů editoru.

Kompilátor jazyka F# a F# interactive
  • Byla přidána podpora pro P/Invoke pro F# interactive v .NET Core. (#6544)
  • Byla přidána optimalizace kompilátoru pro Span<'T> při použití smyčky for. (#6195)
  • Byla přidána optimalizace, která zabraňuje nadbytečnému přidělení Some pro možnosti jazyka F# v různých situacích. (#6532)
  • Bylo změněno pořadí provádění výrazů použitých v instanci anonymních záznamů. Nyní budou prováděny shora dolů, nikoli v abecedním pořadí, aby odpovídaly aktuálnímu prostředí s normální záznamy. (#6487)
  • Byla vyřešena chyba, kdy velmi velké literálové výrazy nebo velmi velké deklarace struktury můžou způsobit přetečení zásobníku kompilátoru při sestavení. (#6258)
  • Byla opravena chyba, kdy se při ladění funkce s anonymními záznamy již nespustí zarážky. (#6512)
  • Byla opravena chyba, kdy předání anonymních záznamů konstruktům očekávajícím parametr obj způsobilo zhroucení kompilátoru. (#6434)
  • Byla opravena chyba, kdy smyčka for var expr1 to expr2 do ... může mít za následek podivně platnou (a zrušenou) syntaxi.(#6586)
  • Byla opravena chyba způsobující, že anonymní záznamy nebylo možné správně použít s událostmi. (#6572)
  • Opravili jsme dlouhodobou chybu s extrémně velkými generovanými analyzátory v FsLexYacc (více než 100 milionů řádků). (#5967
  • Byl vyřešen dlouhodobý problém v komponentě Poskytovatel typu kompilátoru, který mohl vést k nevracení paměti způsobené poskytovatelem typu. (#6409)
  • Do kompilátoru jazyka F# byla Saulem Rennisonem přidána podpora pro --pathmap. Je tak vyřešen problém, kdy výsledný spustitelný soubor mohl obsahovat absolutní cesty ke zdrojovým souborům ve vloženém prostředku souboru podpisu jazyka F#. (#5213)
  • Uživatelem ncave byla přidána optimalizace F# AST, která zlepšuje využití v jiných nástrojích a prostředích (například Fable). (#6333)
  • Steffen Forkmann přidal optimalizaci ínformací o průchodu při překladu členů. (#4457)
  • Gauthier Segay přidal vylepšení pro chybové zprávy. Pokud při implementaci typu chybí nezbytné přepsání, je oznámen seznam těchto chybějících přepsání. (#4982)
Nástroje jazyka F#
  • Rozevírací seznam Cílová architektura pro projekty F# v sadě .NET SDK bude nyní obsahovat hodnoty pro všechna dostupná rozhraní .NET Core, .NET Standard a .NET Framework, což usnadní migraci na rozhraní .NET Core z rozhraní .NET Framework v sadě .NET SDK.
  • Byla opravena chyba, kdy přejmenování parametrů generického typu vytváří názvy s dvojitou zpětnou uvozovkou. (#5389)
  • Byl vyřešen dlouhodobý problém s redundantním opětovným vytvářením instancí poskytovatelů typu, což působilo masivní alokace v průběhu času. (#5929)
  • Byl vyřešen dlouhodobý problém, kdy čtení IL zbytečně přidělilo 20 MB během krátkého časového období. (#6403)
  • Vasilij Kirichenko vyřešil chybu, kdy metoda GetToolTipText ve službě kompilátoru jazyka F# mohla zobrazit stejný podpis XML pro přetížení více členů. (#6244)
Open source infrastruktura jazyka F#

Vylepšili jsme přispěvatelské prostředí následujícím způsobem:

  • Dokončili jsme náš build ze zdrojového procesu tak, aby kompilátor jazyka F# a základní knihovna bylo možné sestavit pomocí úložiště zdrojového buildu .NET Core.
  • Odstranili jsme závislost na netstandard1.6, takže celý základ kódu jednotně cílí na netstandard2.0 a net472.
  • Přidali jsme soubor .vsconfig do kořenového adresáře úložiště, takže přispěvatelé používající Visual Studio nemusí předem vědět, co vše je nutné nainstalovat.
  • Byl přepracován soubor README projektu, abychom odstranili potenciálně matoucí informace, zahrnuli jsme rychlý start pro nové přispěvatele a pokusili se být více informativní v našich zprávách o druzích změn, které bychom rádi provedli.

Produktivita platformy .NET

  • Nyní je k dispozici experimentální dokončování IntelliSense pro neimportované typy. Uživatelé teď budou od IntelliSense dostávat návrhy pro typy v závislostech v rámci projektů, přestože do souboru zatím nepřidali příkaz k importu. Tuto možnost zapnete tady: Nástroje > Možnosti > Textový editor > C# > Intellisense.
Intellisense completion for unimported types
Dokončování IntelliSense pro neimportované typy
  • Prostřednictvím klávesové zkratky (Ctrl+K,/) je teď dostupné přepínání jednořádkového komentáře/zrušení komentáře. Tento příkaz přidá nebo odebere jednořádkový komentář v závislosti na tom, jestli už je výběr opatřený komentářem.
  • Styly pojmenování je teď možné vyexportovat tlačítkem Generovat editorconfig tady: Nástroje > Možnosti > Textový editor > C# > Styl kódu.
  • Pomocí nového pravidla stylu kódu v souboru editorconfig je teď možné vyžádat nebo zabránit používání direktiv using v oboru názvů. Toto nastavení se také vyexportuje při použití tlačítka Generovat editorconfig tady: Nástroje > Možnosti > Textový editor > C# > Styl kódu.
Editorconfig rule for usings outside/inside namespaces
Pravidlo souboru editorconfig pro direktivy using ve vnějších/vnitřních oborech názvů
Tools Options setting for usings inside/outside namespace
Nastavení možností nástrojů pro direktivy using ve vnitřních/vnějších oborech názvů
  • Sloupec pro typ v okně Najít všechny odkazy teď nabízí více možností filtrování a zohledňuje obory názvů a typů.
Find All References Kind column has more filter options
Sloupec pro typ v okně Najít všechny odkazy má více možností filtrování.
  • Byla přidána oprava kódu pro dělení a slučování příkazů if.
Split or merge if statements
Dělení a slučování příkazů if
  • Byla přidána oprava kódu pro balení binárních výrazů.
Wrap binary expressions
Balení binárních výrazů
  • Seznam pro doplňování regulárních výrazů je teď přístupný z řetězce regulárního výrazu prostřednictvím nabídky Intellisense (Ctrl + mezerník). U těchto doplnění je také na řádku popis, co návrh dělá.
Regex completion offered in Intellisense with (Ctrl + space)
Doplňování regulárních výrazů
  • Byla přidána oprava kódu pro rozpečetění třídy.
Unseal a class codefix
Rozpečetění třídy
  • U projektů a řešení teď můžete čistit kód jedním kliknutím. Je možné kliknout pravým tlačítkem myši na projekty nebo řešení v Průzkumníku řešení a vybrat možnosti Spustit vyčištění kódu.
Right-click to run code cleanup over the entire solution
Klikněte pravým tlačítkem myši a spusťte tak čištění kódu v celém řešení.
You will see a dialog box while cleanup is applied to each file
V průběhu čištění jednotlivých souborů se zobrazí dialogové okno.
  • K přesunutí typu do oboru názvů nebo složky je teď možné použít dialog refaktoringu. Umístěte ukazatel myši na název třídy a napište (Ctrl + .). Otevřou se rychlé akce a nabídka refaktoringů. Vyberte možnost Přesunout do oboru názvů. Otevře se dialog, kde můžete vybrat cílový obor názvů, kam chcete přesunout typ.
Place cursor in class name and type (Ctrl+.) to view refactorings
Refaktoringy zobrazíte tak, že umístíte kurzor do názvu třídy a napíšete (Ctrl + .).
Select the destination namespace
Vyberte cílový obor názvů.
  • K dispozici je teď možnost přepnout na blokový komentář nebo blokový komentář vypnout prostřednictvím klávesové zkratky (Ctrl + Shift + /) nebo z nabídky Upravit > Upřesnit > Přepnout blokový komentář. Tento příkaz přidá nebo odebere blokové komentáře podle toho, co vyberete.
Toggle block comment with (Ctrl+Shift+/)
Přepnutí komentáře k bloku pomocí klávesové zkratky Ctrl + Shift + /
  • K dispozici je teď oprava kódu umožňující zápis do polí struktury jen pro čtení. Umístěte kurzor do názvu struktury a napište (Ctrl + .). Otevřou se rychlé akce a nabídka refaktoringů. Vyberte možnost Umožnit zápis do polí jen pro čtení (readonly).
  • Oprava kódu pro přidání soukromého pole z konstruktoru a naopak se dá jednodušeji najít zobrazí se při výběru jakékoliv části názvu pole. Tento refaktoring teď také nabízí všechny možné konstruktory.

Návrhář XAML ve verzi Preview pro vývoj .NET Core 3.0 WPF

  • Pro vývojáře, kteří vytvářejí aplikace .NET Core 3.0 WPF v sadě Visual Studio, je dostupná předběžná ukázka Návrháře XAML. V tuto chvíli nebudou mnohé funkce využívané při návrhu dostupné. Jedná se o předběžnou ukázku, takže pokud narazíte na problémy (například na chybové ukončení), pošlete prosím týmu názor na Visual Studio, abychom mohli prostředí nadále vylepšovat.
  • S každou aktualizací sady Visual Studio 2019 budeme implementovat další funkce, které byly dříve dostupné v Návrháři XAML pro aplikace .NET Framework WPF.

Nástroje sady .NET SDK

V této verzi jsme věnovali spoustu práce, abychom umožnili používání WPF u .NET Core:

  • Byl vyřešen problém, kdy se zobrazilo dialogové okno s chybou, kdykoli jste přidali novou položku do projektu .NET Core WinForms nebo WPF. (#4486)
  • Podpora souborů XAML v projektech .NET SDK (#1467) obsahující mnoho menších položek práce zaměřených na dosažení parity prostředí s projekty . NET ve starém stylu.
  • Podpora položky místní nabídky pro WinForms v rozhraní .NET Core (#137): formulář Windows, uživatelský ovládací prvek, komponenta a třída.
  • Podpora položky místní nabídky pro WPF v rozhraní .NET Core (#137): okno, stránka, uživatelský ovládací prvek, slovník prostředků.
  • Pro projekty .NET SDK je teď povolené okno Zdroje dat. To umožňuje používat scénáře společné správy dat pro WinForms. (#4479

V této verzi byly samostatně přidány různé další opravy:

  • Projekty sady .NET SDK teď podporují soubory.razor. (#4468)
  • Na stránku Vlastnosti ladění byl přidán přístupný text nápovědy, který přečtou čtečky obrazovky. (#4568)
  • Přidali jsme nastavení, které umožňuje zakázat otevření souboru projektu dvojím kliknutím. (#4493)
  • Možnost místní nabídky pro úpravu souboru projektu již neobsahuje název projektu, což řeší problém s příliš širokou místní nabídkou kvůli velmi dlouhému názvu projektu. (#1492)
  • Byla opravena chyba, kdy vytvoření zdroje dat s uživatelským rozhraním datové vazby vytvořilo dva soubory .datasource. (#4485)
  • Byla vyřešena chyba, kdy použití propojených souborů může způsobit selhání kontroly aktuálnosti. (#4580)
  • Byly vyřešeny různé chyby zahrnujících překlad balíčků a zobrazení jejich vyřešeného/nevyřešeného stavu v uzlu Závislosti. (#2924, #4577)

Úplný seznam uzavřených problémů můžete zobrazit tak, že přejdete na milník 16.1 na GitHubu.

Xamarin

  • Aktualizovali jsme výchozí prostředí Android na rozhraní API 28 pro šablony, vytváření zařízení, instalační programy a další.
  • U IntelliSense ve Windows se teď při zápisu kódu Xamarin.Forms XAML zobrazují doporučení pro atributy doby návrhu.

Známé problémy

Pokud se chcete podívat na všechny známé problémy a dostupná řešení pro Visual Studio 2019 verze 16.1, použijte následující odkaz.

Visual Studio 2019 Known Issues


Názory a návrhy

Chceme znát váš názor. O problémech nás můžete informovat prostřednictvím možnosti Nahlásit problém v pravém horním rohu instalačního programu nebo v samotném integrovaném vývojovém prostředí sady Visual Studio. Rozhraní Feedback Icon Ikona se nachází v pravém horním rohu. Na stránce komunity vývojářů sady Visual Studio můžete posílat návrhy k produktu a sledovat svoje nahlášené problémy. Můžete tu pokládat otázky, hledat odpovědi a navrhovat nové funkce. Naše podpora na živém chatu vám navíc poskytne bezplatnou pomoc s instalací.


Blogy

Využijte přehledů a doporučení, které najdete na webu Blogy o vývojářských nástrojích, abyste si udržovali přehled o všech nových vydaných verzích a měli k dispozici podrobné příspěvky popisující širokou škálu funkcí.


Historie zpráv k vydání verzí pro Visual Studio 2019

Další informace o předchozích verzích sady Visual Studio 2019 najdete na stránce s historií zpráv k vydání verzí pro Visual Studio 2019.


Na začátek stránky