Visual Studio Icon Zpráva k vydání verze pro Visual Studio 2019 verze 16.5



Komunita | vývojářů Požadavky | na systém Kompatibilita | Distribuovatelný kód | Licenčních podmínek | Blogy | Nejnovější verze – známé problémy | Novinky v dokumentaci k aplikaci Visual Studio


Po kliknutí na tlačítko si můžete stáhnout nejnovější verzi sady Visual Studio 2019. Pokyny k instalaci a aktualizaci sady Visual Studio 2019 najdete v článku o aktualizaci sady Visual Studio 2019 na nejnovější verzi. Podívejte se také na pokyny k instalaci offline.

Community Download Button Professional Download Button Enterprise Download Button


Novinky v sadě Visual Studio 2019 verze 16.5

Vydání sady Visual Studio 2019 verze 16.5

Blog o sadě Visual Studio 2019

Blog o sadě Visual Studio 2019 je oficiální zdroj informací o produktu, které poskytuje tým technických specialistů sady Visual Studio. Podrobné informace o vydaných verzích sady Visual Studio 2019 najdete v těchto příspěvcích:

Zapojte se do diskuze o zprávách k vydání verze


Release Notes Icon Visual Studio 2019 verze 16.5.5 New release icon

Vydáno 12. května 2020

Opravy v tomto vydání sady Visual Studio 2019 verze 16.5

Oznámení o informačním zpravodaji zabezpečení

CVE-2020-1108 Ohrožení zabezpečení rozhraní .NET Core v podobě útoku DoS

Vzdálený neověřený útočník by mohl zneužít tuto chybu zabezpečení tak, že vydá speciálně vytvořené požadavky na aplikaci .NET Core. Tato aktualizace zabezpečení řeší toto ohrožení zabezpečení tím, že opravuje způsob, jakým webová aplikace .NET Core zpracovává webové žádosti.

CVE-2020-1161 Ohrožení zabezpečení rozhraní .NET Core v podobě útoku DoS

Vzdálený neověřený útočník by mohl zneužít tuto chybu zabezpečení tak, že vydá speciálně vytvořené požadavky na aplikaci ASP.NET Core. Tato aktualizace zabezpečení řeší toto ohrožení zabezpečení tím, že opravuje způsob, jakým webová aplikace ASP.NET Core zpracovává webové žádosti.


Release Notes Icon Visual Studio 2019 verze 16.5.4

Vydáno 14. dubna 2020

Opravy v tomto vydání sady Visual Studio 2019 verze 16.5

Oznámení o informačním zpravodaji zabezpečení

CVE-2020-0899 Ohrožení zabezpečení spočívající v možnosti zvýšit úroveň oprávnění v sadě Microsoft Visual Studio

K ohrožení zabezpečení spočívajícímu v možnosti zvýšit úroveň oprávnění dojde, když aktualizační služba sady Microsoft Visual Studio nesprávně zpracuje oprávnění souboru. Pokud útočník toto slabé místo využije, mohl by přepsat obsah libovolného souboru v kontextu zabezpečení místního systému.

CVE-2020-0900 Ohrožení zabezpečení spočívající v možnosti zvýšit úroveň oprávnění služby pro instalaci rozšíření sady Visual Studio

K ohrožení zabezpečení spočívajícímu v možnosti zvýšit úroveň oprávnění dojde, když služba pro instalaci rozšíření sady Visual Studio nesprávně zpracuje operace se soubory. Pokud útočník toto slabé místo využije, mohl by pomocí zvýšených oprávnění odstraňovat soubory v libovolných umístěních.

CVE-2020-5260 Ohrožení zabezpečení spočívající v úniku přihlašovacích údajů v Gitu pro Visual Studio z důvodu nedostatečného ověřování adres URL

K ohrožení zabezpečení spočívajícímu v úniku přihlašovacích údajů dojde při parsování a odesílání speciálně vytvořených adres URL do pomocných rutin přihlašovacích údajů. To může vést k tomu, že se přihlašovací údaje pošlou nesprávnému hostiteli.


Release Notes Icon Visual Studio 2019 verze 16.5.3

Vydáno 7. dubna 2020

Opravy v tomto vydání sady Visual Studio 2019 verze 16.5


Release Notes Icon Visual Studio 2019 verze 16.5.2 New release icon

Vydáno 31. března 2020

Opravy v tomto vydání sady Visual Studio 2019 verze 16.5


Release Notes Icon Visual Studio 2019 verze 16.5.1 New release icon

Vydáno 24. března 2020

Opravy v tomto vydání sady Visual Studio 2019 verze 16.5


Release Notes Icon Visual Studio 2019 verze 16.5.0

Vydáno 16. března 2020

V tomto vydání sady Visual Studio 2019 verze 16.5


null

  • Při najetí myší se pro každý dokument v seznamu přetečení skupiny karet zobrazí tlačítko Zavřít.
  • Vícenásobný výběr adresářů Azure
  • Byla implementována vylepšení u svislých karet navržená uživateli.

Ladění


Nástroje Azure


C++


Jazyk a nástroje F#


  • Vylepšení výkonu pro rozsáhlá řešení
  • Ochrana funkcí FSharp.Core ve verzi Preview pomocí příznaku LangVersion
  • Různé opravy chyb a vylepšení

Produktivita platformy .NET


Testování


JavaScript/TypeScript


SQL


Nástroje UPW/WPF


Xamarin


Podrobnosti o novinkách v sadě Visual Studio verze 16.5

Visual Studio – sada IDE

Nyní můžete účty filtrovat tak, abyste získali konkrétní podmnožinu služby Azure Active Directory, kterou chcete zpřístupnit pro Visual Studio.

Ladění

  • Spravovaný kód teď můžete dekompilovat i když nemáte symboly, takže si můžete prohlédnout kód, prověřit proměnné a nastavit zarážky.

  • Pomocí dialogového okna Připojit se k procesu se teď můžete připojit k procesům spuštěným v kontejnerech Dockeru s Windows.

Attach to process in Docker Windows container Enclave debugging
  • V nástroji pro sledování přidělení objektů .NET bylo zobrazení Přidělení doplněno o několik vylepšení. Kvůli snadnějšímu rozlišení mezi typem přidělení a volanými funkcemi bylo zobrazení zpětného trasování přesunuto na samostatný panel. Stromy volání byly v zobrazení zpětného trasování převráceny, aby bylo snadnější diagnostikovat, jakým funkcím je přiděleno nejvíce paměti. Byly přidány ikony udávající typy hodnot a odkazů a brzy budou k dispozici další dvě ikony pro kolekce hodnot a odkazů.
Allocation View

C++

  • Vývojáři v jazyce C++ teď mohou modely IntelliCode trénovat na vlastním základu kódu. Říkáme tomu model týmového dokončování, protože můžete využívat postupy svého týmu. Kromě toho jsme vylepšili návrhy IntelliCode pro členské proměnné.

  • IntelliSense teď při práci se standardní knihovnou zobrazuje čitelnější názvy typů.

  • Přidali jsme možnost změnit, jestli se jako potvrzovací klávesa bude používat Enter, Mezerník nebo Tab a jestli se má klávesa Tab používat pro vložení fragmentu. Tato nastavení najdete v části Nástroje > Možnosti > Textový editor > C/C++ > Upřesnit > IntelliSense. Disabling autocomplete options

  • Při oddělování systému sestavení od vzdáleného systému nasazení teď můžete využít nativní podporu sady Visual Studio pro WSL. To vám umožní nativní sestavování na WSL a nasazování artefaktů sestavení do druhého vzdáleného systému pro účely ladění. Tento pracovní postup podporují projekty CMake i linuxové projekty založené na MSBuildu.

  • Nyní můžete s uloženými vzdálenými připojeními pracovat přes příkazový řádek. To je užitečné pro úlohy, jako je například zřízení nového vývojového počítače nebo nastavení sady Visual Studio v rámci kontinuální integrace. C++ Connection Manager

  • Visual Studio teď podporuje režim dodržování předpisů podle FIPS 140-2 při vývoji aplikací C++, které cílí na vzdálený systém Linux.

  • Byla optimalizována kopie zdrojového souboru pro projekty CMake, které cílí na vzdálený systém Linux. Visual Studio teď uchovává „soubor s otiskem“ poslední vzdáleně zkopírované sady zdrojů a optimalizuje chování na základě počtu souborů, které se změnily.

  • Nyní jsou podporovány funkce pro navigaci v kódu, jako Přejít k definici a Najít všechny odkazy, a to pro funkce, proměnné a cíle v souborech skriptů CMake. Language services for CMake scripts

  • Přidávejte, odstraňujte a přejmenovávejte zdrojové soubory a cíle v projektech CMake z integrovaného vývojového prostředí bez nutnosti ručních úprav skriptů CMake. Když přidáváte nebo odebíráte soubory pomocí Průzkumníka řešení, Visual Studio automaticky upraví projekt CMake. Cíle projektu můžete také přidávat, odebírat a přejmenovávat v zobrazení cílů Průzkumníka řešení. 'Add' menu in CMake Targets View

Jazyk a nástroje F#

Primárním cílem této vydané verze je vylepšení výkonu a škálovatelnosti rozsáhlých základů kódu F# v sadě Visual Studio. Tato vylepšení byla provedena na základě přímé spolupráce se zákazníky, kteří mají velmi rozsáhlé základy kódu. Práce na vylepšení výkonu stále probíhají, ale pokud máte střední až velký základ kódu, měli byste zaznamenat menší využití paměti.

Kromě vylepšení výkonu tato vydaná verze zahrnuje celou řadu dalších oprav, z nichž mnoho provedla naše báječná komunita OSS F#.

Jazyk F#

Sloučili jsme několik funkcí jazyka F# ve verzi Preview. Můžete si je vyzkoušet tak, že v souboru projektu nastavíte LangVersion na preview.

kompilátor jazyka F#

Základní knihovna F#

Nástroje F# pro Visual Studio

Vývojové prostředí F# typu open source

  • Build FSharp.Compiler.Service v úložišti F# byl převeden na použití sady SDK .NET. Touto aktualizací přispěl Chet Husk.

Produktivita platformy .NET

Fragment kód teď můžete přeměnit z existující metody na místní funkci pomocí refaktoringu. Zvýrazněte kód, který se má extrahovat. Stisknutím Ctrl+ . aktivujte nabídku Rychlé akce a refaktoring. Vyberte Extrahovat lokální funkci.

Extract local function

Členy teď můžete nastavit jako statické. Umístěte kurzor na název člena. Stisknutím Ctrl+ . aktivujte nabídku Rychlé akce a refaktoring. Vyberte Nastavit jako statickou.

Make members static

Pokud je to možné, můžete teď zjednodušovat řetězcové interpolace. Umístěte kurzor na interpolaci řetězce. Stisknutím Ctrl+ . aktivujte nabídku Rychlé akce a refaktoring. Vyberte Zjednodušit interpolaci.

Simplify-string-interpolation

Nyní přibyla možnost vyloučit generované soubory nebo složky při spouštění analyzátorů. Vytvořte soubor EditorConfig a označte požadované soubory nebo složky jako generované, a to použitím následující syntaxe:

EditorConfig option to exclude generated files or folders

Autor analyzátoru teď může distribuovat vlastní refaktoring kódu jako balíček NuGet (dříve ho mohl distribuovat jenom jako VSIX).

Testování

Nyní můžete profilovat testy pro .NET Core. Nezapomeňte, že požadavkem pro profilování je konfigurace vašich projektů .NET Core tak, aby generovaly úplné soubory PDB. Doporučuje se také upgradovat sadu Microsoft.Test.SDK minimálně na verzi 16.4. To vám umožní profilovat testy v nastavení pro architekturu x86 i x64. Pokud chcete profilovat test, vyberte Profil z místní nabídky v Průzkumníku testů. Profilování testů se podporuje prostřednictvím statické instrumentace a dokumentu Prohlížeče výkonu (.vsp) v sadě Visual Studio.

Výchozí nastavení pro architekturu procesorů u testů teď kromě možností x64 a x86 nabízí ještě třetí možnost: Automaticky. Možnost Automaticky podporuje různé výchozí architektury u testů cílených na .NET Framework oproti .NET Core. Testy pro .NET Framework se nastaví na výchozí hodnotu pro x86 a testy pro .NET Core se nastaví na výchozí hodnotu pro x64. Možnost Automaticky umožňuje, aby uživatel architekturu nenastavoval, a podporuje pro tyto architektury různé výchozí hodnoty. Dříve byla ve všech případech výchozí hodnotou položka x86, ale jak byly zavedeny testy pro .NET Core s výchozí hodnotou x64, je potřeba výchozí nastavení rozdělit.

Tato verze přináší významná vylepšení výkonu při zjišťování a provádění testů, zejména v rozsáhlých řešeních s velkým množstvím testů. Budeme rádi, když si spustíte vlastní srovnávací testy a vyhodnotíte, jak je to přínosné. Se základem kódu Roslyn (kompilátorem pro C# a Visual Basic) snížil Průzkumník testů spotřebu paměti v rozsahu 50 až 60 % a zkrátil dobu načítání až o 60 %.

K dispozici je nyní lepší diagnostika pro Live Unit Testing. Když selže build Live Unit Testing, vytisknou se ve výstupu další diagnostické informace, včetně protokolů MSBuildu. Zaznamenají se také případy, kdy je výstupní cesta pevně kódovaná.

JavaScript/TypeScript

Hledání ve VS teď podporuje hledání typů a členů v souborech TypeScript a JavaScript. Také podporuje vyhledávání bloků JavaScript v otevřených souborech značek (např. HTML, CSHTML).

Visual Studio teď podporuje ESLint pro soubory TypeScript: k dispozici je globální konfigurace se sadou doporučených pravidel nebo je možné ESLint nastavit lokálně jako projekt s úplným přizpůsobením. Další informace a pokyny jsou k dispozici na naší stránce na GitHubu

Xamarin

  • Díky Opětovnému načítání XAML za provozu se teď změny aktualizují v několika cílech Xamarin.Forms najednou. Pomocí několika spouštěcích projektů můžete ladit aplikaci, změnit XAML a kliknutím na Uložit zobrazit změny v Androidu a iOSu současně.

  • V podokně Osnova dokumentu si teď můžete zobrazit hierarchii ovládacích prvků Xamarin.Forms. V systému Windows si ji můžete otevřít pomocí Ctrl+Alt+T (Zobrazení > Ostatní okna > Osnova dokumentu). V systému Mac si ji můžete otevřít přes Zobrazit > Panely > Osnova dokumentu.

  • Teď můžete změny prostředků Androidu provádět za běhu, a to pomocí funkce Aplikovat změny v Androidu. Tato funkce vám umožní rychlé zobrazení změn provedených v souborech prostředků Androidu (rozložení XML, nakreslené prostředky apod.) na zařízení nebo v emulátoru Androidu, aniž by bylo nutné aplikaci restartovat.

Android Apply Changes
  • Nově můžete vytvářet vlastní profily při použití trasování spuštění v aplikaci pro Android. Tím zajistíte ještě výkonnější spouštěcí prostředí s minimálním nárůstem velikosti souboru APK.
  • Nyní můžete generovat vazby Xamarin.Android pro knihovny Kotlin.
  • Při slučování souborů AndroidManifest.xml v projektech pro Android teď můžete využít Google Manifest Merger. To vám umožní přizpůsobit sloučení jednotlivých manifestů a jejich obsahu. Další podrobnosti o pravidlech, která lze použít, najdete v článku o slučování souborů manifestu.
  • Nyní se můžete rozhodnout pro používání nové možnosti, která automaticky znovu načítá všechny otevřené návrhové plochy, když v základu kódu proběhne jakákoli změna.
Custom Control Quick Changes for Android Layouts
  • Využijte funkce konsolidovaného editoru, které zajistí rychlejší a přesnější IntelliSense. Jde o mnoho změn, například o vylepšené dokončování běžných konstrukcí XML, jako jsou uvozovky atributů, a automatické aktualizace názvů koncových značek. Toto chování můžete řídit přes předvolby editoru XML pro Android:
Android XML IntelliSense Options

Nástroje UPW/WPF

  • Přetažení image z průzkumníka řešení projektů do editoru XAML teď vygeneruje značku image XAML s vlastností Source nastavenou na správnou cestu k imagi.

  • Změna barvy pozadí návrhové plochy pro Návrhář XAML teď funguje s projekty WPF .NET Core (Možnosti > Prostředí > Písma a barvy, pak přepněte na nastavení Návrháře XAML a aktualizujte pozadí návrhové plochy).

  • Návrhář XAML teď podporuje načítání projektů .NET Core 3.x, které zahrnují nastavení PublishSingleFile, RuntimeIdenfier a PublishTrimmed ve svém souboru projektu (csproj). Všimněte si, že zahrnutí těchto nastavení zpomalí výkon návrháře.

Hlavní problémy od komunity vývojářů



Známé problémy

Pokud se chcete podívat na všechny známé problémy a dostupná řešení pro Visual Studio 2019 verze 16.5, použijte následující odkaz.

Visual Studio 2019 Known Issues


Názory a návrhy

Chceme znát váš názor. O problémech nás můžete informovat prostřednictvím možnosti Nahlásit problém v pravém horním rohu instalačního programu nebo v samotném integrovaném vývojovém prostředí sady Visual Studio. Rozhraní Feedback Icon Ikona se nachází v pravém horním rohu. Na stránce komunity vývojářů sady Visual Studio můžete posílat návrhy k produktu a sledovat svoje nahlášené problémy. Můžete tu pokládat otázky, hledat odpovědi a navrhovat nové funkce. Naše podpora na živém chatu vám navíc poskytne bezplatnou pomoc s instalací.


Blogy

Využijte přehledů a doporučení, které najdete na webu Blogy o vývojářských nástrojích, abyste si udržovali přehled o všech nových vydaných verzích a měli k dispozici podrobné příspěvky popisující širokou škálu funkcí.


Historie zpráv k vydání verzí pro Visual Studio 2019

Další informace o předchozích verzích sady Visual Studio 2019 najdete na stránce s historií zpráv k vydání verzí pro Visual Studio 2019.


Na začátek stránky