Výběr verze Unity a modulu plug-in XR

I když v současnosti doporučujeme nainstalovat Unity 2020,3 LTS s nejnovějším modulem plug-in OpenXR (Mixed reality ) pro hybridní realitu, můžete vytvářet aplikace i s jinými konfiguracemi Unity.

aktuální doporučená konfigurace Unity pro HoloLens 2 a vývoj Windows Mixed Reality je Unity 2020,3 LTS s nejnovějším modulem plug-in OpenXR pro Mixed reality. K tomu, abyste se vyhnuli známým problémům s výkonem v předchozích 2020,3 sestaveních, musíte použít 2020.3.8 F1 nebo novější.

Důležité

Unity 2020 nepodporuje cílení na HoloLens (1. generace). Tato náhlavní souprava zůstanou podporovaná v Unity 2019 LTS se STARŠÍmi XRy pro celý životní cyklus Unity 2019 LTS až do polovině 2022.

Nejlepším způsobem, jak nainstalovat a spravovat Unity, je prostřednictvím centra Unity:

  1. Nainstalujte centrum Unity.
  2. Vyberte kartu instalace a klikněte na Přidat.
  3. Vyberte Unity 2020,3 LTS a klikněte na Další.

Instalace nové verze v centru Unity

  1. Podívejte se na následující komponenty v části platformy:
    • podpora sestavení Univerzální platforma Windows
    • podpora sestavení Windows (IL2CPP)

možnost podpory sestavení Unity Univerzální platforma Windows

  1. Pokud jste dřív nainstalovali Unity bez těchto možností, můžete je přidat pomocí nabídky přidat moduly v centru Unity:

možnost podpory sestavení Unity Windows

Po instalaci Unity 2020,3 můžete začít vytvářet projekt nebo upgradovat existující projekt pomocí modulu plug-in OpenXR ve smíšeném realitu:

Poznámka

i když doporučujeme používat OpenXR pro všechny nové projekty, Unity 2020,3 LTS také podporuje modul plug-in Windows XR. Tento modul plug-in je plně podporovaný, i když neobdrží nové funkce, například podporu AR Foundation 4,0.

Unity 2019,4 LTS

Pokud potřebujete použít Unity 2019, můžete použít unity 2019 LTS s předdefinovanými XRy ve verziStandard. Pokud chcete začít používat starší verze integrovaných XR v Unity 2019,4 LTS, klikněte sem:

Poznámka

Unity zastaralal svůj starší integrovaný XR podporu od Unity 2019. I když Unity 2019 nabízí novou architekturu modulu plug-in XR, společnost Microsoft v současnosti nedoporučuje tuto cestu v Unity 2019 kvůli nekompatibilitě prostorových kotev Azure s AR Foundation 2. V Unity 2020 jsou prostorové kotvy Azure podporované v rámci XR architektury modulu plug-in.

pokud vyvíjíte aplikace pro HoloLens (1. generace), tyto náhlavní soupravy zůstanou podporované v Unity 2019 LTS s předdefinovanými XR pro celý životní cyklus unity 2019 LTS až po polovině 2022.

Unity 2021,2

Pokud vyzkoušíte buildy s dřívější Unity 2021,2 , začněte s modulem plug-in OpenXR pro Mixed reality. modul plug-in OpenXR je jedinou cestou pro vývoj hybridních realit v Unity 2021,2 a novějším, protože konečná verze Unity pro podporu modulu plug-in Windows XR byla Unity 2021,1.

Unity 2018,4 LTS

Unity 2018,4 LTS získalo na konci dvouletého okna podpory Long-Term Unity a už nepřijímá aktualizace z Unity, i když vaše projekty budou i nadále běžet.

Pokud máte projekt Unity 2018, měli byste zvážit plánování migrace předem do Unity 2020,3 LTS a modul plug-in OpenXR pro Mixed reality.