Exemplarische Vorgehensweise: Erstellen eines Standard C++-Programms (C++)

Sie können Visual Studio verwenden, um C++-Standardprogramme zu erstellen. Indem Sie die Schritte in dieser exemplarischen Vorgehensweise ausführen, können Sie ein Projekt erstellen, dem Projekt eine neue Datei hinzufügen, die Datei ändern, um C++-Code hinzuzufügen. Anschließend können Sie das Programm mithilfe von Visual Studio kompilieren und ausführen.

Sie können ein eigenes C++-Programm eingeben oder eines der Beispielprogramme verwenden. Das Beispielprogramm in dieser exemplarischen Vorgehensweise ist eine Konsolenanwendung. Diese Anwendung verwendet den set Container in der C++-Standardbibliothek.

Hinweis

Wenn die Konformität mit einer bestimmten Version des C++-Sprachstandards (z. B. C++14, C++17 oder C++20) erforderlich ist, verwenden Sie die /std:c++14Compileroption , /std:c++17oder /std:c++20 . (Visual Studio 2017 und höher))

Voraussetzungen

Zur Durchführung dieser exemplarischen Vorgehensweise benötigen Sie Grundkenntnisse in C++.

So erstellen Sie ein neues Projekt und fügen eine Quelldatei hinzu

Die folgenden Schritte variieren leicht, je nachdem, welche Version von Visual Studio Sie verwenden. Um die Dokumentation für Ihre bevorzugte Version von Visual Studio anzuzeigen, verwenden Sie das Auswahlsteuerelement Version. Es befindet sich am Anfang des Inhaltsverzeichnisses auf dieser Seite.

So erstellen Sie ein C++-Projekt in Visual Studio

  1. Klicken Sie im Hauptmenü auf Datei>Neu>Projekt, um das Dialogfeld Neues Projekt erstellen zu öffnen.

  2. Legen Sie oben im Dialogfeld die Sprache auf C++, die Plattform auf Windows und den Projekttyp auf Konsole fest.

  3. Wählen Sie aus der gefilterten Projekttypliste Konsolen-App aus, und klicken Sie auf Weiter. Geben Sie auf der nächsten Seite einen Namen für das Projekt ein, und geben Sie bei Bedarf den Projektspeicherort an.

  4. Klicken Sie auf die Schaltfläche Erstellen, um das Projekt zu erstellen.

So erstellen Sie ein C++-Projekt in Visual Studio 2017

  1. Erstellen Sie ein Projekt, indem Sie im Menü Datei auf Neu zeigen und dann auf Project klicken.

  2. Klicken Sie im Bereich Visual C++ Projekttypen auf Windows Desktop und dann auf Windows Konsolenanwendung.

  3. Geben Sie einen Namen für das Projekt ein. Standardmäßig erhält die Lösung, in der das Projekt enthalten ist, den gleichen Namen wie das Projekt. Sie können jedoch auch einen anderen Namen eingeben. Sie können auch einen anderen Speicherort für das Projekt eingeben.

  4. Klicken Sie auf OK, um das Projekt zu erstellen.

So erstellen Sie ein C++-Projekt in Visual Studio 2015

  1. Erstellen Sie ein Projekt, indem Sie im Menü Datei auf Neu zeigen und dann auf Project klicken.

  2. Klicken Sie im Bereich Visual C++ Projekttypen auf Windows Desktop und dann auf Windows Konsolenanwendung.

  3. Erweitern Sie im Dialogfeld New Project (Neue Project) installedTemplates>>Visual C++ , und wählen Sie dann Win32 aus. Wählen Sie im mittleren Bereich Win32-Konsolenanwendungaus.

  4. Geben Sie einen Namen für das Projekt ein. Standardmäßig erhält die Lösung, in der das Projekt enthalten ist, den gleichen Namen wie das Projekt. Sie können jedoch auch einen anderen Namen eingeben. Sie können auch einen anderen Speicherort für das Projekt eingeben.

  5. Klicken Sie auf OK, um das Projekt zu erstellen.

  6. Schließen Sie den Win32-Anwendungs-Assistenten ab.

  7. Klicken Sie auf Weiter, stellen Sie sicher, dass Konsolenanwendung ausgewählt ist, und deaktivieren Sie das Kontrollkästchen Vorkompilierte Header .

  8. Klicken Sie auf Fertig stellen.

Hinzufügen einer neuen Quelldatei

  1. Wenn Projektmappen-Explorer nicht angezeigt wird, klicken Sie im Menü Ansicht auf Projektmappen-Explorer.

  2. Fügen Sie dem Projekt folgendermaßen eine neue Quelldatei hinzu:

    1. Klicken Sie in Projektmappen-Explorer mit der rechten Maustaste auf den Ordner Quelldateien, zeigen Sie auf Hinzufügen, und klicken Sie dann auf Neues Element.

    2. Klicken Sie im Knoten Code auf C++-Datei (.cpp), geben Sie einen Namen für die Datei ein, und klicken Sie dann auf Hinzufügen.

    Die CPP-Datei wird im Ordner Quelldateien in Projektmappen-Explorer angezeigt, und die Datei wird im Visual Studio-Editor geöffnet.

  3. Geben Sie in der Datei im Editor ein gültiges C++-Programm ein, das die C++-Standardbibliothek verwendet, oder kopieren Sie eines der Beispielprogramme, und fügen Sie es in die Datei ein.

  4. Speichern Sie die Datei .

  5. Klicken Sie im Menü Build auf Projektmappe erstellen.

    Im Fenster Ausgabe werden Informationen zum Kompilierungsstatus angezeigt, z. B. der Speicherort des Buildprotokolls und eine Meldung, die den Buildstatus angibt.

  6. Klicken Sie im Menü Debuggen auf Ohne Debuggen starten.

    Wenn Sie das Beispielprogramm verwendet haben, wird ein Befehlsfenster angezeigt. Dieses gibt an, ob bestimmte ganze Zahlen im Set enthalten sind.

Nächste Schritte

Zurück:Konsolenanwendungen in Visual C++
Weiter:Exemplarische Vorgehensweise: Kompilieren eines nativen C++-Programms über die Befehlszeile

Siehe auch

C++-Programmiersprachenreferenz
C++-Standardbibliothek