Erstellen und Debuggen von Office-Add-Ins in Visual StudioCreate and debug Office Add-ins in Visual Studio

In diesem Artikel erfahren Sie, wie Sie unter Verwendung von Visual Studio 2019 ein Office-Add-In für Excel, Word, PowerPoint oder Outlook erstellen und das Add-In im Office-Desktopclient unter Windows debuggen.This article describes how to use Visual Studio 2017 to create an Office Add-in for Excel, Word, PowerPoint, or Outlook and debug the add-in in the Office desktop client on Windows. Bei Verwendung einer anderen Visual Studio-Version können die Verfahren geringfügig variieren.If you're using another version of Visual Studio, the procedures might vary slightly.

Hinweis

Die Erstellung von Office-Add-Ins für OneNote oder Project wird von Visual Studio nicht unterstützt. Diese Arten von Add-Ins können jedoch mit dem Yeoman-Generator für Office-Add-Ins erstellt werden.Visual Studio does not support creating Office Add-ins for OneNote or Project, but you can use the Yeoman generator for Office Add-ins to create these types of add-ins.

VoraussetzungenPrerequisites

Erstellen des Add-In-Projekts in Visual StudioCreate the add-in project in Visual Studio

Führen Sie zunächst die drei folgenden Schritte aus, und fahren Sie dann im nächsten Abschnitt mit den Schritten für die Art des Add-Ins fort, das Sie erstellen möchten.Start by completing these three steps, and then complete the steps in the following section that corresponds to the type of add-in you're creating.

  1. Öffnen Sie Visual Studio, und wählen Sie auf der Visual Studio-Menüleiste die Option Neues Projekt erstellen aus.Open Visual Studio and from the Visual Studio menu bar, choose FileNewProject.

  2. Geben Sie im Suchfeld Add-Ins, und wählen Sie dann den Typ des Add-In-Projekts aus, den Sie erstellen möchten.Using the search box, enter Add-ins, then choose the type of add-in project you want to create.

  3. Geben Sie einen Namen für das Projekt ein, und klicken Sie dann auf OK.Name the project, and then choose OK.

Word-Web-Add-In oder Outlook-Web-Add-InWord Web Add-in or Outlook Web Add-in

Wenn Sie ein Word-Web-Add-In oder ein Outlook-Web-Add-In erstellen, erstellt Visual Studio eine Projektmappe, und die beiden entsprechenden Projekte werden im Projektmappen-Explorer angezeigt.If you've chosen to create a Word Web Add-in or an Outlook Web Add-in, Visual Studio creates a solution and its two projects appear in Solution Explorer. Danach können Sie die Visual Studio-Projektmappe erkunden.Next, you can explore the Visual Studio solution.

PowerPoint-Web-Add-InPowerPoint Web Add-in

Wenn Sie ein PowerPoint-Web-Add-In erstellen, wird das Dialogfeld Erstellen des Office-Add-Ins angezeigt.If you've chosen to create a PowerPoint Web Add-in, the Create Office Add-in dialog appears.

  • Wenn Sie ein Aufgabenbereich-Add-In erstellen möchten, wählen Sie PowerPoint neue Funktionen hinzufügen und anschließend die Schaltfläche Fertig stellen aus, um die Visual Studio-Projektmappe zu erstellen.To create a task pane add-in, select Add new functionalities to PowerPoint and then choose the Finish button to create the Visual Studio solution.

  • Wenn Sie ein Inhalts-Add-In erstellen möchten, wählen Sie Inhalt in PowerPoint-Folien einfügen und anschließend die Schaltfläche Fertig stellen aus, um die Visual Studio-Projektmappe zu erstellen.To create a content add-in, select Insert content into PowerPoint slides and then choose the Finish button to create the Visual Studio solution.

Danach können Sie die Visual Studio-Projektmappe erkunden.Next, you can explore the Visual Studio solution.

Excel-Web-Add-InExcel Web Add-in

Wenn Sie ein Excel-Web-Add-In erstellen, wird das Dialogfeld Erstellen des Office-Add-Ins angezeigt.If you've chosen to create an Excel Web Add-in, the Create Office Add-in dialog appears.

  • Wenn Sie ein Aufgabenbereich-Add-In erstellen möchten, wählen Sie Excel neue Funktionen hinzufügen und anschließend die Schaltfläche Fertig stellen aus, um die Visual Studio-Projektmappe zu erstellen.To create a task pane add-in, select Add new functionalities to Excel and then choose the Finish button to create the Visual Studio solution.

  • Wenn Sie ein Inhalts-Add-In erstellen möchten, wählen Sie Inhalt in Excel-Tabellen einfügen aus. Wählen Sie dann die Schaltfläche Weiter, eine der folgenden Optionen und anschließend die Schaltfläche Fertig stellen aus, um die Visual Studio-Projektmappe zu erstellen:To create a content add-in, select Insert content into Excel spreadsheets, choose the Next button, select one of the following options, and then choose the Finish button to create the Visual Studio solution:

    • Basis-Add-In: Dient zum Erstellen eines Inhalts-Add-In-Projekts mit minimalem Startcode.Basic Add-in - to create a content add-in project with minimal starter code

    • Dokumentvisualisierungs-Add-In: Dient zum Erstellen eines Inhalts-Add-In-Projekts mit Startcode zur Datenvisualisierung und -bindung.Document Visualization Add-in - to create a content add-in project with starter code to visualize and bind to data

Erkunden der Visual Studio-ProjektmappeExplore the Visual Studio solution

Wenn Sie den Assistenten abgeschlossen haben, erstellt Visual Studio eine Projektmappe, die zwei Projekte enthält.When you've completed the wizard, Visual Studio creates a solution that contains two projects.

ProjektProject BeschreibungDescription
Add-In-ProjektAdd-in project Enthält nur eine XML-Manifestdatei, die alle Einstellungen enthält, die Ihr Add-in beschreiben. Mit diesen Einstellungen kann der Office-Host bestimmen, wann Ihr Add-in aktiviert wird und wo das Add-in angezeigt werden soll. Visual Studio generiert den Inhalt dieser Datei, sodass Sie das Projekt ausführen und Ihre Add-in sofort verwenden können. Durch Ändern der XML-Datei können Sie diese Einstellungen jederzeit ändern.Contains only an XML manifest file, which contains all the settings that describe your add-in. These settings help the Office host determine when your add-in should be activated and where the add-in should appear. Visual Studio generates the contents of this file for you so that you can run the project and use your add-in immediately. You change these settings any time by modifying the XML file.
WebanwendungsprojektWeb application project Enthält die Inhaltsseiten Ihres Add-Ins, darunter alle Dateien und Dateiverweise, die Sie zum Entwickeln von Office-fähigen HTML- und JavaScript-Seiten benötigen. Während Sie Ihr Add-in entwickeln, wird die Webanwendung von Visual Studio auf Ihrem lokalen IIS-Server gehostet. Sobald Sie Ihr Add-In veröffentlichen möchten, müssen Sie dieses Webanwendungsprojekt auf einem Webserver bereitstellen.Contains the content pages of your add-in, including all the files and file references that you need to develop Office-aware HTML and JavaScript pages. While you develop your add-in, Visual Studio hosts the web application on your local IIS server. When you're ready to publish the add-in, you'll need to deploy this web application project to a web server.

Ändern der Add-In-EinstellungenModify your add-in settings

Bearbeiten Sie zum Ändern der Einstellungen Ihres Add-Ins die XML-Manifestdatei im Add-In-Projekt.To modify the settings of your add-in, edit the XML manifest file in the add-in project. Erweitern Sie im Projektmappen-Explorer den Knoten des Add-In-Projekts, erweitern Sie den Ordner mit dem XML-Manifest, und wählen Sie das XML-Manifest aus.In Solution Explorer, expand the add-in project node, expand the folder that contains the XML manifest, and choose the XML manifest. Sie können auf beliebige Elemente in der Datei zeigen, um eine QuickInfo mit einer Beschreibung des Zwecks des Elements einzublenden.You can point to any element in the file to view a tooltip that describes the purpose of the element. Weitere Informationen zur Manifestdatei finden Sie unter XML-Manifest für Office-Add-Ins.For more information about the manifest file, see Office Add-ins XML manifest.

Entwickeln der Inhalte des Add-InsDevelop the contents of your add-in

Während das Add-in-Projekt ermöglicht, die Einstellungen zu ändern, die das Add-in beschreiben, stellt die Webanwendung den Inhalt bereit, der im Add-in angezeigt wird.While the add-in project lets you modify the settings that describe your add-in, the web application provides the content that appears in the add-in.

Das Webanwendungsprojekt enthält eine HTML-Standardseite, eine JavaScript-Datei und eine CSS-Datei, die Sie als Grundlage verwenden können.The web application project contains a default HTML file, JavaScript file, and CSS file that you can use to get started. Einige dieser Dateien enthalten Verweise auf andere JavaScript-Bibliotheken (einschließlich der JavaScript-API für Office).Some of these files contain references to other JavaScript libraries including the JavaScript API for Office. Sie können Ihr Add-In entwickeln, indem Sie diese Dateien aktualisieren und/oder weitere HTML- und JavaScript-Dateien hinzufügen.You can develop your add-in by updating these files and/or adding more HTML and JavaScript files. Die folgende Tabelle beschreibt die Dateien, die das Webanwendungsprojekt standardmäßig enthält, wenn die Visual Studio-Projektmappe erstellt wird.The following table describes the default files that the web application project contains when the Visual Studio solution is created.

DateinameFile name BeschreibungDescription
Home.htmlHome.html
(Excel, PowerPoint, Word)(Excel, PowerPoint, Word)

MessageRead.htmlMessageRead.html
(Outlook)(Outlook)
Die HTML-Standardseite des Add-Ins.The default HTML page of the add-in. Diese Seite wird als erste Seite innerhalb des Add-Ins angezeigt, wenn es in einem Dokument, in einer E-Mail oder in einem Terminelement aktiviert wird.This page appears as the first page inside of the add-in when it is activated in a document, email message, or appointment item. Diese Datei enthält alle Dateiverweise, die Sie für den Einstieg benötigen.This file contains all of the file references that you need to get started. Sie können mit der Entwicklung Ihres Add-Ins beginnen, indem Sie dieser Datei Ihren HTML-Code hinzufügen.You can start developing your add-in by adding your HTML code to this file.
Home.jsHome.js
(Excel, PowerPoint, Word)(Excel, PowerPoint, Word)

MessageRead.jsMessageRead.js
(Outlook)(Outlook)
Die JavaScript-Datei, die der Seite Home.html (Excel, PowerPoint, Word) bzw. der Seite MessageRead.html (Outlook) zugeordnet ist.The JavaScript file associated with the Home.html page (Excel, PowerPoint, Word) or the MessageRead.html page (Outlook). Diese Datei muss sämtlichen spezifischen Code für das Verhalten der Seite Home.html (Excel, PowerPoint, Word) bzw. der Seite MessageRead.html (Outlook) enthalten.This file should contain any code that is specific to the behavior of the Home.html page (Excel, PowerPoint, Word) or the MessageRead.html page (Outlook). Die Datei enthält etwas Beispielcode, um Ihnen den Einstieg zu erleichtern.This file contains some example code to get you started.
Home.cssHome.css
(Excel, PowerPoint, Word)(Excel, PowerPoint, Word)

MessageRead.cssMessageRead.css
(Outlook)(Outlook)
Definiert die Standardformatvorlagen, die auf Ihr Add-in angewendet werden sollen.Defines the default styles to apply to your add-in. Wir empfehlen die Verwendung von Office UI Fabric zum Entwerfen und Gestalten.We recommend using the Office UI Fabric for design and styles. Weitere Informationen finden Sie unter Office UI Fabric in Office-Add-Ins.For more information see Office UI Fabric in Office Add-ins.

Hinweis

Diese Dateien müssen nicht verwendet werden.You don't have to use these files. Sie können dem Projekt auch andere Dateien hinzufügen und diese verwenden.Feel free to add other files to the project and use those instead. Falls als Startseite des Add-Ins eine andere HTML-Datei angezeigt werden soll, öffnen Sie den Manifest-Editor, und legen Sie die Eigenschaft SourceLocation auf den Namen der Datei fest.If you want another HTML file to appear as the initial page of the add-in, open the manifest editor, and then set the SourceLocation property to the name of the file.

Debuggen Ihres Add-InsDebug your add-in

Sie können Visual Studio verwenden, um Ihr Add-In im Office-Desktopclient unter Windows zu debuggen. Dies wird in den folgenden Abschnitten beschrieben:You can use Visual Studio to debug your add-in in the Office desktop client on Windows, as described in the following sections:

Hinweis

Visual Studio kann nicht zum Debuggen von Add-Ins in Office im Web oder Office für Mac verwendet werden.You cannot use Visual Studio to debug add-ins in Office on the web or Mac. Informationen zum Debuggen auf diesen Plattformen finden Sie unter Debuggen von Add-Ins in Office im Web sowie unter Debuggen von Office-Add-Ins auf dem iPad und einem Mac-ComputerFor information about debugging on these platforms, see Debug Office Add-ins in Office on the web or Debug Office Add-ins on iPad and Mac

Überprüfen der Build- und Debugging-EigenschaftenReview the build and debug properties

Überprüfen Sie vor dem Debuggen zunächst die Eigenschaften jedes Projekts, um sich zu vergewissern, dass Visual Studio die gewünschte Hostanwendung öffnet und dass andere Build- und Debugging-Eigenschaften korrekt festgelegt sind.Before you start debugging, review the properties of each project to confirm that Visual Studio will open the desired host application and that other build and debug properties are set appropriately.

Eigenschaften des Add-In-ProjektsAdd-in project properties

Öffnen Sie das Fenster Eigenschaften für das Add-In-Projekt, um die Projekteigenschaften zu überprüfen:Open the Properties window for the add-in project to review project properties:

  1. Wählen Sie im Projektmappen-Explorer das Add-In-Projekt (nicht das Webanwendungsprojekt) aus.In Solution Explorer, choose the add-in project (not the web application project).

  2. Wählen Sie auf der Menüleiste Ansicht > Eigenschaftenfenster aus.From the menu bar, choose View > Properties Window.

In der folgenden Tabelle werden die Eigenschaften des Add-In-Projekts beschrieben:The following table describes the properties of the add-in project.

EigenschaftProperty BeschreibungDescription
StartaktionStart Action Gibt den Debugmodus für Ihr Add-In an.Specifies the debug mode for your add-in. Für Office-Add-In-Projekte wird derzeit nur der Modus Office-Desktopclient unterstützt.Currently only Office Desktop Client mode is supported for Office Add-in projects.
StartdokumentStart Document
(nur Excel-, PowerPoint- und Word-Add-Ins)(Excel, PowerPoint, and Word add-ins only)
Gibt an, welches Dokument beim Starten des Projekts geöffnet werden soll.Specifies what document to open when you start the project.
WebprojektWeb Project Gibt den Namen des Webprojekts an, das dem Add-In zugeordnet ist.Specifies the name of the web project associated with the add-in.
E-Mail-AdresseEmail Address
(nur Outlook-Add-Ins)(Outlook add-ins only)
Gibt die E-Mail-Adresse des Benutzerkontos in Exchange Server oder Exchange Online an, mit dem Sie Ihr Outlook-Add-In testen möchten.Specifies the email address of the user account in Exchange Server or Exchange Online that you want to use to test your Outlook add-in.
EWS-URLEWS Url
(nur Outlook-Add-Ins)(Outlook add-ins only)
Exchange-Webdienst-URL (Beispiel: https://www.contoso.com/ews/exchange.aspx).Exchange Web service URL (For example: https://www.contoso.com/ews/exchange.aspx).
OWA-URLOWA Url
(nur Outlook-Add-Ins)(Outlook add-ins only)
Outlook im Web-URL (zum Beispiel: https://www.contoso.com/owa).Outlook on the web URL (For example: https://www.contoso.com/owa).
Mehrstufige Authentifizierung verwendenUse multi-factor auth
(nur Outlook-Add-Ins)(Outlook add-ins only)
Boolescher Wert, der angibt, ob die mehrstufige Authentifizierung verwendet werden soll.Boolean value that indicates whether multi-factor authentication should be used.
BenutzernameUser Name
(nur Outlook-Add-Ins)(Outlook add-ins only)
Gibt den Namen des Benutzerkontos in Exchange Server oder Exchange Online an, mit dem Sie Ihr Outlook-Add-In testen möchten.Specifies the name of the user account in Exchange Server or Exchange Online that you want to use to test your Outlook add-in.
ProjektdateiProject File Gibt den Namen der Datei mit den Build-, Konfigurations- und anderen Informationen zum Projekt an.Specifies the name of the file containing build, configuration, and other information about the project.
ProjektordnerProject Folder Der Speicherort der Projektdatei.The location of the project file.

Hinweis

Bei Outlook-Add-Ins können Sie im Fenster Eigenschaften optional Werte für einzelne oder mehrere der Outlook-Add-In-spezifischen Eigenschaften angeben.For an Outlook add-in, you may choose to specify values for one or more of the Outlook add-in only properties in the Properties window, but doing so is not required.

Eigenschaften des WebanwendungsprojektsWeb application project properties

Öffnen Sie das Fenster Eigenschaften für das Webanwendungsprojekt, um die Projekteigenschaften zu überprüfen:Open the Properties window for the web application project to review project properties:

  1. Wählen Sie im Projektmappen-Explorer das Webanwendungsprojekt aus.In Solution Explorer, choose the web application project.

  2. Wählen Sie auf der Menüleiste Ansicht > Eigenschaftenfenster aus.From the menu bar, choose View > Properties Window.

In der folgenden Tabelle werden die Eigenschaften des Webanwendungsprojekts beschrieben, die für Office-Add-In-Projekte besonders relevant sind:The following table describes the properties of the web application project that are most relevant to Office Add-in projects.

EigenschaftProperty BeschreibungDescription
SSL-fähigSSL Enabled Gibt an, ob SSL für die Website aktiviert ist.Specifies whether SSL is enabled on the site. Diese Eigenschaft sollte bei Office-Add-In-Projekten auf True festgelegt sein.This property should be set to True for Office Add-in projects.
SSL-URLSSL URL Gibt die sichere HTTPS-URL für die Website an.Specifies the secure HTTPS URL for the site. Schreibgeschützt.Read-only.
URLURL Gibt die HTTP-URL für die Website an.Specifies the HTTP URL for the site. Schreibgeschützt.Read-only.
ProjektdateiProject File Gibt den Namen der Datei mit den Build-, Konfigurations- und anderen Informationen zum Projekt an.Specifies the name of the file containing build, configuration, and other information about the project.
ProjektordnerProject Folder Gibt den Speicherort der Projektdatei an.Specifies the location of the project file. Schreibgeschützt.Read-only. Die Manifestdatei, die Visual Studio zur Laufzeit generiert, wird an diesem Speicherort in den Ordner bin\Debug\OfficeAppManifests geschrieben.The manifest file that Visual Studio generates at runtime is written to the bin\Debug\OfficeAppManifests folder in this location.

Debuggen des Add-Ins unter Verwendung eines vorhandenen DokumentsUse an existing document to debug the add-in

Wenn Sie über ein Dokument mit Testdaten verfügen, die Sie beim Debuggen Ihres Excel-, PowerPoint- oder Word-Add-Ins verwenden möchten, kann Visual Studio so konfiguriert werden, dass das Dokument beim Start des Projekts geöffnet wird.If you have a document that contains test data you want to use while debugging your Excel, PowerPoint, or Word add-in, Visual Studio can be configured to open that document when you start the project. Gehen Sie wie folgt vor, um ein vorhandenes Dokument anzugeben, das beim Debuggen des Add-Ins verwendet werden soll:To specify an existing document to use while debugging the add-in, complete the following steps.

  1. Wählen Sie im Projektmappen-Explorer das Add-In-Projekt (nicht das Webanwendungsprojekt) aus.In Solution Explorer, choose the add-in project (not the web application project).

  2. Wählen Sie auf der Menüleiste Projekt > Vorhandenen Element hinzufügen aus.From the menu bar, choose Project > Add Existing Item.

  3. Wählen Sie im Dialogfeld Vorhandenes Element hinzufügen das Dokument aus, das Sie hinzufügen möchten.In the Add Existing Item dialog box, locate and select the document that you want to add.

  4. Wählen Sie die Schaltfläche Hinzufügen aus, um das Dokument zu Ihrem Projekt hinzuzufügen.Choose the Add button to add the document to your project.

  5. Wählen Sie im Projektmappen-Explorer das Add-In-Projekt (nicht das Webanwendungsprojekt) aus.In Solution Explorer, choose the add-in project (not the web application project).

  6. Wählen Sie auf der Menüleiste Ansicht > Eigenschaftenfenster aus.From the menu bar, choose View > Properties Window.

  7. Wählen Sie im Fenster Eigenschaften die Liste Startdokument und anschließend das Dokument aus, das Sie dem Projekt hinzugefügt haben.In the Properties window, choose the Start Document list, and then select the document that you added to the project. Das Projekt ist jetzt so konfiguriert, dass das Add-In mit diesem Dokument gestartet wird.The project is now configured to start the add-in in that document.

Starten des ProjektsStart the project

Wählen Sie auf der Menüleiste Debuggen > Debugging starten aus, um das Projekt zu starten.Start the project by choosing Debug > Start Debugging from the menu bar. Visual Studio erstellt automatisch die Lösung und startet Office, um Ihr Add-In zu hosten.Visual Studio will automatically build the solution and start Office to host your add-in.

Hinweis

Wenn Sie ein Outlook-Add-In-Projekt starten, werden Sie zur Eingabe von Anmeldeinformationen aufgefordert.When you start an Outlook add-in project, you'll be prompted for login credentials. Wenn Sie mehrmals zur Anmeldung aufgefordert werden oder eine Fehlermeldung erhalten, dass Sie nicht berechtigt sind, ist möglicherweise die Standardauthentifizierung für Konten in Ihrem Office 365-Mandanten deaktiviert.If you're asked to log in repeatedly or if you receive an error that you are unauthorized, then Basic Auth may be disabled for accounts on your Office 365 tenant. Verwenden Sie in diesem Fall ein Microsoft-Konto.In this case, try using a Microsoft account instead. Möglicherweise müssen Sie auch die Eigenschaft "Mehrstufige Authentifizierung verwenden" im Dialog Projekteigenschaften des Outlook-Web-Add-Ins auf "True" einstellen.You may also need to set the property "Use multi-factor auth" to True in the Outlook Web Add-in project properties dialog.

Bei der Projekterstellung werden von Visual Studio folgende Aufgaben ausgeführt:When Visual Studio builds the project it performs the following tasks:

  1. Eine Kopie der XML-Manifestdatei wird erstellt und dem Verzeichnis _ProjectName_\bin\Debug\OfficeAppManifests hinzugefügt.Creates a copy of the XML manifest file and adds it to _ProjectName_\bin\Debug\OfficeAppManifests directory. Die Hostanwendung verwendet diese Kopie, wenn Sie Visual Studio starten und das Add-In debuggen.The host application consumes this copy when you start Visual Studio and debug the add-in.

  2. Auf Ihrem Computer wird ein Satz von Registrierungseinträgen erstellt, die die Anzeige des Add-Ins in der Hostanwendung ermöglichen.Creates a set of registry entries on your computer that enable the add-in to appear in the host application.

  3. Das Webanwendungsprojekt wird erstellt und anschließend auf dem lokalen IIS-Webserver (https://localhost) bereitgestellt.Builds the web application project, and then deploys it to the local IIS web server (https://localhost).

  4. Wenn dies das erste Add-In-Projekt ist, das Sie auf dem lokalen IIS-Webserver bereitgestellt haben, werden Sie möglicherweise aufgefordert, ein selbstsigniertes Zertifikat im vertrauenswürdigen Stammzertifikatspeicher des aktuellen Benutzers zu installieren.If this is the first add-in project that you have deployed to local IIS web server, you may be prompted to install a Self-Signed Certificate to the current user's Trusted Root Certificate store. Dies ist erforderlich, damit IIS Express den Inhalt Ihres Add-Ins richtig anzeigt.This is required for IIS Express to display the content of your add-in correctly.

Hinweis

Die neueste Version von Office verwendet möglicherweise ein neueres Websteuerelement, um die Inhalte des Add-Ins unter Windows 10 anzuzeigen.The latest version of Office may use a newer web control to display the add-in contents when running on Windows 10. Wenn dies der Fall ist, kann Visual Studio Sie dazu auffordern, eine Loopback-Ausnahme für das lokale Netzwerk hinzuzufügen.If this is the case, Visual Studio may prompt you to add a local network loopback exemption. Dies ist erforderlich für das Web-Steuerelement in der Office-Host-Anwendung, damit auf die auf dem lokalen IIS-Webserver bereitgestellte Website zugegriffen werden kann.This is required for the web control, in the Office host application, to be able to access the website deployed to the local IIS web server. Sie können diese Einstellung auch jederzeit in Visual Studio unter Tools > Optionen > Office-Tools (Web) > Debuggen von Web-Add-In ändern.You can also change this setting anytime in Visual Studio under Tools > Options > Office Tools (Web) > Web Add-In Debugging.

Danach führt Visual Studio folgende Aktionen aus:Next, Visual Studio does the following:

  1. Das Element SourceLocation der XML-Manifestdatei wird geändert, indem das Token ~remoteAppUrl durch die vollqualifizierte Adresse der Startseite (beispielsweise https://localhost:44302/Home.html) ersetzt wird.Modifies the SourceLocation element of the XML manifest file by replacing the ~remoteAppUrl token with the fully qualified address of the start page (for example, https://localhost:44302/Home.html).

  2. Das Webanwendungsprojekt wird in IIS Express gestartet.Starts the web application project in IIS Express.

  3. Die Hostanwendung wird geöffnet.Opens the host application.

Visual Studio zeigt beim Erstellen des Projekts keine Überprüfungsfehler im Fenster OUTPUT an.Visual Studio doesn't show validation errors in the OUTPUT window when you build the project. Aufgetretene Fehler und Warnungen werden von Visual Studio im Fenster ERRORLIST gemeldet.Visual Studio reports errors and warnings in the ERRORLIST window as they occur. Darüber hinaus weist Visual Studio im Code- und im Text-Editor durch verschiedenfarbige wellenförmige Unterstreichungen auf Überprüfungsfehler hin.Visual Studio also reports validation errors by showing wavy underlines (known as squiggles) of different colors in the code and text editor. Diese Markierungen weisen auf Probleme hin, die von Visual Studio in Ihrem Code gefunden wurden.These marks notify you of problems that Visual Studio detected in your code. Weitere Informationen zum Aktivieren oder Deaktivieren der Überprüfung finden Sie unter Optionen, Text-Editor, JavaScript, IntelliSense.For more information about how to enable or disable validation, see Options, Text Editor, JavaScript, IntelliSense.

Informationen zu den Überprüfungsregeln der XML-Manifestdatei in Ihrem Projekt finden Sie unter XML-Manifest für Office-Add-Ins.To review the validation rules of the XML manifest file in your project, see Office Add-ins XML manifest.

Debuggen des Codes für ein Excel-, PowerPoint- oder Word-Add-InDebug the code for an Excel, PowerPoint, or Word add-in

Sollte Ihr Add-In in dem Dokument, das nach dem Starten des Projekts in der Hostanwendung (Excel, PowerPoint oder Word) angezeigt wird, nicht zu sehen sein, starten Sie das Add-In manuell in der Hostanwendung.If your add-in isn't visible within the document that's displayed in the host application (Excel, PowerPoint, or Word) after you've started the project, manually launch the add-in in the host application. Ein Aufgabenbereich-Add-In können Sie beispielsweise starten, indem Sie auf dem Menüband der Registerkarte Start die Schaltfläche Aufgabenbereich anzeigen auswählen. Sobald Ihr Add-In in Excel, PowerPoint oder Word angezeigt wird, können Sie Ihren Code wie folgt debuggen:For example, launch your task pane add-in by choosing the Show Taskpane button in the ribbon of the Home tab. After your add-in is displayed in Excel, PowerPoint, or Word, you can debug your code by doing the following:

  1. Wählen Sie in Excel, PowerPoint oder Word die Registerkarte Einfügen und anschließend den Abwärtspfeil rechts neben Meine Add-Ins aus.In Excel, PowerPoint, or Word, choose the Insert tab and then choose the down-arrow located to the right of My Add-ins.

    Hervorgehobener Pfeil neben „Meine Add-Ins“ auf der Registerkarte „Einfügen“ des Menübands von Excel unter Windows

  2. Navigieren Sie in der Liste mit den verfügbaren Add-Ins zum Abschnitt Entwickler-Add-Ins, und wählen Sie Ihr Add-In aus, um es zu registrieren.In the list of available add-ins, find the Developer Add-ins section and select the your add-in to register it.

  3. Legen Sie in Visual Studio Haltepunkte in Ihrem Code fest.In Visual Studio, set breakpoints in your code.

  4. Interagieren Sie in Excel, PowerPoint oder Word mit Ihrem Add-In.In Excel, PowerPoint, or Word, interact with your add-in.

  5. Gehen Sie den Code anhand der Haltepunkte in Visual Studio nach Bedarf durch.As breakpoints are hit in Visual Studio, step through the code as needed.

Sie können Ihren Code ändern und die Auswirkungen dieser Änderungen in Ihrem Add-In überprüfen, ohne die Hostanwendung schließen und das Projekt neu starten zu müssen.You can change your code and review the effects of those changes in your add-in without having to close the host application and restart the project. Laden Sie nach dem Speichern Ihrer Codeänderungen einfach das Add-In in der Hostanwendung neu.After you save changes to your code, simply reload the add-in in the host application. Wenn Sie also beispielsweise ein Aufgabenbereich-Add-In neu laden möchten, wählen Sie die rechte obere Ecke des Aufgabenbereichs aus, um das Persönlichkeitsmenü zu aktivieren, und wählen Sie anschließend Neu laden aus.For example, reload a task pane add-in by choosing the top-right corner of the task pane to activate the personality menu and then choose Reload.

Debuggen des Codes für ein Outlook-Add-InDebug the code for an Outlook add-in

Öffnen Sie nach dem Starten des Projekts und nachdem Visual Studio Outlook gestartet hat, um Ihr Add-In zu hosten, eine E-Mail oder ein Terminelement.After you've started the project and Visual Studio launches Outlook to host your add-in, open an email message or appointment item.

Outlook aktiviert die Add-In für das Element, vorausgesetzt die Aktivierungskriterien sind erfüllt. Die Add-In-Leiste wird oben im Inspektorfenster oder im Lesebereich angezeigt, und Ihr Outlook-Add-In wird als Schaltfläche in der Add-In-Leiste angezeigt. Wenn Ihr Add-In über ein Add-In-Befehl verfügt, wird eine Schaltfläche im Menüband angezeigt, entweder die Standardregisterkarte oder eine benutzerdefinierte Registerkarte, und das Add-In wird nicht in der Add-In-Leiste angezeigt.Outlook activates the add-in for the item as long as the activation criteria are met. The add-in bar appears at the top of the Inspector window or Reading Pane, and your Outlook add-in appears as a button in the add-in bar. If your add-in has an add-in command, a button will appear in the ribbon, either in the default tab or a specified custom tab, and the add-in will not appear in the add-in bar.

Wählen Sie die Schaltfläche für Ihr Outlook-Add-In aus, um es anzuzeigen.To view your Outlook add-in, choose the button for your Outlook add-in. Wenn Ihr Add-In in Outlook angezeigt wird, können Sie Ihren Code wie folgt Debuggen:After your add-in is displayed in Outlook, you can debug your code by doing the following:

  1. Legen Sie in Visual Studio Haltepunkte in Ihrem Code fest.In Visual Studio, set breakpoints in your code.

  2. Interagieren Sie in Outlook mit Ihrem Add-In.In Outlook, interact with your add-in.

  3. Gehen Sie den Code anhand der Haltepunkte in Visual Studio nach Bedarf durch.As breakpoints are hit in Visual Studio, step through the code as needed.

Sie können Ihren Code ändern und die Auswirkungen dieser Änderungen in Ihrem Add-In überprüfen, ohne Outlook schließen und das Projekt neu starten zu müssen.You can change your code and review the effects of those changes in your add-in without having to close Outlook and restart the project. Öffnen Sie nach dem Speichern Ihrer Codeänderungen einfach das Kontextmenü für das Add-in (in Outlook), und wählen Sie Neu laden aus.After you save changes to your code, simply open the shortcut menu for the add-in (in Outlook), and then choose Reload.

Nächste SchritteNext steps

Wenn Ihr Add-In ordnungsgemäß funktioniert, lesen Sie Bereitstellen und Veröffentlichen Ihres Office-Add-Ins, um zu erfahren, wie Sie das Add-In an Benutzer verteilen können.After your add-in is working as desired, see Deploy and publish your Office Add-in to learn about the ways you can distribute the add-in to users.