Aktivieren oder Deaktivieren von Hyperlinkwarnungen in Office-Programmen

Einführung

In diesem Schritt-für-Schritt-Artikel wird beschrieben, wie Sie die Anzeige einer Warnmeldung jedes Mal aktivieren oder deaktivieren, wenn Sie in einem Microsoft Office-Programm auf einen Link klicken.

Weitere Informationen

Wichtig

Dieser Abschnitt, diese Methode bzw. diese Aufgabe enthält eine Beschreibung der Schritte zum Bearbeiten der Registrierung. Durch die falsche Bearbeitung der Registrierung können schwerwiegende Probleme verursacht werden. Daher ist es wichtig, bei der Ausführung der folgenden Schritte sorgfältig vorzugehen. Für zusätzlichen Schutz sichern Sie die Registrierung, bevor Sie sie ändern. Sie können die Registrierung wiederherstellen, wenn ein Problem auftritt. Weitere Informationen zum Sichern und Wiederherstellen der Registrierung finden Sie unter Sichern und Wiederherstellen der Registrierung in Windows.

Wenn Sie in Microsoft Office Anwendungen auf einen Link oder ein Objekt klicken, das mit einer ausführbaren Datei verknüpft ist, wird die folgende Warnmeldung angezeigt:

Opening "path/filename". 

Hyperlinks can be harmful to your computer and data. To protect your computer, click only those hyperlinks from trusted sources. Do you want to continue? 

Dieses Verhalten tritt unabhängig von den Einstellungen für die Sicherheitsstufe auf.

Hinweis

Um die Einstellungen für die Sicherheitsstufe zu finden, zeigen Sie im Menü "Extras" auf "Makro", und klicken Sie dann auf "Sicherheit".

Darüber hinaus wird beim Öffnen von TIFF-Bildern oder Microsoft Document Imaging (MDI)-Dateien die folgende Warnmeldung angezeigt:

Opening path/filename. 

Some files can contain viruses or otherwise be harmful to your computer. It is important to be certain that this file is from a trustworthy source. Would you like to open this file?

Diese Warnmeldung wird auch dann angezeigt, wenn Sie den in diesem Artikel beschriebenen Registrierungsschlüssel bereits implementiert haben. Diese Warnmeldung stammt aus der HLINK.dll Datei, wenn die Linknavigation behandelt wird. Sie können die Warnmeldung Microsoft Office Hyperlinks von der HLINK-Warnmeldung unterscheiden, indem Sie in der Warnmeldung nach Anführungszeichen um den Dateipfad suchen. Die Microsoft Office Nachricht enthält Anführungszeichen. Die HLINK-Nachricht enthält keine Anführungszeichen. Microsoft Office versucht zu ermitteln, ob der Dateityp selbst unsicher ist, indem er die Erweiterung, die Progid, die ClassID und den MIME-Typ des Dokuments überprüft.

Um die Hyperlinkwarnungen in Microsoft Office Programmen zu aktivieren oder zu deaktivieren, wenn eine https:// Adresse, eine notes:// Adresse oder eine ftp:// Adresse verwendet wird, müssen Sie einen neuen Registrierungsunterschlüssel erstellen. Gehen Sie dazu wie folgt vor:

  1. Klicken Sie auf Start und anschließend auf Ausführen.

  2. Geben Sie im Dialogfeld " Öffnen " "regedit" ein, und klicken Sie dann auf "OK".

    Hinweis

    • Sie müssen nur einen dieser Registrierungsunterschlüssel ändern. Sie müssen nicht beides ändern.
    • Wenn der Unterschlüssel "Sicherheit" bereits vorhanden ist, fahren Sie direkt mit Schritt 6 fort, nachdem Sie den Unterschlüssel "Sicherheit" ausgewählt haben.
  3. Suchen Sie den folgenden Registrierungsunterschlüssel, und wählen Sie ihn aus (wenn der Unterschlüssel nicht vorhanden ist, erstellen Sie ihn manuell): HKEY_CURRENT_USER\Software\Microsoft\Office\xx.0\Common

    Hinweis Ersetzen Sie in diesem Unterschlüssel "xx.0" durch 12.0 für Office 2007, 14.0 für Office 2010, 15.0 für Office 2013 und 16.0 für Office 2016 und höher.

  4. Klicken Sie auf den Registrierungsunterschlüssel, zeigen Sie im Menü "Bearbeiten" auf "Neu", und klicken Sie dann auf "Schlüssel".

  5. Geben Sie "Sicherheit" ein, und drücken Sie dann die EINGABETASTE, um die Taste zu benennen.

  6. Zeigen Sie im Menü Bearbeiten auf Neu, und klicken Sie anschließend auf DWORD-Wert.

  7. Geben Sie DisableHyperlinkWarning ein, und drücken Sie dann die EINGABETASTE, um den Eintrag zu benennen.

  8. Klicken Sie im rechten Bereich mit der rechten Maustaste auf "DeaktivierenHyperlinkWarning", und klicken Sie dann auf "Ändern".

  9. Klicken Sie im Dialogfeld "DWORD-Wert bearbeiten " auf " Dezimal", und geben Sie dann unter " Wertdaten" den Wert "1" oder "0" ein.

    Hinweis

    Der Wert 0 aktiviert die Hyperlinkwarnung. Der Wert 1 deaktiviert die Hyperlinkwarnung.

  10. Klicken Sie auf OK.

  11. Beenden Sie den Registrierungs-Editor.

Führen Sie die folgenden Schritte aus, um die Anzeige von Sicherheitswarnungen für ein bestimmtes Protokoll zu deaktivieren:

  1. Klicken Sie auf Start und dann auf Ausführen, geben Sie „regedit“ ein und klicken Sie auf OK.

  2. Suchen Sie den folgenden Registrierungsunterschlüssel:

    HKEY_CURRENT_USER\Software\Policies\Microsoft\Office\xx.0\Common\Security\Trusted Protocols\All Applications

    Hinweis Ersetzen Sie in diesem Unterschlüssel "xx.0" durch 12.0 für Office 2007, 14.0 für Office 2010, 15.0 für Office 2013 und 16.0 für Office 2016 und höher.

  3. Klicken Sie auf den Unterschlüssel "Alle Anwendungen".

  4. Zeigen Sie im Menü Bearbeiten auf Neu, und klicken Sie dann auf Schlüssel.

  5. Geben Sie den Namen des Protokolls ein, das Sie ausschließen möchten. Wenn Sie beispielsweise die Anzeige einer Sicherheitswarnung für das Protokoll "Notes:" deaktivieren möchten, geben Sie "Notes:" ein.

    Hinweis Stellen Sie sicher, dass Sie den Doppelpunkt (:) Charakter.

  6. Drücken Sie die EINGABETASTE.

  7. Beenden Sie den Registrierungs-Editor.

Wenn Weiterhin eine Warnmeldung angezeigt wird

Nachdem Sie Warnmeldungen deaktiviert haben, erhalten Sie möglicherweise weiterhin eine Warnmeldung von Microsoft Windows. Wenn Sie weiterhin eine Warnmeldung erhalten, nachdem Sie die Schritte in diesem Artikel ausgeführt haben, verwenden Sie eine der folgenden Methoden, um das Problem zu beheben.

Hinweis

Methode 1 gilt nur für Windows XP und frühere Versionen von Windows. Verwenden Sie für Windows Vista und für spätere Versionen von Windows Methode 2.

Methode 1: Deaktivieren der Option "Nach dem Download öffnen bestätigen" für den Dateityp, den Sie öffnen möchten

  1. Doppelklicken Sie auf "Arbeitsplatz".
  2. Klicken Sie im Menü "Extras " auf "Ordneroptionen".
  3. Wählen Sie auf der Registerkarte " Dateitypen " im Feld "Registrierte Dateitypen " die entsprechende Dateinamenerweiterung (z. B. WMV) aus, und klicken Sie dann auf "Erweitert".
  4. Aktivieren Sie das Kontrollkästchen " Nach download öffnen bestätigen ", und klicken Sie dann auf "OK".
  5. Klicken Sie im Dialogfeld "Ordneroptionen " auf "Schließen".

Methode 2: Ändern des Registrierungsunterschlüssels HKEY_CLASSES_ROOT\<CLSID>\EditFlags

Verwenden Sie diese Methode, wenn sich die Warnmeldung auf mehrere Computer auswirkt.

Führen Sie die folgenden Schritte aus, um die Warnmeldung zu deaktivieren:

  1. Klicken Sie auf Start und dann auf Ausführen, geben Sie „regedit“ ein und klicken Sie auf OK.

  2. Suchen Sie den folgenden Registrierungsunterschlüssel:

    \<CLSID>HKEY_CLASSES_ROOT\EditFlags

    Wenn die Dateinamenerweiterung beispielsweise WMV ist, wählen Sie HKEY_CLASSES_ROOT\WMVFile\EditFlags

  3. Klicken Sie auf "BearbeitenFlags" und dann im Menü "Bearbeiten**" auf "Umbenennen**".

  4. Geben Sie OldEditFlags ein, und drücken Sie dann die EINGABETASTE.

  5. Zeigen Sie im Menü "Bearbeiten" auf "Neu", und klicken Sie dann auf "DWORD-Wert".

  6. Geben Sie EditFlags ein, und drücken Sie dann die EINGABETASTE.

  7. Klicken Sie im Menü Bearbeiten auf Ändern.

  8. Klicken Sie im Dialogfeld "DWORD-Wert bearbeiten" unter "Basis" auf "Hexadezimal".

  9. Geben Sie "10000" ein, und klicken Sie dann auf "OK".

Führen Sie die folgenden Schritte aus, um die Warnmeldung erneut zu aktivieren:

  1. Klicken Sie auf Start und dann auf Ausführen, geben Sie „regedit“ ein und klicken Sie auf OK.

  2. Suchen Sie den folgenden Registrierungsunterschlüssel:

    \<CLSID>HKEY_CLASSES_ROOT\EditFlags

  3. Klicken Sie auf "BearbeitenFlags" und dann im Menü "Bearbeiten" auf "Ändern".

  4. Geben Sie "0" ein, und klicken Sie dann auf "OK".

Hinweis

Selbst nachdem Sie diese Schritte ausgeführt haben, wird die Warnmeldung angezeigt, wenn Sie Dateien in der geschützten Ansicht öffnen.

Wurde das Problem behoben?

Testen Sie, ob das Problem behoben ist. Wenn das Problem beseitigt ist, sind Sie mit diesem Abschnitt fertig. Wenn das Problem noch nicht behoben ist, wenden Sie sich an den Support.