Informationen zum Outlook AutoVervollständigen-Liste

Ursprüngliche KB-Nummer:   2199226

Zusammenfassung

Dieser Artikel enthält eine Übersicht über die Microsoft Outlook AutoVervollständigen-Liste (auch als Outlook AutoVervollständigen-Liste bezeichnet). Zusätzlich zur Beschreibung des Features enthält dieser Artikel weitere Informationen und schrittweise Anweisungen für fortgeschrittene Benutzer zum Verwalten der Liste.

Weitere Informationen

Outlook verwaltet die AutoVervollständigen-Liste. Die Liste wird sowohl vom feature für die automatische Namensüberprüfung als auch vom Feature für die automatische Vervollständigung verwendet. Die AutoVervollständigen-Liste, die auch als Spitznamencache bezeichnet wird, wird automatisch generiert, wenn Sie E-Mail-Nachrichten von Outlook senden. Die Liste enthält SMTP-Adressen, LegacyExchangeDN-Einträge und Anzeigenamen für Personen, an die Sie zuvor E-Mails gesendet haben.

Hinweis

Die AutoVervollständigen-Liste für Outlook ist spezifisch für Outlook und wird nicht von Outlook Web App (OWA) freigegeben. OWA verwaltet eine eigene AutoVervollständigen-Liste.

Die folgenden Abschnitte enthalten Informationen zum AutoVervollständigen-Feature.

Grenzwert für die Anzahl von Einträgen

Outlook beschränkt die Anzahl der Einträge, die Sie in der AutoVervollständigen-Liste speichern können. Nachdem Sie diesen Grenzwert erreicht haben, verwendet Outlook einen internen Algorithmus, um die besten Namen zu ermitteln, die aus der Liste entfernt werden sollen. Dies erfolgt basierend auf einer Verwendungsgewichtung. Daher finden Sie möglicherweise einige Namen, die unerwartet aus Ihrem Spitznamencache entfernt wurden. Es gibt zwei allgemeine Ansätze, die Sie verwenden können, um diese Situation zu vermeiden:

  1. Sie können AutoVervollständigen-Listeneinträge, die Sie nicht mehr benötigen, proaktiv entfernen. Dies ist der bevorzugte Ansatz. Weitere Informationen hierzu finden Sie im Abschnitt "Entfernen von AutoVervollständigen-Listeneinträgen nacheinander".
  2. Sie können den Grenzwert für den Spitznamencache erhöhen. Da diese Konfiguration nicht getestet wird, wird sie nicht empfohlen. Wenn Sie über einen größeren Cache für Spitznamen verfügen, können Sie auch eine größere Anzahl von zwischengespeicherten Einträgen verlieren, wenn ihr Spitznamencache aufgrund einer Beschädigung nicht mehr verwendet werden kann. Weitere Informationen zum Erhöhen des Grenzwerts finden Sie im Abschnitt "Ändern des Grenzwerts für die AutoVervollständigen-Liste".

Die Grenzwerte sind wie folgt:

  • Outlook 2019: 1.000 Einträge
  • Outlook 2016: 1.000 Einträge
  • Outlook 2013: 1.000 Einträge
  • Outlook 2010: 1.000 Einträge
  • Outlook 2007: 2.000 Einträge
  • Outlook 2003: 1.000 Einträge

So aktivieren Sie das AutoVervollständigen-Feature

In diesem Abschnitt wird beschrieben, wie Sie das AutoVervollständigen-Feature aktivieren oder deaktivieren.

Outlook 2010, Outlook 2013, Outlook 2016 und Outlook 2019

Gehen Sie folgendermaßen vor, um auf die AutoVervollständigen-Einstellung zuzugreifen:

  1. Wählen Sie im Menü "Datei" die Option "Optionen" aus.

  2. Wählen Sie die Registerkarte "E-Mail" aus.

  3. Scrollen Sie ungefähr in der Mitte nach unten, bis Nachrichten gesendet werden. Stellen Sie sicher, dass die AutoVervollständigen-Liste zum Vorschlagen von Namen bei der Eingabe in die Zeilen An, Cc und Bcc aktiviert ist.

    Fenster "Nachrichten senden", "AutoVervollständigen"-Liste verwenden, um Namen vorzuschlagen, wenn sie in das Kontrollkästchen "An", "Cc" und "Bcc" einchecken.

Outlook 2003 und Outlook 2007

Führen Sie die folgenden Schritte aus, um auf die AutoVervollständigen-Einstellungen zuzugreifen:

  1. Wählen Sie "Extras" und dann "Optionen" aus.

  2. Wählen Sie die Schaltfläche "E-Mail-Optionen" aus.

  3. Wählen Sie die Schaltfläche "Erweiterte E-Mail-Optionen" aus.

  4. Stellen Sie sicher, dass das Feld "Namen vorschlagen" beim Ausfüllen der Felder "An", "Cc" und "Bcc" aktiviert ist. (Der Screenshot für diesen Schritt folgt.)

    Fenster "Erweiterte E-Mail-Optionen", "Namen vorschlagen" beim Ausfüllen der Felder "An", "Cc" und "Bcc" aktiviert

Importieren von NK2-Dateien in Outlook 2010, Outlook 2013, Outlook 2016 und Outlook 2019

Microsoft Office Outlook 2007 und frühere Versionen speichern die AutoVervollständigen-Liste in einer Spitznamendatei (.nk2) auf dem Datenträger. Outlook 2010, Outlook 2013, Outlook 2016 und Outlook 2019 speichern Sie die AutoVervollständigen-Liste als ausgeblendete Nachricht in Ihrem primären Nachrichtenspeicher. Outlook 2010, Outlook 2013, Outlook 2016 und Outlook 2019 können Sie die älteren NK2-Dateien importieren.

Weitere Informationen zum Importieren von NK2-Dateien in Outlook 2010 finden Sie unter Import Auto-Complete List from another computer.

Kopieren der AutoVervollständigen-Liste

Die Schritte zum Exportieren und Importieren der AutoVervollständigen-Liste unterscheiden sich je nach der Version von Outlook, die Sie verwenden.

Outlook 2010, Outlook 2013, Outlook 2016 und Outlook 2019

Führen Sie die folgenden Schritte aus, um die AutoVervollständigen-Liste zu kopieren:

Schritt 1

Führen Sie die folgenden Schritte aus, um die AutoVervollständigen-Postfachnachricht zu exportieren:

  1. Beenden Sie Outlook, und schließen Sie dann Outlook Web Access oder Outlook Web App (OWA) auf allen Arbeitsstationen, die mit Ihrem Postfach verbunden sind.
  2. Laden Sie MFCMAPIherunter, und installieren Sie es.
  3. Führen Sie mfcmapi.exe aus.
  4. Klicken Sie im Menü Sitzung auf Anmeldung.
  5. Wenn Sie zur Eingabe eines Profils aufgefordert werden, wählen Sie den gewünschten Profilnamen und dann OK aus.
  6. Suchen Sie im oberen Bereich die Zeile, die Ihrem Postfach entspricht, und doppelklicken Sie dann darauf.
  7. Erweitern Sie im linken Navigationsbereich den Stammcontainer und dann den oberen Rand der Informationen Store oder IPM_SUBTREE.
  8. Klicken Sie mit der rechten Maustaste auf den Ordner "Posteingang", und wählen Sie "Zugeordnete Inhaltstabelle öffnen" aus. Mit dieser Aktion wird ein neues MFCMAPI-Fenster geöffnet, das verschiedene Eigenschaften enthält.
  9. Klicken Sie in der Spalte "Betreff" mit der rechten Maustaste auf das Element, das den Betreff IPM.ConfigUration enthält. AutoVervollständigen, und klicken Sie dann auf "Nachricht exportieren". Mit dieser Aktion wird das Fenster "Nachricht in Datei speichern" geöffnet.
  10. Wählen Sie in der Dropdownliste MSG-Datei (UNICODE) und dann OK aus.
  11. Wählen Sie einen Ordnerspeicherort aus, an dem Sie die Nachricht speichern möchten, und wählen Sie dann "Speichern" aus. Beachten Sie diesen Speicherort.

Schritt 2

Führen Sie die folgenden Schritte aus, um die AutoVervollständigen-Postfachnachricht zu importieren.

  1. Beenden Sie Outlook, und schließen Sie dann Outlook Web Access oder Outlook Web App (OWA) auf allen Arbeitsstationen, die mit Ihrem Postfach verbunden sind.

  2. Laden Sie MFCMAPIherunter, und installieren Sie es.

  3. Führen Sie mfcmapi.exe aus.

  4. Klicken Sie im Menü Sitzung auf Anmeldung.

  5. Wenn Sie zur Eingabe eines Profils aufgefordert werden, wählen Sie den gewünschten Profilnamen und dann OK aus.

  6. Suchen Sie im oberen Bereich die Zeile, die Ihrem Postfach entspricht, und doppelklicken Sie dann darauf.

  7. Erweitern Sie im linken Navigationsbereich Stamm - Postfach und dann oben Store oder IPM_SUBTREE.

  8. Klicken Sie mit der rechten Maustaste auf den Ordner "Posteingang", und wählen Sie "Zugeordnete Inhaltstabelle öffnen" aus. Mit dieser Aktion wird ein neues MFCMAPI-Fenster geöffnet, das verschiedene Eigenschaften enthält.

  9. Um doppelte Einträge zu vermeiden, müssen Sie die vorhandene AutoVervollständigen-Nachricht löschen.

    Hinweis

    Vor dem Löschen der IPM.ConfigUration. AutoVervollständigen Nachricht, you must export the message by using the steps in the How to copy the AutoComplete list section.

    Führen Sie die folgenden Schritte aus, um die vorhandene AutoVervollständigen-Nachricht zu löschen:

    1. Suchen Sie in der Spalte Betreff das Element mit der Betreff-IPM.Config-Uration. AutoVervollständigen.
    2. Klicken Sie mit der rechten Maustaste auf das Element, und wählen Sie dann "Nachricht löschen" aus. Dadurch wird das Fenster "Element löschen" geöffnet.
    3. Wählen Sie in der Dropdownliste die Option "Dauerhafte Löschung" aus (bei Unterstützung wird die Aufbewahrung gelöschter Elemente gelöscht), und wählen Sie dann "OK" aus.
  10. Wählen Sie im Menü "Ordner" die Option "Importieren" und dann "Aus MSG" aus.

  11. Suchen Sie die MSG-Datei, die Sie in Schritt 11 des Abschnitts "Kopieren der AutoVervollständigen-Liste" erstellt haben, und wählen Sie dann OK aus.

  12. Wählen Sie im angezeigten Fenster "MSG laden" in der Liste "Formatvorlagen laden" die Option "Nachricht laden" in den aktuellen Ordner aus, und wählen Sie dann "OK" aus.

Die AutoVervollständigen-Informationen werden aus der IPM.Config-Uration importiert. Autocomplete_ <hexadecimal code> MSG, wobei der Platzhalter <hexadecimal code> eine lange Zeichenfolge von Zahlen und Buchstaben darstellt.

Outlook 2007 und Outlook 2003

Die Schritte zum Kopieren der AutoVervollständigen-Liste in Outlook 2003 und Outlook 2007 unterscheiden sich. Dies liegt daran, dass Outlook 2003 und Outlook 2007 die AutoVervollständigen-Liste in der NK2-Datei speichern.

Informationen zum Kopieren der AutoVervollständigen-Liste in Outlook 2007 finden Sie unter Importieren oder Kopieren der AutoVervollständigen-Liste auf einen anderen Computer.

So entfernen Sie AutoVervollständigen-Listeneinträge nacheinander

Gehen Sie folgendermaßen vor, um Einträge aus dem AutoVervollständigen-Cache nacheinander zu entfernen:

  1. Öffnen Sie eine neue E-Mail-Nachricht.
  2. Geben Sie die ersten Zeichen des AutoVervollständigen-Eintrags ein, den Sie entfernen möchten.
  3. Wenn der Eintrag in der Liste der Vorschläge angezeigt wird, bewegen Sie den Mauszeiger über den Vorschlag, bis er hervorgehoben wird, aber wählen Sie ihn nicht aus.
  4. Wenn das X-Symbol neben dem hervorgehobenen Vorschlag angezeigt wird, wählen Sie X aus, um den Eintrag aus der Liste zu entfernen, oder drücken Sie die Löschtaste auf der Tastatur.

Wenn Sie X auswählen, wird verhindert, dass dieser Eintrag (Name) erneut in der AutoVervollständigen-Liste angezeigt wird, aber nicht aus Ihrem Konto entfernt wird. Dieser Eintrag kann in anderen Bereichen in Outlook (z. B. Suchfeldern) weiterhin angezeigt werden.

Hinweis

Wenn Sie einer Person eine neue E-Mail senden, nachdem Sie ihren Namen aus der AutoVervollständigen-Liste entfernt haben, werden deren Informationen wieder zur Liste hinzugefügt.

So löschen Sie die gesamte AutoVervollständigen-Liste

In diesem Abschnitt wird erläutert, wie Sie die AutoVervollständigen-Liste löschen.

Outlook 2010, Outlook 2013, Outlook 2016 und Outlook 2019

Verwenden Sie eine der folgenden beiden Methoden, um die AutoVervollständigen-Liste zu löschen.

Methode 1

  1. Öffnen Sie Outlook.

  2. Klicken Sie auf der Registerkarte Datei auf Optionen.

  3. Wählen Sie die Registerkarte "E-Mail" aus.

  4. Wählen Sie unter "Nachrichten senden" die Option "Leere AutoVervollständigen-Liste" aus.

    Outlook Optionsfenster

  5. Wählen Sie Ja aus.

Methode 2

Starten Sie Outlook mithilfe der Option /CleanAutoCompleteCache. Führen Sie hierzu folgende Schritte aus:

  1. Wählen Sie Start und dann Ausführen aus.
  2. Geben Sie Outlook.exe /CleanAutoCompleteCache ein.

Hinweis

Wenn Outlook nicht am Standardspeicherort installiert ist, müssen Sie auf den Pfad der Outlook.exe zeigen.

Outlook 2007 und Outlook 2003

Um die AutoVervollständigen-Liste in Outlook 2003 und Outlook 2007 zu löschen, müssen Sie die NK2-Datei manuell löschen. Führen Sie die folgenden Schritte aus, um die NK2-Datei zu löschen:

  1. Beenden Sie Outlook.

  2. Wählen Sie "Start" und dann "Computer" aus.

  3. Wählen Sie "Organisieren" und dann "Ordner" und "Suchoptionen" aus.

  4. Wählen Sie auf der Registerkarte Ansicht ausgeblendete Dateien, Ordner und Laufwerke anzeigen aus.

  5. Wählen Sie OK aus.

  6. Wählen Sie "Start", "Alle Programme", "Zubehör" und dann "Ausführen" aus.

  7. Geben Sie im Dialogfeld Ausführen den folgenden Befehl ein (einschließlich der Anführungszeichen), und wählen Sie dann OK aus:

    C:\ \Benutzerbenutzername\AppData\Roaming\Microsoft\Outlook

    Hinweis

    Der Benutzername in diesem Pfad ist der Name des aktuell angemeldeten Windows Benutzers.

  8. Klicken Sie mit der rechten Maustaste auf die . NK2-Datei mit dem Namen des Profils, das Sie zurücksetzen möchten, und wählen Sie dann Umbenennen aus.

  9. Benennen Sie die Datei in den Profilnamen.bak um, und drücken Sie dann die EINGABETASTE.

  10. Starten Sie Outlook.

Probleme mit dem AutoVervollständigen-Cache

In diesem Abschnitt werden bekannte Probleme beschrieben, die beim AutoVervollständigen-Cache auftreten können. Der AutoVervollständigen-Cache kann im Laufe der Zeit beschädigt werden und speichert möglicherweise keine neuen Einträge. In diesem Fall können Sie versuchen, einzelne Einträge aus der Liste zu entfernen. Informationen hierzu finden Sie im Abschnitt "Entfernen von AutoVervollständigen-Listeneinträgen nacheinander". Wenn das Problem dadurch nicht behoben wird, kann die gesamte AutoVervollständigen-Liste zurückgesetzt werden. Informationen hierzu finden Sie im Abschnitt "Löschen der gesamten AutoVervollständigen-Liste".

Ändern des Grenzwerts für die AutoVervollständigen-Liste

Da diese Konfiguration nicht getestet wird, wird sie nicht empfohlen. Wenn Sie über eine größere AutoVervollständigen-Liste verfügen, können Sie auch eine größere Anzahl von zwischengespeicherten Einträgen verlieren, wenn der AutoVervollständigen-Cache aufgrund einer Beschädigung nicht mehr verwendet werden kann. Aufgrund dieses Haftungsausschlusses können Sie die folgenden Registrierungsdaten verwenden, um das Limit der AutoVervollständigen-Liste in Outlook zu erhöhen.

Wichtig

Dieser Abschnitt, diese Methode bzw. diese Aufgabe enthält eine Beschreibung der Schritte zum Bearbeiten der Registrierung. Durch die falsche Bearbeitung der Registrierung können schwerwiegende Probleme verursacht werden. Daher ist es wichtig, bei der Ausführung der folgenden Schritte sorgfältig vorzugehen. Für zusätzlichen Schutz sichern Sie die Registrierung, bevor Sie sie ändern. Sie können die Registrierung wiederherstellen, wenn ein Problem auftritt. Weitere Informationen zum Sichern und Wiederherstellen der Registrierung finden Sie unter Sichern und Wiederherstellen der Registrierung in Windows.

  1. Beenden Sie Outlook.

  2. Starten Sie den Registrierungs-Editor.

    • Drücken Sie in Windows 8.x die Windows Taste, geben Sie regedit ein, und drücken Sie dann die EINGABETASTE.
    • Wählen Sie in Windows 7 und Windows Vista "Start" aus, geben Sie "regedit" in das Feld "Suche starten" ein, und drücken Sie dann die EINGABETASTE.
  3. Klicken Sie auf den folgenden Registrierungsunterschlüssel:
    HKEY_CURRENT_USER\Software\Microsoft\Office\<x.0>\Outlook\AutoNameCheck

    Hinweis

    Der Platzhalter <x.0-> in diesem Registrierungsunterschlüssel stellt Ihre Version von Microsoft Office dar. Verwenden Sie den entsprechenden Wert aus der folgenden Liste.

    • Outlook 2019 = 16,0
    • Outlook 2016 = 16,0
    • Outlook 2013 = 15,0
    • Outlook 2010 = 14,0
    • Outlook 2007 = 12,0
    • Outlook 2003 = 11,0
  4. Zeigen Sie im Menü "Bearbeiten" auf "Neu", und wählen Sie dann den DWORD-Wert aus.

  5. Geben Sie MaxNickNames ein, und drücken Sie dann die EINGABETASTE.

  6. Wählen Sie im Menü "Bearbeiten" die Option "Ändern" aus.

  7. Geben Sie den neuen Wert für den Grenzwert ein, und wählen Sie dann OK aus.

    Hinweis

    • Stellen Sie sicher, dass Sie die Zahl im Dezimalformat eingeben. Dies ist das richtige Formular, in das die Nummer eingegeben werden soll.
    • Versuchen Sie, den Grenzwert nur um einen bestimmten Betrag zu erhöhen, um den neuen Grenzwert zu testen. Um beispielsweise eine Erhöhung des Grenzwerts in Outlook 2013 um 20 Prozent zu erstellen, geben Sie 1200 für den MaxNickNames Wert an.
  8. Beenden Sie den Registrierungs-Editor.

  9. Starten Sie Outlook.

Hinweis

Der MaxNickNames Registrierungswert gibt lediglich den Grenzwert an, der nicht standardmäßig ist. Daher können Sie diesen Wert auch verwenden, um den Grenzwert des Spitznamencaches zu senken.