Beim Anzeigen einer Liste von Aktivitätsansichten in Microsoft Dynamics CRM 2011 werden möglicherweise doppelte Aktivitätsansichten angezeigt.

Dieser Artikel bietet eine Lösung für ein Problem, bei dem doppelte Aktivitätsansichten angezeigt werden können, wenn Sie eine Liste der Aktivitätsansichten in Microsoft Dynamics CRM 2011 anzeigen.

Gilt für: Microsoft Dynamics CRM 2011
Ursprüngliche KB-Nummer: 2637480

Problembeschreibung

Beim Anzeigen einer Liste von Aktivitätsansichten in Microsoft Dynamics CRM 2011 werden Ansichten möglicherweise als dupliziert angezeigt. Wenn Sie zu Einstellungen navigieren, Anpassungen auswählen und System anpassen auswählen, wird die Standardlösung angezeigt. Wählen Sie dann Entitäten aus, wählen Sie die Entität aus, in der die duplizierte Ansicht angezeigt wird, und wählen Sie Ansichten aus. Die vollständige Liste der Ansichten für das System wird angezeigt. Die duplizierten Sichten verfügen über ein Beschreibungstag von (zur asynchronen Verwendung).

Ursache

Für die Ansichten wurde irgendwann der Wert des Abfragetyps geändert. Dies könnte sich im aktuellen System befinden oder während eines Imports von Anpassungen aus einer separaten Umgebung aktualisiert worden sein. Der Abfragetypwert in der customization.xml-Datei wird als 0 anstelle von 1024 angezeigt.

Lösung

Gehen Sie folgendermaßen vor, um dieses Problem zu lösen:

  1. Navigieren Sie zu Einstellungen, und wählen Sie dann im Abschnitt Anpassung die Option Lösungen aus.
  2. Wählen Sie für eine neue Lösung Neu aus, und geben Sie Werte für alle erforderlichen Felder an. Speichern Sie dann die Projektmappe.
  3. Wählen Sie Vorhandene hinzufügen aus, und fügen Sie die Entität oder Entitäten hinzu, die die Symptome anzeigen.
  4. Speichern Sie die Projektmappe, und wählen Sie dann Projektmappe exportieren aus, und speichern Sie die Datei.
  5. Extrahieren Sie den Inhalt der erstellten ZIP-Datei, und öffnen Sie die customizations.xml Datei.
  6. Suchen Sie dann nach den duplizierten Ansichten. Dies kann einfach durch die Suche nach für die asynchrone Verwendung erfolgen.
  7. Ändern Sie dann den wert querytype so, dass 1024 anstelle von 0 gelesen wird.
  8. Wiederholen Sie die Schritte 6 und 7 für alle Ansichten, die als Duplikate angezeigt werden.
  9. Speichern Sie die customizations.xml-Datei.
  10. Zippen Sie die extrahierten Dateien erneut, und importieren Sie sie wieder in Microsoft Dynamics CRM.
  11. Veröffentlichen Sie die Änderungen für alle betroffenen Entitäten.

Weitere Informationen

Das System ist so konzipiert, dass Ansichten mit dem Abfragetyp 1024 auf der Benutzeroberfläche ignoriert werden.