Fehler beim Synchronisieren von Microsoft Office Outlook mit dem Microsoft Dynamics CRM Server

Dieser Artikel bietet eine Lösung für das Problem, dass Sie Microsoft Office Outlook aufgrund des Fehlers Sie haben bereits Microsoft CRM Client für Outlook auf einem anderen Computer installiert nicht mit dem Microsoft Dynamics CRM-Client für Outlook synchronisieren können.

Gilt für: Microsoft Dynamics CRM 2011
Ursprüngliche KB-Nummer: 953774

Problembeschreibung

Sie installieren den Microsoft Dynamics CRM-Client für Microsoft Office Outlook mithilfe des Lastenausgleichs und eines Roamingprofils. Anschließend verbinden Sie den Client mit einem Server und definieren ihn als Synchronisierungsclient. Als Nächstes verbinden Sie den Client mit einem anderen Server als derselbe Benutzer. Wenn Sie versuchen, Outlook mit dem Microsoft Dynamics CRM-Client für Outlook zu synchronisieren, wird die folgende Fehlermeldung angezeigt:

Sie haben bereits Microsoft CRM Client für Outlook auf einem anderen Computer installiert. Nur ein Clientcomputer pro Benutzer kann den automatischen Prozess ausführen, der Massenupdates von Outlook-Elementen mit Mic durchführt. CRM-Daten. Dieser Client sollte der Computer sein, der am häufigsten online ist (z. B. ein Desktopcomputer) oder der primäre Computer des Benutzers. Um den Synchronisierungsclient zu ändern, klicken Sie im Menü CRM auf Optionen und dann auf die Registerkarte Synchronisieren.

Ursache

Dieses Problem tritt auf, weil der HKEY_CURRENT_USER (HKCU) Registrierungsschlüssel nicht ordnungsgemäß kopiert wird, wenn Sie in einem Roamingprofilszenario eine Verbindung mit einem neuen Server herstellen.

Der Synchronisierungsclient wird durch den outlooksyncsubscriptionid Registrierungseintrag und den outlooksyncclientid Registrierungseintrag bestimmt. Wenn die Registrierungseinträge im HKCU Registrierungsschlüssel nicht vorhanden sind, wird der Client nicht als synchronisierter Client betrachtet.

Lösung

Gehen Sie wie folgt vor, um das Problem zu beheben:

  1. Überprüfen Sie, ob der outlooksyncsubscriptionid Registrierungseintrag und der outlooksyncclientid Registrierungseintrag im HKCU\software\microsoft\mscrmclient Registrierungsschlüssel vorhanden sind, wenn Sie eine Verbindung mit einem neuen Server herstellen.
  2. Wenn die Registrierungseinträge nicht im HKCU\software\microsoft\mscrmclient Registrierungsschlüssel enthalten sind, überprüfen Sie, ob eine der folgenden Gruppenrichtlinie-Objekteinstellungen (GPO) aktiviert ist.
    • Verhindern der Weitergabe von Roamingprofiländerungen an den Server
    • Nur lokale Benutzerprofile zulassen
  3. Wenn die GPO-Einstellungen aktiviert sind, deaktivieren Sie sie.