Fehler "ROI.EXE funktioniert nicht mehr" in Microsoft Dynamics SL

Dieser Artikel bietet eine Lösung für einen Fehler, der auftritt, wenn Sie versuchen, einen Bericht in Microsoft Dynamics SL 2011 zu drucken.

Gilt für: Microsoft Dynamics SL 2011, Microsoft Dynamics SL 2011 Service Pack 1
Ursprüngliche KB-Nummer: 2721084

Problembeschreibung

Wenn Sie versuchen, einen Bericht in Microsoft Dynamics SL 2011 zu drucken, erhalten Sie die folgende Fehlermeldung:

ROI.EXE funktioniert nicht mehr

Ursache

Der RI_ID-Wert in der RPTRUNTIME-Tabelle hat den Grenzwert von 32.767 überschritten.

Lösung

Löschen Sie die Datensätze in der RPTRUNTIME-Tabelle, um den RI_ID Wert wieder auf 1 zurückzusetzen. Gehen Sie dazu wie folgt vor:

  1. Vergewissern Sie sich, dass sich alle Benutzer bei Microsoft Dynamics SL abgemeldet haben.

  2. Starten Sie Microsoft SQL Server Management Studio.

  3. Führen Sie die folgende Anweisung für die SL System-Datenbank und die SL-Anwendungsdatenbank(en) aus.

    delete from rptruntime
    

Weitere Informationen

Die TABELLE RPTRUNTIME enthält temporäre Informationen, die sich auf einen aktiven Druckprozess beziehen. In der Regel ist diese Tabelle leer, wenn keine Benutzer einen Bericht ausführen. Gelegentlich kann ein Datensatz in dieser Tabelle gestrandet sein, was die Wahrscheinlichkeit erhöhen kann, dass die RI_ID Werte maximal überschritten werden.