Fehler "Crystal Print Engine Error: Failed to open a rowset" (Crystal Print Engine-Fehler: Fehler beim Öffnen eines Rowsets beim Drucken eines Berichts in Microsoft Dynamics SL)

Dieser Artikel enthält Lösungen für Fehler, die auftreten, wenn Sie versuchen, einen Bericht in Microsoft Dynamics SL zu drucken.

Gilt für: Microsoft Dynamics SL
Ursprüngliche KB-Nummer: 905310

Problembeschreibung

Wenn Sie versuchen, einen Bericht in Microsoft Dynamics SL oder in Microsoft Business Solutions - Solomon zu drucken, erhalten Sie eine Fehlermeldung, die dem folgenden Beispiel ähnelt:

Crystal Reports Hilfsanwendung für Solomon IV

Der Druckauftrag kann nicht gestartet werden.

Bericht: Laufwerk :\Programme\Solomon\Module_Code\XXXXX. RPT Crystal Print Engine-Fehler: 723 - Fehler in Laufwerk :\Programme\Solomon\Module_Code\XXXXX. RPT:

Fehler beim Öffnen eines Rowsets.

Hinweis

In dieser Fehlermeldung stellt Drive das Laufwerk dar, auf dem Sie Microsoft Dynamics SL installiert haben, Module_Code den Modulcode, der dem Microsoft Dynamics SL-Modul entspricht, in dem sich der Bericht befindet, und XXXXX stellt den Dateinamen des Berichts dar.

Ursache

Dieses Problem tritt aus einem oder mehreren der folgenden Gründe auf.

Ursache 1

Der Bericht enthält Notizen. Siehe Auflösung 1.

Ursache 2

Sie haben Microsoft Solomon 6.0 installiert, und der Bericht, der den Fehler verursacht, ist die Kontoverteilung (01.ACC. DI) melden. Siehe Auflösung 2.

Ursache 3

Der Bericht ist ein benutzerdefinierter Bericht, der eine Vorverarbeitung verwendet. Siehe Auflösung 3.

Ursache 4

Die Open DataBase Connectivity (ODBC) Data Source Names (DSNs) fehlen oder sind beschädigt. Siehe Auflösung 4.

Ursache 5

Die Option zum Verwenden von ANSI-Bezeichnern in Anführungszeichen ist nicht ausgewählt. Siehe Auflösung 5.

Ursache 6

Auf dem Computer, auf dem Microsoft SQL Server ausgeführt wird, steht nicht genügend freier Speicherplatz zur Verfügung, auf dem die Microsoft Dynamics SL-Datenbanken oder die Datenbanken microsoft Business Solutions – Solomon gehostet werden. Siehe Auflösung 6.

Lösung

Verwenden Sie die entsprechende Lösung, um dieses Problem zu beheben.

Lösung 1

Wenn Sie die Fehlermeldung erhalten, wenn Sie versuchen, einen Bericht zu drucken, der Notizen enthält, aktivieren Sie das Kontrollkästchen Eindeutige Datensätze auswählen im Menü Datenbank in Crystal Reports for Solomon.

Lösung 2

Wenn Sie die Fehlermeldung nur erhalten, wenn Sie versuchen, die Kontoverteilung (01.ACC. DI) melden und Microsoft Solomon 6.0 installiert haben, ersetzen Sie die Datei 01acctdi.rpt, die sich in Ihrer Installation befindet, indem Sie die Datei 01acctdi.rpt von der Microsoft Solomon 5.5-Installations-CD verwenden.

Lösung 3

Wenn Sie die Fehlermeldung erhalten, wenn Sie versuchen, einen benutzerdefinierten Bericht zu drucken, der eine Vorverarbeitung verwendet, verwenden Sie eine der folgenden Methoden.

Methode 1

Fügen Sie den benutzerdefinierten Bericht als separates Element in der Microsoft Dynamics SL-Menüstruktur hinzu.

Methode 2

Fügen Sie den benutzerdefinierten Bericht als neues Berichtsformat an einen vorhandenen Bericht an, der keine Vorverarbeitung verwendet. Führen Sie die folgenden Schritte aus, um den benutzerdefinierten Bericht anzufügen:

  1. Starten Sie Microsoft Dynamics SL.

  2. Wählen Sie im Menü Hilfsprogramm die Option Berichtssteuerungswartung aus.

    Hinweis

    Das Dialogfeld Berichtssteuerungswartung (98.300.00) wird geöffnet.

  3. Geben Sie im Feld Berichtsnummer die Nummer des Berichts ein, an den Sie den benutzerdefinierten Bericht anfügen möchten.

  4. Wählen Sie Steuerungsoptionen aus.

  5. Vergewissern Sie sich, dass das Feld Vorprozess leer ist. Wenn das Feld Vorprozess nicht leer ist, fahren Sie mit Schritt 3 fort, und geben Sie dann eine andere Berichtsnummer ein.

  6. Geben Sie in der ersten leeren Zeile den Anzeigenamen des Berichts in das Feld Berichtsformatname und dann den Namen der Berichtsdatei in das Feld Berichtsformat ein.

    In diesem Schritt bezieht sich "der Bericht" auf den Bericht Crystal Reports in Microsoft Windows. Geben Sie beispielsweise 01accdi in das Feld Berichtsformat ein, wenn der Name der Berichtsdatei 01accdi.rpt lautet.

  7. Klicken Sie auf Speichern. Wählen Sie dann Schließen aus.

Lösung 4

Entfernen Sie die ODBC-DSNs der Microsoft Dynamics SL- oder Microsoft Solomon-Datenbank, und erstellen Sie sie erneut. Gehen Sie dazu wie folgt vor:

  1. Wählen Sie Start, Systemsteuerung, Verwaltung und dann Datenquellen (ODBC) aus.
  2. Wählen Sie auf der Registerkarte Benutzer-DSN eine Dynamics SL-Datenbank und dann Entfernen aus. Wiederholen Sie den Vorgang für alle Dynamics SL-Datenbanken, die in der Liste angezeigt werden.
  3. Wählen Sie auf der Registerkarte System-DSN eine Systemdatenquelle aus, die sich auf eine Dynamics SL-Datenbank bezieht, und wählen Sie dann Entfernen aus.
  4. Wählen Sie OK aus.
  5. Um die ODBC-DSNs neu zu erstellen, starten Sie Microsoft Dynamics SL, und führen Sie dann eine Druckvorschau eines beliebigen Berichts aus.

Lösung 5

Aktivieren Sie ANSI (American National Standards Institute) in Anführungszeichen. Gehen Sie dazu wie folgt vor:

  1. Wählen Sie Start, Systemsteuerung, Verwaltung und dann Datenquellen (ODBC) aus.
  2. Wählen Sie auf der Registerkarte Benutzer-DSN die entsprechende Datenbank und dann Konfigurieren aus.
  3. Wählen Sie Weiter aus.
  4. Geben Sie die entsprechenden Anmeldeinformationen an, und wählen Sie dann Weiter aus.
  5. Aktivieren Sie das Kontrollkästchen Ansi-Bezeichner in Anführungszeichen verwenden .
  6. Wählen Sie Weiter aus.
  7. Wählen Sie Fertig stellen aus.
  8. Klicken Sie zweimal auf OK.

Lösung 6

Geben Sie Speicherplatz auf dem Computer frei. Löschen Sie dazu unnötige Daten, oder erhöhen Sie die Datenträgerkapazität.