MailboxNotEnabledForRESTAPI-Warnung wird in der Microsoft Dynamics 365-Postfachwarnung angezeigt

Dieser Artikel bietet eine Lösung für einen Fehler, der in der Microsoft Dynamics 365-Postfachwarnung auftritt.

Gilt für:   Microsoft Dynamics 365 Customer Engagement Online
Ursprüngliche KB-Nummer:   4534628

Problembeschreibung

In einer Postfachwarnung in Dynamics 365 wird eine Warnung wie im folgenden Beispiel angezeigt:

"Beim Senden der E-Mail-Nachricht "Test SSS with incoming via EXO profile but really on-prem through the mailbox" ist ein allgemeiner Postfachzugriffsfehler <Mailbox Name> aufgetreten. Der Besitzer des zugeordneten E-Mail-Serverprofils Microsoft Exchange Online wurde benachrichtigt. Das System versucht, die Nachricht später erneut zu senden.
Fehlercode des E-Mail-Servers: MailboxNotEnabledForRESTAPI. Exchange.server den Fehler 404 zurückgegeben."

Ursache

Diese Warnung kann protokolliert werden, wenn das Postfach mit einem Exchange Online E-Mail-Serverprofil in Dynamics 365 konfiguriert ist, das Postfach jedoch tatsächlich ein Exchange lokales Postfach ist.

Lösung

Wenn es sich bei dem Postfach um ein Exchange lokale Postfach handelt, überprüfen Sie, ob das für den Postfachdatensatz konfigurierte E-Mail-Serverprofil kein Exchange Online Profil ist. Beim Herstellen einer Verbindung mit einem Exchange lokalen Postfach sollte ein Exchange Server profil (Hybrid) verwendet werden.

Weitere Informationen zum Konfigurieren von Dynamics 365 Online mit Exchange lokal finden Sie unter Verbinden Dynamics 365 for Customer Engagement-Apps (online) für Exchange Server (lokal).