Nachschlagen filtert Datensätze nicht wie erwartet für eine bestimmte Entität in Dynamics 365

Dieser Artikel enthält Problemumgehungen für ein Problem, bei dem beim Nachschlagen alle Datensätze anstelle nur der Datensätze angezeigt werden, die sich auf die eingegebenen Datensätze beziehen.

Gilt für:   Power Apps
Ursprüngliche KB-Nummer:   4603850

Problembeschreibung

Wenn Sie ein Nachschlagesteuerelement eingeben, zeigt die Suche alle Datensätze in der Ansicht anstelle nur der Datensätze an, die sich auf die eingegebenen Daten beziehen. Wenn Sie einen Bildlauf durch die Datensätze durchführen, wird datensatztext fett formatiert angezeigt, wenn der Text mit dem Suchtext übereinstimmt.

Screenshot: Der Datensatztext ist fett formatiert, wenn der Text mit dem Suchtext übereinstimmt.

Ursache

Es gibt zwei mögliche Ursachen für dieses Problem:

Ursache 1

Das Problem tritt auf, weil in der Schnellsuche-Ansicht der Entität keine Spalten "Suchen" vorhanden sind.

Die Nachschlageansicht bestimmt, welche Spalten innerhalb des Nachschlagesteuerelements angezeigt werden, aber die Spalten der Schnellsuche-Ansichtssuche - bestimmen, welche Spalten im Nachschlagesteuerelement durchsucht werden. Wenn Sie einen Wert in ein Nachschlagesteuerelement eingeben, wird in den Suchspalten nach einer Übereinstimmung gesucht. Anschließend werden Datensätze mit einer Übereinstimmung ausgewählt und Informationen angezeigt, die von der Nachschlageansicht bestimmt werden. Der Grund, warum alle Datensätze angezeigt werden, ist, dass in der Schnellsuche-Ansicht keine Spalten "Suchen" festgelegt sind.

Hinweis

Spalten der Schnellsuche-Ansicht sind nicht mit den Spalten für die Schnellsuche-Ansichtssuche - identisch. Es können viele Spalten in der Schnellsuche-Ansicht vorhanden sein, aber wenn keine als "Suchen"-Spalten markiert sind, funktioniert die Suche nicht wie erwartet.

Der Grund, warum die angezeigten und durchsuchten Spalten unterschiedlich sein können, ist ihre Leistung. Je weniger Spalten durchsucht werden, desto schneller kann die Suche ausgeführt werden. Möglicherweise möchten Sie jedoch viele Informationen im Nachschlagesteuerelement anzeigen, um sicherzustellen, dass Sie den richtigen Datensatz auswählen.

Die Schritte zum Hinzufügen von "Suchen"-Spalten finden Sie unter Problemumgehung 1.

Ursache 2

Das Problem tritt auf, weil keine Spalten vom Typ "String" in der Ansicht vorhanden sind, die vom Nachschlagesteuerelement verwendet werden.

Das Nachschlagesteuerelement kann spalten, die keine Zeichenfolgentypen sind, nicht filtern. Die verwendete Ansicht muss mindestens eine Zeichenfolgentypspalte aufweisen, z. B. Text, E-Mail, Telefon, URL usw.

Die Schritte zum Hinzufügen einer Zeichenfolgentypspalte finden Sie unter Problemumgehung 2.

Problemumgehungen

Um dieses Problem zu umgehen, verwenden Sie eine der folgenden Problemumgehungen:

Problemumgehung 1

  1. Wechseln Sie in "Anpassungen" zur Schnellsuche-Ansicht für die Entität des Nachschlagesteuerelements.

  2. Wählen Sie "Nach Spalten hinzufügen" aus.

    Screenshot, um das Element "Spalten suchen" hinzuzufügen.

  3. Fügen Sie alle Spalten hinzu, die innerhalb des Nachschlagesteuerelements durchsucht und abgeglichen werden sollen.

    Screenshot, um alle Spalten hinzuzufügen, die innerhalb des Nachschlagesteuerelements durchsucht und abgeglichen werden sollen.

  4. Speichern und Veröffentlichen von Änderungen.

Problemumgehung 2

Sie müssen der Ansicht, die vom Nachschlagesteuerelement verwendet wird, eine Zeichenfolgentypspalte hinzufügen.

  1. Wechseln Sie in "Anpassungen" zur Ansicht, die vom Nachschlagesteuerelement verwendet wird, in der die Filterung unterbrochen ist.

  2. Wählen Sie Spalten hinzufügen aus.

    Screenshot, um das Element "Spalten hinzufügen" in der Testansicht auszuwählen.

  3. Fügen Sie mindestens eine Zeichenfolgentypspalte hinzu.