So bearbeiten Sie die Boot.ini-Datei in Windows 2000

In diesem Artikel werden die Schritte zum Bearbeiten der Boot.ini-Datei in einer Windows 2000-Umgebung beschrieben.

Hinweis

Dieser Artikel bezieht sich auf Windows 2000. Der Support für Windows 2000 endet am 13. Juli 2010. Das Windows 2000 End-of-Support Solution Center ist ein Ausgangspunkt für die Planung Ihrer Migrationsstrategie ab Windows 2000. Weitere Informationen finden Sie in der Microsoft Support-Lifecycle-Richtlinie.

Gilt für:   Windows 2000
Ursprüngliche KB-Nummer:   311578

Zusammenfassung

In diesem Schritt-für-Schritt-Artikel wird beschrieben, wie Sie die Boot.ini-Datei in einer Windows 2000-Umgebung bearbeiten. NTLDR zeigt den Bootstrap-Ladebildschirm an, auf dem Sie ein Betriebssystem auswählen können, das gestartet werden soll. Dieser Bildschirm basiert auf den Informationen in der Boot.ini Datei. Wenn Sie keinen Eintrag auswählen, bevor der Zähler null erreicht, lädt NTLDR das Betriebssystem, das durch den Standardparameter in der Boot.ini Datei angegeben ist. Windows 2000 Setup platziert die Boot.ini Datei in der aktiven Partition. NTLDR verwendet Informationen in der Boot.ini-Datei, um den Bootstrap-Ladebildschirm anzuzeigen, auf dem Sie das Betriebssystem auswählen.

Sie sollten die Boot.ini Datei sichern, bevor Sie sie bearbeiten. Die ersten Aufgaben umfassen das Ändern der Ordneroptionen, damit Sie ausgeblendete Dateien anzeigen können, und das anschließende Sichern der Boot.ini Datei.

Ändern von Ordneroptionen

  1. Klicken Sie mit der rechten Maustaste auf "Start", und klicken Sie dann auf "Durchsuchen".
  2. Klicken Sie im Menü "Extras" auf "Ordneroptionen" und dann auf "Anzeigen".
  3. Klicken Sie im Bereich "Erweitert Einstellungen" auf das Kontrollkästchen Ausgeblendete Dateien und Ordner anzeigen, deaktivieren Sie das Kontrollkästchen "Geschützte Betriebssystemdateien ausblenden (Empfohlen),klicken Sie auf OK und dann auf OK.
  4. Klicken Sie im linken Bereich auf "%systemroot%", klicken Sie mit der rechten Maustaste auf Boot.ini im Anzeigebereich, und klicken Sie dann auf "Eigenschaften".
  5. Klicken Sie, um das Kontrollkästchen "Schreibgeschütztes Attribut" zu deaktivieren, und klicken Sie dann auf "OK".

Speichern einer Sicherungskopie von Boot.ini

  1. Klicken Sie mit der rechten Maustaste auf "Start", und klicken Sie dann auf "Durchsuchen".
  2. Klicken Sie im linken Bereich auf das Laufwerk %systemroot%, klicken Sie im rechten Bereich auf die datei Boot.ini, und klicken Sie dann auf "Kopieren".
  3. Öffnen Sie einen temporären Ordner im linken Bereich, klicken Sie mit der rechten Maustaste auf den rechten Anzeigebereich, und klicken Sie dann auf "Einfügen", um eine Kopie der Boot.ini Datei in diesem Ordner zu erstellen.

Beispieldatei für Boot.ini

Dies ist ein Beispiel für eine Standardmäßige Boot.ini-Datei von einem Windows serverbasierten Computer mit 2000:


[boot loader]
timeout=30
default=multi(0)disk(0)rdisk(0)partition(1)\WINNT
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINNT="Windows 2000 Server" /fastdetect

Dies ist ein Beispiel der vorherigen Boot.ini-Datei nach dem Hinzufügen einer anderen Partition, die Windows XP-Professional ausgeführt wird.


[boot loader]
timeout=30
default=multi(0)disk(0)rdisk(0)partition(1)\WINNT
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINNT="Windows 2000 Server" /fastdetect
multi(0)disk(0)rdisk(0)partition(2)\WINNT="Windows XP Professional" /fastdetect

Bearbeiten der Boot.ini Datei

  1. Klicken Sie auf "Start", zeigen Sie auf "Programme", zeigen Sie auf "Zubehör", und klicken Sie dann auf Editor.
  2. Klicken Sie in Editor im Menü "Datei" auf "Öffnen".
  3. Klicken Sie im Feld "Suchen in" auf das Laufwerk "%systemroot%", klicken Sie auf die datei Boot.ini, und klicken Sie dann auf "Öffnen".

Entfernen eines Betriebssystems aus dem Menü

  1. Wählen Sie in Editor die Zeile aus, die Informationen zu dem Betriebssystem enthält, das Sie entfernen möchten, und drücken Sie dann DELETE. Beispiel für die zu markierende Zeile:

    multi(0)disk(1)rdisk(0)partition(2)\Windows="Windows 98" /fastdetect  
    
  2. Klicken Sie im Menü Datei auf Speichern .

Ändern der Menüreihenfolge des Betriebssystems

  1. Wählen Sie in Editor die zu verschiebende Linie aus, drücken Sie STRG+C, drücken Sie ENTF, klicken Sie, um den Cursor an die Position zu setzen, an der die Linie platziert werden muss, und drücken Sie dann STRG+V.
  2. Wiederholen Sie Schritt 1 nach Bedarf für Ihre Konfiguration, und klicken Sie dann im Menü "Datei" auf "Speichern".

Ändern des Standardbetriebssystems

Der Standardwert stellt das Betriebssystem dar, das geladen wird, wenn vor dem Timeout keine Auswahl getroffen wird.

  1. Ändern Sie in Editor die folgende Zeile, um das Standardmäßige Betriebssystem widerzuspiegeln:

    default=multi(0)disk(0)rdisk(0)partition(1)\WINNT  
    

    Beispiel: Ändern der Standardeinstellung von Windows 2000 Server zu Microsoft Windows 95

    default=multi(0)disk(0)rdisk(0)partition(1)\WINNT  
    

    würde geändert werden in:

    default=multi(0)disk(0)rdisk(1)partition(2)\Windows  
    
  2. Klicken Sie im Menü Datei auf Speichern .

Ändern des Timeouts

Das Timeout gibt die Anzahl der Sekunden an, die Sie im Menü auswählen dürfen, bevor das Standardbetriebssystem geladen wird.

  1. Bearbeiten Sie in Editor die folgende Zeile, um die Anzahl der benötigten Sekunden widerzuspiegeln.timeout=30

  2. Klicken Sie im Menü Datei auf Speichern .

Problembehandlung

  • Wenn ein Problem mit der zu bearbeitenden Datei vorliegt, kopieren Sie die ursprüngliche Boot.ini Datei, die in den Ordner %systemroot% gesichert wurde.