Code-31-Fehler im Geräte-Manager für WAN-Miniportgerät (Netzwerkmonitor) in Windows

Dieser Artikel enthält eine Problemumgehung für ein Problem, bei dem der Geräte-Manager neben dem WAN-Miniportgerät (Netzwerkmonitor) ein gelbes Ausrufezeichen anzeigt.

Gilt für:   Windows 10 – alle Editionen, Windows Server 2012 R2
Ursprüngliche KB-Nummer:   2871372

Problembeschreibung

Stellen Sie sich folgendes Szenario vor:

  • Sie installieren Windows.
  • Sie öffnen den Geräte-Manager, nachdem die Installation abgeschlossen ist.

In diesem Szenario zeigt der Geräte-Manager neben dem WAN-Miniportgerät (Netzwerkmonitor) ein gelbes Ausrufezeichen an. Darüber hinaus wird auf der Registerkarte "Details" des Fensters "Geräteeigenschaften" die folgende Meldung angezeigt:

Das Gerät funktioniert nicht ordnungsgemäß, da Windows die für dieses Gerät erforderlichen Treiber nicht laden können. (Code 31)

Ursache

Dieses Problem tritt auf, weil Windows die Treiber, die für das WAN-Gerät (Netzwerkmonitor) erforderlich sind, nicht laden können. Da dem Gerät kein Treiber zugeordnet ist, kann es nicht aus dem Geräte-Manager entfernt werden.

Lösung

Um dieses Problem bei zukünftigen Installationen zu verhindern, müssen Sie Update-2822241 in das Installationsmedium integrieren, das Sie während des Setups verwenden.

Informationen zur Verwendung von DISM (Deployment Image Servicing and Management) zum Integrieren eines Hotfixpakets in Installationsmedien finden Sie unter "Hinzufügen oder Entfernen von Paketen offline".

Problemumgehung

Führen Sie die folgenden Schritte aus, wenn Sie das Betriebssystem bereits installiert haben und derzeit auf dem WAN-Miniportgerät (Netzwerkmonitor) den Fehler "Code 31" erhalten:

  1. Öffnen Sie den Geräte-Manager.
  2. Klicken Sie mit der rechten Maustaste auf das WAN-Miniportgerät (Netzwerkmonitor), und klicken Sie dann auf "Treibersoftware aktualisieren".
  3. Klicken Sie auf "Meinen Computer nach Treibersoftware durchsuchen".
  4. Klicken Sie auf "Auswählen aus einer Liste der Gerätetreiber auf meinem Computer".
  5. Deaktivieren Sie das Kontrollkästchen kompatible Hardware anzeigen.
  6. Wählen Sie in der Spalte auf der linken Seite Microsoft aus, und wählen Sie in der Spalte auf der rechten Seite Microsoft KM-TEST Loopback Adapter aus.
  7. Klicken Sie im Dialogfeld "Treiberwarnung aktualisieren" auf "Ja", um die Installation dieses Treibers fortzusetzen.
  8. Klicken Sie nach der Installation des Treibers mit der rechten Maustaste auf das Gerät, und klicken Sie dann auf "Deinstallieren".
  9. Klicken Sie nach der Deinstallation des Geräts im Geräte-Manager mit der rechten Maustaste auf den Computernamen, und klicken Sie dann auf "Nach Hardwareänderungen suchen".
  10. Klicken Sie im Menü Ansicht auf ausgeblendete Geräte anzeigen. Das WAN-Miniportgerät (Netzwerkmonitor) sollte jetzt gestartet werden und nicht mehr über ein gelbes Ausrufezeichen verfügen.