Gliedern

Gilt für:yes Visual Studio Visual Studio nofür Mac noVisual Studio Code

Um einen Codebereich aus der Ansicht auszublenden, können Sie ihn reduzieren, sodass es unter einem Pluszeichen (+) im Text-Editor angezeigt wird. Klicken Sie dann auf das Pluszeichen, um einen reduzierten Bereich zu erweitern.

Tipp

Wenn Sie eine Tastatur verwenden, können Sie STRG+M+M drücken, um Bereiche zu reduzieren bzw. zu erweitern.

Wenn Sie einen Seitenbereich reduzieren möchten, doppelklicken Sie auf eine beliebige Zeile in der Region am Rand, die nur links vom Code angezeigt wird. Sie können den Inhalt eines reduzierten Bereichs als QuickInfo sehen, wenn Sie auf den reduzierten Bereich zeigen.

Bereiche am Gliederungsrand werden auch hervorgehoben, wenn Sie mit der Maus auf den Rand zeigen. Die standardmäßige Hervorhebungsfarbe wird möglicherweise in einigen Farbkonfigurationen etwas schwach angezeigt. Diese können Sie unter Extras>Optionen>Umgebung>Schriftarten und Farben>Reduzierbarer Bereich ändern.

Wenn Sie mit Code mit Rand arbeiten, können Sie die Bereiche erweitern, an denen Sie arbeiten, sie reduzieren, wenn Sie fertig sind, und dann mit anderen Bereichen fortfahren. Wenn Sie die Gliederung nicht anzeigen möchten, können Sie mit dem Befehl Gliederung entfernen die Gliederungsinformationen entfernen, ohne damit zugrunde liegenden Code zu beeinträchtigen.

Diese Aktionen werden durch die Befehle Rückgängig und Wiederholen im Menü Bearbeiten beeinflusst. Bei den Befehlen Kopieren, Ausschneiden und Einfügen sowie bei Drag & Drop-Vorgängen werden Gliederungsinformationen beibehalten, der Zustand des zuklappbaren Bereichs jedoch nicht. Wenn Sie beispielsweise einen zugeklappten Bereich kopieren, wird der kopierte Text beim Vorgang Einfügen als aufgeklappter Bereich eingefügt.

Achtung

Wenn Sie einen gegliederten Bereich ändern, geht die Gliederung möglicherweise verloren. Beispielsweise wird durch Löschvorgänge oder Suchen und Ersetzen das Ende des Bereichs möglicherweise gelöscht.

Die folgenden Befehle befinden sich im Untermenü Bearbeiten>Gliedern.

name Beschreibung
Aktuelles Element umschalten (STRG+M, STRG+H): Reduziert einen ausgewählten Codeblock, der normalerweise nicht für eine Gliederung verfügbar wäre, beispielsweise einen if-Block. Verwenden Sie die Option Gliederung in aktuellem Element entfernen, oder drücken Sie STRG+M, STRG+U, um den benutzerdefinierten Bereich zu entfernen. Nicht in Visual Basic verfügbar.
Gliederungserweiterung umschalten STRG+M, STRG+M kehrt den aktuellen Zustand (ausgeblendet oder erweitert) des innersten Gliederungsbereichs um, wenn sich der Cursor in einem verschachtelten reduzierten Bereich befindet.
Alle Gliederungen umschalten (STRG+M, STRG+L): Legt alle Bereiche auf denselben reduzierten oder erweiterten Zustand fest. Wenn einige Bereiche erweitert und andere reduziert sind, werden die reduzierten Bereiche erweitert.
Gliederung entfernen (STRG+M, STRG+P): Entfernt alle Gliederungsinformationen für das gesamte Dokument.
Gliederung in aktuellem Element entfernen (STRG+M, STRG+U) – Entfernt die Klammerinformationen für den aktuell ausgewählten benutzerdefinierten Bereich. Nicht in Visual Basic verfügbar.
Nur Definitionen anzeigen (STRG+M, STRG+O): Reduziert die Members aller Typen.
Block reduzieren:<logische Grenze> (C++) Reduziert einen Bereich in der Funktion mit der Einfügemarke. Wenn beispielsweise die Einfügemarke innerhalb einer Schleife platziert ist, wird die Schleife ausgeblendet.
Alle in reduzieren: <logische Strukturen> (C++) Reduziert alle Strukturen innerhalb der Funktion.

Tipp

Weitere Informationen zur Verwendung der Tastatur finden Sie unter Tastenkombinationen in Visual Studio.

Sie können auch das Visual Studio SDK verwenden, um die Textbereiche zu definieren, die Sie erweitern oder reduzieren möchten. Weitere Informationen finden Sie unter Exemplarische Vorgehensweise: Gliedern.

Siehe auch