PreviewLogoVisual Studio 2022 Version 17.3 Versionshinweise


Tipp

Sehen Sie sich die Aufzeichnungen der Visual Studio 2022-Einführungsveranstaltung an, um mehr über die neuen Funktionen zu erfahren, Tipps und Tricks zu erhalten und kostenloses digitales Zubehör herunterzuladen.

| Entwicklercommunity Visual Studio 2022 Roadmap | Systemanforderungen | | KompatibilitätskompatibilitätverteilbareCodeversionslizenzbedingungen | | | | Blogs neueste bekannteProbleme | , die inVisual Studio-Dokumenten neu sind


Klicken Sie auf eine Schaltfläche, um die aktuelle Version von Visual Studio 2022 herunterzuladen. Anweisungen zum Installieren und Aktualisieren von Visual Studio 2022 finden Sie unter Aktualisieren von Visual Studio 2022 auf das aktuelle Release. Sehen Sie sich auch die Anweisungen zur Offlineinstallation an.

Schaltfläche herunterladen herunterladen"

Besuchen Sie die Visual Studio-Website , um andere Visual Studio 2022-Produkte herunterzuladen.

Wichtig

Der Vorschaukanal befindet sich nicht in der endgültigen Phase und ist nicht für die Verwendung auf Produktionscomputern oder zur Erstellung von Produktionscode vorgesehen. Weitere Informationen finden Sie unter Projektlebenszyklus und Wartung in Visual Studio.

Schaltfläche herunterladen" Schaltfläche "Professionelle Vorschau herunterladen" Schaltfläche "Enterprise Preview herunterladen


Neuerungen in Visual Studio 2022 Version 17.3

Visual Studio 2022-Blog

Im Visual Studio 2022-Blog finden Sie alle wichtigen Informationen zu Produkten direkt vom Visual Studio-Engineeringteam. In den folgenden Beiträgen finden Sie ausführliche Informationen zu den Visual Studio 2022-Releases:


17.3.0 Visual Studio 2022 Version 17.3

veröffentlicht am 9. August 2022

Entwicklercommunity Vorschläge: Sie haben gefragt, wir hören!

Sehen Sie sich die nachstehende Liste der Entwicklercommunity Probleme an, die in Visual Studio 2022 Version 17.3 behoben wurden.


Zusammenfassung der Neuerungen in dieser Version von Visual Studio 2022 Version 17.3

  • MAUI-Workload-GA-Build
  • MAUI/Blazor CSS Hot Reload Support
  • Sie können jetzt eine Auswahl neuer Features in Visual Studio mit jedem Update ausprobieren, indem Sie unser Feature "Neuerungen" verwenden.
  • Wählen Sie jedes Feature aus, um mehr über das bestimmte Feature zu erfahren.

Neues in Visual Studio

Apple-Entwicklerkonten

Diese Vorschau enthält anfängliche Unterstützung für einzelne AppStoreConnect-Konten, die für Nicht-Enterprise-Apple-Entwickler benötigt werden.

  • Um ein einzelnes Konto hinzuzufügen, öffnen Sie Tools\Optionen, und wählen Sie dann das Element "Apple-Konten" im Abschnitt "Xamarin" aus. Klicken Sie im "Apple-Konten" auf "Konto hinzufügen...". klicken Sie auf "Einzelnes Konto hinzufügen", und geben Sie die AppStoreConnect-API-Schlüsselinformationen ein.
  • Nachdem das Konto erstellt wurde, können Zertifikate und Bereitstellungsprofile über die Schaltfläche "Details anzeigen" zugegriffen werden.
  • Bekannte Probleme:
    • Die automatische Bereitstellung funktioniert möglicherweise nicht ordnungsgemäß für einzelne Konten in einigen Fällen. Um dies zu umgehen, befolgen Sie die Anweisungen zur manuellen Bereitstellung.

Audio-Hinweise im Editor

  • Wir haben neue Audio-Hinweise im Visual Studio-Editor eingeführt. Bei aktivierter Aktivierung wird Visual Studio Sounds wiedergeben, wenn die Bearbeitungspflege an einer Zeile mit einem Haltepunkt, einem Fehler oder einer Warnung ankommt. Standardmäßig verwendet Visual Studio dieselben Sounds wie Visual Studio Code, aber diese Sounds können für die Einstellung des Benutzers konfiguriert werden.
  • Um Audiohinweise zu aktivieren , navigieren Sie zu Tools\Optionen, und suchen Sie unter "Umgebung" nach "Vorschaufeatures". In den Vorschaufeatures ist die neue Option "Audio-Hinweise für den Editor aktivieren". Wenn dies aktiviert ist, wird das nächste Mal, wenn Visual Studio gestartet wird, die Sounds wiedergegeben.
  • Um einzelne Audiohinweise zu konfigurieren, tippen Sie in Windows 10 oder Windows 11 auf die Windows-Taste, und suchen Sie nach "Systemsounds ändern". Suchen Sie unter den Programmereignissen nach dem Knoten "Microsoft Visual Studio" in der Programmereignissestruktur. Die neuen Ereignisse sind "Line has Breakpoint", "Line has Error" und "Line has Warning". Dies kann verwendet werden, um einzelne Sounds anzupassen oder zu deaktivieren.

Sound Systemsteuerung in Windows

Git-Tools

Unterstützung für Zeilenstaging, auch als interaktives Staging bekannt, mit der Möglichkeit, bestimmte Codezeilen und/oder -blöcke direkt über den Editor und die Differenzansicht zu stagen Um zu beginnen, führen Sie eine Der letzten Änderungen durch Auswählen des entsprechenden Farbrands und verwenden die Vorschauunterschied-BEnutzeroberfläche, um Ihre Änderung zu stufen.

Lesen Sie unseren Blogbeitrag , um mehr zu erfahren und Ihr Feedback zu teilen.

Unterstützung für die Line-Staging

C++

  • Die Arm64EC-Toolkette wird nicht mehr als experimentell gekennzeichnet und ist bereit für die Produktionsverwendung.
  • Das Visual Studio-Terminal kann jetzt als SSH-Client mit Ihren gespeicherten SSH-Verbindungen verwendet werden. Öffnen Sie mit dem installierten C++ für Linux-Tools das Terminaltoolfenster, und das Terminal-Dropdown wird mit Ihren gespeicherten Verbindungen gefüllt. Wenn ausgewählt, öffnen sie ein neues Terminalfenster innerhalb von Visual Studio und ein Pseudoterminal auf Ihrem Remotesystem. Steuerelementzeichen, Farben und Cursorpositionsbewusstsein werden unterstützt.
  • Visual Studio kann jetzt Unreal Engine-Klassenvorlagen für Ihre UE-Projekte hinzufügen. Um dieses Feature zu testen, stellen Sie sicher, dass "IDE-Unterstützung für unreal Engine" im VS-Installationsprogramm in der Arbeitslast "Spieleentwicklung mit C++" ausgewählt ist. Wenn Sie an einem UE-Projekt arbeiten, klicken Sie mit der rechten Maustaste im Projekt oder einem Ordner/Filter, und wählen Sie "UE-Klasse hinzufügen > " aus.
  • Wechseln Sie zur Definition, und navigieren Sie entsprechend, wenn eine bessere Übereinstimmung nicht verfügbar ist (z. B. nachdem Sie die Signatur eines der Paare manuell geändert haben).
  • Verbesserte Reaktionsfähigkeit von "Go To All". Zuvor wurden die Ergebnisse angezeigt, nachdem Sie die Eingabe beendet haben. In der neuen Benutzeroberfläche werden Die Ergebnisse während der Eingabe angezeigt.
  • In Kontexten, in denen die Aufzählung des Typs abgeschlossen werden muss (z. B. Zuordnungen zu Aufzählungsvariablen, case Bezeichnungen, Zurückgeben des Aufzählungstyps usw.) werden die Autovervollständigenliste nun nur auf die übereinstimmenden Aufzählungen und verwandte Konstrukte gefiltert.
  • NuGet PackageReference-Unterstützung für C++/CLI MSBuild-Projekte für .NET Core hinzugefügt. Diese Änderung wurde vorgenommen, um gemischte Codebasen zu blockieren, um .NET Core zu übernehmen. Dies funktioniert nicht für andere C++-Projekttypen oder C++-Projekttypen, die auf .NET Framework abzielen. Es gibt keine Pläne, packageReference-Unterstützung auf zusätzliche C++-Szenarien zu erweitern, da das Team an separaten Erfahrungen mit vcpkg arbeitet, die für Nicht-MSBuild-Szenarien funktionieren und zusätzliche Funktionen hinzufügen.
  • Es wurde ein Fenster für die serielle Überwachung für eingebettete Entwicklung hinzugefügt, das über den Debuggen > von Windows > Serial Monitor verfügbar ist.
  • Verbesserte C++-Indizierung um ~66 % im Vergleich zu 17,2.
  • Aktualisiert die Version von CMake, die mit Visual Studio in Version 3.23 gesendet wurde. Weitere Informationen zu den verfügbaren Versionshinweisen finden Sie unter CMake 3.23 .
  • Aktualisiert die Versionen von LLVM-Tools, die mit Visual Studio auf v14 geliefert wurden. Weitere Informationen zu den verfügbaren Informationen finden Sie in den LlVM - und Clang-Versionshinweisen .
  • Aktualisiert das querseitige Dev 16.11 C++ Toolset auf Version 14.29.30145.00. Die neueste Version des Dev 16.11 C++ Toolset enthält wichtige Fehlerkorrekturen, einschließlich der Behebung aller verbleibenden C++20-Fehlerberichte. Informationen zu Fehlerkorrekturen, einschließlich C++20-Fehlerberichte in Dev 16.11, finden Sie unter https://docs.microsoft.com/en-us/visualstudio/releases/2019/release-notes#16.11.14
  • Wir haben verschiedene Verbesserungen an der Benutzeroberfläche von C++-Modulen vorgenommen. "Wir arbeiten kontinuierlich daran, die Qualität der Erfahrung zu verbessern, aber ermutigen Sie, 17.3 zu versuchen und weitere Probleme über Entwicklercommunity zu melden.

Debuggen und Diagnose

  • Diagnoseanalysetools enthalten jetzt eine Analyse, die die eindeutigen Anrufstapel in einem Speicherabbild zusammen mit den ausgeführten Threads auflisten.
  • IEnumerable Visualrs unterstützen jetzt den Datenexport im CSV-Format. Verwenden Sie einfach das Dropdown in der oberen rechten Ecke, und wählen Sie CSV aus. Mit dem Visualr können Sie auch datenbasierte gewünschte Filterzeichenfolge filtern. Die Schnellansicht gibt alle Zeilen zurück, die einen Wert enthalten, der mit der Filterzeichenfolge übereinstimmt. Sie können die gefilterten und sortierten Ergebnisse auch im CSV/Excel-Format exportieren.

Visualizer_Filte

  • Außerdem wurden die Designerstellungsunterstützung für die IEnumerable- und DataSet-DatenSet-Visualisierung hinzugefügt, sodass beide dieser Visualisierungsfenster für das dunkle, helle und blaue Design von Visual Studio behandelt werden.

Visualizer_Filte

  • Ab 17.3 Preview 3 Debugger werden automatisch pervious decompilierte Artefakte wie Symbole und PDB-Dateien neu geladen. Wenn Sie sich für alle nächsten Sitzungen entscheiden, werden die Artefakte automatisch für alle nächsten Sitzungen neu geladen und erhalten Sie schneller in externen Quellenknoten. Dadurch werden Ihre JMC-Einstellungen weiterhin berücksichtigt.
  • Debugger bietet jetzt eine neue Option zum Deaktivieren des Ladens von NGEN oder bereit zum Laden von RDR-Images für verwalteten Code. Sie können die Einstellungen unter Extras > Options> Debugging > General > Prevent mithilfe vorkompilierter Bilder beim Laden des Moduls ändern, oder Sie können auch ganz einfach die Einstellungen mithilfe eines der Schlüsselworte in der Visual Studio-Suchleiste durchsuchen.
  • Jetzt werden die Ausnahmestapelframes im Fenster "Anrufstapel" angezeigt. Daher können Sie für alle asynchronen Ausnahmen Symbole schnell laden oder Quellen suchen und direkt zur Website der Ausnahme wechseln. Ausnahmestapelframes innerhalb des Anrufstapelfensters bieten Funktionen des tatsächlichen Anrufstapels. Features wie automatische Navigation, schnelles Wechseln zwischen Frames und Symbollade-/Dekompilierungsoptionen, um wieder zum Quellcode zurückzukehren, in dem die Ausnahme ausgelöst wurde.

Visualizer_Filte

Allgemein

  • GitHub-Konten wechseln jetzt über Computer hinweg, wenn Sie sich auf einem neuen Computer mit demselben Personalisierungskonto anmelden (Konto oben links im Dialogfeld "Kontoeinstellungen").

Installationsprogramm

  • Sie können jetzt alle parallelen Versionen von Visual Studio mit der Schaltfläche „Alle aktualisieren“ im Installationsprogramm aktualisieren.

Microsoft Teams Development Tools (Teams Toolkit)

  • Die Microsoft Teams App-Projektvorlage wurde verbessert und erstellt jetzt verschiedene Arten von Teams-Apps, einschließlich Benachrichtigungs-Bot, Befehls-Bot, Registerkarten-App und Nachrichtenerweiterungen. Sie können jetzt verschiedene Microsoft Teams-Apps mithilfe des Teams-Toolkits für Visual Studio erstellen und debuggen.
  • Es wird empfohlen, ein neues Projekt mithilfe der aktualisierten Vorlage für alle vorhandenen Teams-Apps zu erstellen, die Sie mit früheren Versionen des Teams Toolkits erstellt haben.
  • Sie können jetzt auswählen, wann Sie sich mit Ihrer M365-Identität anmelden und Teams-App-Ressourcen registrieren möchten, indem Sie die Menüoption " >> Teams-App-Abhängigkeiten vorbereiten" verwenden.
  • Vorbereiten von Teams-App-Abhängigkeiten registriert die Teams-App und der Bot für Ihr Teams-Projekt.
  • Aktualisierungen mit den Dateien "manifest.template.json" können mit dem Teams-Entwicklerportal für lokale Debug synchronisiert werden, indem Sie jederzeit die Menüoption "Teams-App-Abhängigkeiten vorbereiten" auswählen.
  • Aktualisierungen mit den Dateien "manifest.template.json" können mit dem Teams Developer Portal für die Remotevorschau synchronisiert werden, indem Sie Project auswählen.> Menüoption "Teams Toolkit > Update Manifest" im Microsoft Teams-Entwicklerportal.
  • Sie können eine Vorschau der Manifestdatei vor der Synchronisierung anzeigen, indem Sie mit der rechten Maustaste auf "manifest.template.json"-Datei klicken und die Menüoption "Vorschaumanifestdatei" verwenden.
  • Verwenden Sie die Project > Teams Toolkit-Bereitstellung > im Cloudmenü, um Ressourcen in einem Azure-Abonnement zu erstellen.
  • Verwenden Sie das Menü „Projekt > Teams Toolkit > In der Cloud bereitstellen“, um Code für diese Ressourcen zu veröffentlichen.
  • Sie können Teams-App remote in einem Browser öffnen, der über das Menü "Bereitstellen" mithilfe des Menüs "Teams-Vorschau"-App erstellt wird.
  • Sie können die Teams-App zippen und App-Paket generieren, indem Sie die Menüoption "Zip-App-Paket" des Project > Teams-Toolkits > zum Freigeben und Hochladen auswählen.
  • Sie finden alle Menüoptionen des Teams-Toolkits, indem Sie mit der rechten Maustaste auf das Teams-App-Projekt klicken, sie sind identisch mit dem Menü "Project > Teams Toolkit".
  • Weitere Informationen zum Teams Toolkit finden Sie unter https://aka.ms/teams-toolkit-vs-docs

.NET-Produktivität

  • In C# 10 haben wir globale Usings eingeführt. Globale Usings fügt die Verwendungen oben in einer Datei unsichtbar und automatisch hinzu. Es wird nun ein Symbol oben in der Datei angezeigt, um Ihnen mitzuteilen, ob globale Verwendungen in Ihrer Datei aktiv sind und wenn Sie auf das Symbol klicken, wird ihnen angezeigt, was diese globalen Verwendungen sind. Globale Verwendungen

  • Die Vorschaudefinition unterstützt jetzt Quelllinks, eingebettete Quellen und dekompilierte Quellen. Definition einsehen

  • Wir haben die folgenden drei Optionen zum Reduzieren und Ausführen von Ansichten zum Öffnen der Datei hinzugefügt:

    • Reduzieren #regions beim Öffnen der Datei
    • Reduzieren von Verwendungen beim Öffnen der Datei
    • Reduzieren von Implementierungen aus Metadaten beim Öffnen der Datei
  • Sie können jetzt Fix All sowohl auf die als Convert to raw string literal auch auf die Use expression body or block body Umgestaltung anwenden.

  • Sie verfügen nun über einen Codefix, der ungültige Einschränkungen korrigiert. Platzieren Sie den Cursor im Editor über der unterringelten Diagnose. Drücken Sie STRG+., um das Menü Schnellaktionen und Refactorings aufzurufen. Wählen Sie Einschränkung korrigieren aus. Fixeinschränkung

  • Sie verfügen nun über ein Refactoring, das es Ihnen ermöglicht, zwischen Anweisungen auf oberster Ebene und dem Format „Program.Main“ zu wechseln. Platzieren Sie den Cursor über einer Anweisung auf oberster Ebene. Drücken Sie STRG+., um das Menü Schnellaktionen und Refactorings aufzurufen. Wählen Sie Zu „Programm.Main“-Formatprogramm konvertieren aus. In

  • Wir haben dem Vorgang „Alle korrigieren“ zusätzliche Bereiche hinzugefügt. Zusätzlich zum Anwenden des Vorgangs „Alle korrigieren“ auf ein Dokument, Projekt und eine Projektmappe können Sie „Alle korrigieren“ auf einen enthaltenden Member und einen enthaltenden Typ anwenden. Beheben aller enthaltenden Elemente und enthaltenden Typen

  • Einzeilige Kommentare werden jetzt automatisch in Dokumentkommentare konvertiert, wenn Sie einem einzeiligen Kommentar einen zusätzlichen Schrägstrich hinzufügen.

  • Sie können jetzt eine Codeformatoption nutzen, um bei möglichen Ausnahmen in einer Foreach-Schleife zu warnen. Foreach-Schleifen wandeln entwurfsbedingt implizit zu abgeleiteten Typen um. Dies war erforderlich, bevor Generics vorhanden waren, kann jedoch in manchen Fällen zu Runtimeausnahmen führen.

Personalisierung

  • Die Dokumentverwaltungsfunktionen wurden aktualisiert. Weitere Informationen finden Sie in unserem Blogbeitrag.

Zu diesen Features zählen:

  • Registerkarten, die in mehreren Zeilen angeordnet sind.
  • Zuletzt verwendete Dokumente wiederherstellen.
  • Geänderte schmutzige Indikator.
  • Dropdown zeigt Namen unsichtbarer Dokumente kursiv an.

Razor-Editor (ASP.NET Core)

  • Der neue Razor-Editor verfügt jetzt über eine vollständige Fertigstellungsunterstützung innerhalb eines <attribute>.
  • Der neue Razor-Editor führt die Fertigstellung für HTML-Attribute beim Eingeben von „= " "“ jetzt richtig aus.
  • Der neue Razor-Editor unterstützt jetzt HTML, JavaScript und CSS OnTypeFormatting.

Testtools

  • Parallel Discovery ist jetzt standardmäßig aktiviert, wenn Tests aus dem Test-Explorer ausgeführt werden. Dadurch kann Visual Studio verfügbare Kerne verwenden, um Tests parallel zu ermitteln und die Zeit zu reduzieren, um Tests im Test-Explorer anzuzeigen.

  • Das Live Unit-Testfenster verfügt jetzt über eine Statusleiste, ähnlich wie im Test-Explorer. Dies sollte Ihnen einen besseren Einblick in die laufenden Vorgänge in Live Unit Testing sowie sichtbaren Oberflächenfehlern geben. Statusleiste für Live-Komponententests

  • vstest.console unterstützt jetzt die Ausführung von Assemblys verschiedener Zielplattformen und Zielframeworks in einer Anforderung.

  • Die Codeabdeckung verfügt jetzt über einen Cache für statische Instrumentierung, um eine bessere Leistung zu erzielen.

  • Microsoft.CodeCoverage.Console wird jetzt den Befehlszeilentools hinzugefügt.

  • Die Standardarchitektur für AnyCPU .NET Framework Testprojekte wurde von x86 in x64 geändert. Durch diese Änderung wird erläutert, wie die Standardarchitektur in allen Arten von Testprojekten bestimmt wird, die immer auf der Architektur von Visual Studio basieren. Dies bedeutet, dass in x64-Version von VisualStudio, x64 verwendet wird und in zukunft ARM64 VisualStudio, ARM64 verwendet wird. Die gleiche Regel gilt auch für dotnet test, und vstest.console. Navigieren Sie zum Zurücksetzen auf die Verwendung von x86 zu Testprozessorarchitektur > für AnyCPU-Projekte > x86

  • Remotetests unterstützen jetzt Testläufe für Remote-arm64-Windows-Umgebungen.

  • Die neue Buildumgebung für [Live Unit Testing] ist jetzt standardmäßig aktiviert. Weitere Informationen finden Sie in unserem Blogbeitrag.

  • Sie können jetzt auswählen, dass Code Coverage-Informationen am Editorrand angezeigt werden, indem Sie im Fenster „Code Coverage-Ergebnisse“ „Randglyphen“ auswählen. In unformatierte Zeichenfolge konvertieren

  • Live Unit Testing bietet jetzt eine Schaltfläche zum Zurücksetzen des gesamten Zustands. Indem Sie den Status "Live Unit Testing" > testen, wird der Status "Live Unit Testing > " für die Lösung zurückgesetzt. Status für Live-Komponententests

  • Live Unit Testing unterstützt jetzt Razor-Dateien.

TypeScript- und JavaScript-Entwicklung

  • JavaScript- und TypeScript-Dateien werden jetzt von der Programmanalyse ausgeschlossen, es sei denn, sie werden von einer tsconfig.json- oder jsconfig.json-Datei referenziert. Das Ergebnis sollte die Leistung in großen Projekten mit vielen TypeScript- und JavaScript-Dateien verbessern.

  • JavaScript-Projekte (ESPROJ), auf die aus einem ASP.NET Projekt verwiesen wird, bieten jetzt eine Option zum Einschließen der Produktionsbuildausgabe in ASP.NET Projektveröffentlichung.

  • Der TypeScript 4.7-Sprachdienst und der Compiler sind in Visual Studio enthalten. Weitere Informationen finden Sie im Blogbeitrag "TypeScript 4.7 ".

  • Der neue JavaScript-Debugger mit mehreren Zielzielen wird jetzt standardmäßig in Node.js Projekten (.njsproj) verwendet.

  • Automatisches Schließen von HTML-Tags in JavaScript- und TypeScript-React (.jsx/.tsx)-Dateien.

  • Es wurde ein Problem behoben, bei dem die automatische Typakquise (ATA) nicht funktionierte, wenn der Standardmäßige TypeScript-Sprachserver ausgewählt ist.

  • Es wurde ein Problem behoben, bei dem der Abhängigkeitsknoten in Node.js -Projekten (njsproj) indirekte Abhängigkeiten gezeigt hat, wenn Pakete mithilfe von npm 7 oder höher wiederhergestellt werden.


Sicherheitsempfehlung


Aus der Entwicklercommunity


Bekannte Probleme

Sehen Sie alle offenen Probleme und verfügbare Problemumgehungen in Visual Studio 2022, indem Sie den folgenden Links folgen.


Feedback und Vorschläge

Wir freuen uns auf Ihr Feedback! Sie können ein Problem melden oder ein Featurefeedbacksymbol vorschlagen, indem Sie das Symbol "Feedback senden" in der oberen rechten Ecke des Installers oder der Visual Studio IDE oder aus "Feedback > senden" verwenden. Sie können Ihre Probleme in der Entwicklercommunity für Visual Studio nachverfolgen, in der Sie Kommentare hinzufügen und Lösungen suchen können. Über unseren Livechatsupport erhalten Sie zudem kostenlose Hilfe bei der Installation.


Blogs

Profitieren Sie von den Einblicken und Empfehlungen auf der Webseite mit Blogs zu Entwicklertools, um sich bei allen Releases auf dem neuesten Stand zu halten und Zugang zu ausführlichen Beiträgen zu zahlreichen Funktionen zu erhalten.


Seitenanfang